none
Perte de l'autodiscover sur Exchange 2013 RRS feed

  • Question


  • Configuration : Windows server 2012 Standard hébergé chez OVH

                             Exchange Standard 2013 Version 15.0 (Build 775.38)

                            Rôles : Boîtes aux lettres, Accès au client


    Bonjour à tous,

    Lors de l'installation de mon serveur j'ai paramétré l'autodiscover qui fonctionnait correctement, mais depuis 1 mois il ne fonctionne plus.

    Aucun changement n'a été effectué sur mes DNS.

    Lorsque je regarde les événements présents sur mon serveur j'aperçois deux messages d'erreurs récurents (tout les jours) :

    Niveau :Erreur              Source : Schannel        ID de l'évenement : 36888   Catégorie : aucun

    Une alerte irrécupérable a été générée et envoyée au point de terminaison distant. Ceci peut entraîner l’arrêt de la connexion. Le code d’erreur irrécupérable défini par le protocole TLS est 10. L’état d’erreur de Windows SChannel est 1203.

    Niveau :Erreur              Source : Schannel        ID de l'évenement : 36874   Catégorie : aucun

    Une alerte irrécupérable a été générée et envoyée au point de terminaison distant. Ceci peut entraîner l’arrêt de la connexion. Le code d’erreur irrécupérable défini par le protocole TLS est 10. L’état d’erreur de Windows SChannel est 1203.

    Je ne trouve pas la source du problème, merci de me venir en aide.

    En attente de vous lire,

    Cordialement

    mardi 29 avril 2014 10:05

Réponses

  • Il est fortement non recommandé d'installer Exchange sur un serveur qui dispose d'autres rôles.

    Je pense que votre role AD CS a écraser la partie IIS d'Exchange, il n'y a pas grand chose à faire : désinstaller Exchange si il n'y a pas d'utilisateurs, et l'installer sur un autre serveur.

    PS : de la meme maniere il n'est pas recommandé de cumuler ADDS et ADCS sur le meme serveur, les deux fonctionnent ensemble, mais vous serez fortement limité dans les choix de désinstallation.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    • Marqué comme réponse Sam2607 vendredi 25 juillet 2014 09:47
    jeudi 15 mai 2014 09:06
    Modérateur

Toutes les réponses

    • Marqué comme réponse Florin Ciuca mardi 6 mai 2014 06:06
    • Non marqué comme réponse Sam2607 lundi 19 mai 2014 08:10
    vendredi 2 mai 2014 13:27
  • Bonjour Florin,

    Merci pour votre réponse et votre renvoi vers le thread mais malheuresement mon problème persiste...

    Voici ce que j'obtiens lors du test autodiscover depuis un client Outlook :

    La résolution DNS autodiscover.mydomain.fr se fait correctement.

    Lorsque je vais sur les URLs pour accéder aux fichiers XMLs voici ce que j'obtiens.

    http://autodiscover.mydomain/autodiscover/autodiscover.xml :

    Erreur d'analyse XML : aucun élément trouvé
    Emplacement : http://autodiscover.gedaf-formation.fr/autodiscover/autodiscover.xml
    Numéro de ligne 1, Colonne 1 :
    ^

    https://autodiscover.mydomain/autodiscover/autodiscover.xml :

    Autodiscover><Response><Error Time="18:03:03.9416577" Id="3007185755"><ErrorCode>600</ErrorCode><Message>Demande non valide</Message><DebugData/></Error></Response></Autodiscover>

    Je n'ai pas la même chose, es-normal ?

    Merci à vous,

    Cordialement,


    • Modifié Sam2607 lundi 12 mai 2014 16:03
    lundi 12 mai 2014 15:55
  • Les erreurs SChannel sont liées à l'établissement du canal sécurisé, donc en général à un problème de certificat ou de sécurité. Je vous conseille d'utiliser l'outil de diagnostique de microsoft : https://testconnectivity.microsoft.com/. Celui-ci permet d'avoir un diagnostique relativement fin.

    Lorsque vous allez depuis un navigateur sur la page d'autodiscover, il est normal d'avoir un retour 

    Autodiscover><Response><Error Time="18:03:03.9416577" Id="3007185755"><ErrorCode>600</ErrorCode><Message>Demande non valide</Message><DebugData/></Error></Response></Autodiscover>


    En effet lors de la découverte par Outlook des paramètres sont passés à la page pour récupérer *vos* paramètres autodiscover, le fichier est généré par le serveur pour chaque requête.






    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mardi 13 mai 2014 06:51
    Modérateur
  • Bonjour Bruce,

    Effectivement lors du test de découverte automatique j'ai des erreurs lors des 4 étapes de tests :

                    L’analyseur de connectivité de Microsoft essaie de tester la découverte automatique pour abc@mydomain.fr... Merci de patienter.

                    Échec de la découverte automatique de test.

                    Détails supplémentaires

                    Étapes de test

                    Essai de chaque méthode pour contacter le service de découverte automatique.

                    Échec de contact du service de découverte automatique avec toute méthode.

                    Détails supplémentaires

    Temps écoulé : 421  ms.

                    Étapes de test

                    Tentative de test de l’URL potentielle de découverte automatique https://mydomain.fr/AutoDiscover/AutoDiscover.xml

                    Le test de cette URL de découverte automatique éventuelle a échoué.

                    Détails supplémentaires

                    Étapes de test               

                    Tentative de résolution du nom d'hôte mydomain.fr dans DNS.

                    Le nom d'hôte a été résolu correctement.

                    Détails supplémentaires

                    Test du port TCP 443 sur l'hôte mydomain.fr pour s'assurer qu'il écoute/est ouvert.

                    Le port a été ouvert correctement.

                    Détails supplémentaires

                    Test du certificat SSL pour confirmer sa validité.

                    Échec du certificat SSL à une ou plusieurs vérification(s) de validation de certificat.

                    Détails supplémentaires

                    Étapes de test

                    Tentative de test de l’URL potentielle de découverte automatique https://autodiscover.mydomain.fr/AutoDiscover/AutoDiscover.xml

                    Le test de cette URL de découverte automatique éventuelle a échoué.

                    Détails supplémentaires

                   

                    Étapes de test

                    Tentative de résolution du nom d'hôte autodiscover.mydomain.fr dans DNS.

                    Le nom d'hôte a été résolu correctement.

                    Détails supplémentaires

                    Test du port TCP 443 sur l'hôte autodiscover.mydomain.fr pour s'assurer qu'il écoute/est ouvert.

                    Le port a été ouvert correctement.

                    Détails supplémentaires

                    Test du certificat SSL pour confirmer sa validité.

                    Échec du certificat SSL à une ou plusieurs vérification(s) de validation de certificat.

                    Détails supplémentaires

                   

                    Étapes de test

                    Tentative de contact du service de découverte automatique à l'aide de la méthode de redirection HTTP.

                    La tentative de contact de découverte automatique à l'aide de la méthode de redirection HTTP a échoué.

                    Détails supplémentaires

                   

                    Étapes de test

                    Tentative de résolution du nom d'hôte autodiscover.mydomain.fr dans DNS.

                    Le nom d'hôte a été résolu correctement.

                    Détails supplémentaires

                    Test du port TCP 80 sur l'hôte autodiscover.mydomain.fr pour s'assurer qu'il écoute/est ouvert.

                    Le port a été ouvert correctement.

                    Détails supplémentaires

                    L’analyseur de connectivité de Microsoft vérifie la découverte automatique d'hôte mydomain.fr pour une redirection HTTP vers le service de découverte automatique... Merci de patienter.

                    Désolé... L’analyseur de connectivité de Microsoft n’a pas pu obtenir de réponse de redirection HTTP pour la découverte automatique.

                    Détails supplémentaires

                    Tentative de contact du service de découverte automatique à l'aide de la méthode de redirection DNS SRV.

                    Désolé... L’analyseur de connectivité de Microsoft n’a pas pu contacter le service de découverte automatique à l’aide de la méthode de redirection DNS SRV.

                    Détails supplémentaires

     

                    Étapes de test

                    Tentative pour localiser l’enregistrement SRV _autodiscover._tcp.mydomain.fr dans DNS.

                    Échec de recherche d'un enregistrement SRV de découverte automatique dans DNS.

                     En savoir plus sur ce problème et sa résolution

                    Détails supplémentaires


    D'après ces résultats j'aurais effectivement un problème de certificat, actuellement tous mes clients se connectent hors domaine avec le certificat installé sur leurs postes et ça fonctionne a part l'autodiscover.

    Mon certificat est valide jusqu'en 2019, il est installé sur mon serveur et comporte les objets suivants (Il y a 3 nom de domaines sur mon serveur) :

    exchange.mydomain.fr

    autodiscover.mydomain.fr

    autodiscover.mydomain1.fr

    autodiscover.mydomain2.fr

    exchange

    mydomain.fr

    mydomain1.fr

    mydomain2.fr

    Le certificat est affectés aux services suivants :

    SMTP

    IMAP

    POP

    IIS

    Je ne voit pas ce qu'il manque... merci pour votre aide.


    • Modifié Sam2607 mercredi 14 mai 2014 08:38
    mercredi 14 mai 2014 08:36
  • Pour informations complémentaire mon serveur se nomme Exchange.

    Lorsque je tente d'accéder à l'URL https://Exchange/certsrv , j'obtient une erreur.

    "HTTP ERROR 404.4 - NOT FOUND"

    "Erreur code : 0x80070002

    Cela est-il lié à IIS ?

    Dans mes services IIS : 

    =>EXCHANGE

          =>Default Web Site

    Volet de droite liasons  :

    Type         Nom de l'hôte   Port   Adresse IP  

    https        exchange         443      127.0.0.1

    Je clique dessus et je voit bien mon certificat SSL


    • Modifié Sam2607 mercredi 14 mai 2014 15:59
    mercredi 14 mai 2014 15:43
  • Avez-vous installé autre chose que Exchange sur ce serveur? Comme par exemple le rôle AD Domain Service ou AD Certificate Service?

    Votre configuration IIS ne semble pas correspondre à celle d'un serveur Exchange.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr


    jeudi 15 mai 2014 07:12
    Modérateur
  • Bonjour Bruce,

    C'est le seul serveur de mon organisation.

    j'ai effectivement les rôles AD Domain Service et AD Certificate Service d'installés.

    Le rôle AD Certificate Service n'est pas configuré, est-t-il nécessaire à la connexion de mes clients hors domaine ?

    Merci.


    • Modifié Sam2607 jeudi 15 mai 2014 08:52
    jeudi 15 mai 2014 08:46
  • Il est fortement non recommandé d'installer Exchange sur un serveur qui dispose d'autres rôles.

    Je pense que votre role AD CS a écraser la partie IIS d'Exchange, il n'y a pas grand chose à faire : désinstaller Exchange si il n'y a pas d'utilisateurs, et l'installer sur un autre serveur.

    PS : de la meme maniere il n'est pas recommandé de cumuler ADDS et ADCS sur le meme serveur, les deux fonctionnent ensemble, mais vous serez fortement limité dans les choix de désinstallation.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    • Marqué comme réponse Sam2607 vendredi 25 juillet 2014 09:47
    jeudi 15 mai 2014 09:06
    Modérateur
  • Le serveur est actuellement en production.

    Si je désinstalle le rôle ADCS et conserve mon rôle ADDS, je n'ai pas la possibilité de restaurer la partie IIS d'Exchange ?


    Ou de réinstaller les services IIS d'Exchange?

    • Modifié Sam2607 jeudi 15 mai 2014 09:57
    jeudi 15 mai 2014 09:25
  • Je vous conseille de désinstaller Exchange et de l'installer sur un autre serveur.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    vendredi 16 mai 2014 15:26
    Modérateur
  • Dans le cas ou ce serveur est hébergé sur une VM chez OVH... quelle seraient les opérations a faire?
    Comment migrer les BAL sur un nouveau serveur dans ce cas là?

    Nous n'avons jamais eu de problèmes sur les versions antérieures d'Exchange installés sur des contrôleurs de domaine, est ce dut à cette version uniquement?

    Il doit bien y avoir une possibilité de n'avoir qu'un seul serveur faisant AD et Exchange sur le même serveur, sans passer par du SBS malgré cet article:

    http://technet.microsoft.com/fr-fr/library/ms.exch.setupreadiness.warninginstallexchangerolesondomaincontroller%28v=exchg.150%29.aspx

    Merci pour vos précisions

    (PS je suis un collègue de Sam2607)

    lundi 19 mai 2014 06:57
  • Nous n'avons jamais eu de problèmes sur les versions antérieures d'Exchange installés sur des contrôleurs de domaine, est ce dut à cette version uniquement?

    Il n'a jamais été recommandé d'installer Exchange sur un DC (au moins depuis E2007), même si cela *pouvait* fonctionner, il y a toujours eu des effets de bords, ne serait ce que sur la désactivation du cache d'écriture des disques.

    Il doit bien y avoir une possibilité de n'avoir qu'un seul serveur faisant AD et Exchange sur le même serveur, sans passer par du SBS malgré cet article:

    Lorsque vous n'avez qu'un seul serveur physique, il est préférable d'y installer le rôle HyperV, et de virtualisé deux serveurs différents, l'un avec l'AD et l'autre Exchange. 

    Pour Exchange 2013, pour l'instant toutes les personnes qui ont essayé d'installer Exchange sur un DC se sont cassés les dents. 



    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mardi 20 mai 2014 08:12
    Modérateur
  • Merci pour votre réponse, nous y ferons plus attention dans nos futurs installations.

    Concernant notre problème actuel, nous avons créé une seconde VM, quelles seraient les étapes à suivre afin de solutionner notre situation.

    Exemple:

    1. intégration du second serveur dans le domaine
    2. installation Exchange2013 sur le second serveur
    3. migration des comptes
    4. migration des certificats
    5. suppression d'Exchange2013 sur le premier serveur

      ???

    Nous vous remercions par avance pour votre assistance.

    mardi 20 mai 2014 12:43
  • Bonjour, 

    J'intervertirais la partie 3 et 4, votre serveur, même vide, doit être parfaitement opérationnel avant de migrer des utilisateurs dessus. Sinon c'est effectivement cela.



    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mardi 20 mai 2014 12:53
    Modérateur
  • merci bien, nous allons regarder cela et ferons un retour ici même
    mardi 20 mai 2014 13:33
  • Bonjour,

    Suite à vos conseils nous avons :

    - Installé un nouveau serveur Exchange sur OVH (Exchange2013.mydomain.com)

    - Intégré au domaine

    - Migré les comptes sauf 7 où nous avons des erreurs dans les évenements (1050)

    - Crée un nouveau certificat (Exchange2013.mydomain.fr) car problème de nom lors des connexions outlook anywhere avec les clients

    - Modifié les DNS autodiscover.mydomain.fr pointant sur le nouveau serveur

    Aujourd'hui nous rencontrons deux problèmes.

    Le premier suite aux erreurs de migration des boîtes.

    Le second suite aux problèmes de connexion Outlook anywhere de nos client.Pour récapitulatif nous possédons dorénavant deux serveurs chez OVH.

    Le premier Exchange (nom interne et externe) ayant les services IIS HS et le second Exchange2013 (nom interne et externe) fonctionnel.

    Depuis un poste client dans les paramètres du proxy nous modifions l'adresse par celle du nouveau serveur : exchange2013.mydomain.fr

    le msstd par notre nouveau CN : exchange2013.mydomain.fr  

    Par contre, dès que nous fermons et réouvrons Outlook nous avons une erreur de certificat :

    "Un problème s'est produit au niveau du certificat de sécurité du serveur proxy.

    Le nom sur le certificat de sécurité n'est pas valide ou ne correspond pas au nom du site cible exchange.mydomain.fr.

    Outlook ne peut pas se connecter au serveur proxy. (Code d'erreur 0)."

    La connexion Outlook anywhere est forcée sur l'ancien serveur et non le nouveau.

    Sur les serveurs j'ai modifié les paramètres suivants :

    Set-OutlookProvider -Identity WEB -CertPrincipalName msstd:exchange2013.mydomain.fr

    Set-OutlookProvider -Identity EXCH -CertPrincipalName msstd:exchange2013.mydomain.fr

    Set-OutlookProvider -Identity EXPR -CertPrincipalName msstd:exchange2013.mydomain.fr

    Dans serveurs/serveurs/Exchange/Outlook Anywhere :

    Nom hôte externe : exchange2013.mydomain.fr (essayé exchange.mydomain.fr mais même problème)

    Nom hôte interne : exchange.mydomain.fr

    Méthode d'authentification : NTLM

    Dans serveurs/serveurs/Exchange2013/Outlook Anywhere :

    Nom hôte externe : exchange2013.mydomain.fr

    Nom hôte interne : exchange2013.mydomain.fr

    Méthode d'authentification : NTLM

    Volià pour les explications j'espère que c'est assez clair.

    Nous devons connecter nos clients manuellement c'est très gênant...

    Dans l'attente de vous lire, cordialement.

    Merci.



    • Modifié Sam2607 lundi 7 juillet 2014 08:21
    lundi 7 juillet 2014 07:43
  • Vous devriez essayer l'outil fourni par Microsoft : Remote Connectivity Analyzer : https://testconnectivity.microsoft.com/

    Vous allez pouvoir faire un diagnostic sur le protocole OA. Pour rappel, les paramètres de configuration de vos clients sont trouvés via l'autodiscover, celui-ci va construire ces paramètres selon les URL et méthodes d'authentification que vous avez indiquer.

    A minima pour un OA fonctionnel, vous devez avoir une méthode d'autodiscover publiée sur vos DNS internet (enregistrement Autodiscover, SRV ou racine), puis pour les VDir EWS et OAB les ExternalURL positionnées.

    Pour Outlook Anywhere, définir les paramètres ExternalHostname sur le nom sur Internet, et DefaultAuthenticationMethod sur BASIC Voici la cmdlet associée : http://technet.microsoft.com/fr-fr/library/bb123545%28v=exchg.150%29.aspx


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr


    lundi 7 juillet 2014 08:23
    Modérateur
  • Voici le résultat du test :

                    L’analyseur de connectivité de Microsoft essaie de tester la découverte automatique pour toto@mydomain.fr... Merci de patienter.

                    Échec de la découverte automatique de test.

                

                    Détails supplémentaires

                   

    Temps écoulé : 4276 ms.

                   

                    Étapes de test

                   

                    Essai de chaque méthode pour contacter le service de découverte automatique.

                    Échec de contact du service de découverte automatique avec toute méthode.

                   

                    Détails supplémentaires

                   

    Temps écoulé : 4276 ms.

                   

                    Étapes de test

                   

                    Tentative de test de l’URL potentielle de découverte automatique https://mydomain.fr:443/Autodiscover/Autodiscover.xml

                    Le test de cette URL de découverte automatique éventuelle a échoué.

                   

                    Détails supplémentaires

                   

                    Étapes de test

                   

                    Tentative de résolution du nom d'hôte mydomain.fr dans DNS.

                    Le nom d'hôte a été résolu correctement.

                   

                    Détails supplémentaires

                    Test du port TCP 443 sur l'hôte mydomain.fr pour s'assurer qu'il écoute/est ouvert.

                    Le port a été ouvert correctement.

                   

                    Détails supplémentaires

                    Test du certificat SSL pour confirmer sa validité.

                    Échec du certificat SSL à une ou plusieurs vérification(s) de validation de certificat.

                   

                    Détails supplémentaires

                   

                    Étapes de test

                    Tentative de test de l’URL potentielle de découverte automatique https://autodiscover.mydomain.fr:443/Autodiscover/Autodiscover.xml

                    Le test de cette URL de découverte automatique éventuelle a échoué.

                   

                    Détails supplémentaires

                   

                    Étapes de test

                   

                    Tentative de résolution du nom d'hôte autodiscover.mydomain.fr dans DNS.

                    Le nom d'hôte a été résolu correctement.

                   

                    Détails supplémentaires

                    Test du port TCP 443 sur l'hôte autodiscover.mydomain.fr pour s'assurer qu'il écoute/est ouvert.

                    Le port a été ouvert correctement.

                   

                    Détails supplémentaires

                    Test du certificat SSL pour confirmer sa validité.

                    Échec du certificat SSL à une ou plusieurs vérification(s) de validation de certificat.

                   

                    Détails supplémentaires

                   

                    Étapes de test

                    Tentative de contact du service de découverte automatique à l'aide de la méthode de redirection HTTP.

                    La tentative de contact de découverte automatique à l'aide de la méthode de redirection HTTP a échoué.

                   

                    Détails supplémentaires

                   

                    Étapes de test

                   

                    Tentative de résolution du nom d'hôte autodiscover.mydomain.fr dans DNS.

                    Le nom d'hôte a été résolu correctement.

                   

                    Détails supplémentaires

                    Test du port TCP 80 sur l'hôte autodiscover.mydomain.fr pour s'assurer qu'il écoute/est ouvert.

                    Le port a été ouvert correctement.

                   

                    Détails supplémentaires

                    L’analyseur de connectivité de Microsoft vérifie la découverte automatique d'hôte mydomain.fr pour une redirection HTTP vers le service de découverte automatique... Merci de patienter.

                    Désolé... L’analyseur de connectivité de Microsoft n’a pas pu obtenir de réponse de redirection HTTP pour la découverte automatique.

                   

                    Détails supplémentaires

                    Tentative de contact du service de découverte automatique à l'aide de la méthode de redirection DNS SRV.

                    Désolé... L’analyseur de connectivité de Microsoft n’a pas pu contacter le service de découverte automatique à l’aide de la méthode de redirection DNS SRV.

                   

                    Détails supplémentaires

                   

                    Étapes de test

                   

                    Tentative pour localiser l’enregistrement SRV _autodiscover._tcp.mydomain.fr dans DNS.

                    Échec de recherche d'un enregistrement SRV de découverte automatique dans DNS.

                     En savoir plus sur ce problème et sa résolution

                   

                    Détails supplémentaires

    Les champs DNS autodiscover sont bien renseignés par contre nous avons une erreur de certificat.

    Est-il nécessaire de rajouter les champs SRV ?

    Comment positionner les VDir EWS et OAB sur les ExternalURL ?

    Pour info supplémentaire lorsque je supprime le certificat de l'ancien serveur Exchange et que je ré-ouvre Outlook, il me demande d'installer celui-ci. Je pense qu' un paramètre sur le serveur doit pousser la connexion autodiscover sur l'ancien serveur.

    merci d'avance.


    • Modifié Sam2607 lundi 7 juillet 2014 09:23
    lundi 7 juillet 2014 09:11
  • Vous n'avez besoin que d'une méthode, la plus connue étant celle du type https://autodiscover.<domaine de messagerie>/autodiscover/autodiscover.xml

    Il faut que votre certificat dispose du nom autodiscover.<domaine de messagerie> dans ses entrées SAN.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    lundi 7 juillet 2014 09:45
    Modérateur
  • l'Autodiscover est déjà renseigné dans le certificat avec chaque domaines du serveur.

    Lorsqu'on reconfigure nos clients Outlook sur le nouveau serveur (adresse de serveur + proxy), nous obtenons ce message d'erreur:

    Il nous demande généralement ensuite de retaper le mot de passe du compte et ça passe.

    mardi 8 juillet 2014 07:00
  • Pour info supplémentaire :

    (A savoir : Exchange = Ancien serveur, Exchange2013 = nouveau serveur=

    [PS] C:\Windows\system32>Get-WebServicesVirtualDirectory | fl identity,internalurl,externalurl

    Identity    : EXCHANGE\EWS (Default Web Site)
    InternalUrl : https://exchange.mydomain.fr/EWS/Exchange.asmx
    ExternalUrl : https://exchange.mydomain.fr/ews/exchange.asmx

    Identity    : EXCHANGE2013\EWS (Default Web Site)
    InternalUrl : https://exchange2013.mydomain.fr/EWS/Exchange.asmx
    ExternalUrl : https://exchange2013.mydomain.fr/EWS/exchange.asmx

    [PS] C:\Windows\system32>Get-OabVirtualDirectory | fl identity,internalurl,externalurl

    Identity    : EXCHANGE\OAB (Default Web Site)
    InternalUrl : https://exchange.mydomain.fr/OAB
    ExternalUrl :

    Identity    : EXCHANGE2013\OAB (Default Web Site)
    InternalUrl : https://exchange2013.mydomain.fr/OAB
    ExternalUrl :

    [PS] C:\Windows\system32>Get-ClientAccessServer | fl identity,internalurl,externalurl

    Identity : EXCHANGE
    Identity : EXCHANGE2013

    Pour Outlook anywhere :

    [PS] C:\Windows\system32>Get-OutlookAnywhere


    RunspaceId                         : b7566e33-85a6-46fd-b7cf-687965d6dfe4
    ServerName                         : EXCHANGE
    SSLOffloading                      : False
    ExternalHostname                   : exchange.mydomain.fr
    InternalHostname                   : exchange.mydomain.fr
    ExternalClientAuthenticationMethod : Ntlm
    InternalClientAuthenticationMethod : Ntlm
    IISAuthenticationMethods           : {Basic, Ntlm, Negotiate}
    XropUrl                            :
    ExternalClientsRequireSsl          : True
    InternalClientsRequireSsl          : True
    MetabasePath                       : IIS://Exchange.mydomain.fr/W3SVC/1/ROOT/Rpc
    Path                               : C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\rpc
    ExtendedProtectionTokenChecking    : None
    ExtendedProtectionFlags            : {}
    ExtendedProtectionSPNList          : {}
    AdminDisplayVersion                : Version 15.0 (Build 775.38)
    Server                             : EXCHANGE
    AdminDisplayName                   :
    ExchangeVersion                    : 0.20 (15.0.0.0)
    Name                               : Rpc (Default Web Site)
    DistinguishedName                  : CN=Rpc (Default Web Site),CN=HTTP,CN=Protocols,CN=EXCHANGE,CN=Servers,CN=Exchange
                                         Administrative Group (FYDIBOHF23SPDLT),CN=Administrative
                                         Groups,CN=gedaf-formation,CN=Microsoft
                                         Exchange,CN=Services,CN=Configuration,DC=gedaf-formation,DC=fr
    Identity                           : EXCHANGE\Rpc (Default Web Site)
    Guid                               : 401be16e-8c4e-4bb2-badf-a6c788a6f57f
    ObjectCategory                     : mydomain.fr/Configuration/Schema/ms-Exch-Rpc-Http-Virtual-Directory
    ObjectClass                        : {top, msExchVirtualDirectory, msExchRpcHttpVirtualDirectory}
    WhenChanged                        : 07/07/2014 17:07:58
    WhenCreated                        : 18/12/2013 14:59:58
    WhenChangedUTC                     : 07/07/2014 15:07:58
    WhenCreatedUTC                     : 18/12/2013 13:59:58
    OrganizationId                     :
    OriginatingServer                  : Exchange.mydomain.fr
    IsValid                            : True
    ObjectState                        : Changed

    RunspaceId                         : b7566e33-85a6-46fd-b7cf-687965d6dfe4
    ServerName                         : EXCHANGE2013
    SSLOffloading                      : False
    ExternalHostname                   : exchange2013.mydomain.fr
    InternalHostname                   : exchange2013.mydomain.fr
    ExternalClientAuthenticationMethod : Ntlm
    InternalClientAuthenticationMethod : Ntlm
    IISAuthenticationMethods           : {Basic, Ntlm, Negotiate}
    XropUrl                            :
    ExternalClientsRequireSsl          : True
    InternalClientsRequireSsl          : True
    MetabasePath                       : IIS://EXCHANGE2013.mydomain.fr/W3SVC/1/ROOT/Rpc
    Path                               : C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\rpc
    ExtendedProtectionTokenChecking    : None
    ExtendedProtectionFlags            : {}
    ExtendedProtectionSPNList          : {}
    AdminDisplayVersion                : Version 15.0 (Build 775.38)
    Server                             : EXCHANGE2013
    AdminDisplayName                   :
    ExchangeVersion                    : 0.20 (15.0.0.0)
    Name                               : Rpc (Default Web Site)
    DistinguishedName                  : CN=Rpc (Default Web
                                         Site),CN=HTTP,CN=Protocols,CN=EXCHANGE2013,CN=Servers,CN=Exchange Administrative
                                         Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=gedaf-formation,CN=Microsoft
                                         Exchange,CN=Services,CN=Configuration,DC=gedaf-formation,DC=fr
    Identity                           : EXCHANGE2013\Rpc (Default Web Site)
    Guid                               : f7cbd769-01f3-4134-ac78-cf1770983e72
    ObjectCategory                     : mydomain.fr/Configuration/Schema/ms-Exch-Rpc-Http-Virtual-Directory
    ObjectClass                        : {top, msExchVirtualDirectory, msExchRpcHttpVirtualDirectory}
    WhenChanged                        : 07/07/2014 17:08:14
    WhenCreated                        : 23/06/2014 17:29:57
    WhenChangedUTC                     : 07/07/2014 15:08:14
    WhenCreatedUTC                     : 23/06/2014 15:29:57
    OrganizationId                     :
    OriginatingServer                  : Exchange.mydomain.fr
    IsValid                            : True
    ObjectState                        : Changed


    • Modifié Sam2607 jeudi 10 juillet 2014 15:14
    mercredi 9 juillet 2014 16:06

  • Bonjour,

    Voici ce qui est mis en place :

    [PS] C:\Windows\system32>Get-OutlookProvider

    Name                          Server                        CertPrincipalName             TTL
    ----                          ------                        -----------------             ---
    EXCH                                                        msstd:exchange2013.mydomai... 1
    EXPR                                                        msstd:exchange2013.mydomai... 1
    WEB                                                         msstd:exchange2013.mydomai... 1

    Peut-on forcer la connexion à notre nouveau serveur avec la commande suivante :

    Set-OutlookProvider EXPR -Server exchange2013.mydomain.fr

    Et autoriser nos 2 certificats avec celle-ci :

    Set-OutlookProvider EXPR -CertPrincipalName msstd:*.mydomain.fr

    Merci d'avance pour votre retour.


    • Modifié Sam2607 vendredi 11 juillet 2014 08:25
    vendredi 11 juillet 2014 07:40
  • Bonjour,

    vous devez refaire votre certificat ! Il ne contient plus le nom correct du serveur Exchange.

    L'erreur se fait sur le nom "Exchange.mydomain.fr" alors que le serveur s'appelle maintenant Exchange2013.

    A noter que le nom "Exchange" pour le serveur de messagerie n'est pas du tout conseillé... Certains problèmes ont déjà été constatés au moment de passer en configuration de type Cluster/Dag.

    A bientôt,


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(80 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    vendredi 11 juillet 2014 12:16
    Modérateur
  • Bonjour,

    Nous avons déjà refait un certificat au nom du nouveau serveur : CN=Exchange2013.mydomain.fr .

    Au niveau des clients Outlook (Anywhere), au démarrage nous avons l'erreur de certificat mentionné plus haut, mais nous constatons aussi que nous perdons le bon URL proxy aléatoirement à chaque redémarrage.

    Au lieu d'avoir exchange2013.mydomain.fr nous constatons exchange.mydomain.fr.

    J'ai l'impression qu'un paramètre pousse sur l'ancien serveur...

    D'autant plus que dans l'erreur de certificat il est mentionné comme hôte cible l'ancien serveur exchange.mydomain.fr.

    Merci pour l'info nous y penserons pour nos futures installations.

    Et merci aussi d'avoir pris le temps de nous répondre, dans l'attente de vos retours.

    Cordialement.

    vendredi 11 juillet 2014 14:38
  • Pour information, lorsque je fais un test autodiscover depuis Outlook j'obtiens cela:




    Il fait bien appel aux 2 serveurs, est ce un problème de rôles?

    vendredi 11 juillet 2014 15:10
  • Le problème peut-il venir de là ?

    [PS] C:\Windows\system32>get-autodiscoverVirtualDirectory | fl identity,internalurl,externalurl


    Identity    : EXCHANGE\Autodiscover (Default Web Site)
    InternalUrl :
    ExternalUrl :

    Identity    : EXCHANGE2013\Autodiscover (Default Web Site)
    InternalUrl :
    ExternalUrl :

    Merci.

    mardi 15 juillet 2014 15:13
  • Pour précision supplémentaire voici la config :

    [PS] C:\Windows\system32>Get-AutodiscoverVirtualDirectory | fl identity,internalurl,externalurl


    Identity    : EXCHANGE\Autodiscover (Default Web Site)
    InternalUrl :
    ExternalUrl :

    Identity    : EXCHANGE2013\Autodiscover (Default Web Site)
    InternalUrl :
    ExternalUrl :



    [PS] C:\Windows\system32>Get-ClientAccessServer | fl identity,AutodiscoverServiceInternalUri


    Identity                       : EXCHANGE
    AutoDiscoverServiceInternalUri : https://exchange2013.mydomain.fr/Autodiscover/autodiscover.xml

    Identity                       : EXCHANGE2013
    AutoDiscoverServiceInternalUri : https://exchange2013.mydomain.fr/Autodiscover/Autodiscover.xml



    [PS] C:\Windows\system32>Get-WebServicesVirtualDirectory | fl identity,internalurl,externalurl


    Identity    : EXCHANGE\EWS (Default Web Site)
    InternalUrl : https://exchange.mydomain.fr/EWS/Exchange.asmx
    ExternalUrl : https://exchange.mydomain.fr/ews/exchange.asmx

    Identity    : EXCHANGE2013\EWS (Default Web Site)
    InternalUrl : https://exchange2013.mydomain.fr/EWS/Exchange.asmx
    ExternalUrl : https://exchange2013.mydomain.fr/EWS/exchange.asmx



    [PS] C:\Windows\system32>Get-OabVirtualDirectory | fl identity,internalurl,externalurl


    Identity    : EXCHANGE\OAB (Default Web Site)
    InternalUrl : https://exchange.mydomain.fr/OAB
    ExternalUrl :

    Identity    : EXCHANGE2013\OAB (Default Web Site)
    InternalUrl : https://exchange2013.mydomain.fr/OAB
    ExternalUrl : https://exchange2013.mydomain.fr/OAB



    [PS] C:\Windows\system32>Get-OwaVirtualDirectory | fl identity,internalurl,externalurl


    Identity    : EXCHANGE\owa (Default Web Site)
    InternalUrl : https://exchange.mydomain.fr/owa
    ExternalUrl :

    Identity    : EXCHANGE2013\owa (Default Web Site)
    InternalUrl : https://exchange2013.mydomain.fr/owa
    ExternalUrl : https://exchange2013.mydomain.fr/owa



    [PS] C:\Windows\system32>Get-EcpVirtualDirectory | fl identity,internalurl,externalurl


    Identity    : EXCHANGE\ecp (Default Web Site)
    InternalUrl : https://exchange.mydomain.fr/ecp
    ExternalUrl :

    Identity    : EXCHANGE2013\ecp (Default Web Site)
    InternalUrl : https://exchange2013.mydomain.fr/ecp
    ExternalUrl : https://exchange2013.mydomain.fr/ecp



    [PS] C:\Windows\system32>Get-ActiveSyncVirtualDirectory | fl identity,internalurl,externalurl


    Identity    : EXCHANGE\Microsoft-Server-ActiveSync (Default Web Site)
    InternalUrl : https://exchange.mydomain.fr/Microsoft-Server-ActiveSync
    ExternalUrl :

    Identity    : EXCHANGE2013\Microsoft-Server-ActiveSync (Default Web Site)
    InternalUrl : https://exchange2013.mydomain.fr/Microsoft-Server-ActiveSync
    ExternalUrl : https://exchange2013.mydomain.fr/Microsoft-Server-ActiveSync



    [PS] C:\Windows\system32>Get-OutlookAnywhere | fl identity,internalhostname,externalhostname


    Identity         : EXCHANGE\Rpc (Default Web Site)
    InternalHostname : exchange.mydomain.fr
    ExternalHostname : exchange.mydomain.fr

    Identity         : EXCHANGE2013\Rpc (Default Web Site)
    InternalHostname : exchange2013.mydomain.fr
    ExternalHostname : exchange2013.mydomain.fr

    mardi 22 juillet 2014 15:56