none
Issues moving and importing .mp4 files

    Question

  • Hi, I'm a SharePoint sub site owner and I regularly record, edit and produce videos in a video source file library.  Videos are produced in .mp4 format with video player.  Supporting files for source videos are zipped and the mp4 remains a stand-alone file. Only site owners have access to source files.  The aim is then to transfer only the .mp4 file into a site member library, so that zipped files and folders are not seen by video end users.  I've tried copying, moving, saving and importing .mp4 files in several ways so that just the .mp4 file is visible in the member library, but on each occasion, the file is automatically placed under a new sub-folder that SharePoint auto-generates and alongside the .mp4 file in the same sub-folder are 2 additional sub-folders called "Preview images" & "Additional Content".  Both of these sub-folders are always empty.  No matter how many times I try to move the .mp4 file to the master directory and delete the folder within which it is embedded, along with its sub-folders, the .mp4 file is deleted upon deletion of the linked folders.  Any pointers, please?  Thanks


    • Modifié Lisareyno lundi 2 juillet 2018 15:26
    lundi 2 juillet 2018 15:24

Toutes les réponses

  • Hi Lisareyno,

    How did you create the site member library? Could you please provide the screenshot?

    Per my test in my SharePoint 2013 environment, I create the asset library and upload the .mp4 file. There are no sub folders called "Preview images" & "Additional Content". 

    And I suggest you could use asset library to store the .mp4 files.

    More reference:

    Set up an Asset Library to store image, audio, or video files.

    https://support.office.com/en-us/article/set-up-an-asset-library-to-store-image-audio-or-video-files-96532bf6-dc72-4f82-bf0a-21ef945c4d04

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    mardi 3 juillet 2018 07:43
    Modérateur
  • Hello Sara,

    That's interesting.  The videos are not being stored as assets.  At the moment, the files are stored in a document library because there are videos and documents supporting the same content... so to facilitate navigation, usability and management, we would really like to keep PDF and MP4 files in the same series of system divided content libraries.  In addition to which, content in these libraries is shared with different user groups in different ways, based on a filtered control column.  I will certainly test the use of an asset library, but not sure that this is a real option for us.  This issue has only recently presented itself, had no such difficulties previously, so it's a little frustrating.

    Thank you for the suggestion, though.

    Lisa

    mardi 3 juillet 2018 08:41
  • Hi Lisareyno,

    How is everything going?

    Is there anything update about this issue?


    Best regards,

    Sara Fan

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    jeudi 5 juillet 2018 09:28
    Modérateur
  • Hello Sara,

    I added an asset library app today and tested .mp4 upload.  I have exactly the same problem in this type of library as I do a document library.  The .mp4 file uploads and then moments later, it is embedded in a folder with 2 additional subfolders.  I've tried to attach a screen shot showing the file alongside the sub folders and the breadcrumb showing that all have been dropped into a parent folder, but I can't upload until account verification is complete.  Is there a configuration that might be causing this?

    As a point of note, I have noticed that if the file is moved and surplus folders deleted whilst in Tiles view, the folders are not re-created, but the same is not true in List view mode.

    Thanks

    Lisa



    • Modifié Lisareyno vendredi 6 juillet 2018 15:07
    vendredi 6 juillet 2018 14:40
  • Hi Lisareyno,

    To troubleshoot the issue, check things below:

    1. Create a new site and upload the .mp4 file to the new site to check if the same issue will occur.

    2. Check if there is workflow in the site to create the folder when uploading the file.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    lundi 9 juillet 2018 09:44
    Modérateur
  • Hello Sara,

    The site that I'm currently using was created as a new site for the purposes of the content that it holds.  Content migration was completed in May and we are now beginning to supplement content.  I can confirm that there are no workflows for this site.  I am the site owner.

    Kind regards

    Lisa

    mardi 10 juillet 2018 08:40
  • Hi Lisareyno,

    To troubleshoot the issue, you could reset to site definition.

    Go to site settings->site actions-> reset to site definition-> Reset all pages in this site to site definition version.

    And then RESET IIS.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    vendredi 13 juillet 2018 09:38
    Modérateur
  • Hi Lisareyno,

    How is everything going?

    Is there anything update about this issue?

    Best regards,

    Sara Fan

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    lundi 16 juillet 2018 01:22
    Modérateur
  • Hi Lisareyno,

    I am checking to see how things are going there on this issue. Please let us know if you would like further assistance.

    If the issue was resolved, you can mark the helpful post as answer to help other community members find the helpful information quickly. 

    Best regards,

    Sara Fan

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    jeudi 19 juillet 2018 01:41
    Modérateur