none
Redémarrage aprés install d'une application RRS feed

  • Question

  • Bonjour,

    Je souhaites faire quelque chose qui me paraissait pourtant simple dans l'idée mais qui au final, s'avère plus compliqué que prévu.

    J'ai packagé une application afin de la déployer via le centre de logiciel. Il s'agit d'un .exe.

    Aprés l'installation de cette application via le centre de logiciel, je souhaiterai redémarrer le poste car seul un redémarrage permettra à l'application de fonctionner correctement.

    Une idée de comment lancer la commande de redémarrage de manière automatique.

    J'ai pensé à utiliser la commande shutdown via un fichier *.cmd que j'ajouterai en déploiement supplémentaire dans l'application mais ce dernier ne se lance pas. (j'ai pourtant changé la méthode de détection mais rien n'y fait)

    D'avance merci pour vos réponses

    vendredi 20 avril 2018 14:24

Réponses

  • Je n'ai malheureusement pas réussi à forcer le redémarrage avec cette méthode. Je suis parvenu à faire afficher par le centre de logiciel la nécessité de redémarrer le poste mais le redémarrage ne se lance pas automatiquement et immédiatement aprés l'installation.

    J'ai donc opté pour un fichier en .cmd dans lequel j'ajoute une ligne shutdown /r /f  et ça fonctionne

    Merci quand même :-)

    mardi 24 avril 2018 13:06

Toutes les réponses

  • Bonjour,

    Vous pouvez très bien avoir dans le package de votre application :

    le fichier .exe

    un fichier .cmd

    dans le fichier .cmd vous auriez :

    setup.exe /S 

    exit "n° retour qui nécessite un reboot"

    Pour les msi c'est 3010 par exemple.

    Il faut savoir lequel c'est pour votre exe à vous et ainsi un redémarrage sera nécessaire


    Merci de marquer comme reponses les interventions qui vous ont ete utile.

    samedi 21 avril 2018 15:47
  • Je n'ai malheureusement pas réussi à forcer le redémarrage avec cette méthode. Je suis parvenu à faire afficher par le centre de logiciel la nécessité de redémarrer le poste mais le redémarrage ne se lance pas automatiquement et immédiatement aprés l'installation.

    J'ai donc opté pour un fichier en .cmd dans lequel j'ajoute une ligne shutdown /r /f  et ça fonctionne

    Merci quand même :-)

    mardi 24 avril 2018 13:06