none
Installation de CRM 3.0 sur Windows Server 2003 / SQL Server 2005 RRS feed

  • Question

  • Bonjour,

    Je bute sur l'installation de la CRM 3.0 sur Windows Server 2003 Small Business.

    Voici le message d'erreur que j'obtiens :

    Configuration requise

    Résultats

    Entrée utilisateur Microsoft CRM Server

    Un ou plusieurs groupes Microsoft CRM n'existent pas

    Microsoft SQL Server Reporting Services

    Le site Web Site Web par défaut permettant d'installer SQL Server Reporting Services contient déjà les répertoires ...

    Les bases de données suivantes existent déjà sur le serveur SQL spécifié : ReportServer et ReportServer...


    J'ai suivi le tutorial : http://fablain.developpez.com/tutoriel/crm/install-server/

    Passer l'étape "Aidez nous à améliorer le produit" je tombe directement sur le résumé des composants manquant.

    je ne passe même pas les étapes de sélection de l'emplacement d'installation, du site web, du serveur sql, du serveur Reporting Services, du l'unité de l'organisation,...

    Je précise que c'est une VM Server 2003 sur machine hôte Windows Server 2016 64bits.

    Pouvez vous m'aider à poursuivre l'installation.

    En vous remerciant d'avance.

    vendredi 9 juin 2017 11:48

Toutes les réponses

  • Bonjour,

    Attention Windows Server 2003 n'est plus supporter et représente une faille de sécurité dans un système d'information. Dynamics CRM 3.0 aussi https://blogs.msdn.microsoft.com/crm/2016/04/07/microsoft-dynamics-crm-3-0-support-lifecycle-announcement/ .

    Voici par contre des tutoriaux qui peuvent néanmoins t'aider:


    Cordialement,

    Yannick VILSANS

    • Proposé comme réponse matteu31400 dimanche 11 juin 2017 15:44
    dimanche 11 juin 2017 15:27
  • Bonjour,

    En fait je recherche à récupérer ma base de données (trois fichier en .bak).

    Notre serveur physique 2003 est tombé et nous avons acheté un serveur Windows 2016 pour prendre la relève.

    L'idée était de créer une machine virtuelle 2003 et de récupérer cette base de données dessus.

    Je vais essayer tes liens .

    Merci.

    lundi 12 juin 2017 06:47
  • Les liens n'ont pas pu m'aider...

    Y a t il quelque chose à faire sur le serveur SQL après son installation pour le préparer à la CRM?

    Il semble que les pré-requis ne sont pas tous présents ce qui explique pourquoi j'ai ces messages d'erreur.

    lundi 12 juin 2017 07:08
  • J'ai réussi à avancer dans mon installation. En fait il fallait choisur l'installation personnalisée et non standard.

    J'obtiens toutefois encore une dernière erreur :

    Impossible d'ouvrir le fichier physique 'D:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data\TEST_MSCRM.mdf'.
    Erreur du système d'exploitation 2 : '2(Le fichier spécifié est introuvable.)'.

    En recherchant un peu, il s'avère qu'en créant une clé de registre dans HKLM\software\microsoft\MSCRM cela aura pour effet de supprimer les messages de diagnostic.

    voici le forum dans lequel j'ai trouvé l'information :

    http://microsoft.public.fr.crm.narkive.com/AQkOlUe7/crm-3-0-fr-installation-avec-sql-server-2005-erreur-de-creation-de-base-de-donnees

    Cependant impossible de trouver le registre MSCRM.

    Quelqu'un a t il une idée?

    mardi 13 juin 2017 15:03
  • Bonjour,

    Dans le poste précédent il par le de langue. as tu essayé justement de modifier la langue de tes utilisateurs?

    concernant ta clef de registre tu peux créer une DWORD avec le nom IgnoreChecks et la valeurs 1 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM]

    http://gustafwesterlund.blogspot.com/2011/05/ignoring-system-checks-during.html

    Cordialement,

    Yannick VILSANS

    mardi 13 juin 2017 18:10
  • Oui j'ai enfin pu installé la CRM 3.0 avec l'idée de la langue mais pas avec le BUILTIN/Administrateur mais avec le nom que j'ai donné à mon organisation.

    En fait, cela a pour effet de créer un compte qui possède les mêmes attributs que BUILTIN/Administrateur.

    J'ai donc passé du Français à l'Anglais et pousuivi mon installation.

    Il n'y a plus eu d'erreur.

    C'est vrai qu'installer un système qui date de plus de 10 ans sans documentation n'est pas de tout repos...

    Merci encore pour ton aide.

    mercredi 14 juin 2017 05:22
  • Rebonjour,

    J'ai toujours un problème.

    L'installation s'est bien passée et je peux voir que la CRM est bien démarrée.

    Cependant lorsuqe je passe à l'assistant de confiuration ou directement sur la console de gestion des serveurs, le service CRM ne semble pas répondre.

    Par exemple lorsque j'essaie de créer des utilisateurs, il me dit :

    le serveur http://test:5555/MSCRMServices/ ne répond pas. Causes possibles : le serveur est temporairement indisponible, il ne s'agit pas d'un serveur Microsoft CRM ou vous ne disposez pas de privilèges suffisant pour exécuter le gestionnaires des utilisateurs.

    Pouvez vous m'aider ?

    mercredi 14 juin 2017 09:28
  • J'ai trouvé l'erreur : en fait il fallait garder la base de données nouvellement créée et configurer ainsi le serveur CRM.

    il doit y avoir un ID ou un numéro d'instance affecté à la base de donnée à partir de laquelle a été faite l'installation de la CRM.

    L'assistant de configuration me créer un utilisateur CRM en prenant le compte Administrateur.

    Bref cela se passe bien le serveur CRM semble marcher.

    Toutefois le but est de pouvoir restaurer l'ancienne base de donnée. La restauration de la base METABASE se déroule bien main pour la base MSCRM, j'obtiens l'erreur : Impossible d'obtenir l'accès exclusif car la base de données est en cours d'utilisation

     En recherchant un peu, le problème semble lier aux utilisateur connectés sur la base de données.

     J'ai trouvé une astuce pour "éjecter les utilisateurs" sur ce forum :

    http://codes-sources.commentcamarche.net/forum/affich-726982-prob-de-restauration-base-de-donnees

    mais cela ne semble pas marcher dans mon cas...

    mercredi 14 juin 2017 15:03