none
erreur Live migration sous win2016 essentiel RRS feed

  • Discussion générale

  • bonjour,

    je viens d'installer deux serveurs en win2016 avec HyperV dessus.

    je voudrais teste la live migration de l'un a l'autre mais j'ai un superbe message d'erreur :

    "Échec de l'opération de migration d'ordinateur virtuel à l'emplacement source de la migration; Échec de l’établissement d'une connexion avec l’hôte XXX: Aucune information d'identification n'est disponible dans le package de securité ( 0X8009030E)). Le service de gestion d'ordinateurs virtuels n'a pas pu authentifier la connexion d'une migration d'ordinateur virtuel au niveau de l’hôte source: aucune information d’identification appropriée n'est disponible. Assurez vous que l’opération est initiée sur l’hôte source de la migration ou que l’hôte source est configure pour utiliser kerberos pour l'authentification des connexion de migration et que la delegation contrainte est activée pour l’hôte dans l'AD etc......."

     à savoir que mes deux serveurs sont en mode core, je bosses dessus grace un un pc de gestion en win10 entp. le parefeu est désactivé, ils sont tous les 3 dans le meme domaine. j'utilise un compte admin du domaine pour effectuer mes tests.

    Mes hyperv sont paramétrés pour les migrations dynamique avec la bonne plage ip, en kerberos. Sur les comptes ad des serveurs j'ai bien les delagations de mise en place (cifs et microsoft virtual system migration service)

    j'ai plus trop d'idée, merci de votre aide

    mardi 9 octobre 2018 11:47

Toutes les réponses

  • Bonjour Cendy,

    Peut être ces liens pourrons t'aider :

    GRAPHIQUE 2012

    https://www.it-connect.fr/hyper-v-comment-utiliser-la-live-migration/

    POWERSHELL 2016

    https://www.tech-coffee.net/2-node-hyperconverged-cluster-with-windows-server-2016/


    "Marquer comme réponse" les réponses qui ont résolu votre problème

    mardi 9 octobre 2018 13:57
  • bonjour,

    merci pour tes liens, donc pour le premier je l'avais deja suivi, j'ai effectué la derniere manipulation ( le restant etant effectué tout pareil :))

    donc la commande:

    (Compare-VM -Name "VM01" -DestinationHost "HYPERV2").Incompatibilities  et

    (Compare-VM -Name "VM01" -DestinationHost "HYPERV2").Incompatibilities | Ft Message

    me renvoi le message

    Compare-VM : Échec de l'opération sur l'ordinateur SRv-XXX : WinRM ne peut pas traiter la demande. L’erreur
    suivante s’est produite avec le code d’erreur 0x8009030e lors de l’utilisation de l’authentification Kerberos: Une
    ouverture de session spécifiée n’existe pas. Elle est peut-être déjà terminée.
     Causes possibles :
      -Le nom d’utilisateur ou le mot de passe spécifié n’est pas valide.
      -Kerberos est utilisé alors qu’aucune méthode d’authentification ni aucun nom d’utilisateur ne sont spécifiés.
      -Kerberos accepte les noms d’utilisateur de domaine, mais pas les noms d’utilisateur local.
      -Le nom de principal du service correspondant au nom et au port de l’ordinateur distant n’existe pas.
      -L’ordinateur client et l’ordinateur distant sont dans des domaines différents et il n’existe pas d’approbation
    entre ces domaines.
     Après avoir vérifié les problèmes ci-dessus, essayez les solutions suivantes :
      -Consultez les événements liés à l’authentification dans l’Observateur d’événements.
      -Changez de méthode d’authentification, ajoutez l’ordinateur de destination au paramètre de configuration
    TrustedHosts pour WinRM ou utilisez le transport HTTPS.
     Notez que les ordinateurs de la liste TrustedHosts ne sont peut-être pas authentifiés.
       -Pour plus d’informations sur la configuration de WinRM, exécutez la commande suivante : winrm help config.
    Au caractère Ligne:1 : 2
    + (Compare-VM -Name "WIN2016T" -DestinationHost "SRV-XXX" ...
    +  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Compare-VM], VirtualizationException
        + FullyQualifiedErrorId : Unspecified,Microsoft.HyperV.PowerShell.Commands.CompareVM

    dans la liste de causes possible tout m'a l'air bon

    Le second lien est super je ne le connaissais pas merci je vais aller voir j'ai deja fait quelque modif note dedans,

    j'ai essaye aussi cela

    https://www.it-connect.fr/powershell-remoting-avec-winrm/

    mais rien

    j'ai verifier ensuite ceux ci :https://www.it-connect.fr/powershell-remoting-avec-winrm/

    donc le service est bien demarre sur les 2 serveurs

    mardi 9 octobre 2018 15:36
  • bonjour,

    alors apres plusieurs recherches, il s'est avere que j'avais change de dhcp,

    les dns avaient gardes ces vieilles adresses et donc impossible d'effectuer mes deplacements,

    voila un truc tout bete

    merci pour l'aide

    mercredi 5 décembre 2018 12:49