none
Configuration FTP RRS feed

  • Question

  • Bonjour,

    Y aurait-il un lien pas à pas avec images à l'appuis qui indique comment configurer un serveur FTP sur Windows server 2012 car j'ai beau suivre les indications sur le site de microsoft  mais sa ne fonctionne pas.

    Dès que je mets l'options «isolate users» à user name directory, plus moyen de se connecter, j'ai tout refait les droits sans succès.

    Pourtant j'ai fait cette même configuration sur un serveur Windows 2008 sans problèmes.

    Quelqu'un peut m'aider ?

    Merci et bonne journée!

    jeudi 16 juillet 2015 15:44

Réponses

  • Bonjour,

    J'ai finalement trouvé une solution et c'est tout simple, il suffit de passer par le NETBIOS:

    C:\inetpub\ftproot\NETBIOSNAME\USERNAME

    À noter, dans mon cas que ftproot\DOMAINNAME ou ftproot\LOCALUSER ne fonctionne pas

    Ce billet est donc considéré comme résolu!

    Merci à tous et spécialement à Nathanaël pour ton support...

    • Marqué comme réponse PierreTellier mercredi 24 février 2016 15:39
    mercredi 24 février 2016 15:39
  • Bonjour Pierre Tellier,

    Voici des pistes suggérées sur un autre forum, en espérant que cela puisse vous aider.

    Cordialement

    Emile


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    • Proposé comme réponse Emile Supiot mercredi 12 août 2015 08:03
    • Marqué comme réponse Emile Supiot mercredi 19 août 2015 09:32
    jeudi 6 août 2015 09:50

Toutes les réponses

  • Bonjour,

    voici un lien pas à pas.

    Un autre lien vers des videos.

    A+


    L’information n’a de valeur que si elle est partagée!! AK |Mon Blog|


    jeudi 16 juillet 2015 15:59
  • Bonjour,

    Merci Ahmed les liens, j'avais vue et essayé le premier mais sans succès.

    En gros j'essaie tout comme sur mon serveur 2008 utiliser l'option «User Isolation» afin de permettre à chaque utilisateur de n'avoir que son répertoire d'affiché en passant par le même site FTP. Il me manque forcément une configuration quelque part car sa ne fonctionne pas, je n'ai pas de message d'erreur, c'est simplement qu'il me demande sans cesse le mot de passe.

    Je suis ouvert à d'autres suggestions...

    Merci à l'avance à tous!

    jeudi 16 juillet 2015 17:18
  • Bonjour à nouveau,

    Toujours pas trouvé le problème, à mon avis il s'agit d'un histoire de droits car si je n'utilise pas l'option «isolate user» je me connecte sans problème peu importe le «users» utilisés cependant j'accède à la racince pour tous, ce que je ne veux pas.

    Quelqu'un a des pistes ?

    Merci à l'avance!

    vendredi 17 juillet 2015 13:33
  • Bonjour Pierre Tellier,

    Voici des pistes suggérées sur un autre forum, en espérant que cela puisse vous aider.

    Cordialement

    Emile


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    • Proposé comme réponse Emile Supiot mercredi 12 août 2015 08:03
    • Marqué comme réponse Emile Supiot mercredi 19 août 2015 09:32
    jeudi 6 août 2015 09:50
  • Bonjour,

    Je me permet de ré-ouvrir ce post n'ayant toujours pas trouvé de solution pour régler ce problème.

    Comme solution de rechange je n'active pas le «user isolation» ce qui a pour but que tous le monde voit ce qu'il y a à la racine et j'interdit l'accès manuellement pour chacun ne lui attribuant l'autorisation que pour son répertoire.

    Ce n'est pas une bonne pratique mais tous les tutoriels à ce sujet son un échec de mon côté.

    Merci de vos réponses et bienvenue si vous avez d'autres pistes...

    Pier 



    jeudi 18 février 2016 21:39
  • Bonjour,

    Le serveur FTP est il hébergé en domaine ou en workgroup ?
    Quel type d'isolation avez-vous définie ? ( enable / disable global virtual directory ? )

    Avez-vous bien créer les folders (root) et (user) avec les bons droits ?
    Est-ce que les répertoire utilisateurs corresponde bien à leur logon name ?




    vendredi 19 février 2016 03:43
  • Bonjour Nathanaël,

    D'abord merci pour votre réponse et voici les réponses à vos questions:

    • Le serveur FTP est hébergé en domaine.
    • Le type d'isolation que je tente d'utiliser est (disable global virtual directory ).
    • Pour les folders root, j'utilise « C:\inetpub\ftproot » auquel j'ajoute un folder par user et dont je donne droit à modifier au user concerné.
    • Les répertoires et les login name sont effectivement identique.

    J'ai également 2 serveurs Windows 2008 configuré ainsi sans problème. Dès que j'active le user isolation sur mon win server 2012, plus aucun accès ne fonctionne. L'erreur renvoi le code 530 «User can not Log in, home directory inaccessible». En parcourant le net avec cette erreur, je ne trouve rien de concret malheureusement.

    Merci encore de tenter de me venir en aide.

    Pier



    vendredi 19 février 2016 16:11
  • Bonjour,

    Cela me semble correct en effet,  on va faire d'autres vérifications (peut-être déjà tenté, mais on finira par trouver)

    Pouvez-vous vérifier dans IIS, au niveau de votre site FTP si :

    • Une FTP Authorization Rule existe ?
    • Si elle n'existe pas, ajouter une nouvelle règle autorisant vos utilisateurs FTP (all users, ou groupe) à faire du read/write.
    • Redémarrer le service FTP windows.


    Autre question : Avez-vous un host header / port particulier de configuré pour votre site FTP ?

    vendredi 19 février 2016 16:23
  • Et je rajoute que si vous utilisez des utilisateur d'un domaine, la structure du FTP doit-être la suivante :

    Windows domain accounts
    (Requires Basic authentication) %FtpRoot%\%UserDomain%\%UserName%

    si je reprend votre exemple :

    • C:\inetpub\ftproot
    • >> C:\inetpub\ftproot\DOMAIN\USERNAME

    vendredi 19 février 2016 16:31
  • Bonjour à nouveau Nathanaël,

    J'ai refait mon site FTP en suivant cette procédure : http://www.sherweb.com/blog/how-to-set-up-ftp-access-for-multiple-users-with-user-isolation/

    J'utilise le groupe «Domain users» dont j'ai attribué les droits en read/write à la racine du FTP.

    J'ai redémarré le service FTP de Microsoft et le site FTP (mon master en fait)

    Le port utilisé est celui par défaut, soit le 21.

    Et j'ai toujours mon erreur  « User can not Log in, home directory inaccessible»

    Merci!

    vendredi 19 février 2016 19:20
  • Bonjour,

    J'ai finalement trouvé une solution et c'est tout simple, il suffit de passer par le NETBIOS:

    C:\inetpub\ftproot\NETBIOSNAME\USERNAME

    À noter, dans mon cas que ftproot\DOMAINNAME ou ftproot\LOCALUSER ne fonctionne pas

    Ce billet est donc considéré comme résolu!

    Merci à tous et spécialement à Nathanaël pour ton support...

    • Marqué comme réponse PierreTellier mercredi 24 février 2016 15:39
    mercredi 24 février 2016 15:39
  • Bonne nouvelle ! Ravi de voir que la solution n'était pas loin
    En effet dans les "filepath" le domaine correspond souvent à sa nomeclature NETBIOS (DOMAIN\)

    N'hésitez pas à marquer la ou les solutions(y compris la vôtre) ayant aidé!
    Bonne continuation

    mercredi 24 février 2016 15:59