none
Certificat et ferme rdp + ts gateway RRS feed

  • Question

  • bonjour a tous

    J'ai un problème avec la gestion des certificat public/privé sur ma ferme RDP avec une publication TS gateway

    Mon infra est la suivante :

    2 serveurs RDP 2012RDP01 et 2013RDP02. Le ferme RDP s'appel RDP01 elle est publié a travers un serveur TMG et un serveur TSGateway : 2012TSG. J'ai installée le service broker sur un autre serveur et je n'ai pas configurer de service NLB mais j'utilise les enregistrement DNS accompagné des GPO.

    J'ai était obligé d'acheter un certificat public parce que tous les clients ne sont pas dans mon domaine.

    Le problème que j'ai c'est que lorsque je me connecte, en local ou a distance, j'ai toujours la fenêtre d'avertissement que le certificat n'est pas bon. J'ai publiée le certificat public secure.domaine.fr sur le TMG et le TGgateway mais pas sur les serveur RDP.

    Pour être franche, je me perd dans tout ces certificats. est ce qu'il faut que le certificat public soit également publié sur les serveur RDP ? et faut il un certificat SAN qui prenne en compte également le nom des serveurs RDP, de la ferme et du serveur Gateway ??

    Merci pour votre aide

    Ccordialement


    lundi 18 mars 2013 09:51

Réponses

Toutes les réponses

  • Bonjour,

    Quel erreur de certificat avez-vous exactement ? (WebAcces, Client RDC... / mise en garde ou échec de connexion)

    Quel certificat est présenté lors de la consultation de la page WebAccess en interne et en externe ?

    Arrivez-vous à vous connecter aux applications RemoteApps malgré l'erreur de certificat ?

    Cdt,


    Jérémy DHUIT

    mardi 19 mars 2013 08:50
  • Bonjour

    Lors de la connexion a la ferme RDP j'ai un message avertissement disant que le certificat n'est pas valide. Ce qui est bizarre c'est que ca a l'air d'être le certificat auto signé du serveur Gateway (il porte sont nom et il est renouveler a chaque connexion)

    Lorsque je le connecte sur le site web https://secure.domaine.com/rdweb je vois bien le bon certificat public

    Merci par avance

    mardi 19 mars 2013 15:42
  • OK donc vous n'avez pas dû indiquer le certificat pour les connexion RDP et c'est encore l’auto signé.

    Dans la 'configuration d'hôte de session Bureau à distance' il faut éditer les propriété de la connexion RDP-tcp et dans l'onglet Général sélectionner le certificat voulu (le public dans votre cas).

    Pour les connexions RDP, le serveur présente aussi un certificat (de la même manière que pour le serveur WebAcces et le certificat dans IIS).

    Cdt,


    Jérémy DHUIT

    mardi 19 mars 2013 16:14
  • ok

    j'ai installer le certificat sur la connexion RDP dans configuration d'hote de session Bureau distance sur le serveur Gateway, mais j'ai toujours le meme message d'avertissement a la connexion.

    J'ai essayé de mettre le certificat sur  la connexion RDP dans configuration d'hote de session Bureau distance mais cette fois ci sur le serveur TSE mais j'ai un message disant Aucun certificat n'est installé sur ce serveur hôte de session Bureau a distance.

    J'ai pourtant installer le certificat public sur l'ordinateur local dans le magasin Personnel et REmote Destktop

    Merci par avance

    Cordialement

    mercredi 20 mars 2013 14:36
  • Bonjour,

    ça me mets un doute.

    Dans le 'Gestionnaire Remoteapps', dans 'Paramètres de déploiement Remoteapps', onglet 'Passerelle de services...', quel est le nom renseigné pour la passerelle interne ou externe ?

    Si je ne me trompe pas, il faut mettre le nom externe de la passerelle à cette endroit (secure.domaine.com dans vote cas).

    Dans l'onglet 'Signer numériquement', vous devez pouvoir choisir un certificat pour signer vos Remoteapps. Mais ici j'ai un doute aussi si on signe avec un certificat interne ou externe. Je serai tenté de dire qu'il faut le signer avec le certificat public car pour vos utilisateurs extérieur, un certificat interne ne fera pas l'affaire.

    Je ne connais pas vraiment TMG donc peut-être aussi vérifier la configuration dessus (j'ai fait l'expérience une fois pour la publication d'un site web et j'ai découvert que c'est le TMG qui envoie le certificat et pas le serveur web IIS) :  

    http://technet.microsoft.com/fr-FR/library/gg589607(WS.10).aspx

    Cdt,


    Jérémy DHUIT

    • Marqué comme réponse Florin Ciuca jeudi 21 mars 2013 11:18
    • Non marqué comme réponse Sandrine M jeudi 21 mars 2013 23:54
    • Marqué comme réponse Florin Ciuca vendredi 22 mars 2013 05:40
    jeudi 21 mars 2013 10:37
    • Marqué comme réponse Sandrine M jeudi 21 mars 2013 23:54
    • Non marqué comme réponse Sandrine M jeudi 21 mars 2013 23:54
    • Marqué comme réponse Florin Ciuca vendredi 22 mars 2013 05:39
    jeudi 21 mars 2013 11:20
  • Bonjour et merci pour votre a tous les 2

    Apparemment le problème est résolu lorsque j'ai activé le pontage SSL sur le service Gateway

    Bonne journée

    Cordialement

    • Marqué comme réponse Florin Ciuca vendredi 22 mars 2013 05:39
    jeudi 21 mars 2013 23:55