locked
Fichier réponse WDS - Joindre un domaine RRS feed

  • Question

  • Bonjour,

    J'essaie actuellement de joindre un domaine avec un fichier réponse associé à WDS. Ma configuration est la suivante : j'ai un serveur Windows Server 2008 R2 qui est DC + AD + DNS. Mon domaine s'appelle BENJAMIN

    J'ai créé un fichier de réponses avec les outils fournis dans le WAIK et j'ai donc généré un fichier unattended.xml.

    Mon problème est que j'essaie désespérément de joindre mon domaine en déployant l'image de Windows 7 (install.wim présent sur le DVD de Windows 7).

    Voici le contenu du fichier XML, en espérant que quelqu'un puisse m'aider. Merci

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SetupUILanguage>
                    <UILanguage>fr-FR</UILanguage>
                </SetupUILanguage>
                <InputLocale>fr-FR</InputLocale>
                <SystemLocale>fr-FR</SystemLocale>
                <UILanguage>fr-FR</UILanguage>
                <UserLocale>fr-FR</UserLocale>
            </component>
            <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <WindowsDeploymentServices>
                    <Login>
                        <Credentials>
                            <Domain>BENJAMIN</Domain>
                            <Password>Adm.2012</Password>
                            <Username>Administrateur</Username>
                        </Credentials>
                    </Login>
                    <ImageSelection>
                        <InstallImage>
                            <Filename>install.wim</Filename>
                            <ImageName>Windows 7 ENTERPRISE</ImageName>
                            <ImageGroup>ImageGroup1</ImageGroup>
                        </InstallImage>
                        <InstallTo>
                            <DiskID>0</DiskID>
                            <PartitionID>1</PartitionID>
                        </InstallTo>
                    </ImageSelection>
                </WindowsDeploymentServices>
                <DiskConfiguration>
                    <Disk wcm:action="add">
                        <CreatePartitions>
                            <CreatePartition wcm:action="add">
                                <Order>1</Order>
                                <Type>Primary</Type>
                                <Size>10000</Size>
                                <Extend>false</Extend>
                            </CreatePartition>
                        </CreatePartitions>
                        <DiskID>0</DiskID>
                        <WillWipeDisk>true</WillWipeDisk>
                        <ModifyPartitions>
                            <ModifyPartition wcm:action="add">
                                <Active>true</Active>
                                <Format>NTFS</Format>
                                <Label>Win7</Label>
                                <Order>1</Order>
                                <PartitionID>1</PartitionID>
                                <Extend>true</Extend>
                                <Letter>C</Letter>
                            </ModifyPartition>
                        </ModifyPartitions>
                    </Disk>
                    <WillShowUI>Never</WillShowUI>
                </DiskConfiguration>
                <UserData>
                    <AcceptEula>true</AcceptEula>
                    <FullName>ENI Ecole Informatique</FullName>
                    <Organization>ENI</Organization>
                </UserData>
            </component>
        </settings>
        <settings pass="specialize">
            <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <Identification>
                    <Credentials>
                        <Domain>BENJAMIN</Domain>
                        <Password>Administrateur</Password>
                        <Username>Adm.2012</Username>
                    </Credentials>
                    <JoinDomain>BENJAMIN</JoinDomain>
                    <DebugJoin>False</DebugJoin>
                    <UnsecureJoin>True</UnsecureJoin>
                </Identification>
            </component>
            <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <RunSynchronous>
                    <RunSynchronousCommand wcm:action="add">
                        <Path>cmd /c reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v EnableLUA /t REG_DWORD /d 0 /f</Path>
                        <Order>1</Order>
                        <Description>Desactive UAC</Description>
                    </RunSynchronousCommand>
                    <RunSynchronousCommand wcm:action="add">
                        <Description>Promp en Admin</Description>
                        <Order>2</Order>
                        <Path>cmd /c reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v ConsentPromptBehaviorAdmin /t REG_DWORD /d 0 /f</Path>
                    </RunSynchronousCommand>
                </RunSynchronous>
            </component>
            <component name="Microsoft-Windows-ErrorReportingCore" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DisableWER>1</DisableWER>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <ComputerName>*</ComputerName>
            </component>
            <component name="Microsoft-Windows-TerminalServices-LocalSessionManager" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <fDenyTSConnections>false</fDenyTSConnections>
            </component>
            <component name="Networking-MPSSVC-Svc" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <FirewallGroups>
                    <FirewallGroup wcm:action="add" wcm:keyValue="RemoteDesktop">
                        <Active>true</Active>
                        <Group>RemoteDesktop</Group>
                        <Profile>all</Profile>
                    </FirewallGroup>
                </FirewallGroups>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <NetworkLocation>Work</NetworkLocation>
                    <ProtectYourPC>1</ProtectYourPC>
                </OOBE>
                <DisableAutoDaylightTimeSet>true</DisableAutoDaylightTimeSet>
                <RegisteredOrganization>ENI Ecole 1</RegisteredOrganization>
                <RegisteredOwner>ENI Proprio</RegisteredOwner>
                <ShowWindowsLive>false</ShowWindowsLive>
                <TimeZone>W. Europe Standard Time</TimeZone>
                <UserAccounts>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <DisplayName>Toto</DisplayName>
                            <Name>Toto</Name>
                            <Group>Administrators</Group>
                            <Password>
                                <Value>cABhAHMAcwB3AG8AcgBkAFAAYQBzAHMAdwBvAHIAZAA=</Value>
                                <PlainText>false</PlainText>
                            </Password>
                        </LocalAccount>
                    </LocalAccounts>
                </UserAccounts>
            </component>
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>040c:0000040c</InputLocale>
                <SystemLocale>fr-FR</SystemLocale>
                <UILanguage>fr-FR</UILanguage>
                <UserLocale>fr-FR</UserLocale>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:f:/sources/install.wim#Windows 7 ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>

    mercredi 30 janvier 2013 15:58

Réponses

Toutes les réponses

  • Salut,

    Comme toi, je travaille depuis 2 jours sur l'intégration au domaine de machines en utilisant les fichiers unattend depuis WDS.

    En regroupant plusieurs informations, j'ai réussi à créer un fichier unattend qui intègre bien la machine au domaine.

    Voici le fichier à compléter avec tes propres informations:

     

      <?xml version="1.0" encoding="utf-8" ?> 
    - <unattend xmlns="urn:schemas-microsoft-com:unattend">
    - <settings pass="windowsPE">
    - <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State">
    - <UpgradeData>
      <Upgrade>false</Upgrade> 
      </UpgradeData>
    - <Display>
      <ColorDepth>16</ColorDepth> 
      <HorizontalResolution>1024</HorizontalResolution> 
      <RefreshRate>60</RefreshRate> 
      <VerticalResolution>768</VerticalResolution> 
      </Display>
    - <ComplianceCheck>
      <DisplayReport>OnError</DisplayReport> 
      </ComplianceCheck>
    - <UserData>
      <AcceptEula>true</AcceptEula> 
      </UserData>
      </component>
    - <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    - <SetupUILanguage>
      <UILanguage>fr-FR</UILanguage> 
      </SetupUILanguage>
      <InputLocale>040c:0000040c</InputLocale> 
      <SystemLocale>fr-FR</SystemLocale> 
      <UILanguage>fr-FR</UILanguage> 
      <UserLocale>fr-FR</UserLocale> 
      </component>
      </settings>
    - <settings pass="specialize">
    - <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State">
    - <Identification>
    - <Credentials>
      <Domain>TON_DOMAINE</Domain> 
      <Password>MDP</Password> 
      <Username>UTILISATEUR DU DOMAINE AVEC LE POUVOIR D'INTEGRER</Username> 
      </Credentials>
      <JoinDomain>TON_DOMAINE</JoinDomain> 
      <DebugJoin>False</DebugJoin> 
      <UnsecureJoin>False</UnsecureJoin> 
      </Identification>
      </component>
    - <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State">
      <ComputerName>TON_NOM DE MACHINE</ComputerName> 
      <RegisteredOrganization>RDG</RegisteredOrganization> 
      <RegisteredOwner>RDG</RegisteredOwner> 
      <TimeZone>Romance Standard Time</TimeZone> 
      <DoNotCleanTaskBar>true</DoNotCleanTaskBar> 
      </component>
    - <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <Home_Page>http://www.google.fr</Home_Page> 
      <IEWelcomeMsg>false</IEWelcomeMsg> 
      </component>
    - <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    - <RunSynchronous>
    - <RunSynchronousCommand wcm:action="add">
      <Description>EnableAdmin</Description> 
      <Order>1</Order> 
      <Path>cmd /c net user Administrator /active:yes</Path> 
      </RunSynchronousCommand>
    - <RunSynchronousCommand wcm:action="add">
      <Description>UnfilterAdministratorToken</Description> 
      <Order>2</Order> 
      <Path>cmd /c reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v FilterAdministratorToken /t REG_DWORD /d 0 /f</Path> 
      </RunSynchronousCommand>
      </RunSynchronous>
      </component>
    - <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <InputLocale>040c:0000040c</InputLocale> 
      <SystemLocale>fr-FR</SystemLocale> 
      <UILanguage>fr-FR</UILanguage> 
      <UserLocale>fr-FR</UserLocale> 
      </component>
      </settings>
    - <settings pass="oobeSystem">
    - <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State">
    - <UserAccounts>
    - <AdministratorPassword>
      <Value>UABAAHMAcwB3ADAAcgBkAEEAZABtAGkAbgBpAHMAdAByAGEAdABvAHIAUABhAHMAcwB3AG8AcgBkAA==</Value> 
      <PlainText>false</PlainText> 
      </AdministratorPassword>
      </UserAccounts>
    - <AutoLogon>
      <Enabled>true</Enabled> 
      <Username>UTILISATEUR DU DOMAINE</Username> 
      <Domain>TON_DOMAINE</Domain> 
    - <Password>
      <Value>MDP</Value> 
      <PlainText>false</PlainText> 
      </Password>
      <LogonCount>1</LogonCount> 
      </AutoLogon>
    - <Display>
      <ColorDepth>32</ColorDepth> 
      <HorizontalResolution>1024</HorizontalResolution> 
      <RefreshRate>60</RefreshRate> 
      <VerticalResolution>768</VerticalResolution> 
      </Display>
    - <OOBE>
      <HideEULAPage>true</HideEULAPage> 
      <NetworkLocation>Work</NetworkLocation> 
      <ProtectYourPC>1</ProtectYourPC> 
      <SkipUserOOBE>true</SkipUserOOBE> 
      </OOBE>
      <RegisteredOrganization>RDG</RegisteredOrganization> 
      <RegisteredOwner>RDG</RegisteredOwner> 
      </component>
    - <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <InputLocale>040c:0000040c</InputLocale> 
      <SystemLocale>fr-FR</SystemLocale> 
      <UILanguage>fr-FR</UILanguage> 
      <UserLocale>fr-FR</UserLocale> 
      </component>
      </settings>
      <cpi:offlineImage cpi:source="catalog:d:/technet/windows 7/en_windows_7_enterprise_x64/sources/install_windows 7 enterprise.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" /> 
      </unattend>


    J'ai volontairement activé l'autologon, mais si cela ne t'intéresse pas, passe la valeur en "false".

    J'espère que cela t'aidera...Maintenant je vais tester l'incrémentation des noms de machine. Si tu as des infos sur la variable à utiliser dans le fichier unattend, je suis preneur...du type: PC-01, PC-02, PC-03...etc

    Bon courage.



    jeudi 31 janvier 2013 11:07
  • Bonjour,

    Tu dois utiliser les 2 fichiers et non faire tout en un. Tu peux récuperer des exemples avec le lien ci dessous.

    Installation automatisée de Windows 7 avec WDS


    Fait les modifications et essaye à nouveau.
    Laisse aussi dans le fichier (ImageUnattend.xml) la paramètre <UnsecureJoin>true</UnsecureJoin>


    Revue du Geek | Astuces pour déployer Windows 7

    jeudi 31 janvier 2013 17:29