none
Migration Hybride - Groupe de distribution / Room Mbx RRS feed

  • Question

  • Bonjour,

    J'ai configuré l'hybridation entre mon exchange 2013 et Office 365.

    Lors de la migration d'une boîte de ressource type salle ou RoomMailbox, seuls les utilisateurs migrés dans 365 peuvent voir les RoomMailboxes on-premise + celles migrées sur 365.

    En revanche, les utilisateurs on-premise ne voient que celles non migrées, donc toujours sur l'exchange on-premise, il semblerait que ce soit un problème connu avec la version 2013 d'exchange et cette relation "unidirectionnelle".

    Quelqu'un a-t-il déjà rencontré ce cas ?

    Ma seconde question est la suivante, j'ai des groupes de distribution synchronisés avec AADConnect, est-ce possible de les convertir en cloud only ?

    Si je les sors de la synchronisation AADConnect, théoriquement, ceux-ci vont être supprimés de 365 ?

    Ma question est donc, dois-je scripter pour recréer à la main ces groupes de distribution dans 365 afin qu'ils soient managés sur 365 et non sur l'AD on-prem ?

    Merci d'avance pour votre aide !


    mercredi 24 juillet 2019 09:02

Réponses

Toutes les réponses

  • Bonjour,

    Pour ta première question, je ne vais pas avoir de réponse... pour ce qui est de la deuxième, je vais peut être pouvoir t'aider.

    A tester avec un groupe de test avant : 

    - Faire en sorte que le groupe soit synchronisé.

    - Supprimer le groupe de ton AD local et attendre la synchro, a ce moment là ton groupe devrait être supprimer de O365.

    - Dans ton portail O365, tu devrais pouvoir restaurer le groupe et celui doit normalement passer en Cloud Only.

    Romain.

    mercredi 24 juillet 2019 10:06
  • Je travaille pour un client qui dispose d'un serveur exchange 2013 en local (dernier CU installé) et en mode hybride avec exchange Online.

    Toutes les ressources (salles et équipements) ont étés migrées vers Exchange Online.

    Les ressources apparaissent comme telles dans le serveurs Exchange Online. Par contre, elles apparaissent en tant que boite à lettres office 365 dans le Exchange 2013 on premise.

    La liste d'adresses globale unifiée montre les ressources aussi bien pour les utilisateurs ayant des boites on premise que pour ceux en online.

    Quand tu regarde sur ton exchange 2013 local, tu vois bien dans boite aux lettres tout le monde ?

    mercredi 24 juillet 2019 11:33
  • Je vois bien les boîtes, mais je pense aussi avoir oublié une chose, cocher la case "déploiement hybride exchange" sur aadconnect...ça pourrait potentiellement résoudre le problème.

    Dans mes recherches je suis aussi tomber sur la documentation et ce qui est supporté ou non :

    docs.microsoft.com/en-us/exchange/permissions ainsi que cet article très intéressant :

    practical365.com/exchange-online/configuring-exchange-hybrid-cross-forest-permissions/

    J'espère me sortir de cette galère car sinon ça implique que je suis obligé de migrer tout le monde en même temps ce qui n'est pas possible dans le cadre d'une migration hybride..

    mercredi 24 juillet 2019 11:45
  • Oui pour la connexion hybride sur aadconnect. Il faut l'activer.

    • Marqué comme réponse exp0zd mercredi 24 juillet 2019 12:38
    mercredi 24 juillet 2019 12:28
  • Exact, du fait que je l'avais installé dans le passé, je n'avais pas re-contrôler..

    Par contre, je suppose qu'il faut attendre 15mn voire beaucoup plus lorsque l'on assigne un full access à un user on-prem par exemple sur une shared mailbox dans 365 pour que ceci se répercute dans son client / owa ?

    Et après double check, ma boîte partagée qui a été migrée apparaît bien dans mon ECP on-prem, ainsi que sur 365, en revanche, la roomMailbox migré n'apparaît que sur l'ECP 365, @Vincent, as-tu le même comportement ?

    • Modifié exp0zd mercredi 24 juillet 2019 12:37
    mercredi 24 juillet 2019 12:30
  • Pour AADConnect, toutes les 30 minutes pour avoir le résultat du local vers office365.

    Vérifie que ton AADConnect est à jour. Il y a eu des erreurs de mise à jour automatique si tu l'avais activé via PowerShell. Tu le voie au niveau de  l'admin office 365 nouvelle version dans état d'intégrité/Etat de la synchronisation.

    Je repose ma question initiale : vois tu les migrations sur ton exchange local des éléments migrés sur office 365 en tant que boite office 365 ?

    mercredi 24 juillet 2019 12:47
  • Autre vérification essentielle : quel version de CU sur ton exchange 2013 local ?

    Logiquement, tu ne dois pas avoir plus de 2 version de CU d'écart avec le Online.

    mercredi 24 juillet 2019 12:49
  • Je vois bien les éléments migrés sur mon exchange local, sauf la roomMailbox, c'est ça qui me pose problème à vrai dire.

    La CU est la dernière, la 23

    Ad connect idem j'ai pris la dernière version et je force un synchro de type delta après mes modifications

    mercredi 24 juillet 2019 12:57
  • Tu as reconfiguré l'hybride pour Exchange sur ADConnect ?

    Une fois fait, le plus simple, tu fais une migration d'exchange online vers le local, puis tu refais la migration vers le online.

    Ca met à jour des propriétés sur ton AD du guid local ainsi que du distant.

    Teste sur une ressource et si ça te vas, tu feras les autres ;-)

    mercredi 24 juillet 2019 13:02
  • Oui l'hybride exchange est bien activé sur AADConnect et j'ai reforcé une delta sync.

    Pour la room, je vais la faire redescendre on-prem puis la renvoyer à nouveau et on va voir ce que ça donne.

    En revanche, mais délégations de boîtes ne sont toujours pas appliquées, as-tu du passer cette commande sur ton 2013 pour que ça fonctionne ?

    Set-OrganizationConfig -ACLableSyncedObjectEnabled $true

    mercredi 24 juillet 2019 13:13
  • Pour ne pas avoir de soucis, je crée toujours tout sur le serveur exchange 2013 local.

    J'attend la synchronisation adconnect.

    Ensuite, je fais les migrations vers exchange online pour que l'AD local connaisse les éléments migrés et les affichent dans l'exchange local.

    Je n'ai pas eu à faire ta commande PowerShell sur l'organisation.

    Mais il est vrai que ce n'est pas toujours intuitif. Pense que la majorité des éléments vont de AD vers AAD mais rarement dans l'autre sens, hormis les groupes office365 qui peuvent redescendre vers ton AD.

    mercredi 24 juillet 2019 13:22
  • Effectivement et je dois avouer qu'à chaque migration, je me retrouve avec des problématiques différentes, c'est peut-être du "pas de bol" ...

    Pour ma part, la valeur renvoyée par la commande ci-dessous est à $false on-prem:

    Get-OrganizationConfig | ft ACLableSyncedObjectEnabled

    Et comme dit dans la doc sur un exchange 2013, il faut que je la passe à $true :docs.microsoft.com/en-gb/exchange/hybrid-deployment/set-up-delegated-mailbox-permissions#enable-acls-on-remote-mailboxes

    Ca va peut-être résoudre mon souci.

    mercredi 24 juillet 2019 13:32
  • Je viens de vérifier et la propriété est sur $false également pour moi.

    Après vérification du lien que tu fournis, c'est pour gérer la partie des boites déléguées.

    Quel est ton besoin/problème particulier concernant les boites déléguées ?

    mercredi 24 juillet 2019 13:50
  • A vrai dire, j'ai plusieurs problèmes :

    Sur une boîte on-premise :

    - Attribuer une délégation Full Access à un utilisateur migré : je vois bien dans le pepole picker les utilisateurs migrés et on-premise, j'ai donc sélectionné un utilisateur migré pour lui donner une délégation Full Access sur cette boîte.

    ==>Pour l'instant, depuis l'owa de mon utilisateur migré, je ne parviens pas à ouvrir la boîte on-premise pour laquelle j'ai configuré la délégation précédente

    - Attribuer une délégation Send on behalf un utilisateur migré : je ne vois pas dans le people picker les utilisateurs migrés (pourtant la délégation Send on behalf semble être supportée en hybride)

    - Attribuer une délégation Send as un utilisateur migré : je ne vois pas dans le people picker les utilisateurs migrés (il semble que la délégation send as ne soit pas supporté en hybride)

    Sur une boîte migrée :

    L'attribution de ces 3 délégations fonctionne, cependant, je ne parviens toujours pas à ouvrir depuis cette boîte migrée la boîte on-prem pour laquelle j'ai ces délégations

    ==>Temps de synchro/réplication entre exchange on-prem et 365 ?

    Autre cas, une shared mailbox migrée n'est accessible que pour les utilisateurs migrés, ceux qui doivent y avoir accès et qui sont on-premise ne peuvent pas y accéder.

    ==>Temps de synchro/réplication entre exchange on-prem et 365 ?

    J'ai donc passé la commande ci-dessous et force une synchro AADConnect ensuite:

    Get-RemoteMailbox -ResultSize unlimited | ForEach {Get-AdUser -Identity $_.Guid | Set-ADObject -Replace @{msExchRecipientDisplayType=-1073741818}}

    Mais pour le moment, je reste comme avant...:((

    <u1:p></u1:p>


    mercredi 24 juillet 2019 14:02
  • J'ai passé l'organisation en $True.

    J'ai exécuté la commande de mise à niveau des BAL distantes en PowerShell.

    Je fait des essais et te tiens au courant.

    mercredi 24 juillet 2019 14:36
  • Merci pour l'aide :) je demande autour de moi aussi mais je ne crois pas avoir jamais autant eu du mal avec une migration !

    Je fais aussi des tests en parallèle afin de voir ce que ça donne !

    mercredi 24 juillet 2019 14:37
  • Bonjour,

    Je viens de vérifier à nouveau, j'ai toujours les mêmes problèmes ...j'ai repassé tous les steps d'hybridation mais rien n'y fait ...

    Existe-t-il des logs ou autre afin de troubleshooter plus profondément ce problème ?

    jeudi 25 juillet 2019 07:04