none
Event ID 1020 SMTP Receive RRS feed

  • Question

  • Bonjour,

    Sur une infra 2008 Server + 2007 Exchange SP1 avec les 3 rôles sur la même machine, j'ai le log suivant Event ID 1020 SMTP Receive

    Le compte « AUTORITE NT\ANONYMOUS LOGON » a fourni des informations d'identification valides, mais n'est pas autorisé à utiliser le serveur ; échec d'authentification.

    J'ai bien de coché Utilisateurs Anonyme sur les connecteurs de réceptions, est-ce  bien la même chose ?

    Sur le technet, il faut assigner les droits du compte, dans mon cas anonymous logon, pour être autorisé à utiliser le serveur de messagerie  avec le droit "MS-Exch-SMTP-Submit mais je ne vois pas comment on peut le faire. Quel est l'incidence de cette manip. Je ne cherche pas à faire un relais smtp anonyme, si c'est bien la même chose.

    Merci pour votre aide

    Fred

    jeudi 8 avril 2010 09:02

Réponses

  • Bonjour,

     

    as tu plusieurs controlleurs de domaine ? si oui tes réplication fonctionnent bien ?

    Exchange lit ses informations de configuration dans l'AD, et selon le controlleur de domaine qu'utilise Exchange,

    si ce dernier ne possède pas les bonnes informations de configuration (les autorisations sur tes connecteurs de réception),

    du fait d'un probleme de réplication, tu auras le problème aléatoirement en fonction du DC utilisé par Exchange.

    donc ca peut etre une piste, vérifie tes réplications si tu as plusieurs DC.

     

    Sinon pour résoudre cette erreur voir cette technet:

    http://technet.microsoft.com/en-us/library/bb218360%28EXCHG.80%29.aspx

     

     Explanation

    This Warning event indicates that the specified account is authorized to use the Receive connector to accept inbound messages, but the account is not authorized to use the Microsoft Exchange Server 2007 Hub Transport server or Edge Transport server that contains the Receive connector. The specified account requires the MS-Exch-SMTP-Submit permission to submit inbound messages by using a Receive connector.

    Receive connectors use permission groups to define the entities that can submit messages to the Receive connector and the permissions that are assigned to those groups. A permission group is a predefined set of permissions that is granted to well-known security principals and assigned to a Receive connector. Security principals include users, computers, and security groups.

    The set of permission groups is predefined in Exchange 2007. This means that you cannot create additional permission groups. Also, you cannot modify the permission group members or the associated permissions. For a complete description of the permission groups and the associated security principals, see Receive Connectors .

     User Action

    To resolve this warning, verify that the account that is specified in the event text has the MS-Exch-SMTP-Submit permission assigned to it on the appropriate Receive connectors on the Hub Transport server or Edge Transport server.

    Un moyen un peu brut force peut etre serait d'utiliser ADSI Edit et d'aller voir les permissions sur ton connecteur de réception.

    Tu peux le faire sur tout tes DC afin de voir que les autorisations soient bien identiques sur tout tes DC.

    yohan

    vendredi 9 avril 2010 13:33

Toutes les réponses

  • Bonjour,

     

    essaie de redémarrer le service transport éventuellement ?

    net stop msexchangetransport

    net start msexchangetransport

    Ensuite vérifie si tu as plusieurs connecteurs de réception que tu aies bien cocher la case "anonymes"

    sur le connecteur sur lequel tes clients se connectent.

     

    yohan

    jeudi 8 avril 2010 09:55
  • Bonjour Yohan,

     

    J'ai fait la manip mais le message d'erreur est revenu ce matin vers 00 h 00 alors que je n'avais plus rien hier après-midi !

     

    Sinon tous les connecteurs ont  bien la case anonyme de coché sur chaque connecteur actif de l'organisation.

    vendredi 9 avril 2010 06:56
  • Bonjour,

     

    as tu plusieurs controlleurs de domaine ? si oui tes réplication fonctionnent bien ?

    Exchange lit ses informations de configuration dans l'AD, et selon le controlleur de domaine qu'utilise Exchange,

    si ce dernier ne possède pas les bonnes informations de configuration (les autorisations sur tes connecteurs de réception),

    du fait d'un probleme de réplication, tu auras le problème aléatoirement en fonction du DC utilisé par Exchange.

    donc ca peut etre une piste, vérifie tes réplications si tu as plusieurs DC.

     

    Sinon pour résoudre cette erreur voir cette technet:

    http://technet.microsoft.com/en-us/library/bb218360%28EXCHG.80%29.aspx

     

     Explanation

    This Warning event indicates that the specified account is authorized to use the Receive connector to accept inbound messages, but the account is not authorized to use the Microsoft Exchange Server 2007 Hub Transport server or Edge Transport server that contains the Receive connector. The specified account requires the MS-Exch-SMTP-Submit permission to submit inbound messages by using a Receive connector.

    Receive connectors use permission groups to define the entities that can submit messages to the Receive connector and the permissions that are assigned to those groups. A permission group is a predefined set of permissions that is granted to well-known security principals and assigned to a Receive connector. Security principals include users, computers, and security groups.

    The set of permission groups is predefined in Exchange 2007. This means that you cannot create additional permission groups. Also, you cannot modify the permission group members or the associated permissions. For a complete description of the permission groups and the associated security principals, see Receive Connectors .

     User Action

    To resolve this warning, verify that the account that is specified in the event text has the MS-Exch-SMTP-Submit permission assigned to it on the appropriate Receive connectors on the Hub Transport server or Edge Transport server.

    Un moyen un peu brut force peut etre serait d'utiliser ADSI Edit et d'aller voir les permissions sur ton connecteur de réception.

    Tu peux le faire sur tout tes DC afin de voir que les autorisations soient bien identiques sur tout tes DC.

    yohan

    vendredi 9 avril 2010 13:33