none
Nos utilisateurs Active Directory ont disparus RRS feed

  • Question

  • Bonjour,


    Aujourd'hui, 95%  de nos utilisateurs enregistrés dans l'active directory ont disparu.

    Nous avons été obligé de les restaurés un à un à la main (enfin en utilisant Veeam).


    Nous ne parvenons pas à expliquer cela ni à en trouver la cause.

    Pourriez-vous m'aider ?


    Nous avons démissionner nos anciens AD la semaine dernière, le 25 fevrier (il y a 11 jour).


    Merci,


    Cédric

    lundi 7 mars 2016 17:40

Réponses

  • Si vous utilisez HyperV avec des VM de génération 1 il est recommandé de stocker l'AD sur un autre disque SCSI ajouté. Par défaut les VM de génération 1 simule un disque IDE pour démarrer et il existe des problèmes avec AD même si vous désactiver le cache en écriture .Voir http://pbarth.fr/node/103

    Quand vous parlez de 3 AD c'est 3 contrôleurs de domaine pour le même domaine ? Puis vous avez ajouter 3 DC dans le même domaine ?

    Quel version les anciens DC ? les nouveaux ? Niveau fonctionnel ?

    Vous avez activez la corbeille AD ?

    De la a expliquer la disparition de 95 % d'utilisateurs ...

    • Proposé comme réponse Emile Supiot lundi 14 mars 2016 09:43
    • Marqué comme réponse Emile Supiot vendredi 18 mars 2016 07:28
    mardi 8 mars 2016 19:42
    Modérateur

Toutes les réponses

  • Combien de DC ? 

    dcdiag  et repadmin /showrepl ?

    lundi 7 mars 2016 17:43
    Modérateur
  • Bonjour,

    Nous avions 3 AD mal fait (Copier/coller du VHDX.... houuu c'est mal ;-) ). 

    Nous avons recrée 3 AD correctement.

    Ils ont cohabité une semaine. On a ensuite décommissionné les trois premiers.

    Nous avons donc maintenant AD4, AD5 et AD6

    DC DIAG

    • AD4 : Démarrage du test : FrsEvent - Erreurs ou avertissements détectés au cours des dernières 24 heures après le partage de SYSVOL. Des problèmes liés à l'échec de la réplication SYSVOL peuvent provoquer des problèmes de Stratégie de groupe.
    • AD5 : OK
    • AD6 : OK

    repadmin /showrepl

    • AD4 : OK
    • AD5 : OK
    • AD6 : OK

    Je trouve l'avertissement suivant dans les jounaux : "Le service de réplication de fichiers a détecté du cache d’écriture sur disque activé sur le lecteur contenant l’annuaire c:\windows\ntfrs\jet sur l’ordinateur AD4. Le service de réplication de fichiers peut ne pas être rétabli lorsque l’alimentation du lecteur est interrompue et que les mises à jour critiques sont perdues."

    Est-ce la source de l'erreur relevée par le DC Diag ?

    Merci d'avance,


    Cédric 

    mardi 8 mars 2016 08:30
  • Bonjour,

    la source du problème/risque est probablement la même (Cache en écriture activé), mais ce sont 2 choses différentes.

    Dans les journaux, c'est la base AD qui "risque" d'être corrompue.

    Dans DCDIAG, ce sont les fichiers répliqués par SYSVOL qui sont en cause.

    A+


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(82 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    mardi 8 mars 2016 15:49
  • Si vous utilisez HyperV avec des VM de génération 1 il est recommandé de stocker l'AD sur un autre disque SCSI ajouté. Par défaut les VM de génération 1 simule un disque IDE pour démarrer et il existe des problèmes avec AD même si vous désactiver le cache en écriture .Voir http://pbarth.fr/node/103

    Quand vous parlez de 3 AD c'est 3 contrôleurs de domaine pour le même domaine ? Puis vous avez ajouter 3 DC dans le même domaine ?

    Quel version les anciens DC ? les nouveaux ? Niveau fonctionnel ?

    Vous avez activez la corbeille AD ?

    De la a expliquer la disparition de 95 % d'utilisateurs ...

    • Proposé comme réponse Emile Supiot lundi 14 mars 2016 09:43
    • Marqué comme réponse Emile Supiot vendredi 18 mars 2016 07:28
    mardi 8 mars 2016 19:42
    Modérateur
  • Bonjour,

    concernant la disparition des 95% des comptes... Il s'agit probablement d'une erreur de manipulation, surtout si plusieurs personnes agissent simultanément sur l'AD.

    Y a t-il eu des réorganisations d'OUs, des déplacements d'utilisateurs pendant la migration des DC ?

    Il arrive que l'on supprime une OU que l'on croit(voit) vide, les comptes sont alors supprimés en même temps que l'OU. Il y a bien un message de confirmation/d'alerte, mais que l'on valide souvent bien vite.

    A bientôt,


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(82 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    lundi 14 mars 2016 11:04
  • Bonjour,

    Et merci pour votre aide.

    Je pense que le problème est du au décommissionement brutal de notre ancien serveur Exchange...

    :-(

    Bonne journée !


    Cédric

    lundi 14 mars 2016 15:13