none
Comment rendre sharepoint 2010 accessible depuis internet? RRS feed

  • Question

  • Bonjour,

    Je suis entrain de déployer un sharepoint 2010 entreprise edition et je souhaiterai rendre accessible mon site via internet.

    Mon application web est sur le port 80, et je dipose déjà d'un site internet sur le port 80, est ce grave?

    Existe t'il un tuto pas à pas pour effectuer cette configuration? J'ai beaucoup cherché sur internet, mais je n'ai rien trouvé de très complet...

    Merci de vos réponses,

    Cordialement,

    vendredi 9 juillet 2010 13:49

Réponses

  • Bonjour,

    Pour la redirection de port c'est ton routeur qui va gérer ça ce qui veut dire qu'il va acheminer les requêtes depuis le port publié vers le port interne, ce qui tu dois configurer au niveau de SharePoint c'est le port sur le quel les requête vont parvenir depuis le routeur et non depuis Internet car c'est sur ce port que le routeur va communiquer avec ton SharePoint. (N'oublie pas le HOST HEADER)  

    C'est normal que la partie AAM (Alterbate Access Mapping) se complète automatiquement suite à la configuration de l'extension de l'application.

    Cdt

     

     

      


    J.K
    • Proposé comme réponse AlexWeb_85 mercredi 8 septembre 2010 14:41
    • Marqué comme réponse Pascal P mardi 24 janvier 2012 09:48
    mardi 13 juillet 2010 15:11

Toutes les réponses

  • Bonjour,

    il est aussi complique de mettre sharepoint sur internet que de mettre un site sous IIS :) Il faut, sous l'alternate access mapping, definir une url qui soit compréhensible sur internet (www.microsoft.com par exemple et pas srvmoss001 :) ) ensuite declarer les dns pour cette url pour qu'ils pointent sur l'ip du serveur (necessite une ip statique). Comme vous avez deja un site sur le port 80 il faut aussi un host header différent pour ce site. Mettre la securite pour anonymous afin que les visiteurs puissent acceder au site (attention à la licence).

    voila, si des points sont a eclaircir je suis la.
    PS: je conseille l'utilisation d'un reverse proxy et d'un firewall pour des raisons de securité ;)


    Xavier VANNESTE
    www.xvanneste.com
    media.xvanneste.com
    blog.xvanneste.com
    vendredi 9 juillet 2010 15:40
    Modérateur
  • Bonjour,

    Merci de vos réponses et de tous vos liens.

    Il me semble etre parvenu au plus dur, lorsque, depuis internet j'accède à mon site sharepoint, il commence par me demander de m'authentifier. (Ce que je souhaite)

    Mais une fois les informations de login complétés, il me dit "Impossible de trouver la page..."

    Avez vous une idée?

    Ai-je oublié une étape?

    Merci d'avance!

     

    Cordialement,

    lundi 12 juillet 2010 15:22
  •  

    Bonjour,

    Il faut étendre l'application Web que tu veux publier via internet an utilisant l'adresse que t'as configuré au niveau de l'alternate Access Mapping.

    Depuis la console d'admin centrale cliquer sur Application Management ==> Create or Extend Web Application ==>   Extend An Existing Web Application

    Choisir l'application Web actuel de ton site, précise le port 80 et tape le Host Header qui correpond à l'URL configurée au niveau de l'alternate Access Mapping comme te l'a indiqué Xavier.

     

    Cdt   

     

          


    J.K
    lundi 12 juillet 2010 15:37
  • Bonjour,

    Enfaite mon application web est sur le port 80 en interne mais j'ai fait une redirection de port sur mon routeur pour l'utiliser sur un autre port en internet...

    Dans Extend web application, lorsque que je complète, dois je remplir le port 80 ou le port qui devra etre renseigné par mes utilisateurs internet?

    Aussi, lorsque je complète "Extend web application", la partie alternate access mapping se complète automatiquement... est-ce normal?

     

    Merci des vos réponses,

    Cordialement,

     

     

    mardi 13 juillet 2010 14:57
  • Bonjour,

    Pour la redirection de port c'est ton routeur qui va gérer ça ce qui veut dire qu'il va acheminer les requêtes depuis le port publié vers le port interne, ce qui tu dois configurer au niveau de SharePoint c'est le port sur le quel les requête vont parvenir depuis le routeur et non depuis Internet car c'est sur ce port que le routeur va communiquer avec ton SharePoint. (N'oublie pas le HOST HEADER)  

    C'est normal que la partie AAM (Alterbate Access Mapping) se complète automatiquement suite à la configuration de l'extension de l'application.

    Cdt

     

     

      


    J.K
    • Proposé comme réponse AlexWeb_85 mercredi 8 septembre 2010 14:41
    • Marqué comme réponse Pascal P mardi 24 janvier 2012 09:48
    mardi 13 juillet 2010 15:11
  • Bonjour à tous, 

    J'ai besoin d'ouvrir un site SharePoint Foundation vers internet car l'accès en extranet est trop contraignant (donc en gardant l'authentification) et j'ai un soucis :

    j'ai étendu mon application Web, j'ai ouvert mon port sur mon routeur (on va dire 8081) j'arrive à accéder à mes données depuis l'extérieur en tapant l'adresse IP de mon serveur (pas de DNS pour le moment je voudrais que ça fonctionne avant).

    J'arrive a m'authentifier, mais je suis redirigé vers le ports 80. Alors je met manuellement le port 8081, ça fonctionne bien mais lorsque que je change d'onglet, je suis encore redirigé vers le port 80.

    Pour vérifier mon lien, je laisse mon curseur sur le lien il y a bien marqué que ca redirige vers 8081.

     

    Quelqu'un a-t-il une idée de cette redirection intempestive vers mon port 80 ?


    Cordialement, Nicolas SCHUB
    lundi 16 janvier 2012 09:43
  • Bonjour ,

     

    Est ce que t'es en train de réaliser les test depuis ton intranet ou depuis l'extranet ?

    Quels sont les zones configurées au niveau de ton application Web ? 

     

    Cdt

     


    J.K
    lundi 16 janvier 2012 13:45
  • Merci de me répondre déjà ;)

     

    Je réalise les tests sur mon intranet parce qu'il parait mon contraignant d'ouvrir L'intranet sur Internet que de déployé un Extranet.

    J'ai configué la zone Internet (en plus de celle par défaut). J'ai étendu mon application Web, et j'ai vérifié dans IIS, j'ai bien un nouveau site qui a été créé avec le port 8081 et cela fonctionne en partie puisque j'y accède.

    Mais sur chaque page je dois entrer à la main ":8081" car la redirection est toujours vers le port 80

     

    Cordialement,

    Nicolas


    Cordialement, Nicolas SCHUB
    lundi 16 janvier 2012 15:33
  • Est ce que tu peux vérifier la configuration AAM (Altenate Access Mapping) de ton Web App et vériie que l'URL que tu prévoit à la Zone Intenet et bien configurée.

    Cdt 


    J.K
    lundi 16 janvier 2012 15:57
  • Pour la configuration AAM j'ai :

    par défaut : http://monserveur

    Internet : http://monserveur:8081

    et les autres vides

     

    Nicolas


    Cordialement, Nicolas SCHUB
    lundi 16 janvier 2012 16:07
  • Petit UP svp !

     

    je rappel mon problème, je ne sais pas pourquoi, j'ai étendu un site sur la zone Internet via le port 8081. lorsque j'accède a mon site via le web même si je spécifie le port, je suis redirigé vers le port 80. alors je marque le port 8081 à la main mais je dois changer le port A CHAQUE FOIS que je change de site (ce qui est plutôt embêtant pour les utilisateurs).

     

    merci de votre aide,

    Nicolas


    Cordialement, Nicolas SCHUB
    lundi 23 janvier 2012 11:03
  • Salut Nicolas Schub,

    Pourrais tu regarder dans ton IIS, dans les Bindings, sur quelle port pointe ton web application? Soit bien sur que là, il est en 8081


    Bonne chance, Gokan


    Founder of SharePoint CookBook: http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    lundi 23 janvier 2012 11:49
  • Je viens de vérifier et effectivement c'est bien du 8081.

    Ne faut-il pas que je mette 8081 aussi sur mon site ISS SharePoint - 80 ?

     

    je vais tester on ne sais jamais (même si ça ne me parait pas logique)

     

    EDIT :

    J'ai testé, ca ne fonctionne pas. par contre j'ai fais une nouvelle découverte :

    quand je suis en interne donc : http://monserveur:8081 la redirection sur les autres site se fait correctement, ya vraiment que depuis une accès internet que je suis redirigé vers le port 80

     


    Cordialement, Nicolas SCHUB
    lundi 23 janvier 2012 12:26
  • Le problème est just sur IE? ou sur firefox/chrome aussi?
    Founder of SharePoint CookBook: http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    mardi 24 janvier 2012 08:30
  • Bonjour,

    J'avoue ne pas avoir testé, par défaut SharePoint = IE donc je ne me pose jamais la question.

    Mais hier soir, je me suis faché et j'ai trouver une autre solution, au lieu de dire j'utilise le port 80 en internet et le port 8081 sur internet redirigé vers le 80 en interne, j'utilise le 80 et le 8081 en interne et depuis internet j'utilise le 8081 qui redirige donc vers le 8081.

    Ce n'est pourtant pas la première fois que je déploie un site sur internet je ne comprend pas ce que j'ai fais de travers.

     

    Merci à tous pour votre aide,

    Nicolas


    Cordialement, Nicolas SCHUB
    • Proposé comme réponse Nicolas Schub mardi 24 janvier 2012 08:40
    mardi 24 janvier 2012 08:40
  • Bonjour,

     

    Je me permets de m'incruster dans ce Thread car nous avons mis également en place une application intranet qui doit être accessible depuis internet (via reverse proxy). L'accès fonctionne très bien. Sauf qu'il est maintenent plus possible de se connecter via SharePoint Designer.  Nous avons une erreur

     

    Avez-vous le même problème??

     

    Merci d'avance!

     

    Nicolas

    vendredi 27 janvier 2012 07:53
  • Bonjour,

    Chez moi, SharePoint Designer fonctionne très bien. Est-ce que tu essayes de toucher ton application Web pricipale ou ton application web étendue ?

    dans mon cas : application principale port 80 fonctionne

    application étendue port 8081 ne peux pas être touché par designer.

     

    Nicolas


    Cordialement, Nicolas SCHUB
    vendredi 27 janvier 2012 08:57
  • Bonjour,

    Merci de votre retour.

    J'essaye vers l'application principale.  le problème d'accès avec SPD n'est peut être pas dû au double accès de l'application web... Je vais investiguer... Si je n'y arrive pas , j'ouvrirai un nouveau thread

     

    Nicolas

     

    vendredi 27 janvier 2012 09:26