locked
Gestion Idle des Smart Cards RRS feed

  • Question

  • Bonjour a tous ,

    Merci déjà a tous ceux qui me liront :).

    Je vous expose mon problème, je cherche à désactiver par défaut la coche :

    Pour toutes les Devices USB Smart Card utilisant ce pilote (WUDF) - WUDFRd.sys

    Apres quelques recherche j'ai trouver cette clef qui permet de le faire :
    HKLM\SYSTEM\CurrentControlSet\Enum\USB\[DEVICE_ID]\[INSTANCE_ID]\Device Parameters
    >DefaultIdleState (pas sûr de son utilité)
    >DeviceIdleEnable (d'apres moi sert a activer l'onglet de gestion d'alimentation)
    >UserSetDeviceIdleEnable (Permet de griser la case pour que l'utilisateur ne puisse pu la réactiver)
    >WDF\IdleInWorkingState (La clef qui permet de décocher la case)
    >WDF\DefaultIdleInWorkingState (pas compris a quoi servait celle la)

    Lorsque je place les 2 clefs en gras ci dessus à 0 j'obtiens bien le résultat voulu (case décochée et grisée afin qu'elle ne puisse pu être réactivée par un user)

    Le problème est que une autre carte utilisant ce driver prendra les valeurs par défaut qui placeront ces clefs a 1.
    De même si le Device est réinstallé les Clefs sont recrées et reprennent la valeur 1, ce qui dégrise la case et la réactive.

    La question est donc la suivante: Comment faire en sorte que toutes les nouvelles Devices utilisant ce pilotes reçoivent les valeurs voulues, est il possible de jouer sur les class id des smart card ({50dd5230-ba8a-11d1-bf5d-0000f805f530}) ou le service utilisé par le pilote (WUDFRd) ou est ce tout autrement ?

    merci d'avance.

    Ben.

    • Type modifié Teodora Sharkova mercredi 8 juillet 2015 14:01
    • Type modifié BeN0o8 mercredi 8 juillet 2015 15:14
    mardi 7 juillet 2015 14:53

Réponses

  • Bonjour et merci de votre retour.

    J'ai visiblement le meme probleme que celui decrit dans le lien. Sortie de veille aleatoire des lecteurs de smart cards.

    Nous en avons plusieurs model dans le parc (USB ou integré dans des claviers) Pour les premiers une modification du registre a suffit a regler le probleme (Driver Gemalto).

    Pour les claviers le probleme se corse car le pilote WUDFRd.sys ne prevois pas ce genre de modification (pas de WDF). heuresement j'ai trouver des pilotes qui reglent le probleme, malheuresement un clavier smart card utilise toujours le pilote generique Microsoft de 2006...

    Il ne semble pas y avoir de pilote pour ce dernier clavier. J'ai abandonner les recherches pour que toutes les smart card quelque soit le pilote aient la gestion d'energie desactivée, mais je n'ai pas l'impression que cela soit possible/prevu par Windows 7.

    Si d'autre personnes ont des pistes sinon j'ai bien peur de devoir me separer d'une partie des claviers de mon parcs :s...


    • Modifié BeN0o8 mardi 21 juillet 2015 09:09
    • Proposé comme réponse Emile Supiot lundi 3 août 2015 10:08
    • Marqué comme réponse Teodora Sharkova mercredi 5 août 2015 13:03
    mardi 21 juillet 2015 09:08

Toutes les réponses

  • Pas beaucoup d'activité par ici ;).

    Je ne sais pas si je n'ai pas ete assez clair dans ma question ou si personne n'a la reponse mais voila les tests que j'ai deja effectué :

    Nous avons dans le parc un autre type de Smart card qui utilise un pilote Gemalto.
    Dans ce cas je peux agir directement sur le pilote et non sur la device grace au registre et a la clef:
    HKLM\SYSTEM\CurrentControlSet\services\GemCCID\SelectiveSuspendFeatureOn
    Cette clef a 0, toutes les devices presentes et futures utilisant ce pilote verront la case "autoriser l'ordinateur a eteindre ce...." desactivée.

    Je cherche a reproduire ceci avec le pilote Microsoft WUDFRd mais ce service ne prend pas cette option, Je me suis pencher alors du coté des ClassID de smart card :
    HKLM\SYSTEM\CurrentControlSet\Control\Class\{50DD5230-BA8A-11D1-BF5D-0000F805F530}\

    Mais la je ne trouve pas... je ne suis pas sur que cela soit possible de cette facon.

    Bref je suis preneur de toutes piste que vous pourriez me fournir.

    Merci.

    BeN.

    lundi 13 juillet 2015 09:28
  • Bonjour, BeN0o8,

    J'espère que les solutions proposées dans le thread en bas vous seront utiles:

    Windows 7: WUDFRd.sys Causing Errors Awakening From Sleep

    Merci de nous tenir au courant.

    Cordialement,
    Téodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    jeudi 16 juillet 2015 13:52
  • Bonjour et merci de votre retour.

    J'ai visiblement le meme probleme que celui decrit dans le lien. Sortie de veille aleatoire des lecteurs de smart cards.

    Nous en avons plusieurs model dans le parc (USB ou integré dans des claviers) Pour les premiers une modification du registre a suffit a regler le probleme (Driver Gemalto).

    Pour les claviers le probleme se corse car le pilote WUDFRd.sys ne prevois pas ce genre de modification (pas de WDF). heuresement j'ai trouver des pilotes qui reglent le probleme, malheuresement un clavier smart card utilise toujours le pilote generique Microsoft de 2006...

    Il ne semble pas y avoir de pilote pour ce dernier clavier. J'ai abandonner les recherches pour que toutes les smart card quelque soit le pilote aient la gestion d'energie desactivée, mais je n'ai pas l'impression que cela soit possible/prevu par Windows 7.

    Si d'autre personnes ont des pistes sinon j'ai bien peur de devoir me separer d'une partie des claviers de mon parcs :s...


    • Modifié BeN0o8 mardi 21 juillet 2015 09:09
    • Proposé comme réponse Emile Supiot lundi 3 août 2015 10:08
    • Marqué comme réponse Teodora Sharkova mercredi 5 août 2015 13:03
    mardi 21 juillet 2015 09:08