none
SBS 2008 - poste de travail Web à distance RRS feed

  • Question

  • Bonjour,

    Je suis en cours d'installation d'un SBS 2008.

    Les premières étapes se sont bien déroulées :
    - Création d'un nom de domaine <dom> qui fonctionne correctement.
    - Ouverture des ports du routeur (y compris 987)
    - Utilisateurs créés, postes LAN rattachés avec http://connect.
    - Les emails sont bien reçus dans les boîtes exchange <user>@<dom>
    - Le site companyweb fonctionne sur le LAN par ses deux noms (http://companyweb ou https://<dom>:987/).
    - Le certificat du serveur SBS a été déposé sur le poste distant que je veux utiliser (w7)
    - Le poste de travail Web à distance fonctionne pour l'interface principale (https://<dom>/Remote), owa (https://<dom>/owa) et les accès postes ou serveur depuis ce poste distant.

    MAIS l'accès à companyweb depuis ce poste distant (par https://<dom>:987/) ne fonctionne pas.

    J'ai vérifié les éléments de la liste fournie par MS dans technet :
    - Les utilisateurs doivent être membres des groupes de sécurité Utilisateurs du poste de travail Web à distance ou Admins du domaine.
    - Windows SBS 2008 doit autoriser les connexions via les ports TCP 80, 443, 987 et 3389.
    - L’ordinateur utilisé pour se connecter au poste de travail Web à distance doit autoriser les connexions via les ports TCP 80, 443, 987 et 3389.
    - Les routeurs sur Windows SBS 2008 doivent être configurés pour transférer le trafic Internet vers les ports TCP 80, 443, 987 et 3389.
    - Le navigateur utilisé pour afficher le poste de travail Web à distance doit prendre en charge et accepter les cookies. Sinon, le poste de travail Web à distance refuse la connexion.

    - PS :
     - je n'ai pas touché au VPN pour l'instant
     - mon routeur est une freebox paramétrée à la main

    A priori tout est OK j'ai désactivé le parefeu du poste, etc. bref je sèche.

    Merci à l'avance pour toutes vos bonnes idées.

    Philippe
    mardi 11 mai 2010 09:52

Réponses

  • Bonjour,

    Eh bien je suis loin d'être un spécialiste en certificats ... je vous fais confiance et vous livre simplement mes observations qui vous parleront sûrement plus qu'à moi.

    - A ma connaissance, j'ai retiré "remote" du serveur (ma valeur <sous dom> est un mot différent de "remote")

    - La modification du nom dans le serveur (remote.<sous dom>.<dom-public> => <sous dom>.<dom-public>) n'a pas eu pour effet de régénérer le certificat automatiquement (le fichier sur le serveur est le même)

    - Le poste distant avait eu un certificat installé depuis le départ (que j'ai repris tel quel et installé aussi dans Firefox pour vérifier)

    Mis à part de futures surprises que je pourrais avoir, l'accès fonctionne à présent à distance

    Voilà, j'espère donc ne pas avoir loupé un gros truc ... et vous remercie en tout cas pour votre aide ...

    ... et votre blog ... magnifique ... j'ai attaqué hier soir les mails et les SPF, il n'est pas exclu que je revienne avec des questions sur ce sujet !

    Bien cordialement

    • Marqué comme réponse phanpile mercredi 12 mai 2010 04:48
    mercredi 12 mai 2010 04:47

Toutes les réponses

  • Bonjour,
     
    Lors de l'assistant définissant votre adresse internet, si vous avez gardé les valeurs par défaut votre certificat autorisera l'usage de https://remote.<dom>
    Il faut donc que remote soit défini au sein de votre dns public et utiliser cette adresse.
    Vous pouvez éventuellement utiliser le nom de domaine sans nom d'hôte, mais cela doit être défini au niveau de l'assistant.

    --
    Cordialement,
     
    Yves Gourlé MCSA - MCTS - MCITP
    http://blog.gourle.com
    http://forums.sbsfr.org/
    "phanpile" a écrit dans le message de groupe de discussion : c9243115-bea8-443b-b2ec-ce5638622e2e...
    Bonjour,

    Je suis en cours d'installation d'un SBS 2008.

    Les premières étapes se sont bien déroulées :
    - Création d'un nom de domaine <dom> qui fonctionne correctement.
    - Ouverture des ports du routeur (y compris 987)
    - Utilisateurs créés, postes LAN rattachés avec http://connect.
    - Les emails sont bien reçus dans les boîtes exchange <user>@<dom>
    - Le site companyweb fonctionne sur le LAN par ses deux noms (http://companyweb ou https://<dom>:987/).
    - Le certificat du serveur SBS a été déposé sur le poste distant que je veux utiliser (w7)
    - Le poste de travail Web à distance fonctionne pour l'interface principale (https://<dom>/Remote), owa (https://<dom>/owa) et les accès postes ou serveur depuis ce poste distant.

    MAIS l'accès à companyweb depuis ce poste distant (par https://<dom>:987/) ne fonctionne pas.

    J'ai vérifié les éléments de la liste fournie par MS dans technet :
    - Les utilisateurs doivent être membres des groupes de sécurité Utilisateurs du poste de travail Web à distance ou Admins du domaine.
    - Windows SBS 2008 doit autoriser les connexions via les ports TCP 80, 443, 987 et 3389.
    - L’ordinateur utilisé pour se connecter au poste de travail Web à distance doit autoriser les connexions via les ports TCP 80, 443, 987 et 3389.
    - Les routeurs sur Windows SBS 2008 doivent être configurés pour transférer le trafic Internet vers les ports TCP 80, 443, 987 et 3389.
    - Le navigateur utilisé pour afficher le poste de travail Web à distance doit prendre en charge et accepter les cookies. Sinon, le poste de travail Web à distance refuse la connexion.

    - PS :
     - je n'ai pas touché au VPN pour l'instant
     - mon routeur est une freebox paramétrée à la main

    A priori tout est OK j'ai désactivé le parefeu du poste, etc. bref je sèche.

    Merci à l'avance pour toutes vos bonnes idées.

    Philippe

    Cordialement,
    Yves Gourlé MCSA - MCTS - MCITP
    blog.gourle.com
    mardi 11 mai 2010 10:26
    Modérateur
  • Bonjour,

    Merci pour vos 2 réponses.

    Pour compléter mon explication, nous avons un nom et un site web hébergé depuis longtemps chez un hébergeur externe. Appelons ce nom de domaine <dom-public>


    Les deux manips que j'ai réalisées avant mon installation SBS :

    1/ J'ai ajouté au serveur DNS de cet hébergeur une entrée "A" qui crée un sous domaine <sous dom> qui pointe sur l'adresse IP de mon serveur SBS (dans nos locaux)

    2/ J'ai indiqué le nom du reverse DNS à notre FAI (free) : .<sous dom>.<dom-public>

    Je n'ai indiqué "remote" nulle part

    (hormis dans une première étape dans le nom du reverse DNS créé au départ comme remote.<sous dom>.<dom-public> mais j'ai changé depuis au moins 3 semaines, je suppose que ça n'a aucun impact)


    Dans SBS, puisque j'avais déjà mon nom de domaine, j'ai utilisé l'option "Je souhaite gérer le nom de domaine moi-même". J'ai donc peut être loupé une étape.


    Aujourd'hui <sous dom>.<dom-public> pointe bien vers notre serveur local.



    voulez vous dire que je devrais ajouter une redirection remote.<sous dom> chez mon hébergeur ?

    Encore merci pour le temps que vous me consacrez

     

    mardi 11 mai 2010 12:17
  • Bonjour,
     
    Je développe cela en large ici :
     

    --
    Cordialement,
     
    Yves Gourlé MCSA - MCTS - MCITP
    http://blog.gourle.com
    http://forums.sbsfr.org
     
    "phanpile" a écrit dans le message de groupe de discussion : 2064f11d-d02d-4057-8049-b78168017cd5...

    Bonjour,

    Merci pour vos 2 réponses.

    Pour compléter mon explication, nous avons un nom et un site web hébergé depuis longtemps chez un hébergeur externe. Appelons ce nom de domaine <dom-public>


    Les deux manips que j'ai réalisées avant mon installation SBS :

    1/ J'ai ajouté au serveur DNS de cet hébergeur une entrée "A" qui crée un sous domaine <sous dom> qui pointe sur l'adresse IP de mon serveur SBS (dans nos locaux)

    2/ J'ai indiqué le nom du reverse DNS à notre FAI (free) : .<sous dom>.<dom-public>

    Je n'ai indiqué "remote" nulle part

    (hormis dans une première étape dans le nom du reverse DNS créé au départ comme remote.<sous dom>.<dom-public> mais j'ai changé depuis au moins 3 semaines, je suppose que ça n'a aucun impact)


    Dans SBS, puisque j'avais déjà mon nom de domaine, j'ai utilisé l'option "Je souhaite gérer le nom de domaine moi-même". J'ai donc peut être loupé une étape.


    Aujourd'hui <sous dom>.<dom-public> pointe bien vers notre serveur local.



    voulez vous dire que je devrais ajouter une redirection remote.<sous dom> chez mon hébergeur ?

    Encore merci pour le temps que vous me consacrez

     


    Cordialement,
    Yves Gourlé MCSA - MCTS - MCITP
    blog.gourle.com
    mardi 11 mai 2010 13:23
    Modérateur
  • Merci beaucoup,

    J'avais zappé le lien "Paramètres avancés" qui avait donc gardé "remote" par défaut.

     

    Je devais donc avoir :

    - Sur SBS : "remote.<sous dom>.<dom-public>"

    - Dans le DNS public : "<sous dom>.<dom-public>"

     

    Du coup j'ai remplacé

    - Dans Nom de domaine et extension : "<sous dom>.<dom-public>" par "<dom-public>"

    - Dans Paramètres avancés/Préfixe de domaine "remote" par "<sous dom>".

     

    Ca marche toujours en local, je vais tester à distance.

    Par contre le certificat, lui, n'a pas changé de date ... n'aurait il pas dû être régénéré ?

     

    mardi 11 mai 2010 15:37
  • bonsoir
     
    En fait le certificat que vous installez sur les postes c'est celui de l'autorité de certification fournie avec le sbs. De la sorte vous acceptez tout certificat émis par cette autorité, donc celui se rapportant à remote.domaine. Pour que cela fonctionne il faut néanmoins que l'adresse utilisée soit justement remote.domaine

    --
    Cordialement,
     
    Yves Gourlé [MCSA - MCTS - MCITP]
    http://blog.gourle.com
    http://forums.sbsfr.org
    "phanpile" a écrit dans le message de groupe de discussion : 702e6a60-9f2d-487f-af2e-6e6b90d17251...

    Merci beaucoup,

    J'avais zappé le lien "Paramètres avancés" qui avait donc gardé "remote" par défaut.

     

    Je devais donc avoir :

    - Sur SBS : "remote.<sous dom>.<dom-public>"

    - Dans le DNS public : "<sous dom>.<dom-public>"

     

    Du coup j'ai remplacé

    - Dans Nom de domaine et extension : "<sous dom>.<dom-public>" par "<dom-public>"

    - Dans Paramètres avancés/Préfixe de domaine "remote" par "<sous dom>".

     

    Ca marche toujours en local, je vais tester à distance.

    Par contre le certificat, lui, n'a pas changé de date ... n'aurait il pas dû être régénéré ?

     


    Cordialement,
    Yves Gourlé MCSA - MCTS - MCITP
    blog.gourle.com
    • Marqué comme réponse phanpile mercredi 12 mai 2010 04:33
    • Non marqué comme réponse phanpile mercredi 12 mai 2010 04:33
    mardi 11 mai 2010 16:37
    Modérateur
  • Bonjour,

    Eh bien je suis loin d'être un spécialiste en certificats ... je vous fais confiance et vous livre simplement mes observations qui vous parleront sûrement plus qu'à moi.

    - A ma connaissance, j'ai retiré "remote" du serveur (ma valeur <sous dom> est un mot différent de "remote")

    - La modification du nom dans le serveur (remote.<sous dom>.<dom-public> => <sous dom>.<dom-public>) n'a pas eu pour effet de régénérer le certificat automatiquement (le fichier sur le serveur est le même)

    - Le poste distant avait eu un certificat installé depuis le départ (que j'ai repris tel quel et installé aussi dans Firefox pour vérifier)

    Mis à part de futures surprises que je pourrais avoir, l'accès fonctionne à présent à distance

    Voilà, j'espère donc ne pas avoir loupé un gros truc ... et vous remercie en tout cas pour votre aide ...

    ... et votre blog ... magnifique ... j'ai attaqué hier soir les mails et les SPF, il n'est pas exclu que je revienne avec des questions sur ce sujet !

    Bien cordialement

    • Marqué comme réponse phanpile mercredi 12 mai 2010 04:48
    mercredi 12 mai 2010 04:47
  • Bonjour,
     
    Merci beaucoup pour vos compliments, n'hésitez pas à revenir avec vos questions !

    --
    Cordialement,
     
    Yves Gourlé [MCSA - MCTS - MCITP]
    http://blog.gourle.com
    http://forums.sbsfr.org

    Cordialement,
    Yves Gourlé MCSA - MCTS - MCITP
    blog.gourle.com
    mercredi 12 mai 2010 09:37
    Modérateur