none
probleme de deploiement du Bureau à distance RRS feed

  • Question

  • Bonjour,

    Voici mon soucis (pour ne pas dire plusieurs :( ) :

    J'ai plusieurs serveurs en 2012 R2 standard qui sont chacun utilisés par différents services via le Bureau à distance.

    1. Lors de ma première installation du rôle bureau à distance j'ai du laissé le déploiement de "bureaux basés sur un ordinateur virtuel" au lieu du "déploiement de bureaux basés sur une session". Lorsque je veux réinstaller évidement le choix du déploiement par session est grisé :( comment puis-je y remédier ???
    2. je sais que mon install n'est pas parfait mais dans un soucis de rapidité j'avais installé tous les rôles du bureau à distance sur chaque serveurs pour être sur que ça fonctionne car j'avais beau installer le pack de licences sur un serveur avec le role gestionnaire des licences mais les autres serveur 2012 ne recevaient pas les licnces :( .... donc je me retrouve avec plusieurs serveur de licences alors que j'ai par exemple acheter que 2 pack de 40 licences  :( . Maintenant je voudrais supprimer les serveurs de licences et n'en garder qu'un seule (voir 2) et savoir si çà me remettra t-il en conformité ? car je pense n’être pas trop conforme malgré que je ne dépasse pas le nombre de connexion TSE que j'ai acheté .
    3. j'ai dans les diagnostiques de licences un problème car il recherche un ancien serveur de licence qui n'existe plus .. comment puis-je le supprimer ?
    4. l'un des serveurs qui fonctionnait parfaitement a commencer a se dérégler du jour au lendemain mais j'ai l'impression que çà a commencer suite à l'installation du role AD DS sur ce même serveur (le service de gestion de bureau à distance ne veut plus se lancer)

    voila mes soucis "en gros" :(

    Merci de vos retours


    • Modifié Nicolas CH vendredi 24 mars 2017 09:44 oubli du pblm 4
    vendredi 24 mars 2017 09:40

Réponses

  • Bonjour ,

    Pour le 1) Il vous faut supprimer le role bureaux basé sur un ordinateur virtuel pour installé basé sur une session.

    2)Si vous avez installé tous les roles sur tous les serveurs, vous pouvez recommencer à 0.

    On installe une ferme RDS à partir d'un seul serveur qui va installer tout seul les roles sur les autres serveurs que l'on défini comme hote de session, serveur de licence, gateway...

    Voici un très bon tutoriel pour la mise en place d'une infra RDS

    https://hichamkadiri.wordpress.com/2015/04/22/guide-pas-a-pas-mise-en-place-dune-infrastructure-rds-2012-r2-hautement-disponible-part-1/

    3)Il faut en haut à gauche sélectionner la connexion vers un autre serveur.

    4)On n'installe pas l'AD sur un serveur hote de session...

    Pour résumer, vous pouvez recommencer complètement l'installation de l'infra RDS.

    Ensuite, on n'installe pas Active directory sur une vm ou on a le role RDS également

    vendredi 24 mars 2017 10:23
  • Bonjour,

    Merci de tous vos retours .

    J'aurais une dernière question concernant le point 4:

    • 4)On n'installe pas l'AD sur un serveur hote de session...

    cela signifie qu'on ne peut pas se connecter en TSE déçu ?

    car je vais installer les rôles TSE via la console de déploiement mais qu'est ce que je choisis pour mon serveur AD ???

    Bonjour

    Pour se connecter sur un DC à distance , il faut juste activer le remote desktop depuis les propriétés systèmes du contrôleur de domaine en question vous n'avez pas besoin d'installer aucun rôle supplémentaire (ni hote de session ni TSE):


    Please don't forget to mark the correct answer, to help others who have the same issue. Thameur BOURBITA MCSE | MCSA My Blog : http://bourbitathameur.blogspot.fr/

    mercredi 5 avril 2017 10:26
    Modérateur
  • Ok, c'est déjà un peu plus clair.

    Alors, il faut depuis Gestion que vous fassiez ajouter un serveur hote de session et vous ajoutez TEST. Si jamais vous n'avez pas installé test comme ca, supprimer le role sur test et réinstallez le de cette manière.

    C'est via cette interface qu'il faut le faire. Donc il faut depuis le serveur GESTION dans le gestionnaire de serveur ajouter le serveur TEST pour pouvoir le spécifier ensuite dans la console broker.

    Une fois fini il installe le role sur le serveur puis le fait redémarrer. Stipulez également le serveur de licence au niveau du broker et il aura lieu pour tous les serveurs de la ferme. Ensuite, lorsqu'une connexion sera initié sur un des 2 serveurs, il ira contacter le serveur de licence spécifié.

    Si jamais vous prévoyez d'avoir de nombreux hote de session, cela est également faisable via GPO pour les réglages de la ferme. Je vous déconseille fortement de mixer un paramètrage via la console + GPO afin de mieux comprendre le paramétrage qui s'applique réellement sur les serveurs.


    Merci de marquer comme réponse les sujets qui vous ont permis d'avancer afin que cela puisse être bénéfique aux personnes qui rencontrent le même problème.

    jeudi 6 avril 2017 08:33

Toutes les réponses

  • Bonjour ,

    Pour le 1) Il vous faut supprimer le role bureaux basé sur un ordinateur virtuel pour installé basé sur une session.

    2)Si vous avez installé tous les roles sur tous les serveurs, vous pouvez recommencer à 0.

    On installe une ferme RDS à partir d'un seul serveur qui va installer tout seul les roles sur les autres serveurs que l'on défini comme hote de session, serveur de licence, gateway...

    Voici un très bon tutoriel pour la mise en place d'une infra RDS

    https://hichamkadiri.wordpress.com/2015/04/22/guide-pas-a-pas-mise-en-place-dune-infrastructure-rds-2012-r2-hautement-disponible-part-1/

    3)Il faut en haut à gauche sélectionner la connexion vers un autre serveur.

    4)On n'installe pas l'AD sur un serveur hote de session...

    Pour résumer, vous pouvez recommencer complètement l'installation de l'infra RDS.

    Ensuite, on n'installe pas Active directory sur une vm ou on a le role RDS également

    vendredi 24 mars 2017 10:23
  • merci de votre retour,

    en gros :

    • je désinstalle tous les services bureau à distance sur tous les serveurs,
    • puis j'installe tous les services sur un seul 2012 qui n'est pas AD .
    • Puis sur les autres Windows 2012 j’installe que le host c'est ça?
    vendredi 24 mars 2017 11:26
  • Vous désinstaller tout partout.

    Puis vous lancez l'installation sur un mais pas en mode rapide. Il va vous demandez qui est votre serveur de licence, qui est votre serveur session host etc... Vous devez donc à ce moment la spécifier les serveurs que vous souhaitez.

    Tout est expliqué dans le lien que je vous ai fourni.

    Vous n'avez aucune manipulation à faire sur les autres serveurs. Tout va se passer au niveau du serveur qui possède le role broker, donc celui à partir duquel vous lancez l'installation.

    vendredi 24 mars 2017 18:35
  • Très bien, merci de votre retour.

    Mon but étant juste d'avoir un serveur qui gère les licences puis que mes utilisateurs puissent se connecter en TSE sur chaques serveurs .

    il faudrait que je le fasse hors production du coup :@

    J'avais une dernière question, concernant le serveur de licence , si je décide de mettre un deuxième serveur de licence avec un ajout de licence pack , le premier serveur de licence aura accès au licences ajouter sur le 2m serveur ?

    lundi 27 mars 2017 10:14
  • Non, cela ne fonctionnera pas comme vous le souhaitez.

    Si jamais vous mettez en place un second serveur de licence, il sera utilisé seulement sur les serveur session host que vous spécifiez.

    Il n'y à pas de "répartition de charge" avec les serveurs de licence.

    La méthode de haute dispo proposé pour ce service est disponible de 2 manières :

    -Avoir un serveur de licence en parallèle et on le spécifie en seconde position dans la liste des serveurs de licence et on assigne la moitié des licences au premier serveur et l'autre moitié à l'autre.

    -Préparer un serveur de licence puis l'éteindre. Si le premier à un problème, on l'allume et on fait pointer tout le monde dessus.


    Merci de marquer comme réponse les sujets qui vous ont permi d'avancer afin que cela puisse être bénéfique aux personnes qui rencontrent le même problème.

    lundi 27 mars 2017 10:51
  • Bonjour,

    Merci de tous vos retours .

    J'aurais une dernière question concernant le point 4:

    • 4)On n'installe pas l'AD sur un serveur hote de session...

    cela signifie qu'on ne peut pas se connecter en TSE déçu ?

    car je vais installer les rôles TSE via la console de déploiement mais qu'est ce que je choisis pour mon serveur AD ???

    mercredi 5 avril 2017 10:14
  • Bonjour,

    Merci de tous vos retours .

    J'aurais une dernière question concernant le point 4:

    • 4)On n'installe pas l'AD sur un serveur hote de session...

    cela signifie qu'on ne peut pas se connecter en TSE déçu ?

    car je vais installer les rôles TSE via la console de déploiement mais qu'est ce que je choisis pour mon serveur AD ???

    Bonjour

    Pour se connecter sur un DC à distance , il faut juste activer le remote desktop depuis les propriétés systèmes du contrôleur de domaine en question vous n'avez pas besoin d'installer aucun rôle supplémentaire (ni hote de session ni TSE):


    Please don't forget to mark the correct answer, to help others who have the same issue. Thameur BOURBITA MCSE | MCSA My Blog : http://bourbitathameur.blogspot.fr/

    mercredi 5 avril 2017 10:26
    Modérateur
  • Le fait d'installer le role TSE/RDS permet de lever la limitation de 2 connexions simultanées sur un serveur.

    Merci de marquer comme réponse les sujets qui vous ont permis d'avancer afin que cela puisse être bénéfique aux personnes qui rencontrent le même problème.

    mercredi 5 avril 2017 10:39
  • Merci pour l'info concernant l'AD ;)

    Par contre j'ai encore des soucis de déploiement .. je m'explique.

    J'ai désinstaller tous les rôles liés au bureau a distance sur une serveur TEST pour tester .

    J'ai un serveur GESTION où tous les rôles de bureau à distance sont installés . Le pack de licence fonctionne bien , mais sur le serveur TEST en 2012 où je déploie le rôle "hote de session" avec service BROKER lié à GESTION mais il n'arrive pas à récupérer les licences  alors que j'ai bien configuré le déploiement par user et stipulé que le serveur de licence était GESTION . help pls :(

    mercredi 5 avril 2017 12:59
  • Honnetement, je ne comprends pas....

    Pouvez vous clairement expliquer ce que vous avez installé sur :

    GESTION

    TEST

    ex :

    gestion : serveur de licence + hote de session

    test : broker + hote de session

    Parce que la, je comprends pas quel role est installé où mais encore une fois, il suffit juste de suivre ce guide pour avoir une infra hautement disponible:

    https://hichamkadiri.wordpress.com/2015/04/22/guide-pas-a-pas-mise-en-place-dune-infrastructure-rds-2012-r2-hautement-disponible-part-1/


    Merci de marquer comme réponse les sujets qui vous ont permis d'avancer afin que cela puisse être bénéfique aux personnes qui rencontrent le même problème.



    mercredi 5 avril 2017 13:39
  • Bonjour,

    c'est vrai que c'est un peu le fouillis car j'ai voulu faire simple .

    J'ai voulu tout simplement:

    • installé sur un serveur nommé GESTION tous les services du bureau à distance (hote+broker+licence+..)
    • sur les autres serveurs 2012, j'ai juste besoin de me connecter en TSE déçu donc j'ai déployé le service d’hôte mais le premier serveur TEST n'arrive pas à récupérer les licences et je ne comprend pas pourquoi. Pourtant quand je déploie le service bureau à distance, j'ai bien choisi le service broker (GESTION) et j'ai installer le rôle hôte sur TEST mais j'ai l'impression qu'il doit manquer quelques choses pour récupérer les licences pack installé sur GESTION :(


    jeudi 6 avril 2017 08:19
  • Ok, c'est déjà un peu plus clair.

    Alors, il faut depuis Gestion que vous fassiez ajouter un serveur hote de session et vous ajoutez TEST. Si jamais vous n'avez pas installé test comme ca, supprimer le role sur test et réinstallez le de cette manière.

    C'est via cette interface qu'il faut le faire. Donc il faut depuis le serveur GESTION dans le gestionnaire de serveur ajouter le serveur TEST pour pouvoir le spécifier ensuite dans la console broker.

    Une fois fini il installe le role sur le serveur puis le fait redémarrer. Stipulez également le serveur de licence au niveau du broker et il aura lieu pour tous les serveurs de la ferme. Ensuite, lorsqu'une connexion sera initié sur un des 2 serveurs, il ira contacter le serveur de licence spécifié.

    Si jamais vous prévoyez d'avoir de nombreux hote de session, cela est également faisable via GPO pour les réglages de la ferme. Je vous déconseille fortement de mixer un paramètrage via la console + GPO afin de mieux comprendre le paramétrage qui s'applique réellement sur les serveurs.


    Merci de marquer comme réponse les sujets qui vous ont permis d'avancer afin que cela puisse être bénéfique aux personnes qui rencontrent le même problème.

    jeudi 6 avril 2017 08:33
  • dans la console ci-dessus :

    j'ai le serveur GESTION en tant que :

    • service broker
    • gestionnaire de licence
    • accés web

    j'ai créer un serveur tout vierge nommé SRV2012. Depuis le gestionnaire de GESTION j'ai ajouté SRV2012 comme serveur à gérer et j'ai ajouté rôle "hôte de session"... SRV2012 redémarre et il me dit que le mode de licence n'est pas configuré ... comment est-ce possible sachant que j'ai installé depuis la console de GESTION :( ....  il doit me manquer un truc ....

    ps: sachant que lorsque je vais dans le gestionnaire de SRV2012 , dans la "vue d'ensemble" il me dit qu'  "il y a pas de serveur broker dans le pool serveur" mais on s'en fiche d'ajouter dans le pool du SRV2012 le serveur GESTION car concrètement nous ne sommes pas amené à gérer les services RDS depuis les serveurs hotes nan ?

    où serait ma faute ? :(

    jeudi 6 avril 2017 12:59
  • Sur le serveur gestion, quand vous aller sur le gestionnaire de broker, vous avez bien le serveur de licence de renseigné ?

    Il faut qu'en faisant

    puis gestionnaire de license, le serveur de license soit bien spécifié à cet endroit

    Vous devez ici spécifier si c'est un serveur par utilisateur ou par périphérique ainsi que le nom du serveur de licence.

    Tu peux également vérifier dans l'AD que le groupe serveur de licence contient bien GESTION (dans l'OU built in)


    Merci de marquer comme réponse les sujets qui vous ont permis d'avancer afin que cela puisse être bénéfique aux personnes qui rencontrent le même problème.



    jeudi 6 avril 2017 14:58
  • bonjour,

    je voyais bien le serveur de licence c’était bien la le soucis :(

    Par contre j'ai trouvé je pense ma solution, le fait qu'il n'y avait pas de "collection" semblait posé problème... donc j'ai recréé une collection et rajouté encore en hôte le serveur TEST et là par magie le serveur TEST a récupéré les licences .....

    J'avais une dernière question à vous posez avant de clore le ticket ...

    Lorsque j’installe le service bureau a distance sur un serveur qu’intègre via le Broker, le choix de "déploiement de bureaux basés sur une session" est grisé :( il ne me sélectionne que "déploiement de bureaux basés sur un ordinateur virtuel"

    pouvez vous m'expliquez ??? sachant que ça ne semble pas de poser de problème pour la session car il récupère bien les licences , le service d’hôte de session s'ajoute bien etc .....

    vendredi 7 avril 2017 13:49
  • Bonjour,

    Le broker ne peut être utilisé que pour un des 2 types de déploiement. Si vous l'avez déjà utilisé pour les déploiements basés sur une VM alors il est rataché à ce type de déploiement.

    Il faut supprimer puis réinstaller les roles avec le bon paramètrage si celui disponible n'est pas celui que vous souhaitez.


    Merci de marquer comme réponse les sujets qui vous ont permis d'avancer afin que cela puisse être bénéfique aux personnes qui rencontrent le même problème.

    dimanche 9 avril 2017 15:33