none
migration sbs2008 vers exchange2013 RRS feed

  • Discussion générale

  • Bonjour,

    Je migre actuellement un serveur sbs2008 vers Exchange2013.

    J'ai bien installé toutes les mises à jours exchange2007 sur le serveur SBS.

    J'ai installé les pré-requis sur mon nouveau serveur ( serveur 2012 ).

    L'installation d'Exchange2013 c'est passé sans aucun problème.

    Mon problème est que je vois pas monté la base exchange2013 sur l'exchange2007.

    Je n'arrive pas à accéder à l'administration " ecp ", j'ai un message " serveur introuvable.

    J'ai essayé d'installer le sp1 d'exchange2013. Je suis bloqué à l'étape 14 sur 18. Et j'ai le message suivant :

    Erreur :
    L'erreur suivante est survenue lors de l'exécution de "$error.Clear(); 
              $name = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxUniqueName;
              $dispname = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxDisplayName;
              $dismbx = get-mailbox -Filter {name -eq $name} -IgnoreDefaultScope -resultSize 1;
              if( $dismbx -ne $null)
              {
              $srvname = $dismbx.ServerName;
              if( $dismbx.Database -ne $null -and $RoleFqdnOrName -like "$srvname.*" )
              {
              Write-ExchangeSetupLog -info "Setup DiscoverySearchMailbox Permission.";
              $mountedMdb = get-mailboxdatabase $dismbx.Database -status | where { $_.Mounted -eq $true };
              if( $mountedMdb -eq $null )
              {
              Write-ExchangeSetupLog -info "Mounting database before stamp DiscoverySearchMailbox Permission...";
              mount-database $dismbx.Database;
              }

              $mountedMdb = get-mailboxdatabase $dismbx.Database -status | where { $_.Mounted -eq $true };
              if( $mountedMdb -ne $null )
              {
              $dmRoleGroupGuid = [Microsoft.Exchange.Data.Directory.Management.RoleGroup]::DiscoveryManagement_InitInfo.WellKnownGuid;
              $dmRoleGroup = Get-RoleGroup -Identity $dmRoleGroupGuid -DomainController $RoleDomainController -ErrorAction:SilentlyContinue;
              if( $dmRoleGroup -ne $null )
              {
                trap [Exception]
                {
                  Add-MailboxPermission $dismbx -User $dmRoleGroup.Name -AccessRights FullAccess -DomainController $RoleDomainController -ErrorAction SilentlyContinue;
                  continue;
                }
                
                Add-MailboxPermission $dismbx -User $dmRoleGroup.Identity -AccessRights FullAccess -DomainController $RoleDomainController -WarningAction SilentlyContinue;
              }
              }
              }
              }
            " : "Échec du montage de la base de données « DB01 ». Erreur : Une opération Active Manager a échoué. Erreur : L'action de base de données a échoué. Erreur : Une erreur s\'est produite lors de la préparation du montage de la base de données « 05aeadf8-075a-4b60-a440-b4a44f9cd304 » sur le serveur « SRV-EXCHANGE ». Erreur : Échec d'une opération d'administration côté serveur. Le délai imparti à l\'opération « ReplaySystemRunConfigurationUpdaterSingleConfig » pour la base de données « 05aeadf8-075a-4b60-a440-b4a44f9cd304 » a expiré au bout de « 00:00:05 ». [Base de données: DB01, Serveur: SRV-EXCHANGE.robatech.fr].".

    Pouvez-vous me dire si j'ai raté quelque chose dans ma configuration ?

    Cordialement

    Frédéric Verlant

    mercredi 15 juillet 2015 12:56

Toutes les réponses

  • Bonjour,

    il semble que ce problème est survenu lors de la création de la première bases de donnée pendant l'installation du rôle Mailbox.

    Essayez d'abord de vérifier à travers Adsedit de supprimer la base avec le nom indiqué dans le message d'erreur. Puis ressayez l'installation. 

    mercredi 15 juillet 2015 15:15
    Modérateur
  • Bonjour, 

    Merci de votre réponse.

    J'ai recommencé une installation. Mais j'ai d'autres problèmes.

    Maintenant je ne peux plus accéder en owa sur le serveur exchange 2007, message suivant :

    Request
    Url: http://fr-ad1.robatech.fr:80/owa/default.aspx

    Exception
    Exception type: Microsoft.Exchange.Data.Storage.ConnectionFailedTransientException
    Exception message: Cannot open mailbox /o=Robatech/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=Administrator.

    Call stack
    à Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry) à Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry) à Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString) à Microsoft.Exchange.Data.Storage.MailboxSession.Initialize(LogonType logonType, ExchangePrincipal owner, DelegateLogonUser delegateUser, Object identity, OpenMailboxSessionFlags flags) à Microsoft.Exchange.Data.Storage.MailboxSession.CreateMailboxSession(LogonType logonType, ExchangePrincipal owner, DelegateLogonUser delegateUser, Object identity, OpenMailboxSessionFlags flags, CultureInfo cultureInfo, String clientInfoString) à Microsoft.Exchange.Data.Storage.MailboxSession.Open(ExchangePrincipal mailboxOwner, WindowsPrincipal authenticatedUser, CultureInfo cultureInfo, String clientInfoString) à Microsoft.Exchange.Clients.Owa.Core.OwaWindowsIdentity.CreateMailboxSession(ExchangePrincipal exchangePrincipal, CultureInfo cultureInfo) à Microsoft.Exchange.Clients.Owa.Core.UserContext.Load(OwaContext owaContext) à Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.CreateUserContext(OwaContext owaContext, UserContextKey userContextKey, UserContext& userContext) à Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.PrepareRequestWithoutSession(OwaContext owaContext, UserContextCookie userContextCookie) à Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.InternalDispatchRequest(OwaContext owaContext) à Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchRequest(OwaContext owaContext) à System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() à System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    Inner Exception
    Exception type: Microsoft.Mapi.MapiExceptionLogonFailed
    Exception message: MapiExceptionLogonFailed: Unable to open message store. (hr=0x80040111, ec=1010) Diagnostic context: Lid: 18969 EcDoRpcExt2 called [length=889] Lid: 27161 EcDoRpcExt2 returned [ec=0x0][length=124][latency=15] Lid: 23226 --- ROP Parse Start --- Lid: 27962 ROP: ropLogon [254] Lid: 17082 ROP Error: 0x3F2 Lid: 26937 Lid: 21921 StoreEc: 0x3F2 Lid: 27962 ROP: ropExtendedError [250] Lid: 1494 ---- Remote Context Beg ---- Lid: 26426 ROP: ropLogon [254] Lid: 4740 StoreEc: 0x80070005 Lid: 30409 StoreEc: 0x80070005 Lid: 19145 StoreEc: 0x3F2 Lid: 23241 StoreEc: 0x3F2 Lid: 32186 Lid: 8620 StoreEc: 0x3F2 Lid: 1750 ---- Remote Context End ---- Lid: 26849 Lid: 21817 ROP Failure: 0x3F2 Lid: 26297 Lid: 16585 StoreEc: 0x3F2 Lid: 32441 Lid: 1706 StoreEc: 0x3F2 Lid: 24761 Lid: 20665 StoreEc: 0x3F2 Lid: 25785 Lid: 29881 StoreEc: 0x3F2

    Call stack

    à Microsoft.Mapi.MapiExceptionHelper.ThrowIfError(String message, Int32 hresult, Int32 ec, DiagnosticContext diagCtx) à Microsoft.Mapi.ExRpcConnection.OpenMsgStore(OpenStoreFlag storeFlags, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, MapiStore msgStorePrivate, String& correctServerDn, ClientIdentityInfo clientIdentityAs, String userDnAs, String applicationId, CultureInfo cultureInfo) à Microsoft.Mapi.ConnectionCache.OpenMapiStore(String mailboxDn, Guid mailboxGuid, Guid mdbGuid, ClientIdentityInfo clientIdentity, String userDnAs, OpenStoreFlag openStoreFlags, CultureInfo cultureInfo, String applicationId) à Microsoft.Mapi.ConnectionCache.OpenMailbox(String mailboxDn, Guid mailboxGuid, Guid mdbGuid, WindowsIdentity windowsIdentityAs, String userDnAs, OpenStoreFlag openStoreFlags, CultureInfo cultureInfo, String applicationId) à Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry

    Aussi, je ne peux pas accéder à l'interface ECP du serveur 2013. ( page introuvable )

    Je n'arrive pas migrer une boîte mail vers l'autre serveur.

    Cordialement

    Frédéric Verlant 

     
    lundi 20 juillet 2015 13:42
  • Bonjour, Frédéric ASTINFO,

    Je crois que la meilleure solution pour vous sera de contacter le support Microsoft par téléphone, pour obtenir une solution le plus vite possible.
    Bonne journée.

    Cordialement,
    Téodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    mercredi 5 août 2015 14:27
  • Bonjour,

    cela fait beaucoup de problèmes...

    Il faut d'abord retrouver un fonctionnement normal de Exchange 2007.

    L'installation de Exchange 2013 sur un autre serveur du même domaine ne devrait gêner en rien Exchange 2007. L'outil d'administration étant différent, il est normal de ne pas voir les serveurs et les banques (de la même manière)...

    Ensuite, il faut/faudrait réinstaller Exchange 2013, quitte à repasser par toutes les étapes.

    Si /ecp ne fonctionne pas bien, vérifier les paramètres de bases avec les commandes Powershell (pour voir tous les serveurs, toutes les banques, etc...).

    A bientôt


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(82 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    mercredi 5 août 2015 15:10
    Modérateur