none
Exchange 2013 - SMTP - 421 4.4.1 Connection Timed Out RRS feed

  • Discussion générale

  • Bonjour, 

    Depuis quelques jours, mes e-mails restent bloquer en files d'attente. Dans l'interface de gestion des fils d'attente, il essaye de se connecter au SMTP sans succès. 

    Toutes les 3-4 minutes, il refait une tentative qui n'aboutit pas. Il affiche comme erreur "Primary target IP respond with"421 4.4.1 Connection timed out".

    Le problème a commencé lors que j'ai installé le nouveau certificat SSL (ça ne peut être qu'une coïncidence). 

    Si je passe par Telenet, la connexion/envoi de mail fonctionne très bien. Que les mails soient interne ou externe, ils sont tous ralentis. Le plus surprenant, c'est que parfois, au bout de plusieurs heures, l'ensemble des e-mails est envoyé.
    Puis une file d'attente recommence. 

    J'ai tenté un redémarrage complet, un démarrage du service en différé... Rien y fait. 

    mardi 27 janvier 2015 13:00

Toutes les réponses

  • Bonjour,

    Pouvons-nous avoir un peu plus de précision as-tu plusieurs Exchange ? Le problème concerne t-il uniquement les messages venant de l'extérieur ou entre les serveurs exchange ?

    mardi 27 janvier 2015 13:49
  • Bien sûr !

    Un seul Exchange, 1 mailbox. Le problème ne concerne que les messages voulant sortir hors du domaine. 

    Les e-mails internes circulent correctement. Seuls les e-mails domaine-> hors domaine ce bloque dans la file d'attente. 


    • Modifié Arkentus mardi 27 janvier 2015 14:42
    mardi 27 janvier 2015 14:25
  • Dans l'EAC, dans flux de messagerie, connecteur d'envoi, y a t'il un connecteur de créé ?

    Si oui, peux tu vérifier que :

    - Proxy via serveur d'acccès au client est désactivé

    - dans l'onglet remise, vérifier si tu as mis un relais vers un hote actif si oui, les identifiants sont-ils bons ?

    mardi 27 janvier 2015 22:29
  • Bonjour et merci de votre temps,

    Oui il y a un connecteur

    Oui, le proxy est désactivé

    Oui, il est en mode relais et les aut. sont corrects

    Je rappelle que tout a très bien fonctionné pendant plus d'un mois et que ce n'est que très récemment, sans changement de configuration de ma part, que les messages ont commencé à bloquer. 

    mercredi 28 janvier 2015 06:56
  • Bonjour,

    Avez vous tenté de contacter votre provider, chez qui vous pousser vos mails (smarthost) ?

    Arrivez vous à resoudre le nom du smarthost depuis votre serveur et si vous faites un Telnet sur celui ci que se passe t il ?

    Vous pouvez aussi augmenter la durée du timeout pour tester à l'aide de la cmdlet:

    Set-SendConnector "Votre connecteur" -ConnectionInactivityTimeOut 00:20:00	

    Ref: https://technet.microsoft.com/fr-FR/library/aa998294(v=exchg.150).aspx

    Par défaut le timeout est à 10 minutes

    Merci


    Hakim Taoussi - Consultant Exchange - http://exchangediscover.blogspot.fr

    mercredi 28 janvier 2015 08:15
  • Bonjour,

    J'ai augmenté la durée du TimeOut, la commande est passée sans problème. 

    Avant de me connecter à mon FAI, j'ai fait un test Telenet sur le SMTP en port 25, qui a parfaitement fonctionné. D’ailleurs, si je crée un envoi de mail par ce chemin-là, il est directement transmis. 

    J'ai par la suite contacté mon FAI qui m'a confirmé que je n'étais pas présent sur une black list ni bloquer par leur service.

    mercredi 28 janvier 2015 08:32
  • As-tu activer les logs ?

    Peux-tu aller dans %Exchange Server Dir%\V15\TransportRoles\Logs\ProtocolLog\SmtpSend et regarde dans les logs la réponse envoyée par le serveur distant.

    mercredi 28 janvier 2015 10:41
  • Quelle différence y a t il entre votre test via Telnet et la configuration du send connector? l'authentification par exemple?

    Comme le propose mathdu0083, si les logs sont bien activés, vous pouvez regarder la réponse du serveur distant

    Merci


    Hakim Taoussi - Consultant Exchange - http://exchangediscover.blogspot.fr

    mercredi 28 janvier 2015 10:48
  • Bonjour,

    avez-vous essayé la remise directe ? au moins pour certains domaines...

    Avez-vous modifié le nombre de sessions ouvertes autorisées vers un même domaine ? Si tout est envoyé sur le relais du FAI, cette limite empêche la remise d'un nombre important de messages !

    A bientôt,


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(82 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    mercredi 28 janvier 2015 12:50
    Modérateur
  • Vérifie aussi le décalage du temps avec le prestataire ... J'ai déjà eu ce soucis et j'avais un décallage trop important.

    Enfin, analyse et fais nous remonter les logs, ils seront plus explicites

    mercredi 28 janvier 2015 13:36
  • La journalisation du connecteur est activé mais je ne trouve aucun fichier de log pour le SmtpSend.

    De peur que l’interface web me joue des tour, j'ai tenté l'activation des log via ligne de commande. Mais il m'a dit que "The comman completed successfully but no settings of "Connecteur envoi" have been modified. 

    Donc la journalisation est activé mais aucun log n'apparait nul part...
    mercredi 28 janvier 2015 14:35
  • J'ai retenté une Telnet qui a fonctionner. 

    Il n'y a pas d'authentification sur ce SMTP, il gère directement l'adresse IP de sortie.

    Le send connector est configurer comme suit: 


    Pour ce qui est des logs, comme répondu à mathdu0083, il n'apparaissent pas alors qu'il semble bien activé. 

    mercredi 28 janvier 2015 14:39
  • C'est une possibilité. Mais en général tous les mails sortent vers des domaines à nom privé ou de PME. Mais je vais quand même en confiture voir s’ils sortent tout seul.

    Non je n'ai rien modifié sur le nombre de sessions ouvertes. Mais le flux de mail n'est pas énorme. On parle de 10-20 mails par heures, je ne pense pas atteindre de limites qui sont à plus de 5'000. 

    mercredi 28 janvier 2015 14:43
  • L'idée semble intéressante, mais comment je peux vérifier le temps du serveur SMTP ?

    J'ai fait un test de connexion avec un outil web et il me sort un temps de connexion de 8 sec, se qu'il juge dangereux pour le bon fonctionnement du service. De même, en Telenet la connexion est instantanée. 
    mercredi 28 janvier 2015 14:59
  • " Le plus surprenant, c'est que parfois, au bout de plusieurs heures, l'ensemble des e-mails est envoyé. "

    Avec le temps, tous les messages partent donc ? Ou la plupart ?

    Cette observation peut vous aider à cadrer votre analyse. Si la configuration de l'authentication était mauvaise, cela ne marcherait pas parfois et parfois si.

    Un de nos parternaires a connu des retards comparables. Leur fournisseur de services courriels (Rackspace) recevait une telle quantité de messages (de tout le monde) qu'il ne pouvait pas accepter nos envois si bien que les messages restaient dans la file d'attente. Mais plus tard, les bouchons se dissipant, cela passait enfin.  


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    mercredi 28 janvier 2015 15:05
  • Redémarre le service de transport pour activer la journalisation. selon le CU, l'activation des log n'est prise en compte qu'après le redémarrage du service.

    mercredi 28 janvier 2015 16:03
  • Intéressant, 

    J'utilise les services d'un des principaux FAI de Suisse. Mais je ne vais quand même les contacts on sait jamais ;)

    Mais oui en effet, tous les messages partent au bout d'un moment (20 min comme 10 h plus tard). 

    jeudi 29 janvier 2015 08:10
  • J'ai redémarré le service via restant service msexchangetransport, mais les logs ne sont pas apparu

    J'ai donc redémarré tout le serveur, mais toujours pas.

    Cependant, j'ai trouvé le logs de Send connector protocole log files for the Transport service on Mailbox sérvers

    Ce log provient d'un moment où tout se passe bien.

    2015-01-29T09:00:29.031Z,Connecteur envoi,08D209B8A1319A9C,0,,195.186.136.50:25,*,,attempting to connect 2015-01-29T09:00:29.031Z,Connecteur envoi,08D209B8A1319A9C,1,172.16.1.11:34152,195.186.136.50:25,+,, 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,2,172.16.1.11:34152,195.186.136.50:25,<,220 zhhdzmsp-smtp16.bluewin.ch ESMTP Service (Swisscom Schweiz AG) ready, 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,3,172.16.1.11:34152,195.186.136.50:25,>,EHLO mail.domain.ch, 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,4,172.16.1.11:34152,195.186.136.50:25,<,250-zhhdzmsp-smtp16 says EHLO to 109.164.000.000:34152, 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,5,172.16.1.11:34152,195.186.136.50:25,<,250-STARTTLS, 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,6,172.16.1.11:34152,195.186.136.50:25,<,250-SIZE 100000000, 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,7,172.16.1.11:34152,195.186.136.50:25,<,250-ENHANCEDSTATUSCODES, 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,8,172.16.1.11:34152,195.186.136.50:25,<,250-8BITMIME, 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,9,172.16.1.11:34152,195.186.136.50:25,<,250 PIPELINING, 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,10,172.16.1.11:34152,195.186.136.50:25,>,STARTTLS, 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,11,172.16.1.11:34152,195.186.136.50:25,<,220 2.0.0 continue, 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,12,172.16.1.11:34152,195.186.136.50:25,*,,Sending certificate 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,13,172.16.1.11:34152,195.186.136.50:25,*,"E=webmaster@domain.ch, CN=mail.domain.ch, O=prenom nom, L=ville, S=canton, C=CH",Certificate subject 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,14,172.16.1.11:34152,195.186.136.50:25,*,"CN=StartCom Class 2 Primary Intermediate Server CA, OU=Secure Digital Certificate Signing, O=StartCom Ltd., C=IL",Certificate issuer name 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,15,172.16.1.11:34152,195.186.136.50:25,*,0000000000000000,Certificate serial number 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,16,172.16.1.11:34152,195.186.136.50:25,*,00000000aaaaaaaabbbbbbb,Certificate thumbprint 2015-01-29T09:00:29.046Z,Connecteur envoi,08D209B8A1319A9C,17,172.16.1.11:34152,195.186.136.50:25,*,mail.domaine.ch;domain.ch;webmail.domain.ch;outlook.domain.ch;serveur.domain.ch,Certificate alternate names 2015-01-29T09:00:29.062Z,Connecteur envoi,08D209B8A1319A9C,18,172.16.1.11:34152,195.186.136.50:25,*,,Received certificate 2015-01-29T09:00:29.062Z,Connecteur envoi,08D209B8A1319A9C,19,172.16.1.11:34152,195.186.136.50:25,*,000000000000000000000,Certificate thumbprint 2015-01-29T09:00:29.062Z,Connecteur envoi,08D209B8A1319A9C,20,172.16.1.11:34152,195.186.136.50:25,>,EHLO mail.arches.ch, 2015-01-29T09:00:29.109Z,Connecteur envoi,08D209B8A1319A9C,21,172.16.1.11:34152,195.186.136.50:25,<,250-zhhdzmsp-smtp16 says EHLO to 109.164.000.000:34152, 2015-01-29T09:00:29.109Z,Connecteur envoi,08D209B8A1319A9C,22,172.16.1.11:34152,195.186.136.50:25,<,250-ENHANCEDSTATUSCODES, 2015-01-29T09:00:29.109Z,Connecteur envoi,08D209B8A1319A9C,23,172.16.1.11:34152,195.186.136.50:25,<,250-8BITMIME, 2015-01-29T09:00:29.109Z,Connecteur envoi,08D209B8A1319A9C,24,172.16.1.11:34152,195.186.136.50:25,<,250-PIPELINING, 2015-01-29T09:00:29.109Z,Connecteur envoi,08D209B8A1319A9C,25,172.16.1.11:34152,195.186.136.50:25,<,250 SIZE 100000000, 2015-01-29T09:00:29.109Z,Connecteur envoi,08D209B8A1319A9C,26,172.16.1.11:34152,195.186.136.50:25,*,,sending message with RecordId 5793910882349 and InternetMessageId <00000000aaaaaaabvbbbbbbbb@serveur.domain.ch> 2015-01-29T09:00:29.109Z,Connecteur envoi,08D209B8A1319A9C,27,172.16.1.11:34152,195.186.136.50:25,>,MAIL FROM:<employe2@domaine.ch> SIZE=14976, 2015-01-29T09:00:29.109Z,Connecteur envoi,08D209B8A1319A9C,28,172.16.1.11:34152,195.186.136.50:25,>,RCPT TO:<xxx@yyy.fr>, 2015-01-29T09:00:29.140Z,Connecteur envoi,08D209B8A1319A9C,29,172.16.1.11:34152,195.186.136.50:25,<,250 2.0.0 MAIL FROM accepted, 2015-01-29T09:00:29.156Z,Connecteur envoi,08D209B8A1319A9C,30,172.16.1.11:34152,195.186.136.50:25,<,250 2.0.0 RCPT TO accepted, 2015-01-29T09:00:29.156Z,Connecteur envoi,08D209B8A1319A9C,31,172.16.1.11:34152,195.186.136.50:25,>,DATA, 2015-01-29T09:00:29.156Z,Connecteur envoi,08D209B8A1319A9C,32,172.16.1.11:34152,195.186.136.50:25,<,"354 3.0.0 continue. finished with ""\r\n.\r\n""", 2015-01-29T09:00:29.328Z,Connecteur envoi,08D209B8A1319A9C,33,172.16.1.11:34152,195.186.136.50:25,<,250 2.0.0 OK 56/11-11760-6E6F9C45, 2015-01-29T09:00:29.375Z,Connecteur envoi,08D209B8A1319A9C,34,172.16.1.11:34152,195.186.136.50:25,*,,sending message with RecordId 5793910882367 and InternetMessageId <00000aaaabbbbb@serveur.domaine.ch> 2015-01-29T09:00:29.375Z,Connecteur envoi,08D209B8A1319A9C,35,172.16.1.11:34152,195.186.136.50:25,>,MAIL FROM:<employe1@domaine.ch> SIZE=17405, 2015-01-29T09:00:29.375Z,Connecteur envoi,08D209B8A1319A9C,36,172.16.1.11:34152,195.186.136.50:25,>,RCPT TO:<xxx@yyy.ch>, 2015-01-29T09:00:29.375Z,Connecteur envoi,08D209B8A1319A9C,37,172.16.1.11:34152,195.186.136.50:25,<,250 2.0.0 MAIL FROM accepted, 2015-01-29T09:00:29.406Z,Connecteur envoi,08D209B8A1319A9C,38,172.16.1.11:34152,195.186.136.50:25,<,250 2.0.0 RCPT TO accepted, 2015-01-29T09:00:29.406Z,Connecteur envoi,08D209B8A1319A9C,39,172.16.1.11:34152,195.186.136.50:25,>,DATA, 2015-01-29T09:00:29.406Z,Connecteur envoi,08D209B8A1319A9C,40,172.16.1.11:34152,195.186.136.50:25,<,"354 3.0.0 continue. finished with ""\r\n.\r\n""", 2015-01-29T09:00:29.578Z,Connecteur envoi,08D209B8A1319A9C,41,172.16.1.11:34152,195.186.136.50:25,<,250 2.0.0 OK D6/11-11760-6E6F9C45, 2015-01-29T09:00:29.578Z,Connecteur envoi,08D209B8A1319A9C,42,172.16.1.11:34152,195.186.136.50:25,>,QUIT, 2015-01-29T09:00:29.593Z,Connecteur envoi,08D209B8A1319A9C,43,172.16.1.11:34152,195.186.136.50:25,<,221 2.3.0 zhhdzmsp-smtp16 closing connection, 2015-01-29T09:00:29.593Z,Connecteur envoi,08D209B8A1319A9C,44,172.16.1.11:34152,195.186.136.50:25,-,,Local

    Ce log provient d'un moment où les e-mails ne partent pas

    2015-01-29T08:59:28.663Z,Connecteur envoi,08D209B8A1319A9B,0,,195.186.136.50:25,*,,attempting to connect
    2015-01-29T08:59:28.670Z,Connecteur envoi,08D209B8A1319A9B,1,172.16.1.11:33984,195.186.136.50:25,+,,
    2015-01-29T08:59:28.875Z,Connecteur envoi,08D209B8A1319A9B,2,172.16.1.11:33984,195.186.136.50:25,<,220 zhhdzmsp-smtp16.bluewin.ch ESMTP Service (Swisscom Schweiz AG) ready,
    2015-01-29T08:59:28.875Z,Connecteur envoi,08D209B8A1319A9B,3,172.16.1.11:33984,195.186.136.50:25,>,EHLO mail.domaine.ch,
    2015-01-29T08:59:28.881Z,Connecteur envoi,08D209B8A1319A9B,4,172.16.1.11:33984,195.186.136.50:25,<,250-zhhdzmsp-smtp16 says EHLO to 109.164.223.233:33984,
    2015-01-29T08:59:28.881Z,Connecteur envoi,08D209B8A1319A9B,5,172.16.1.11:33984,195.186.136.50:25,<,250-STARTTLS,
    2015-01-29T08:59:28.881Z,Connecteur envoi,08D209B8A1319A9B,6,172.16.1.11:33984,195.186.136.50:25,<,250-SIZE 100000000,
    2015-01-29T08:59:28.881Z,Connecteur envoi,08D209B8A1319A9B,7,172.16.1.11:33984,195.186.136.50:25,<,250-PIPELINING,
    2015-01-29T08:59:28.881Z,Connecteur envoi,08D209B8A1319A9B,8,172.16.1.11:33984,195.186.136.50:25,<,250-8BITMIME,
    2015-01-29T08:59:28.881Z,Connecteur envoi,08D209B8A1319A9B,9,172.16.1.11:33984,195.186.136.50:25,<,250 ENHANCEDSTATUSCODES,
    2015-01-29T08:59:28.881Z,Connecteur envoi,08D209B8A1319A9B,10,172.16.1.11:33984,195.186.136.50:25,>,STARTTLS,
    2015-01-29T08:59:28.889Z,Connecteur envoi,08D209B8A1319A9B,11,172.16.1.11:33984,195.186.136.50:25,<,220 2.0.0 continue,
    2015-01-29T08:59:28.889Z,Connecteur envoi,08D209B8A1319A9B,12,172.16.1.11:33984,195.186.136.50:25,*,,Sending certificate
    2015-01-29T08:59:28.889Z,Connecteur envoi,08D209B8A1319A9B,13,172.16.1.11:33984,195.186.136.50:25,*,"E=webmaster@domaine.ch, CN=mail.doamine.ch, O=Prenom Nom, L=Ville, S=Canton, C=CH",Certificate subject
    2015-01-29T08:59:28.889Z,Connecteur envoi,08D209B8A1319A9B,14,172.16.1.11:33984,195.186.136.50:25,*,"CN=StartCom Class 2 Primary Intermediate Server CA, OU=Secure Digital Certificate Signing, O=StartCom Ltd., C=IL",Certificate issuer name
    2015-01-29T08:59:28.889Z,Connecteur envoi,08D209B8A1319A9B,15,172.16.1.11:33984,195.186.136.50:25,*,00000000,Certificate serial number
    2015-01-29T08:59:28.889Z,Connecteur envoi,08D209B8A1319A9B,16,172.16.1.11:33984,195.186.136.50:25,*,00000aaaaabbbbb,Certificate thumbprint
    2015-01-29T08:59:28.889Z,Connecteur envoi,08D209B8A1319A9B,17,172.16.1.11:33984,195.186.136.50:25,*,mail.domaine.ch;arches.ch;webmail.domaine.ch;outlook.domaine.ch;serveur.domaine.ch,Certificate alternate names
    2015-01-29T08:59:28.982Z,Connecteur envoi,08D209B8A1319A9B,18,172.16.1.11:33984,195.186.136.50:25,*,,Received certificate
    2015-01-29T08:59:28.982Z,Connecteur envoi,08D209B8A1319A9B,19,172.16.1.11:33984,195.186.136.50:25,*,0000000aaaaabbbbbb,Certificate thumbprint
    2015-01-29T08:59:28.982Z,Connecteur envoi,08D209B8A1319A9B,20,172.16.1.11:33984,195.186.136.50:25,>,EHLO mail.domaine.ch,
    2015-01-29T08:59:28.983Z,Connecteur envoi,08D209B8A1319A9B,21,172.16.1.11:33984,195.186.136.50:25,-,,Local

    Malheureusement ce sont les seuls log que j'ai pu trouver. 

    Par contre, j'avais 19 e-mails en attente depuis ce matin. Lorsque j'ai lancé la cmdlet, tous les e-mails sont partis. De même pour les 2 mails suivant lorsque j'ai redémarré le serveur


    • Modifié Arkentus jeudi 29 janvier 2015 09:31
    jeudi 29 janvier 2015 09:30
  • Le serveur distant est apparement un serveur qui accepte un certificat, puisque dans ce cas, on voit bien qu'un certificat est échangé. Dans ce cas avez-vous informé votre prestataire du changement de certificat ?

    jeudi 29 janvier 2015 09:42
  • Non 

    Sa ne mes pas venu a l'esprit. Je n'avais pas fait de démarche pour le premier certificat, je ne pensais pas devoir en faire pour celui-ci

    Le premier certificat était un class 1 qui s'occupait de mail.domaine.ch. J'ai rapidement mis en place un class 2 avec tous les sous-domaines que l'on voit. 

    Je peu sans autre prendre contact avec eu pour controler tout ça. 

    jeudi 29 janvier 2015 10:04
  • Du coup demande à ton prestataire de vérifier les journaux. vu qu'en lisant le message principal j'ai vu que tu avais changé de certificat ...

    jeudi 29 janvier 2015 10:05
  • Selon le prestataire, le seul contrôle qu'il font c'est avec l'IP. Après leur bis est "unmanaged", si le Telnet passe... pour eux tout va

    jeudi 29 janvier 2015 10:30
  • J'ai modifié le connecteur d'envoi, 

    je l'ai réglé de façon à ce qu'il utilise "Enregistrement MX associé au domaine du destinataire" 

    Ça semble correctement fonctionner, je verrais demain. Si cette configuration fonctionne, quel problème vais-je avoir à terme en utilisant ce système ?

    lundi 2 février 2015 15:39
  • Cela spécifie uniquement qu'il va utiliser le système DNS pour acheminer les messages.

    Il n'y a pas de risque, à moins de ne plus avoir de DNS, donc plus d'AD, donc plus d'internet, donc plus d'Exchange :)

    lundi 2 février 2015 16:47
  • Well ...

    Bon bin je vais laisser comme ça alors :D

    Débuter en exchange c'est hard -.-

    En tout cas merci à tous ! 
    mardi 3 février 2015 07:47