locked
Teaming Intel - Cluster Hyper-V RRS feed

  • Discussion générale

  • Bonjour,

    Je viens voir si vous avez un retour d’expérience par rapport au teaming Intel. Voici la description de mon labo (W2K8R2 SP1):

    - 2 serveurs Hyper-V - 64 Go - 1 NIC Broadcom 4 ports - 1 NIC Intel (intégrée - modèle i350) 2 ports

    - Broadcom: 2 ports CSV en 802.3ad (10.0.0.x) - 2 ports iSCSI en SLB (192.168.1.x)

    - Intel: 2 ports Production en 802.3ad (Subnetting: 172.10.0.x => les Hyper-V - 172.10.10.x => les VMs)

    - Switch réseau HP Procurve 1910 - ports configurés en LACP - STP disable - VLAN...

    Je rencontre des problèmes vraiment bizarres, et je pense avoir isolé le problème: les cartes Intel. Je n'ai aucun problème avec mes cartes Broadcom, par contre avec les Intels, je deviens dingue, des problème de pings complétement aléatoire interviennent:

    - des fois je ping tout

    - j'arrive à pinger depuis un hyper-v des vms, des fois pas

    - depuis une vm imposible de pinger une autre vm

    - depuis une vm, j'arrive à pinger un hyper-v, des fois pas...

    - dans n'importe quel cas, lorsque je lance un ping, j'ai une première réponse après plus rien...

    - dans n'importe quel cas, lorsque je lance un ping, j'ai pas de résolution de noms

    - dans n'importe quel cas, lorsque je lance un ping, j'ai pas de réponses tout de suite, mais après 2/3 minutes, j'obtiens des réponses...

    Bref, totalement aléatoire, en désactivant le LACP au niveau du switch, ça à l'air de fonctionner.... (sans en être sûr)

    Je connais la politique de support de MS (http://support.microsoft.com/kb/968703) au sujet du Teaming, que les cartes intégrées ne sont pas recommandées, que c'est un problème connu, etc...

    D'autant plus bizarre que sur un autre serveur, j'avais des erreurs VMSMP (Port '97B1A2BA-D679-4290-AD9B-262DE33C16D6' was prevented from using MAC address '00-15-D5-04-F8-0C' because it is pinned to port 'BFA4D592-1F9D-8484-8ABF-9EDA1534529E'.) que j'ai réussi à résoudre en changeant le type de Teaming (même carte Intel) !

    Je cherche juste un retour d'expérience, savoir si je pousse plus loin ou pas, ou si j'achète une Broadcom ;-)


    -- Cédric GEORGEOT [MVP] Virtual Machine http://www.e-novatic.fr -- Auteur du livre "Bonnes pratiques, planification et dimensionnement des infrastructures de stockage et de serveur en environnement virtuel" -- N'oubliez pas de marquer comme réponse ;-)



    mardi 21 août 2012 06:08

Toutes les réponses

  • Bonjour,

    J'ai trouvé deux liens ci-dessous qui peuvent vous aider à trouver une piste utile:

    Hyper-V* child partition cannot communicate through RLB team

    Hyper-V* virtual NIC will not communicate


    Best regards Bourbita Thameur Microsoft Certified Technology Specialist: Windows Server 2008 R2,Server Virtualizaton

    mardi 21 août 2012 11:55
    Auteur de réponse
  • Bonjour,<o:p></o:p>

    J'ai déjà rencontré un problème similaire sans LACP. Comme cela fait longtemps je n'ai plus tous les détails mais de ce que je me souviens.

    En gros dès que j'utilisai au moins deux port sur la Broadcom (OB) est que j'en utilisai plus de trois sur la Intel je pouvais pinger que une partie du réseau est cela quel que soit les ports utilisés dès qu'il y avait 3 d'utilisé sur la carte Intel.<o:p></o:p>

    Pour résoudre le problème j'ai dû désactiver RSS.

    Donc tu peux essayer des désactiver certaines accélération qui peuvent poser problèmes dans certain cas.

    http://support.microsoft.com/kb/951037.<o:p></o:p>

    Vue que c'est simple à tester est totalement réversible sa vaut la peine d'essayer si ce n'est pas déjà fait.<o:p></o:p>


    dimanche 26 août 2012 14:59
  • Bonjour,

    Merci pour vos réponses. Après de longues et nombreuses investigations, il s'avère que la cohabitation Intel/Broadcom pose des problèmes. J'ai pu remarquer des problèmes MAC sur certaines interfaces aggrégées, un arp -a remontait des adresses MAC différentes d'un serveur à un autre. Même en "forcant" les adresses MAC, pas d'amélioration.

    Pour conclure, voici comment j'ai pu résoudre mon problème:

    - création de VLAN pour le services du CSV, iSCSI, et réseau de production. Chaque VLAN comporte des trunk LACP de la même marque ! (VLAN1: que des cartes Intel, VLAN2: que du Broadcom, ...)

    - je n'ai rien désactivé (RSS, ToE, ....)

    Pour conclure, il faut acheter des cartes de mêmes marques & modèle et désactiver les ports internes de façon à n'utiliser qu'un type de pilote.

    N'oublions pas que Windows Server 2012 gère tout cela en natif !!!


    -- Cédric GEORGEOT [MVP] Virtual Machine http://www.e-novatic.fr -- Auteur du livre "Bonnes pratiques, planification et dimensionnement des infrastructures de stockage et de serveur en environnement virtuel" -- N'oubliez pas de marquer comme réponse ;-)

    lundi 27 août 2012 08:20