locked
.net Framework 3.5 Windows 8 impossible de l'installer. RRS feed

  • Question

  • Bonjour à tous,

    J'ai un problème avec l'installation du framework .net 3.5 et ma version de Windows 8.1 Pro.

    J'ai bien sur suivi la doc : http://msdn.microsoft.com/fr-fr/library/hh506443%28v=vs.110%29.aspx

    Erreur 0x800f0906, j'ai pourtant Internet (connexion WiFi), j'ai suivi la procédure utilisant DISM mais rien n'y fait (j'ai testé avec plusieurs iso (mon original, version trouvé sur le site de Microsoft (entreprise 8.1), torrent), monté les iso avec l'outil inclus de base avec Windows 8, copier le dossier source/sxs à la racine de c:/, rien n'y fait.

    La seule chose que j'ai pu faire de "dangereux" est le fait d'avoir passé un coup de ccleaner (registre) et bien sur je n'ai pas fait de backup. -_-

    Vous pouvez trouver à ce lien mon dossier c:/windows/logs/ contenant les fichier CBS.log et dism.log (ils doivent être relativement pleins à cause de mes nombreux tests).

    A noter, j'ai aussi utilisé .net framework 3.5 offline installer sans résultat.

    Merci à vous.

    mardi 26 août 2014 10:29

Réponses

  • Ok j'ai finalement résolu mon problème.

    Il faut supprimer les mise à jour KB2966826 et KB2966828. Puis retourner dans ajouter/supprimer des fonctionnalités Windows et retenter l'installation de .Net 3.5 (à savoir : j'avais la stratégie de groupe "Spécifier des parametres pour l'installation des composants facultatifs et la réparation de composants" trouvable dans Configuration d'ordinateur/Modèles d'administration/Système d'activer(aucun chemin, aucune case de cochée)).


    Solution trouvée ici : http://superuser.com/questions/799687/net-3-5-installation-comes-up-with-error-0x800f0906-then-0x800f0081f-using-dis
    • Marqué comme réponse Team Boreal mercredi 27 août 2014 15:29
    • Modifié Team Boreal mercredi 27 août 2014 15:29
    mercredi 27 août 2014 15:28

Toutes les réponses

  • Bonjour,

    Avez-vous installé des programmes /outils particulier depuis l'installation de W8 ?

    s'il s'agit d'une install fraîche, ce que vous pouvez faire, c'est de déployer W8 sur une machine temporaire, lancer regedit.exe => faire un export de la BDR, faire un import sur la machine posant problème et lancer l'installer Offline du FrameW .N 3.5 (faire un backup d'abord de la BDR de cette dernière avant import).

    CCleaner peut effectivement effacer des entrées dont le Framework .Net a besoin.

    A+
    HK.


    Hicham KADIRI | Just Another IT Guy

    mardi 26 août 2014 18:24
  • Hélas j'ai installé pas mal de soft dessus (visual studio, filezilla, office, steam, etc.) et l'import ne marchera pas, ou en tout cas fera bug mon PC.

    Il reste la solution de la comparaison de base de registre mais je ne suis pas expert dans ce domaine et je ne sais pas si c'est viable, d'autant plus que j'ai fait toutes les mise à jour Windows depuis l'installation.

    J'espérais qu'il y avait une clef "magique" à remettre mais ça n'a pas l'air si simple.

    mardi 26 août 2014 20:31
  • CCleaner reste une cause probable, mais ça peut être dû à autre chose.

    la méthode qui consiste à activer /ajouter le framework .net 3.5 à l'aide de l'outil DISM, vous dites que cela ne résout pas votre problème mais la question est :

    qu'est ce que vous avez utilisé comme source avec DISM (ce qui suit le paramètre /source: ??

    Je viens de produire ce probleme sur une VM W8 et à l'aide de la commande :

    Dism /online /enable-feature /featurename:NetFx3 /All /Source:D:\sources\sxs /LimitAccess

    le pb est résolu.

    en revanche, je dispose d'un LAN (réseau filaire) chez moi pas un WLAN.

    A+
    HK.


    Hicham KADIRI | Just Another IT Guy

    mardi 26 août 2014 20:39
  • Je lance exactement la même commande (copier/coller), mais cela ne fonctionne pas.

    J'ai bien monté mon iso sur D:\, je tenterais avec le LAN demain même si je doute énormément que cela en soit la cause puisque je ping bien aussi bien des IP que des adresses.

    mardi 26 août 2014 20:51
  • Ok j'ai finalement résolu mon problème.

    Il faut supprimer les mise à jour KB2966826 et KB2966828. Puis retourner dans ajouter/supprimer des fonctionnalités Windows et retenter l'installation de .Net 3.5 (à savoir : j'avais la stratégie de groupe "Spécifier des parametres pour l'installation des composants facultatifs et la réparation de composants" trouvable dans Configuration d'ordinateur/Modèles d'administration/Système d'activer(aucun chemin, aucune case de cochée)).


    Solution trouvée ici : http://superuser.com/questions/799687/net-3-5-installation-comes-up-with-error-0x800f0906-then-0x800f0081f-using-dis
    • Marqué comme réponse Team Boreal mercredi 27 août 2014 15:29
    • Modifié Team Boreal mercredi 27 août 2014 15:29
    mercredi 27 août 2014 15:28