locked
RDC sur MAC vers 2008 R2 : problèmes durant l'exécution du protocole de gestion de licences RRS feed

  • Question

  • Bonjour,

    J'ai construit une infrastructure de type AD + Exchagne sur AD00 ; Remote desktop services sur TS00.

    Tout fonctionne bien sauf sur des Mac à partir desquels il est impossible de se connecter sur le Terminal Server.

    Les MACs renvoient une erreur :

    FR : Vous avez été déconnecté de l'ordinateur Windows en raison de problèmes durant l'exécution du protocole de gestion de licences

    EN : You were disconnected from the Windows-based computer because of problems during the licensing protocol

    Sachez que la connexion fonctionne avec CoRD mais pas avec le Microsoft Remote Desktop client for MAC 2.1.1.

    Ce qui témoigne du fait que si le problème vient du MAC il vient du produit RDC Microsoft installé en son sein pour se connecter à un autr produit Microsoft.

    Si la connexion fonctionne avec CoRD, pourquoi je m'ennuie avec RDC for MAC ?

    Car le support est bin meilleur: Quand cela fonctionne le mapping du clavier et des imprimantes est bien meilleur puis ca lag beaucoup moins.

    J'ai déjà essayé de vider /home/users/shared/Microsoft/Crucial ... et tout ce qui traîne sur le net comme "solutions" : Pas de changement

    Je mentionne que ce même MAC (Book 10.6 est à jour, le RDC aussi) arrive à se connecter sur 3 autres serveurs du même type... qu'ils soient couverts ou non par des licences. Il y a quelque chose dans la configuration qui ne va pas mais laquelle !!??

    J'ai tenté de mettre le rôle RD Licensing sur le même serveur pour repartir à zéro en ce qui concerne les licences. Pas de changement

    Les paramètres de connexion du RD Session Host sont les suivants :

    Le certificat est valide , il s'agit d'un certificat acheté chez godaddy.

    Je viens de faire un lab AD00 + TS00 fresh install et même problème mais/et le MAC arrive toujours à se connecter sur un autre RDS sur lequel cela fonctionnait auparavant.

    D'avance merci pour votre réponse.

    • Modifié NGiloteau lundi 15 octobre 2012 11:11
    lundi 15 octobre 2012 11:06

Réponses

  • Bonjour,

    J'ai rencontré ce genre de souci après installation RDS CAL licences.

    Essayez ceci:

    - Sauvegarde du registre du (des) serveur(s) terminal(aux).

    - Editeur de registre.

    - Rechercez et clic sur la sous-clef suivante:HKEY_LOCL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM- Dans fichier--->Exporter . Saisir "le nom que vous souhaitez"--->Enregistrer.

    - Clic droit sur chaque valeur, supprimer, ok pour confirmer la suppression.

    1) X509 Certificate

    2) X509 Certificate ID

    3) X509 Certificate 2

    http://support.microsoft.com/kb/2477133

    En espérant que cela marche pour vous.

    Cordialement,

    Bricoleur.

    P.S.: impossible de coller un lien sur le site.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT


    mercredi 17 octobre 2012 01:14

Toutes les réponses

  • Pour info, lors de l'établissement d'une connexion, après le Security Audit event 4624, un  Security Audit event n° 4634 survient.

    log Name : Security

    Source : Microsoft Windows Security

    EventID : 4634

    This event is generated when a logon session is destroyed.

    It may be positively correlated with a logon event using the Logon ID valur.

    Logon IDs are only unique between reboots on the same computer


    laurent ulrich UNS SCRL, MS registered partner

    lundi 15 octobre 2012 11:25
  • Bonjour,

    Vous pourriez essayer de réinitialiser la licence de votre client Mac. Merci de consulter le lien suivant:

    Merci de nous tenir au courant.

    Cordialement,
    Dan


    Dan BAJENARU, MSFT    Votez! Appel à la contribution
    Nous vous prions de considérer que dans le cadre de ce forum on n’offre pas de support technique et aucune garantie de la part de Microsoft ne peut être offerte.

    mardi 16 octobre 2012 14:56
  • Bonjour,

    Comme décrit avec moins de précisions dans mon poste précédent j'ai déjà fait une purge (rm -rf) du contenu du dossier "\Users\Shared\Microsoft\RDC Crucial Server Informations" sur le MAC.

    Suite à votre message, j'ai répété l'action après avoir désinstallé le RDC 2.1.1. puis ensuite installé le RDC 1.0.3.

    Ce dernier ne se connecte pas sur le serveur. La connexion tourne en boucle et ne s'établi pas ou plutôt:

    La première fois que je tente de me connecter le RDC 1 me répond :

    TITRE :

    The client could not connect to the remote computer.

    DÉTAILS :

    Because of a security error, the client could not connect to the remote computer.

    Verify that you are logged on to the network, and then try connecting again.

    La deuxième tentative n'aboutit jamais. Ca tourne, ça tourne, ça tourne.

    Je précise qu'avec le RDC 1.0, j'arrive encore et toujours à me connecter sur les serveurs sur lesquels j'arrive à me connecter avec le RDC 2.1.1.

    Les Serveurs OK restent OK quoi que je fasse au niveau de la licence RDC locale du ou des MAC.

    J'ai construit un lab avec la même config 1 AD + 1 TS, mêmes règles de Firewall et même problème. J'arrive à me connecter sur les serveurs sur lesquels cela fonctionnait avant mais pas sur le nouveau TS qui a un certificat valide (GoDaddy).

    Quelques infos en vrac : les serveurs sont à jour, j'ai tenté en désactivant le Windows Firewall, en DisableComponents ffffff pour l'IPv6 suivi d'un reboot, les règles de firewall hardware sont identiques.

    Etant désespéré, je commence à faire des trucs qui n'ont pas beaucoup de sens donc j'ai tenté de supprimer le rôle RD Licensing sur le TS LAB sans que cela n'ait le moindre effet. Prévisible.

    HELP I need somebody...


    laurent ulrich UNS SCRL, MS registered partner

    mardi 16 octobre 2012 23:28
  • Bonjour,

    J'ai rencontré ce genre de souci après installation RDS CAL licences.

    Essayez ceci:

    - Sauvegarde du registre du (des) serveur(s) terminal(aux).

    - Editeur de registre.

    - Rechercez et clic sur la sous-clef suivante:HKEY_LOCL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM- Dans fichier--->Exporter . Saisir "le nom que vous souhaitez"--->Enregistrer.

    - Clic droit sur chaque valeur, supprimer, ok pour confirmer la suppression.

    1) X509 Certificate

    2) X509 Certificate ID

    3) X509 Certificate 2

    http://support.microsoft.com/kb/2477133

    En espérant que cela marche pour vous.

    Cordialement,

    Bricoleur.

    P.S.: impossible de coller un lien sur le site.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT


    mercredi 17 octobre 2012 01:14
  • Bonjour,

    Pas mal pour un "Bricoleur", merci beaucoup, où puis-je faire livrer les fleurs... Que dis-je... où puis-je faire ériger une statue ?

    Voir plus bas car le problème n'a pas été totalement solutionné en se tenant à la suppression les 3 clefs.

    Petit feedback :

    backup .reg : ok
    Suppression des clefs de registre : ok
    reboot : ok
    test de connexion : ok !
    réinstallation du rôle : ok
    re-test de connexion : tjr ok !!
    verif du registre : clefs non recréée automatiquement
    définition du serveur comme serveur de licence : ok
    test de connexion : ok !!!
    activation du licensing server : ok
    test de connexion : ok !!!!
    Je commence à croire que le problème est solutionné
    installation d'une CAL : ok
    test de connexion : NOT OK, erf!
    check des clefs de registre : présentes
    suppression des clefs de registre et redémarrage : ok
    tentative de connexion : ok
    Check de l'état des licences : ok

    Cela fonctionne bien si ce n'est qu'après un redémarrage et/ou après quelques secondes de patience les clefs de registre réapparaissent ce qui rend la connexion à nouveau impossible.

    Après le redémarrage, je dois supprimer les clefs de registre et redémarrer les services RDS ce qui permet la connexion mais après quelques secondes ces clefs réapparaissent et la connexion ne fonctionne denouveau plus.

    J'ai réactivé le serveur de licence et maintenant, bien que les clefs de registre soient présentes la connexion fonctionne à partir du MAC.

    Il faut donc faire une suppression des clefs, un restart des services et un reactivate du serveur de licences. Cela l'a correctement fonctionné qu'après le "reactivate" du serveur de licences.

    J'ai redémarré le MAC et le serveur, tout fonctionne bien.

    Comme je n'ai pas encore mangé assez de MAC cette semaine, l'idée m'a pris l'idée d'installer une licence supplémentaire pour voir comment cela allait se comporter.

    Mauvaise idée, "The licence server authentication was unsuccessful. Make sure the licence server has been properly activated. If the problem persist, try using a different connection method., The requested operation is not supported".

    Pas possible d'installer de nouvelles licencens sans passer par une autre methode, dans mon cas, j'ai utilisé la methode Web Browser.

    La licence s'est bien installée. J'ai ensuite redémarré le serveur, c'est pas que je doute mais...,  et cela fonctionne maintenant sans problème.

    Merci encore 1000x, vous n'avez pas idée à quel point j'apprécie votre support/réponse.

    Toujours pour info, Microsoft n'a pas voulu fournir de support sur ce problème. Je viens d'envoyer un email au support faisant suite à l'envoi de l'enquête de satisfaction pour leur expliquer qu'en effet le problème venait du serveur et que par conséquent j'aurais apprécié qu'ils me fournissent du support ce qui n'a pas été le cas à partir du moment ou les mots "Apple MacBook" ont eu le malheur de sortir de ma bouche.

    Bref, tout va bien mon client a été patient, sur le coup.
    • Modifié NGiloteau mercredi 17 octobre 2012 17:10
    mercredi 17 octobre 2012 15:41
  • Bonjour,

    Merci d'avoir mis en évidence mon oubli du post précédent, à savoir:

    un restart des services et un reactivate du serveur de licences. Cela l'a correctement fonctionné qu'après le "reactivate" du serveur de licences.

    Et merci encore pour la statue qui placé devant le panthéon...

    Dante devant les portes de l'enfer, méditant sur son serveur 2008 R2.

    Cordialement,

    Bricoleur.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT

    mercredi 17 octobre 2012 23:09
  • bonjour

    même problème solutionné grâce a toi oh grand BRICOLEUR

    bénédiction sur toi et les 7 générations qui viendront

    je me prosterne


    Patrick OBRIEN

    samedi 16 mars 2013 12:25
  • Bonjour,

    Réponse : à Vadorsmile (dont étrangement le post n'apparait pas ici).

    Bonsoir

    je sais que cela date d'assez longtemps mais qu'en est-il du même problème
    sur windows 2012 server parce qu'en faite les clefs de registre en question
    n'existe pas???

    mais je ne voudrais surtout pas joué les troubles fêtes mais il y a tellement
    peu d'informations sur 2012 que je rame plus que je n'avance.

    Merci.

    Utilisez-vous la version de Remote Desktop Connection Client 2.1.2 ?

    https://dl.dropbox.com/u/18309066/rdc_2.1.2_120917_release_enu_ship_clean_standard_retail_redlab_120917-apex-Build-XS26-.dmg

    Si vous n'arrivez toujours pas à vous connecter avec la version 2.1.2, essayez ceci (l'un ou l'autre):

    - Répertoire "RDC Crucial Server Information" (répertoire partagé) supprimez (après sauvegarde) le dossier "Microsoft".

    Ou:

    - Ajoutez le suffixe << / console >> après le nom du serveur à l'aide de MS Mac RDP.

    Cordialement,

    Bricoleur.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT


    • Modifié Bricoleur samedi 12 octobre 2013 00:10
    samedi 12 octobre 2013 00:08