none
installation windows server 2016 sans assistance ( Unattend.xml) RRS feed

  • Question

  • Bonjour a tous, 

    afin d'installer windows server 2016  sans assistance,  j'ai tester l'installation avec une vm génération 1 cela à très bien fonctionné mais quand j'ai essayer de faire le teste avec une vm de génération 2 cela ne fonctionne pas !! l'erreur suivante est renvoyé :

     

    voila la partie concerné de mon fichier unattend :

    <DiskConfiguration>
                    <Disk wcm:action="add">
                        <CreatePartitions>
                            <CreatePartition wcm:action="add">
                                <Extend>true</Extend>
                                <Order>1</Order>
                                <Type>Primary</Type>
                            </CreatePartition>
                        </CreatePartitions>
                        <DiskID>0</DiskID>
                        <WillWipeDisk>true</WillWipeDisk>
                        <ModifyPartitions>
                            <ModifyPartition wcm:action="add">
                                <Active>true</Active>
                                <Extend>false</Extend>
                                <Format>NTFS</Format>
                                <Letter>C</Letter>
                                <Order>1</Order>
                                <PartitionID>1</PartitionID>
                            </ModifyPartition>
                        </ModifyPartitions>
                    </Disk>
                    <WillShowUI>OnError</WillShowUI>
                </DiskConfiguration>

    je comprend pas qu'elle config faire lorsqu'il s'agit d'une VM de génération 2, même si les contrôleurs de disque dur sont bien évidement différent, voir IDE pour vm de génération 1 et SCSI pour une VM de génération 2,

    qu'elle est la config requise a ce niveau pour une vm de génération 2 ?

    je vous remercie d'avance pour votre retour 

    bien cordialement 


    jeudi 27 avril 2017 12:31

Réponses

  • Bonjour,

    Voici un fichier d'exemple fourni par microsoft qui devrait vous aider.

    https://technet.microsoft.com/en-us/library/dn621892.aspx

    • Modifié matteu31400 jeudi 27 avril 2017 14:08
    • Marqué comme réponse Racha_SD jeudi 27 avril 2017 14:34
    jeudi 27 avril 2017 13:53
  • Bonjour, 

    je te remercie pour ton retour, 

    en effet cela fonctionne bien, mais aussi on peut aussi laisser la configuration par défaut, on ne spécifier pas <DiskConfiguration> et cela sera effectuer par défaut, sauf que dans la partie  

    <ImageInstall> <OSImage> <InstallTo> <DiskID>0</DiskID> <PartitionID>4</PartitionID> </InstallTo> </OSImage> </ImageInstall>


    il faut bien spécifier id de la partition 4, et cela fonctionne de la même manière que le fichier proposé dans le liens 
    je te remercie encore 
    bien cordialement <o:p></o:p>



    • Marqué comme réponse Racha_SD jeudi 27 avril 2017 14:34
    • Modifié Racha_SD jeudi 27 avril 2017 14:39
    jeudi 27 avril 2017 14:34

Toutes les réponses

  • Bonjour,

    Voici un fichier d'exemple fourni par microsoft qui devrait vous aider.

    https://technet.microsoft.com/en-us/library/dn621892.aspx

    • Modifié matteu31400 jeudi 27 avril 2017 14:08
    • Marqué comme réponse Racha_SD jeudi 27 avril 2017 14:34
    jeudi 27 avril 2017 13:53
  • Bonjour, 

    je te remercie pour ton retour, 

    en effet cela fonctionne bien, mais aussi on peut aussi laisser la configuration par défaut, on ne spécifier pas <DiskConfiguration> et cela sera effectuer par défaut, sauf que dans la partie  

    <ImageInstall> <OSImage> <InstallTo> <DiskID>0</DiskID> <PartitionID>4</PartitionID> </InstallTo> </OSImage> </ImageInstall>


    il faut bien spécifier id de la partition 4, et cela fonctionne de la même manière que le fichier proposé dans le liens 
    je te remercie encore 
    bien cordialement <o:p></o:p>



    • Marqué comme réponse Racha_SD jeudi 27 avril 2017 14:34
    • Modifié Racha_SD jeudi 27 avril 2017 14:39
    jeudi 27 avril 2017 14:34