locked
Ferme RDS, Remote App et profils itinérant RRS feed

  • Question

  • Bonjour,

    Actuellement, je suis en train de mettre en place une ferme RDS pour héberger des applications Remote App. Ma ferme et mon cluster de Broker fonctionne sans problème mais lors de mes tests, je m’aperçois d'un problème assez gênant pour mes utilisateurs finaux.

    En effet, mon utilisateur utilise Word ou Excel sur cette ferme RDS. Le broker lui à ouvert une session sur le serveur RDS 01. Sur cette session l'utilisateur change de nombreux paramètres qui sont lié à son profil (Customisation de Word). L'utilisateur ferme sa session et le lendemain si il est de nouveau redirigé vers ce serveur, il récupère ses préférences.

    Lors de mes tests, je coupe brutalement le serveur RDS01. Mon utilisateur se retrouve donc dirigé vers le serveur RDS 02 et la il n'a plus aucune préférence de mémorisé. Pour résumé, l'utilisateur doit configurer ses préférences sur chacun des trois serveurs RDS afin de le retrouver tout le temps.

    Pour palier au problème, j'ai donc configuré les profils itinérants sur mes serveurs RDS que je redirige vers un serveur tierce. J'ai également redirigé le dossier AppData (Roaming) vers ce même serveur tierce. Les profils se créent bien mais la problématique reste la même.

    Dois-je configurer autre chose pour avoir le résultat que je souhaite ?

    D'avance merci pour toutes vos réponses.

    Bien cordialement

    vendredi 8 février 2013 10:20

Réponses

  • Je pense qu'il n'y a pas vraiment de solution. Vous avez en grande partie résolu le problème en mettant les profils itinérants. Seulement ceux ci sont copiés lors d'une fermeture de session.
    Le problème dans votre test vient de -> "Je coupe Brutalement".
    Ce n'est pas un fonctionnement normal... Je suppose aussi que les customisation de Word seront faite au début et une fois ceci effectué il n'y aura pas beaucoup de modification par la suite. Ainsi même s'il y a une fermeture brutale la configuration du profil datera de la dernière bonne deconnexion.

    La seule solution à ce moment serai de gérer les paramètres des profils par Gpo (c'est tout à faire possible sur Word) comme ça c'est un environnement préparamétré qui arrive lors de l'ouverture de la session. Mais à la description de votre mode de fonctionnement c'est peut être compliqué à mettre en place si chaque utilisateur a des paramètres différents...


    Cordialement Denis ECHE, Ingénieur Système-Réseaux. Mon Blog Si ma réponse vous a été utile, ou a permis la résolution de votre problème; merci de Voter ou de la marquer comme Utile.

    • Marqué comme réponse AVOLANT jeudi 14 février 2013 07:50
    vendredi 8 février 2013 13:19
  • Une article sur la fermeture des sessions remote app.

    http://blogs.msdn.com/b/rds/archive/2007/09/28/terminal-services-remoteapp-session-termination-logic.aspx

    En théorie la session est fermée au bout de 20sec.

    Sinon selon se site ils conseillent de mettre en place une GPO pour déconnecter immédiatement la session :

    http://winplat.net/post/2011/12/11/RemoteApp-program-does-not-save-settings-in-roaming-profile.aspx

    En espérant que ça puisse vous aider.


    Cordialement Denis ECHE, Ingénieur Système-Réseaux. Mon Blog Si ma réponse vous a été utile, ou a permis la résolution de votre problème; merci de Voter ou de la marquer comme Utile.


    • Modifié Denis Eche vendredi 8 février 2013 16:47
    • Marqué comme réponse AVOLANT jeudi 14 février 2013 07:50
    vendredi 8 février 2013 16:47

Toutes les réponses

  • Je pense qu'il n'y a pas vraiment de solution. Vous avez en grande partie résolu le problème en mettant les profils itinérants. Seulement ceux ci sont copiés lors d'une fermeture de session.
    Le problème dans votre test vient de -> "Je coupe Brutalement".
    Ce n'est pas un fonctionnement normal... Je suppose aussi que les customisation de Word seront faite au début et une fois ceci effectué il n'y aura pas beaucoup de modification par la suite. Ainsi même s'il y a une fermeture brutale la configuration du profil datera de la dernière bonne deconnexion.

    La seule solution à ce moment serai de gérer les paramètres des profils par Gpo (c'est tout à faire possible sur Word) comme ça c'est un environnement préparamétré qui arrive lors de l'ouverture de la session. Mais à la description de votre mode de fonctionnement c'est peut être compliqué à mettre en place si chaque utilisateur a des paramètres différents...


    Cordialement Denis ECHE, Ingénieur Système-Réseaux. Mon Blog Si ma réponse vous a été utile, ou a permis la résolution de votre problème; merci de Voter ou de la marquer comme Utile.

    • Marqué comme réponse AVOLANT jeudi 14 février 2013 07:50
    vendredi 8 février 2013 13:19
  • Dans ce cas, mon problème semble venir de fait que les sessions ne se ferment jamais. En effet, j'ai fermé mes application Remote APP et attendu une dizaine de minute. 

    Hors malgré le fait d'avoir attendu les sessions ne se sont pas fermées naturellement.

    Dois-je paramétrer la fermeture de session manuellement ou alors Remote app le fait automatiquement lorsque l'utilisateur ferme l'application Remote App ?

    Cordialement 

    vendredi 8 février 2013 14:17
  • Une article sur la fermeture des sessions remote app.

    http://blogs.msdn.com/b/rds/archive/2007/09/28/terminal-services-remoteapp-session-termination-logic.aspx

    En théorie la session est fermée au bout de 20sec.

    Sinon selon se site ils conseillent de mettre en place une GPO pour déconnecter immédiatement la session :

    http://winplat.net/post/2011/12/11/RemoteApp-program-does-not-save-settings-in-roaming-profile.aspx

    En espérant que ça puisse vous aider.


    Cordialement Denis ECHE, Ingénieur Système-Réseaux. Mon Blog Si ma réponse vous a été utile, ou a permis la résolution de votre problème; merci de Voter ou de la marquer comme Utile.


    • Modifié Denis Eche vendredi 8 février 2013 16:47
    • Marqué comme réponse AVOLANT jeudi 14 février 2013 07:50
    vendredi 8 février 2013 16:47
  • Bonjour,

    Merci pour votre réponse, je fais les tests dans la journée et vous tiens informé.


    lundi 11 février 2013 08:30
  • Bonjour, je confirme cela à fonctionné.

    Merci pour vos réponses.

    jeudi 14 février 2013 07:50