none
Mise en place Stratégie de Redirection de Dossiers par erreur - Retour arrière possible ? RRS feed

  • Question

  • Bonjour,

    Je suis dans la situation délicate d'un retour arrière sans avoir pris le soin de négocier ce retour avec la sauvegarde adéquate.

    Situation : 

    Après avoir mis en place un Serveur 2012-R2 Foundation dans un domaine géré par un 2003 et réalisé toutes les étapes de migration avec succès. Au final dé-promotion et arrêt ancien serveur 2003. J'ai fait une boulette en voulant mettre en place la redirection de dossiers. La stratégie a été appliquée et les données utilisateurs se sont retrouvées sur le nouveau partage \\srv2012\Données Utilisateurs\... J'ai voulu annuler cette stratégie en mettant tous les dossiers de la stratégie de Redirection à la valeur "Non configuré"... Une partie des utilisateurs connectés à profité de l'une et l'autre de la stratégie.

    Evidemment, je n'avais pas fait de sauvegarde des GPO avant de commencer cette action délicate...

    A l'heure actuelle, ce n'est pas bloquant car les utilisateurs ne voient pas de différences, les dossiers sont partagés entre 2 endroits. Le dossier de base c:\users\... et "d:\Données Utilisateurs\..."

    Comment faire maintenant pour retourner à une situation claire qui ne comporte plus de trace de \\serveur\dossiers

    dans le registre (voir la capture suivante) ?

    Pouvez-vous m'aider à remettre un peu d'ordre dans ce serveur qui est en production ?

    Merci d'avance pour vos réponses.

    jeudi 14 janvier 2016 10:51

Réponses

  • Bonjour Marc,

    Normalement vous pouvez retrouver une situation "locale" pour les utilisateurs ayants activé leur GPO de redirection. Toutefois, l'opération n'est pas la plus évidente quand les choses dérape.

    Dans votre GPO où la redirection est configurée, vous l'avez passé en "Non configuré".

    Je vous conseille ceci :

    • Remettre la GPO comme vous l'aviez configurée initialement;
    • Dans : Configuration Utilisateur \ Stratégies \ Windows \ Folder Rerirection
    • Sur chacun des folders redirigés, dans l'onglet "Options" configurer l'option "Suppression de stratégie / Policy Removal"
    • Une fois cette option propagée aux clients, désactiver la stratégie ou mettre "non configuré"

    Dans votre cas, il faudrait mettre l'option "Redirect the folder back to the local userprofile"

    (Désolé, j'ai pas l'option en français sous la main) mais voici la KB : https://support.microsoft.com/fr-fr/kb/888203


    jeudi 14 janvier 2016 12:58
  • "Aie" !  Il n'est pas très recommandé d'ajouter des options dans les Default Domain Policy.
    Il est préférable de segmenter les GPO par "objet" ou "application".

    La manipulation est la même pour cette stratégie là.
    Mais vu qu'elle a été déployée sur tout votre parc, je vous invite à la plus grand prudence lors la mise en place du "Policy Removal"

    Mais ne supprimez PAS la Default Domain Policy

    • Reconfigurez-la avec vos redirections appliquée.(si vous les avez enlevée)
    • Appliquez un gpupdate ou laisser la stratégie se mettre à jour sur l'ensemble de vos clients.
    • Appliquez l'option "Policy Removal" dans Configuration Utilisateur \ Stratégies \ Windows \ Folder Rerirection
    • Laisser la GPO agir : les données présentes dans \\server\share\ seront au logon re-copiée dans C:\users\%username%\
    • Une fois les utilisateurs en profil local, supprimer les options de redirection dans la Default Domain Policy.

    Attention à bien mettre en place le policy removal pour tous les folders redirigés (documents,desktop, favoris, etc)

    A tester avant en effet !

    Cordialement,

    jeudi 14 janvier 2016 19:52

Toutes les réponses

  • Bonjour Marc,

    Normalement vous pouvez retrouver une situation "locale" pour les utilisateurs ayants activé leur GPO de redirection. Toutefois, l'opération n'est pas la plus évidente quand les choses dérape.

    Dans votre GPO où la redirection est configurée, vous l'avez passé en "Non configuré".

    Je vous conseille ceci :

    • Remettre la GPO comme vous l'aviez configurée initialement;
    • Dans : Configuration Utilisateur \ Stratégies \ Windows \ Folder Rerirection
    • Sur chacun des folders redirigés, dans l'onglet "Options" configurer l'option "Suppression de stratégie / Policy Removal"
    • Une fois cette option propagée aux clients, désactiver la stratégie ou mettre "non configuré"

    Dans votre cas, il faudrait mettre l'option "Redirect the folder back to the local userprofile"

    (Désolé, j'ai pas l'option en français sous la main) mais voici la KB : https://support.microsoft.com/fr-fr/kb/888203


    jeudi 14 janvier 2016 12:58
  • Merci pour votre réponse rapide,

    je vais évaluer la technique, que vous proposez dans le lien précédent, sur mon serveur de test. Avant de reproduire sur le site de production.
    Mais j'ai quand même un souci parce qu'au lieu de créer une GPO qui se porte sur une OU, j'ai modifié directement la stratégie Globale du serveur de domaine...Je ne peux pas extraire les utilisateurs de la stratégie ou désactiver la GPO en question.

    Que me conseillez vous?

    Est ce que l'on peut simplement Supprimer "Default Domain Policy" et en créer une nouvelle (à partir d'un modèle, l'importer par exemple...) et l'appliquer ?

    Voici la vision de la console Stratégie de Groupe

    Merci d'avance. A bientôt.



    • Modifié marcv847 jeudi 14 janvier 2016 15:56
    jeudi 14 janvier 2016 15:27
  • "Aie" !  Il n'est pas très recommandé d'ajouter des options dans les Default Domain Policy.
    Il est préférable de segmenter les GPO par "objet" ou "application".

    La manipulation est la même pour cette stratégie là.
    Mais vu qu'elle a été déployée sur tout votre parc, je vous invite à la plus grand prudence lors la mise en place du "Policy Removal"

    Mais ne supprimez PAS la Default Domain Policy

    • Reconfigurez-la avec vos redirections appliquée.(si vous les avez enlevée)
    • Appliquez un gpupdate ou laisser la stratégie se mettre à jour sur l'ensemble de vos clients.
    • Appliquez l'option "Policy Removal" dans Configuration Utilisateur \ Stratégies \ Windows \ Folder Rerirection
    • Laisser la GPO agir : les données présentes dans \\server\share\ seront au logon re-copiée dans C:\users\%username%\
    • Une fois les utilisateurs en profil local, supprimer les options de redirection dans la Default Domain Policy.

    Attention à bien mettre en place le policy removal pour tous les folders redirigés (documents,desktop, favoris, etc)

    A tester avant en effet !

    Cordialement,

    jeudi 14 janvier 2016 19:52
  • Merci Nathanaël,

    Je vais tester et appliquer dès que possible. Je vous tiens informé !

    Bien cordialement.

    vendredi 15 janvier 2016 07:23
  • Déjà, sur mon serveur de test ça fonctionne super bien !

    Maintenant, il faut que j'applique cela sur le serveur de production... C'est une autre aventure, je vous tiens au courant.

    Merci, a bientôt.

    vendredi 15 janvier 2016 13:46
  • Bonjour,

    C'est avec un grand plaisir que j'ai pu effectuer la mise en place recommandée par Nathanael, dans sa réponse précédente. J'ai donc remis la stratégie "Default Domain Policy" dans son état (redirection de dossiers non activé) et tout fonctionne parfaitement. J'ai aussi suivi son conseil de faire une GPO par UO et sauvegardé le tout...

    Merci encore pour vos réponses.

    Bien cordialement

    mercredi 10 février 2016 14:53