none
Exchange 2003/2007 - Problème d'accès OWA/Outlook RRS feed

  • Discussion générale

  •  

    Bonsoir,

    Me revoici avec un autre problème lié à Exchange 2007.

    Nous avons un Exchange 2003 qui a été migré en 2007 en 2009.

    Il y a toujours des comptes qui utilisent l'OU mailbox "Premier Groupe d'Administration".

    Les nouveaux utilisateurs ont la nouvelle OU d'Exchange 2007.

    J'ai eu le cas identique en novembre avec un utilisateur de l'OU d'Exchange 2003, mais j'ai réglé le soucis un peu brutalement (suppression recréation...)

    Je n'ai pas envi de faire la même chose pour ce compte.

    Ce que je veux souligner c'est qu'il est le seul compte qui ne fonctionne plus et dans l'OU d'Exchange 2003.

    Je rajoute que le serveur d'Exchange 2003 n'est plus présent dans notre domaine.

    Voici un extrait des logs ci-dessous:

     

    Request

    Url: https://mail.domaine.com:443/owa/default.aspx


    User host address: 192.168.x.x



    Exception


    Exception type: Microsoft.Exchange.Data.Storage.ConnectionFailedTransientException


    Exception message: Cannot open mailbox /o=domaine/ou=premier groupe d'administration/cn=recipients/cn=users1.




    Call stack




    Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry)


    Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry)


    Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString)


    Microsoft.Exchange.Data.Storage.MailboxSession.Initialize(LogonType logonType, ExchangePrincipal owner, DelegateLogonUser delegateUser, Object identity, OpenMailboxSessionFlags flags)


    Microsoft.Exchange.Data.Storage.MailboxSession.CreateMailboxSession(LogonType logonType, ExchangePrincipal owner, DelegateLogonUser delegateUser, Object identity, OpenMailboxSessionFlags flags, CultureInfo cultureInfo, String clientInfoString)


    Microsoft.Exchange.Data.Storage.MailboxSession.Open(ExchangePrincipal mailboxOwner, WindowsPrincipal authenticatedUser, CultureInfo cultureInfo, String clientInfoString)


    Microsoft.Exchange.Clients.Owa.Core.OwaWindowsIdentity.CreateMailboxSession(ExchangePrincipal exchangePrincipal, CultureInfo cultureInfo)


    Microsoft.Exchange.Clients.Owa.Core.UserContext.Load(OwaContext owaContext)


    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.CreateUserContext(OwaContext owaContext, UserContextKey userContextKey, UserContext& userContext)


    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.PrepareRequestWithoutSession(OwaContext owaContext, UserContextCookie userContextCookie)


    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.InternalDispatchRequest(OwaContext owaContext)


    Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchRequest(OwaContext owaContext)


    System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()


    System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)




    Inner Exception


    Exception type: Microsoft.Mapi.MapiExceptionLogonFailed


    Exception message: MapiExceptionLogonFailed: Unable to open message store. (hr=0x80040111, ec=1010) Diagnostic context: Lid: 18969 EcDoRpcExt2 called [length=491] Lid: 27161 EcDoRpcExt2 returned [ec=0x0][length=124][latency=0] Lid: 23226 --- ROP Parse Start --- Lid: 27962 ROP: ropLogon [254] Lid: 17082 ROP Error: 0x3F2 Lid: 26937 Lid: 21921 StoreEc: 0x3F2 Lid: 27962 ROP: ropExtendedError [250] Lid: 1494 ---- Remote Context Beg ---- Lid: 26426 ROP: ropLogon [254] Lid: 4740 StoreEc: 0x80070005 Lid: 30409 StoreEc: 0x80070005 Lid: 19145 StoreEc: 0x3F2 Lid: 23241 StoreEc: 0x3F2 Lid: 32186 Lid: 8620 StoreEc: 0x3F2 Lid: 1750 ---- Remote Context End ---- Lid: 26849 Lid: 21817 ROP Failure: 0x3F2 Lid: 26297 Lid: 16585 StoreEc: 0x3F2 Lid: 32441 Lid: 1706 StoreEc: 0x3F2 Lid: 24761 Lid: 20665 StoreEc: 0x3F2 Lid: 25785 Lid: 29881 StoreEc: 0x3F2




    Call stack




    Microsoft.Mapi.MapiExceptionHelper.ThrowIfError(String message, Int32 hresult, Int32 ec, DiagnosticContext diagCtx)


    Microsoft.Mapi.ExRpcConnection.OpenMsgStore(OpenStoreFlag storeFlags, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, MapiStore msgStorePrivate, String& correctServerDn, ClientIdentityInfo clientIdentityAs, String userDnAs, String applicationId, CultureInfo cultureInfo)


    Microsoft.Mapi.ConnectionCache.OpenMapiStore(String mailboxDn, Guid mailboxGuid, Guid mdbGuid, ClientIdentityInfo clientIdentity, String userDnAs, OpenStoreFlag openStoreFlags, CultureInfo cultureInfo, String applicationId)


    Microsoft.Mapi.ConnectionCache.OpenMailbox(String mailboxDn, Guid mailboxGuid, Guid mdbGuid, WindowsIdentity windowsIdentityAs, String userDnAs, OpenStoreFlag openStoreFlags, CultureInfo cultureInfo, String applicationId)


    Microsoft.Exchange.Data.Storage.ConnectionCachePool.OpenMailbox(String serverDn, String userDn, String mailboxDn, Guid mailboxGuid, Guid mdbGuid, Object identity, ConnectFlag connectFlag, OpenStoreFlag openStoreFlag, CultureInfo cultureInfo, String clientInfoString, Boolean secondTry)

     

    J'ai cherché et je n'ai vraiment pas trouvé de solution :(

    Merci d'avance pour votre aide.

    Cordialement,

     

     

    mardi 22 février 2011 18:20

Toutes les réponses

  • Bonsoir,

    je m'étonne que tu parles de "OUs" ! Je pense qu'il s'agit des "groupes administratifs", mais vus depuis l'outil ADSIEDIT.MSC !

    Concrêtement, la zone LegacyExchangeDN contient encore l'ancien chemin, ce qui est tout à fait normal pour des utilisateurs migrés.

     "/o=ORGXXXXX/ou=PREMIER GROUPE D'ADMINISTRATION/cn=RECIPIENTS/cn=USERYYYY"

    Le dysfonctionnement ne vient pas de là!

    Peux-tu nous indiquer les valeurs contenues dans : HomeMDB, HomeMTA, etc.. ?

    A+


    Thierry DEMAN. Exchange MVP. https://www.mcpvirtualbusinesscard.com/VBCServer/MVPtdeman/profile (68 MCPs) http://base.faqexchange.info
    samedi 26 février 2011 18:56
    Modérateur
  • Bonjour Thierry,

    Merci d'avance pour ton aide.

    Oui en effet ce n'est pas OU que je veux dire mais le groupe administratif.

    J'ai désactivé son compte puis je l'ai recréer (sans reconnecter sa boite), ça fonctionne et il est sur le nouveau groupe administratif, sauf qu'il n'a plus ses mails.

    J'ai l'impression que c'est un problème de droit...mais ce qui est bizzare c'est comment ça a pu arriver.

    :s

    lundi 28 février 2011 14:58
  • Bonjour, il suffit de reconnecter la boîte pour retrouver le contenu et les messages!
    Thierry DEMAN. Exchange MVP. https://www.mcpvirtualbusinesscard.com/VBCServer/MVPtdeman/profile (68 MCPs) http://base.faqexchange.info
    lundi 28 février 2011 17:03
    Modérateur
  • Bonjour, c'est ce que j'ai fais. Mais idem ça ne marche pas après toujours la même erreur.

    :s

    mardi 1 mars 2011 08:23
  • Bonjour,

    J'ai resolu le soucis en créant une nouvelle boite dans un nouveau groupe de stockage.

    Cordialement,

    lundi 9 mai 2011 15:21