none
Carnet d'adresses en mode hors connexion en cours de connexion à Microsoft Exchange RRS feed

  • Question

  • Bonjour,

    Je viens de terminer une installation d'un serveur Exchange 2013. J'ai installé le SP1 et correctif cumulatif 7.

    J'ai un soucis avec le carnet d'adresse en mode hors connexion.

    Quand je fais envoyer/recevoir dans Outlook sur n'importe quel poste, j'ai le message "Carnet d'adresses en mode hors connexion en cours de connexion à Microsoft Exchange" qui s'affiche indéfiniment et donc l'opération ne se termine jamais.

    Je suis convaincu que le problème vient de la configuration du serveur puisque tous les postes sont impactés. J'ai l'impression qu'Outlook essaye de charger le carnet d'adresse à une mauvaise adresse.

    En OWA, le carnet d'adresse apparait bien avec la liste d'adresse globale (tous les users).

    J'ai fait une analyse du fichier XML de l'autodiscover et je me demande si ce n'est pas un problème d'URL local / externe.

    Je me permet de le poster ici en espérant que quelqu'un pourra m'éclairer.

    Merci par avance

    <?xml version="1.0"?>
    <Autodiscover xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
    <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
    <User>
    <DisplayName>Administrator</DisplayName>
    <LegacyDN>/o=EXCHANGE/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=2a2970f40d554f2ab84347d0a78d861e-Administrator</LegacyDN>
    <DeploymentId>4fbfac4c-b6c0-4967-a240-b0e16d213c96</DeploymentId>
    </User>
    <Account>
    <AccountType>email</AccountType>
    <Action>settings</Action>
    <Protocol>
    <Type>EXCH</Type>
    <Server>07ea47c8-02a0-4ba3-b2bd-25bbf0c603d5@mondomaine.com</Server>
    <ServerDN>/o=EXCHANGE/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=07ea47c8-02a0-4ba3-b2bd-25bbf0c603d5@mondomaine.com</ServerDN>
    <ServerVersion>73C08414</ServerVersion>
    <MdbDN>/o=EXCHANGE/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=07ea47c8-02a0-4ba3-b2bd-25bbf0c603d5@mondomaine.com/cn=Microsoft Private MDB</MdbDN>
    <ASUrl>https://srv2012.exchange.local/EWS/Exchange.asmx</ASUrl>
    <OOFUrl>https://srv2012.exchange.local/EWS/Exchange.asmx</OOFUrl>
    <OABUrl>https://srv2012.exchange.local/OAB/7eb7b984-cd69-49a7-8d60-cec2c94e9096/</OABUrl>
    <UMUrl>https://srv2012.exchange.local/EWS/UM2007Legacy.asmx</UMUrl>
    <Port>0</Port>
    <DirectoryPort>0</DirectoryPort>
    <ReferralPort>0</ReferralPort>
    <AuthPackage>Anonymous</AuthPackage>
    <PublicFolderServer>public.mondomaine.com</PublicFolderServer>
    <AD>srv2012.exchange.local</AD>
    <EwsUrl>https://srv2012.exchange.local/EWS/Exchange.asmx</EwsUrl>
    <EmwsUrl>https://srv2012.exchange.local/EWS/Exchange.asmx</EmwsUrl>
    <EcpUrl>https://srv2012.exchange.local/ecp/</EcpUrl>
    <EcpUrl-um>?rfr=olk&amp;p=customize/voicemail.aspx&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-um>
    <EcpUrl-aggr>?rfr=olk&amp;p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-aggr>
    <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?rfr=olk&amp;exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;&amp;realm=mondomaine.com</EcpUrl-mt>
    <EcpUrl-ret>?rfr=olk&amp;p=organize/retentionpolicytags.slab&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-ret>
    <EcpUrl-sms>?rfr=olk&amp;p=sms/textmessaging.slab&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-sms>
    <EcpUrl-publish>customize/calendarpublishing.slab?rfr=olk&amp;exsvurl=1&amp;FldID=&lt;FldID&gt;&amp;realm=mondomaine.com</EcpUrl-publish>
    <EcpUrl-photo>PersonalSettings/EditAccount.aspx?rfr=olk&amp;chgPhoto=1&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-photo>
    <EcpUrl-tm>?rfr=olk&amp;ftr=TeamMailbox&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-tm>
    <EcpUrl-tmCreating>?rfr=olk&amp;ftr=TeamMailboxCreating&amp;SPUrl=&lt;SPUrl&gt;&amp;Title=&lt;Title&gt;&amp;SPTMAppUrl=&lt;SPTMAppUrl&gt;&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-tmCreating>
    <EcpUrl-tmEditing>?rfr=olk&amp;ftr=TeamMailboxEditing&amp;Id=&lt;Id&gt;&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-tmEditing>
    <EcpUrl-extinstall>Extension/InstalledExtensions.slab?rfr=olk&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-extinstall>
    <ServerExclusiveConnect>off</ServerExclusiveConnect>
    </Protocol>
    <Protocol>
    <Type>EXPR</Type>
    <Server>public.mondomaine.com</Server>
    <ASUrl>https://public.mondomaine.com/EWS/Exchange.asmx</ASUrl>
    <OOFUrl>https://public.mondomaine.com/EWS/Exchange.asmx</OOFUrl>
    <OABUrl>https://public.mondomaine.com/OAB/7eb7b984-cd69-49a7-8d60-cec2c94e9096/</OABUrl>
    <UMUrl>https://public.mondomaine.com/EWS/UM2007Legacy.asmx</UMUrl>
    <Port>0</Port>
    <DirectoryPort>0</DirectoryPort>
    <ReferralPort>0</ReferralPort>
    <SSL>On</SSL>
    <AuthPackage>Negotiate</AuthPackage>
    <EwsUrl>https://public.mondomaine.com/EWS/Exchange.asmx</EwsUrl>
    <EmwsUrl>https://public.mondomaine.com/EWS/Exchange.asmx</EmwsUrl>
    <EcpUrl>https://public.mondomaine.com/ecp/</EcpUrl>
    <EcpUrl-um>?rfr=olk&amp;p=customize/voicemail.aspx&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-um>
    <EcpUrl-aggr>?rfr=olk&amp;p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-aggr>
    <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?rfr=olk&amp;exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;&amp;realm=mondomaine.com</EcpUrl-mt>
    <EcpUrl-ret>?rfr=olk&amp;p=organize/retentionpolicytags.slab&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-ret>
    <EcpUrl-sms>?rfr=olk&amp;p=sms/textmessaging.slab&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-sms>
    <EcpUrl-publish>customize/calendarpublishing.slab?rfr=olk&amp;exsvurl=1&amp;FldID=&lt;FldID&gt;&amp;realm=mondomaine.com</EcpUrl-publish>
    <EcpUrl-photo>PersonalSettings/EditAccount.aspx?rfr=olk&amp;chgPhoto=1&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-photo>
    <EcpUrl-tm>?rfr=olk&amp;ftr=TeamMailbox&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-tm>
    <EcpUrl-tmCreating>?rfr=olk&amp;ftr=TeamMailboxCreating&amp;SPUrl=&lt;SPUrl&gt;&amp;Title=&lt;Title&gt;&amp;SPTMAppUrl=&lt;SPTMAppUrl&gt;&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-tmCreating>
    <EcpUrl-tmEditing>?rfr=olk&amp;ftr=TeamMailboxEditing&amp;Id=&lt;Id&gt;&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-tmEditing>
    <EcpUrl-extinstall>Extension/InstalledExtensions.slab?rfr=olk&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-extinstall>
    <ServerExclusiveConnect>on</ServerExclusiveConnect>
    <EwsPartnerUrl>https://public.mondomaine.com/EWS/Exchange.asmx</EwsPartnerUrl>
    <GroupingInformation>Default-First-Site-Name</GroupingInformation>
    </Protocol>
    <Protocol>
    <Type>WEB</Type>
    <Port>0</Port>
    <DirectoryPort>0</DirectoryPort>
    <ReferralPort>0</ReferralPort>
    <Internal>
    <OWAUrl AuthenticationMethod="Basic, Fba">https://srv2012.exchange.local/owa/</OWAUrl>
    <Protocol>
    <Type>EXCH</Type>
    <ASUrl>https://srv2012.exchange.local/EWS/Exchange.asmx</ASUrl>
    </Protocol>
    </Internal>
    <External>
    <OWAUrl AuthenticationMethod="Fba">https://public.mondomaine.com/owa/</OWAUrl>
    <Protocol>
    <Type>EXPR</Type>
    <ASUrl>https://public.mondomaine.com/EWS/Exchange.asmx</ASUrl>
    </Protocol>
    </External>
    </Protocol>
    <Protocol>
    <Type>EXHTTP</Type>
    <Server>public.mondomaine.com</Server>
    <ASUrl>https://srv2012.exchange.local/EWS/Exchange.asmx</ASUrl>
    <OOFUrl>https://srv2012.exchange.local/EWS/Exchange.asmx</OOFUrl>
    <OABUrl>https://srv2012.exchange.local/OAB/7eb7b984-cd69-49a7-8d60-cec2c94e9096/</OABUrl>
    <UMUrl>https://srv2012.exchange.local/EWS/UM2007Legacy.asmx</UMUrl>
    <Port>0</Port>
    <DirectoryPort>0</DirectoryPort>
    <ReferralPort>0</ReferralPort>
    <SSL>On</SSL>
    <AuthPackage>Ntlm</AuthPackage>
    <EwsUrl>https://srv2012.exchange.local/EWS/Exchange.asmx</EwsUrl>
    <EmwsUrl>https://srv2012.exchange.local/EWS/Exchange.asmx</EmwsUrl>
    <EcpUrl>https://srv2012.exchange.local/ecp/</EcpUrl>
    <EcpUrl-um>?rfr=olk&amp;p=customize/voicemail.aspx&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-um>
    <EcpUrl-aggr>?rfr=olk&amp;p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-aggr>
    <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?rfr=olk&amp;exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;&amp;realm=mondomaine.com</EcpUrl-mt>
    <EcpUrl-ret>?rfr=olk&amp;p=organize/retentionpolicytags.slab&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-ret>
    <EcpUrl-sms>?rfr=olk&amp;p=sms/textmessaging.slab&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-sms>
    <EcpUrl-publish>customize/calendarpublishing.slab?rfr=olk&amp;exsvurl=1&amp;FldID=&lt;FldID&gt;&amp;realm=mondomaine.com</EcpUrl-publish>
    <EcpUrl-photo>PersonalSettings/EditAccount.aspx?rfr=olk&amp;chgPhoto=1&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-photo>
    <EcpUrl-tm>?rfr=olk&amp;ftr=TeamMailbox&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-tm>
    <EcpUrl-tmCreating>?rfr=olk&amp;ftr=TeamMailboxCreating&amp;SPUrl=&lt;SPUrl&gt;&amp;Title=&lt;Title&gt;&amp;SPTMAppUrl=&lt;SPTMAppUrl&gt;&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-tmCreating>
    <EcpUrl-tmEditing>?rfr=olk&amp;ftr=TeamMailboxEditing&amp;Id=&lt;Id&gt;&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-tmEditing>
    <EcpUrl-extinstall>Extension/InstalledExtensions.slab?rfr=olk&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-extinstall>
    <ServerExclusiveConnect>On</ServerExclusiveConnect>
    </Protocol>
    <Protocol>
    <Type>EXHTTP</Type>
    <Server>public.mondomaine.com</Server>
    <ASUrl>https://public.mondomaine.com/EWS/Exchange.asmx</ASUrl>
    <OOFUrl>https://public.mondomaine.com/EWS/Exchange.asmx</OOFUrl>
    <OABUrl>https://public.mondomaine.com/OAB/7eb7b984-cd69-49a7-8d60-cec2c94e9096/</OABUrl>
    <UMUrl>https://public.mondomaine.com/EWS/UM2007Legacy.asmx</UMUrl>
    <Port>0</Port>
    <DirectoryPort>0</DirectoryPort>
    <ReferralPort>0</ReferralPort>
    <SSL>On</SSL>
    <AuthPackage>Negotiate</AuthPackage>
    <EwsUrl>https://public.mondomaine.com/EWS/Exchange.asmx</EwsUrl>
    <EmwsUrl>https://public.mondomaine.com/EWS/Exchange.asmx</EmwsUrl>
    <EcpUrl>https://public.mondomaine.com/ecp/</EcpUrl>
    <EcpUrl-um>?rfr=olk&amp;p=customize/voicemail.aspx&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-um>
    <EcpUrl-aggr>?rfr=olk&amp;p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-aggr>
    <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?rfr=olk&amp;exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;&amp;realm=mondomaine.com</EcpUrl-mt>
    <EcpUrl-ret>?rfr=olk&amp;p=organize/retentionpolicytags.slab&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-ret>
    <EcpUrl-sms>?rfr=olk&amp;p=sms/textmessaging.slab&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-sms>
    <EcpUrl-publish>customize/calendarpublishing.slab?rfr=olk&amp;exsvurl=1&amp;FldID=&lt;FldID&gt;&amp;realm=mondomaine.com</EcpUrl-publish>
    <EcpUrl-photo>PersonalSettings/EditAccount.aspx?rfr=olk&amp;chgPhoto=1&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-photo>
    <EcpUrl-tm>?rfr=olk&amp;ftr=TeamMailbox&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-tm>
    <EcpUrl-tmCreating>?rfr=olk&amp;ftr=TeamMailboxCreating&amp;SPUrl=&lt;SPUrl&gt;&amp;Title=&lt;Title&gt;&amp;SPTMAppUrl=&lt;SPTMAppUrl&gt;&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-tmCreating>
    <EcpUrl-tmEditing>?rfr=olk&amp;ftr=TeamMailboxEditing&amp;Id=&lt;Id&gt;&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-tmEditing>
    <EcpUrl-extinstall>Extension/InstalledExtensions.slab?rfr=olk&amp;exsvurl=1&amp;realm=mondomaine.com</EcpUrl-extinstall>
    <ServerExclusiveConnect>On</ServerExclusiveConnect>
    </Protocol>
    </Account>
    </Response>
    </Autodiscover>



    lundi 16 mars 2015 08:45

Réponses

  • Bonjour,Le problème était lié au DNS. Le serveur avait été installé avec l'adresse IP 192.168.200.2 et passé en 10.80.x.25 en production. Les enregistrements de l'ancienne adresse IP étaient toujours présents. A priori tout le reste fonctionnait bien mais ca posait des problèmes de synchronisation au niveau du carnet d'adresse en mode hors connexion. On a supprimé manuellement les enregistrements obsolètes et la synchro fonctionne correctement. On a également mis en internalURL dans les répertoires virtuels OAB et OWA le nom publique du serveur (le nom du certificat).

    Merci pour votre temps et pour votre aide

    jeudi 26 mars 2015 18:54

Toutes les réponses

  • Bonjour, Sebastien1303,

    Je vous invite à consulter l'information dans l'article en bas:
    Managing OAB in Exchange Server 2013
    Je suis à votre disposition pour toute question complémentaire.
    Merci de nous tenir au courant.

    Cordialement,
    Téodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    mardi 17 mars 2015 08:26
  • Bonjour Teodora,

    J'ai lu l'article du lien mais je n'ai rien trouvé. Toutes les commandes fonctionnent sans me renvoyer d'erreur. J'ai ouvert et redirigé le port 25 et 443 dans le routeur. En faut-il d'autres pour le carnet d'adresse ? Merci par avance.

    Cordialement,

    vendredi 20 mars 2015 16:54
  • Ce n'est pas un problème de port, je viens de tester en local sur le même réseau que le serveur : même problème. Idem en désactivant le parfeu windows.
    vendredi 20 mars 2015 17:38
  • Bonjour, Sebastien1303,


    Avez-vous essayé de supprimer et recréer le carnet d'adresses?:
    Remove an offline address book
    Create an offline address book
    Je vous remercie par avance de votre retour.


    Cordialement,
    Téodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    lundi 23 mars 2015 10:06
  • Pouvez-vous mettre en InternalURL une autre URL que le FQDN du serveur, le nom d'hôte de l'URL doit être porté par le certificat du serveur.

    Vous pouvez mettre la même que l'ExternalURL si vous avez un split brain DNS interne (pour éviter que vos clients sortent et se connectent par l'IP publique d'Exchange).


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    lundi 23 mars 2015 10:49
    Modérateur
  • Bonjour,Le problème était lié au DNS. Le serveur avait été installé avec l'adresse IP 192.168.200.2 et passé en 10.80.x.25 en production. Les enregistrements de l'ancienne adresse IP étaient toujours présents. A priori tout le reste fonctionnait bien mais ca posait des problèmes de synchronisation au niveau du carnet d'adresse en mode hors connexion. On a supprimé manuellement les enregistrements obsolètes et la synchro fonctionne correctement. On a également mis en internalURL dans les répertoires virtuels OAB et OWA le nom publique du serveur (le nom du certificat).

    Merci pour votre temps et pour votre aide

    jeudi 26 mars 2015 18:54