locked
Evènement 10016 - Configuration de la stratégie de sécurité com RRS feed

  • Discussion générale

  • Bonjour à tous et toutes

    Je m’adresse à vous car je ne sais plus comment faire pour me débarrasser d’une erreur dans le Windows Journal que je trouve à chaque démarrage sur mon HP TouchSmart tm2 depuis le premier jour de sa mise en route le 24 février. Peut-être il faut que je vous dise que j’ai également un HPTouchSmart 600-1030fr. Les deux ont Windows 7 et sont reliés un avec l’autre par le Groupe Résidentiel. Je n’ai aucun message d’erreur de ce type sur le PC 600.

    Voici une copie du journal de windows:

    Nom du journal :System

    Source :       Microsoft-Windows-DistributedCOM

    Date :         09/05/2010 08:09:08

    ID de l’événement :10016

    Catégorie de la tâche :Aucun

    Niveau :       Erreur

    Mots clés :    Classique

    Utilisateur :  Système

    Ordinateur :   ruth-PC1

    Description :

    Les paramètres d’autorisation spécifiques à l’application n’accordent pas d’autorisation Local Exécution pour l’application serveur COM avec le CLSID

    {C97FCC79-E628-407D-AE68-A06AD6D8B4D1}

     et l’APPID

    {344ED43D-D086-4961-86A6-1106F4ACAD9B}

     au SID AUTORITE NT\Système de l’utilisateur (S-1-5-18) depuis l’adresse LocalHost (utilisation de LRPC). Cette autorisation de sécurité peut être modifiée à l’aide de l’outil d’administration Services de composants.

    XML de l’événement :

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

        <Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />

        <EventID Qualifiers="49152">10016</EventID>

        <Version>0</Version>

        <Level>2</Level>

        <Task>0</Task>

        <Opcode>0</Opcode>

        <Keywords>0x80000000000000</Keywords>

        <TimeCreated SystemTime="2010-05-09T06:09:08.000000000Z" />

        <EventRecordID>18838</EventRecordID>

        <Correlation />

        <Execution ProcessID="0" ThreadID="0" />

        <Channel>System</Channel>

        <Computer>ruth-PC1</Computer>

        <Security UserID="S-1-5-18" />

      </System>

      <EventData>

        <Data Name="param1">spécifiques à l’application</Data>

        <Data Name="param2">Local</Data>

        <Data Name="param3">Exécution</Data>

        <Data Name="param4">{C97FCC79-E628-407D-AE68-A06AD6D8B4D1}</Data>

        <Data Name="param5">{344ED43D-D086-4961-86A6-1106F4ACAD9B}</Data>

        <Data Name="param6">AUTORITE NT</Data>

        <Data Name="param7">Système</Data>

        <Data Name="param8">S-1-5-18</Data>

        <Data Name="param9">LocalHost (utilisation de LRPC)</Data>

      </EventData>

    </Event>

    Et voici ce que dit Microsoft TechNet:

    http://www.microsofttranslator.com/BV.aspx?ref=IE8Activity&a=http%3A%2F%2Ftechnet.microsoft.com%2Fen-us%2Flibrary%2Fdd337789%28WS.10%29.aspx

    Microsoft Technet me donne donc une traduction de l'Evènement 10016. Je sais y aller, ça veut dire dans la Sécurité com de mon ordinateur, mais là je ne sais pas du tout quoi changer. Je suis totalement perdue malgré les heures j'y ai passé.

    Je serai la plus heureuse si quelqu'un pourra m'expliquer ce que je dois changer, ajouter ou effacer car moi je n'y comprends rien. Peut-être quelqu'un pourra me dire à qui m'adresser, même si c'est payant.

    Un grand merci à tous qui veulent bien m'aider. Ruth

    vendredi 14 mai 2010 14:53

Toutes les réponses

  • Bonjour,

     

    Vous avez suivi les pas de: http://support.microsoft.com/kb/899965 

    Accordez à l'utilisateur les autorisations requises pour démarrer le composant COM. Pour cela, procédez comme suit :

    1. Cliquez sur Démarrer, sur Exécuter, tapez regedit dans la zone Ouvrir, puis cliquez sur OK.
    2. Recherchez la sous-clé de Registre suivante et cliquez dessus :
      HKEY_CLASSES_ROOT\CLSID\CLSID value
      Remarque Dans cette sous-clé, « CLSID value » est un espace réservé pour les informations de CLSID qui apparaissent dans le message.
    3. Dans le volet droit, double-cliquez sur AppID.

      La boîte de dialogue Modification de la chaîne s'affiche. Laissez cette boîte de dialogue ouverte et passez à l'étape suivante.
    4. Cliquez sur Démarrer, sur Exécuter, tapez dcomcnfg dans la zone Ouvrir, puis cliquez sur OK.

      Si un message d'alerte de sécurité Windows vous invite à continuer à bloquer le programme Microsoft Management Console, choisissez de débloquer le programme.
    5. Dans Services de composants, double-cliquez sur Services de composants, sur Ordinateurs, sur Poste de travail, puis cliquez sur Configuration DCOM.
    6. Dans le volet d'informations, recherchez le programme en utilisant le nom convivial.

      Si l'identificateur AppGUID est répertorié au lieu du nom convivial, recherchez le programme en utilisant cet identificateur.
    7. Cliquez avec le bouton droit sur le programme, puis cliquez sur Propriétés.
    8. Cliquez sur l'onglet Sécurité.
    9. Dans la zone Autorisations d'exécution et d'activation, cliquez sur Personnaliser, puis sur Modifier.
    10. Cliquez sur Ajouter, tapez le nom du compte d'utilisateur, puis cliquez sur OK.
    11. Pendant que l'utilisateur est sélectionné, activez les cases à cocher Autoriser correspondant aux éléments suivants :
      • Exécution locale
      • Exécution à distance
      • Activation locale
      • Activation à distance
    12. Cliquez deux fois sur OK.
    13. Quittez l'Éditeur du Registre.

    Vous pouvez consulter aussi: http://support.microsoft.com/kb/920783ous

     

    Merci de nous tenir au courant,

    Cordialement,

    Roxana


    Roxana Panait, MSFT ________ Votez l’article qui vous est utile ou postez un pour participer au concours : Appel a la contribution! Publiez un tip ou un petit tutorial (comment faire) sur la technologie que vous connaissez le mieux ! - http://social.technet.microsoft.com/Forums/fr-FR/1635/thread/c0fc6847-a4b0-4253-85e9-8eac0cc95aa0
    mardi 18 mai 2010 08:41
  • Bonjour Roxana, bonjour à Tous

    Merci de votre réponse, mais malheureusement je connaissais déjà cette solution que je n'aie pas pu exécuter sur mon ordi car je ne trouve pas la clé

    HKEY_CLASSES_ROOT\CLSID\CLSID value

    Mais je vais m’adresser à quelqu’un plus compétent que moi et je vous tiendrai au courant.

    Merci encore et bonne journée.

    Ruth

     

    mardi 18 mai 2010 09:51
  • Bonjour Ruth,

    En fait, c’est assez difficile de trouver cette clé. Un exemple : http://www.sevenforums.com/general-discussion/28840-event-id-10016-dcom-permissions-error.html

    Voilà les pas que j’ai suivi :

    1.       Le premier pas n’est pas nécessaire car le message d’erreur contient déjà l’APPID : Démarrer/Executer/Regedit . Ici allez dans HKEY_Classes_Root et allez jusqu’à CLSID (après tous les clés qui commencent avec point (.nomduclé). Ici vous trouverez la clé : {C97FCC79-E628-407D-AE68-A06AD6D8B4D1} et l’APPID {344ED43D-D086-4961-86A6-1106F4ACAD9B}

    2.       Ce que vous devez faire par la suite c’est d’ouvrir : Panneau de Configuration/Outils d’administration/Services de Composantes. Double clic sur Ordinateur/Poste de travail/Configuration DCOM en refusant tout pop-up avec enregistrement de clé.

    3.       Ici vous devez cherchez IPBusEnum qui a l’appid {344ED43D-D086-4961-86A6-1106F4ACAD9B},clic droit, Propriétés, onglet Sécurité, Modifier et ici ajouter System Accoun, groupe Administrateurs et votre utilisateurs avec des permissions « full ».

     

    J’espère que c’est plus clair maintenant.

    Cordialement,

    Roxana


    Roxana Panait, MSFT ________ Votez l’article qui vous est utile ou postez un pour participer au concours : Appel a la contribution! Publiez un tip ou un petit tutorial (comment faire) sur la technologie que vous connaissez le mieux ! - http://social.technet.microsoft.com/Forums/fr-FR/1635/thread/c0fc6847-a4b0-4253-85e9-8eac0cc95aa0
    mercredi 19 mai 2010 09:17
  • Bonjour Roxana

    bonjour à tous

    merci mille fois pour tout le mal que vous vous donnez. Je n'ai pas mon Laptop chez moi aujourd'hui, je l'ai laissé à mon ancien fournisseur de PC. C’est avec lui je vais essayer de suivre les instructions données par vous dans la réponse de hier soir, mais je ne sais pas quand il aura le temps de le faire.

    Je vous tiendrai au courant bien-sûr.

    Encore merci

     

    Cordialement

    Ruth

     

    jeudi 20 mai 2010 08:26
  • Bonjour Roxana

     

    Bonjour Roxana

    Bonjour à Tous

    Finalement j’ai tenté toute seule la solution proposée car j’ai bien compris ce qu’il fallait faire. Seulement quand j’arrive à IPBusEnum, clic droit, propriétés, onglet Sécurité, tout es grisé, tous les onglets. C’est le même cas sur mon autre ordinateur et pourtant je n’ai pas cette erreur ID 10016 dans le Journal de Windows. Je suis obligée d’abandonner car je ne voudrais pas vous ennuyer plus longtemps. J’espère que mon Laptop survivra quelque temps malgré ce problème dans la source Microsoft-Windows-DistributedCom.

    Je vous remercie encore de tout cœur pour tout.

    Cordialement

    Ruth

    mardi 25 mai 2010 13:49
  • Bonjour Ruth :)

    Dans ce cas, vous pouvez essayer :

    Allez dans le panneau de configuration, Stratégie de sécurité locale/Stratégie Locale /Options de sécurité/ DCOM –Restrictions d’accès à un ordinateur au format du langage SDDL/Modifier la sécurité et ici vérifier les autorisations : http://support.automation.siemens.com/WW/llisapi.dll/31198863?func=ll&objId=31241335&objAction=csView&lang=en&siteid=cseus&aktprim=0&extranet=standard&viewreg=WW&load=treecontent

    Cordialement,

    Roxana


    Roxana Panait, MSFT ________ Votez l’article qui vous est utile ou postez un pour participer au concours : Appel a la contribution! Publiez un tip ou un petit tutorial (comment faire) sur la technologie que vous connaissez le mieux ! - http://social.technet.microsoft.com/Forums/fr-FR/1635/thread/c0fc6847-a4b0-4253-85e9-8eac0cc95aa0
    mercredi 26 mai 2010 07:23
  • Bonjour Roxana

    bonjour à Tous

    Merci encore de votre aide. Mais je ne peux pas trouver la « Stratégie de Sécurité locale », apparemment c’est parce que j’ai Windows 7.  Par contre dans les Services des composants, clic droit sur Propriétés, onglet Propriétés par défaut j’ai mis le Niveau d’authentification par défaut : » par défaut » comme c’était proposé dans le lien parce qu’il y avait chez moi ‘Connexion’, et dans la

    Sécurité COM -  dans Autorisations accès et

                                  Autorisations d’exécution et d’activation

    j’ai donné une autorisation à « Tout le monde’ et tout ce qui était possible comme Anonymous Logon, Interactif etc., et ne rien à changé, l’erreur est toujours bien et beau là.

    Je ne peux pas faire davantage, car d’abord, même si je parle et comprends un peu l’anglais, je ne connais pas le langage informatique en anglais étant donné que je n’ai jamais eu un autre ordinateur qu’en français. En plus, le lien que vous me donnez est bien pour Windows XP. Si un jour le tout sort pour Windows 7, je suppose il sera plus facile pour moi d’y arriver. En plus j’ai peur de faire une bêtise. Je pense que pour une femme de mon âge, j’ai 72 ans et je suis toute seule avec ce problème, je me suis lancée déjà très loin dans ‘l’intérieur’ d’un ordinateur. Je ne dors plus très bien.

    Je vais continuer à chercher, je reviendrai voir dans TechNet très souvent. On peut y apprendre plein de choses. Merci pour votre patience.

    Cordialement

    Ruth

     

    mercredi 26 mai 2010 11:22
  • Bonjour Ruth,

    Je vous félicite pour votre détermination et je vous souhaite beaucoup de santé J

    Je veux m’excuser, j’ai oublié de mentionner que la stratégie de sécurité est dans le panneau de configuration, outils d’administration.

    Voir aussi une image (http://www.forum-seven.com/wp-content/uploads/2009/05/outils-dadministration-2.jpg):

    Cordialement,

    Roxana

    mercredi 26 mai 2010 11:31
  • Bonjour Roxana

    Autant je voudrais trouver la solution de ce problème, autant vous voulez bien m’aider, je vous en remercie beaucoup.

    Le problème est que j’avais bien trouvé Système et Sécurité – Outils d’administration (c’était déjà mentionné dans un autre forum), mais dans la liste ne se trouve pas Stratégie de Sécurité Locale, quand il s’agit de Windows 7 Premium en tout cas. Malheureusement je ne suis pas capable de vous joindre une copie d'écran.

    Merci de me souhaiter une bonne santé. C’est ce que je vous souhaite de tout cœur aussi.

    Cordialement

    Ruth

    mercredi 26 mai 2010 12:46
  • Bonjour Roxana

    Autant je voudrais trouver la solution de ce problème, autant vous voulez bien m’aider, je vous en remercie beaucoup.

    Le problème est que j’avais bien trouvé Système et Sécurité – Outils d’administration (c’était déjà mentionné dans un autre forum), mais dans la liste ne se trouve pas Stratégie de Sécurité Locale, quand il s’agit de Windows 7 Premium en tout cas. Malheureusement je ne suis pas capable de vous joindre une copie d'écran.

    Merci de me souhaiter une bonne santé. C’est ce que je vous souhaite de tout cœur aussi.

    Cordialement

    Ruth

    Bonjour, 

    Je constate que j'ai le même problème avec la même conclusion, je n'ai pas accès l'outil de Stratégie de Sécurité Locale car je suis aussi sur Windows 7 Premium, il m'est donc impossible de procéder de cette manière.

    Y a t'il une autre manière de régler ce problème ? ou un moyen de contourner l'utilisation de gpedit ?

    Pardon pour ce "déterrage" de sujet mais ayant exactement le même problème j'ai pensé qu'il serait préférable de poster ici

    lundi 4 février 2013 14:24
  • En bon québécois, Dans le volet d'informations, recherchez le programme en utilisant le nom convivial.

    Sa dit fuckall ou chercher ! Même d'écrire Si l'identificateur AppGUID est répertorié au lieu du nom convivial, recherchez le programme en utilisant cet identificateur.

    Sa dit rien de plus ! Asti que parfois c'est pas clair (Je te vise pas toi) Mais eux qui ont fait le post et d’ailleurs ils oublie de mentionnez que y'a des fichiers dans le registre que nous nous n'avons pas alors sa complique la tâche

    Moi mon problème arrive 6 semaines plus tard suite a un changement de power supply ! C'est comme si soudainement il manquait un fichier alors wtf

    samedi 7 mars 2015 06:19
  • Bonjour Roxana,

    Désolé de déterrer ce vieux sujet mais comme j'ai exactement le même problème que Ruth... je reprends le flambeau en espérant être lu par vous ou toute autre personne de chez MS.

    Je suis sous Windows 7 pro.

    Je reprends le sujet au niveau "panneau de configuration/outils d'administration/stratégie de sécurité locale/paramètres de sécurité/stratégies locales/options de sécurité/DCOM : restriction d'accès à un ordinateur au format du langage SDDL/propriétés/modifier sécurité"

    "tout le monde" est en accès local et distant autorisé. Seul ANONYMOUS LOGON n'est pas autorisé en distant. Malgré cela, comme pour Ruth, les paramètres sécurité de propriétés IPBusEnum (comme tous les autres paramètres) sont grisés et inaccessibles. J'ai bien exécuté "service de composant" en tant qu'administrateur... que faire ?

    Merci d'avance pour votre aide

    mercredi 21 octobre 2015 21:05
  • Bonjour,

    Bon, j'ai le même soucis sous windows 10. Mais la plupart des solutions reviennent à celle là. 
    tous mes champs sont grisé.
    J'ai regardé les propriétés d'accès et j'ai pourtant les droits de pouvoir les modifier. 

    jeudi 6 avril 2017 16:30
  • Bonjour à tous,

    En ce mois de janvier, je vous envoie mes meilleurs vœux pour 2018, surtout la bienveillance, la prospérité et la santé.

    Pour répondre aux personnes qui ont les paramètres de sécurité grisés, on doit s'approprier la clé dans l'éditeur de registre afin de procéder aux modifications.

     
    • Recherchez la sous-clé de Registre suivante et cliquez droit dessus :
      HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AppID\CLSID value
      , puis cliquez sur Autorisations....
    • Cliquez sur Avancé.
    • Cliquez sur l'onglet Propriétaire.
    • Sélectionnez le groupe Administrateurs.
    • Cliquez sur OK.
    • Sélectionnez le groupe Administrateurs et activez les cases à cocher Autoriser correspondant aux éléments suivants :
      ● Contrôle total
    • Cliquez sur Démarrer, sur Exécuter, tapez services dans la zone Ouvrir, puis cliquez sur OK.
    • Recherchez le service Application système COM+
    • Cliquez avec le bouton droit sur le service, puis cliquez sur Redémarrer.
    • Quittez le gestionnaire de services.
    • Dans Services de composants, cliquez droit sur Configuration DCOM puis cliquez sur Actualiser.

    Vous avez maintenant accès aux autorisations du composant.

    Bonne continuation =)

    • Modifié freddy24fit mercredi 17 janvier 2018 05:47 Correction de l'affichage
    mercredi 17 janvier 2018 05:31