locked
W10 - Comment désactiver le Centre de notification / Action Center ? RRS feed

  • Question

  • Bonjour,

    Je suis en train de réaliser une borne publique avec un Windows 10 Pro et je cherche à couper tous les accès d'administration pour éviter de me les faire bidouiller.

    Une seule application sera lancé mais elle est en Winform donc je ne peux pas utiliser le mode Kiosk. (Appli .Net, déployé en ClickOnce, plein écran, repasse en plein écran quand on la redimensionne, pas de clavier/sourie physique, clavier virtuel Windows désactivé (j'en ai reprogrammé un dans l'appli), en premier plan).

    J'ai désactivé par GPO l'accès au panneau de configuration et aux paramètres. J'aimerai maintenant désactiver l'accès au Centre de notification car il y a quelques boutons gênant en bas.

    J'ai essayé avec la GPO. Cela retire bien le bouton en bas à droite mais le menu reste accessible avec un écran tactile en faisant glisser le doigt du bord droit vers le centre.

    De même j'ai essayé de couper l'ImmersiveShell dans la base de registre. En cliquant sur le bouton en bas à droite le menu perd son habillage et ses boutons, c'est parfait, mais en tactile c'est toujours l'autre menu problématique qui apparaît.

    Il est prématuré de crier au bug mais ça y ressemble.

    Peut-être que je ne m'y prend pas de la bonne façon, je suis ouvert à toutes les idées.

    Merci d'avance de votre aide.

    samedi 9 janvier 2016 21:21

Réponses

  • Vous avez essayez les clés DisableTLcorner et DisableCharmsHint dans l'immersiveShell ?
    Je ne suis pas sur qu'elles soient fonctionnelles en W10...

    Et en effet, la solution n'a pas l'air simple... ( sans désactiver le tactile )
    Difficile de contrôler l'aspect "gesture"...

    Les gens dans le même cas que vous, force un kill explorer pour éviter que ça se produise.
    C'est peut-être pas une solution dans votre cas.

    Bonne chance

    • Marqué comme réponse BoPtz lundi 1 février 2016 14:51
    jeudi 28 janvier 2016 13:32
  • Tiens, chez moi si je désactive cette fonction en registry, je n'arrive plus du tout à ouvrir l'Action Center.

    L'avez-vous essayez ?

    
    [HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Windows\Explorer]
    "DisableNotificationCenter"=dword:00000001

    • Marqué comme réponse BoPtz lundi 1 février 2016 14:51
    jeudi 28 janvier 2016 13:46

Toutes les réponses

  • Bonjour,

    As tu regardé les fonctionnalités intégrées offertes par le mode Kiosque de Windows 10 ?

    https://technet.microsoft.com/fr-fr/library/mt219051%28v=vs.85%29.aspx?f=255&MSPPError=-2147217396

    https://technet.microsoft.com/fr-fr/library/mt219050(v=vs.85).aspx

    Cordialement

    /Christophe

    dimanche 10 janvier 2016 08:04
  • Bonjour,

    Merci pour ta réponse.

    Oui j'ai vu ça mais en Windows 10 Pro seule les applications Windows Universelle sont prise en compte par le mode Kiosk or la mienne est en Winform.

    Cordialement

    dimanche 10 janvier 2016 08:12
  • Bonjour bNach,

    Est-ce que le problème est toujours d'actualité?

    Merci de votre retour en avance.

    Cordialement,

    Boyan

    mercredi 27 janvier 2016 18:40
  • Bonjour,

    Oui, impossible de trouver une solution.

    Je pense de plus en plus à un bug de l'OS.

    Cordialement,

    jeudi 28 janvier 2016 13:05
  • Vous avez essayez les clés DisableTLcorner et DisableCharmsHint dans l'immersiveShell ?
    Je ne suis pas sur qu'elles soient fonctionnelles en W10...

    Et en effet, la solution n'a pas l'air simple... ( sans désactiver le tactile )
    Difficile de contrôler l'aspect "gesture"...

    Les gens dans le même cas que vous, force un kill explorer pour éviter que ça se produise.
    C'est peut-être pas une solution dans votre cas.

    Bonne chance

    • Marqué comme réponse BoPtz lundi 1 février 2016 14:51
    jeudi 28 janvier 2016 13:32
  • Tiens, chez moi si je désactive cette fonction en registry, je n'arrive plus du tout à ouvrir l'Action Center.

    L'avez-vous essayez ?

    
    [HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Windows\Explorer]
    "DisableNotificationCenter"=dword:00000001

    • Marqué comme réponse BoPtz lundi 1 février 2016 14:51
    jeudi 28 janvier 2016 13:46