none
UNIX/Linux: détecter et superviser sans le compte "root" RRS feed

  • Question

  • Bonjour

    Je souhaite utuliser le MP par défaut Unix/Linux, mais les admins systeme sont tres réticents pour que cela se fasse avec le compte "root".

    Dans le wizard de détection d'ordi Unix, il y a une case-à-cocher "C'est un compte superutilisateur", et ausi la notion de "Mot de passe racine"

    Bref, je suis un peu perdu pour répondre à mes admins, le terme "superutilisateur" n'existant pas chez eux.

    L'idéal serait qu'ils me créent un compte "scom" dédié, mais quelles caractéristiques doit-il avoir ?

     

    Merci par avance.

    mardi 29 juin 2010 14:00

Réponses

Toutes les réponses

  • Bonjour,

    Un compte root est nécessaire pour installer les services. Cependant, on peut spécifier un compte d'utilisateur non privilégié (ne pas cocher la case Superutilisateur) pour effectuer la connexion SSH. Il faut aussi indiquer le mot de passe de Root de façon à ce que le processus d'installation fasse un SU une fois la session SSH établie.

    Une fois l'agent installé, Operations Manager fait appel à 2 comptes RunAs. Un non privilégié et un privilégié. Le compte non privilégié est utilisé presque tout le temps. Le compte privilégié est utilisé pour effectuer des actions de récupération. Par exemple, si un service s'arrête, l'agent va utiliser le compte privilégié pour tenter de redémarrer le service.

    Par défaut, toutes les actions de récupération sont désactivées. Donc pour la supervision, le compte non privilégié est suffisant.

    Cordialement,


    Yann Gainche MVP Operations Manager http://www.gainche.net
    mardi 29 juin 2010 14:53
    Modérateur
  • Merci bien - je vais voir avec eux en leur montrant votre réponse.

    Bonne soirée

    mardi 29 juin 2010 14:58
  • Une fois l'agent installé,

    Bonjour, 

     

    Problème: je n'en suis pas encore là, car dans mon cas, c'est la détection qui plante. J'ai essayé sur AIX4.3 et RedHatAS3.

    Les admins systeme m'ont créé sur ces 2 serveurs un compte non-privilégié (user: opsmgr  groupe: scom), que j'ai rentré dans le wizard de détection, décoché la case "Superutilisateur", et ils m'ont tapé le password de root dans la dernière case. J'ai ausi tenté les 2 modes SSH avec et sans.

    Le compte unix opsmgr est bon car j'ai pu me connecter avec puTTY en SSH sur les 2 serveurs.

    Auriez-vous une piste possible ?

     

    Merci et bonne journée

    jeudi 1 juillet 2010 08:33
  • Bonsoir,

    A quel moment de l'installation rencontrez vous le problème

    pouvez vous regarder sur le systeme Linux ou AIX, s'il y a quelque dans le dossier /etc/opt/microsoft ?

    Cdlt,

     


    JF BERENGUER MVP System Center Operations Manager MCSE, MCT, MCSA messaging, NEXTEC SYSTEMS http://actelia.spaces.live.com/
    samedi 3 juillet 2010 19:34
  • Bonjour,

    Pouvez-vous vérifier que le port WS-MAN (1270/tcp) est ouvert sur le firewall des serveurs Linux ?

    Cordialement,


    Yann Gainche MVP Operations Manager http://www.gainche.net
    dimanche 4 juillet 2010 09:09
    Modérateur
  • Bonjour et merci à tous les deux

    @Jeff : c'est la détection qui plante, je n'arrive pas jusqu'à l'installation, et le répertoire /etc/opt est vide :-(

    @Yann: Voilà la réponse de l'ingé system: Il n y a aucun firewall sur ces 2 serveurs  et le port est libre ( n est occupé par aucun process). 

    J'ai cherché sur le net, et on dirait que personne n'a déjà eu ce problème (mais avec root sur un serveur de test, SCOM passe très bien) 

    Si vous avez des idées, je suis preneur ...

    A+

     

    lundi 5 juillet 2010 09:31
  • Bonjour,

     

    pour RedHatAS3, ça va être dur. Sont supportés RHEL4 et 5

    Pour AI, c'est à partir de la version 5.3

    http://www.microsoft.com/downloads/details.aspx?FamilyID=b15fef5c-e331-4006-8913-be376bb0e0c1&displaylang=en

    Cordialement,


    Yann Gainche MVP Operations Manager http://www.gainche.net
    • Marqué comme réponse smartiz mardi 13 juillet 2010 08:12
    lundi 5 juillet 2010 10:03
    Modérateur
  • Ooops - effectivement, si j'essaie sur des versions d'O.S. non supportées, et en plus sans le dernier MP, ça ne risque pas de marcher !

    Je mets tout ça au carré et vous donnerai des nouvelles + tard

    Merci encore et A+

    lundi 5 juillet 2010 12:12
  • Bonjour tout le monde

    Oui ! avec le dernier MP, ça marche.

    Il faut d'abord suivre http://blogs.technet.com/b/birojitn/archive/2010/01/20/monitoring-linux-using-scom-2007-r2.aspx pour créer dans Administration->Configuration de l'identification->Comptes  deux comptes de base.

    Puis faire sur le RMS en mode DOS:    winrm set winrm/config/client/auth @{Basic="true"}

    Bon, le truc c'est que maintenant, c'est l'install de l'agent qui échoue (il manque 2 packages dans l'AIX en pré-requis), mais au moins la détection est OK.

    A+ et merci

     

     

    mardi 13 juillet 2010 07:56
  • Pour ceux qui sont bloqués par la phase de signature du certificat, suivre ce lien :

    http://scug.be/blogs/scom/archive/2009/12/04/opsmgr-certificate-for-this-system-is-not-valid-when-installing-linux-agent.aspx

    Voilà voilou

    A++

    mardi 13 juillet 2010 14:54