none
WSL (Ubuntu 18.04) message d'erreur lors des MAJ (sudo apt upgrade) RRS feed

  • Discussion générale

  • Bonjour,

    J'ai posé la question ci-dessous sur Microsoft Community.

    Ils m'ont redirigé vers vous.

    Voici mon problème :

    Très régulièrement je mets à jour Ubuntu (18.04) sur Windows 10 (ver 18.03); commande sudo apt upgrade (sous 1 bash exécuter en tant qu'administrateur) .

    J'obtiens des messages d'erreurs "insuffisient privileges ...

    Il doit y avoir une corruption quelconque/droits d'accès sur des répertoires du sous-système WSL.

    Je cherche à le désinstaller (pour le réinstaller).

    Sous une console (cmd.exe) avec privilèges admin en lancant la commande "lxrun /uninstall /full" j'obtiens un message d'erreurs Windows:

    "Désinstallation

    Erreur 0x80070002".

    Auriez-vous des suggestions/manip à réaliser?

    D'avance merci pour votre aide.

    jeudi 12 juillet 2018 17:25

Toutes les réponses

  • Bonsoir Monsieur AlanR29

    Vous pouvez suivre cette instruction : 

    puis 

    Merci, a+


    S'il vous plaît n'oubliez pas de =Marquer comme réponse= les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution. Héritier KANDOLO. http://www.rootandadmin.com/

    samedi 14 juillet 2018 16:47
  • En addition au dernier commentaire, pour la syntaxe Debian/Ubuntu voici ce qu'il faut faire pour:

    Mettre à jour les paquets installés : 

    sudo apt-get update && apt-get upgrade -y
    sudo apt-get autoclean
    sudo apt remove

    Mettre à jour la distribution (noyau etc...) et les paquets installés ainsi que leurs dépendances :

    sudo apt-get update && sudo apt-get dist-upgrade
    sudo apt-get --purge autoremove

    Mais ceci ne concerne que la partie Linux, pas la partie Windows
    jeudi 19 juillet 2018 09:41