none
[SP 2010 foundation sur SBS 2011] Erreur création de sous-site RRS feed

  • Discussion générale

  • Bonjour,

    Je suis en train de tester sharepoint foundation livré avec mon SBS 2011.

    J'ai créé un site de base avec certaines chose dedans. Je voulais créer un sous-site mais j'ai une erreur.

    - quand je le fais à partir du site (je crée un site d'equipe) il me fait à priori tout comme il faut, sauf que si j'essaie d'ajouter un document, ou de modifier un élément du site, il me fait une erreur :

    La liste n’existe pas.

    La page sélectionnée contient une liste qui n’existe pas. Elle a peut-être été supprimée par un autre utilisateur.

    Résoudre les problèmes liés à Microsoft SharePoint Foundation.

    ID de corrélation : a5e75d19-5f73-411c-b989-82ee54d9e5a3

    - quand je fais à partir de sharepoint designer, il me fait une erreur : Un modèle de site web déjà appliqué à ce site...

    Une idée d'où peut venir le problème ?

    Merci.

    lundi 27 février 2012 16:23

Toutes les réponses

  • Bonsoir,

    Pour palier à ce problème, il suffit de rajouter dans :

    Mon site > Galerie de pages maîtres > Paramètres > Autorisations 

    l'utilisateur : AUTORITE NT\utilisateurs authentifiés avec les droits lecteur restreinte Ainsi, les  utilisateurs récupèrent le droit d'utiliser les pages de la galerie.

    Dites nous quoi si l'erreur persiste encore .. Merci et bonne soirée, Gokan


    Founder of SharePoint CookBook: http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal

    lundi 27 février 2012 21:37
  • Bonjour,

    Merci de votre aide, mais cela ne fonctionne pas. le message est le même. Voila ce que je fais :

    A partir de mon site de base, je fais Actions du site > Nouveau site. Je lui donne un nom, je définis l'url, et je valide. Il me crée le sous site. Je modifie ma page et ajoutant une bibliothèque de documents ou une liste de tâche, jusque là pas de soucis et j'enregistre.

    Ensuite je vais sur mon nouveau site et je clique sur ajouter un document et c'est là qu'apparait l'erreur.

    Si je fais cela à partir du designer, je vais sur mon site de base et je fais Actions du site > Modifier dans sharepoint designer. La SP designer s'ouvre. Je clique sur sous site, il me demande a partir de quel modele et l'url. je prends un site d'equipe et je définis mon url. et là erreur ! Une erreur s'est produite lors de l'extraction de données à partir de votre site Sharepoint. Un modèle de site web déjà été appliqué à ce site. Dès qu'un modèle a été appliqué à un site, vous devez supprimer ce dernier, puis le recréé afin de lui réappliquer un autre modèle. Pourtant à partir du designer j'ai supprimé mon site que j'ai créé a partir du web, avant de le recréer dans le designer.

    Je précise que je travaille avec le user qui fait partie des propriétaires du site.

    Merci de votre aide.

    mardi 28 février 2012 09:05
  • J'ai refait un test.

    J'ai créé une autre application et dessous un autre sous-site...

    Et bien même erreur !

    Je précise que je suis sur SBS 2011 std, est-ce lié ?

    Merci.

    mardi 28 février 2012 11:48
  • Bonjour,

    Vu que vous disposer d'un ID de corrélation, que dit vos fichiers logs?


    Pascal P
    http://sharepoint-afterwork.fr
    Nouveaux site en FR
    Twitter: @PascalPoeck

    mardi 28 février 2012 16:09
  • Merci de votre aide.

    Dans le log je trouve ceci :

    02/28/2012 18:20:21.52     w3wp.exe (0x3BD4)                           0x305C    SharePoint Foundation             Logging Correlation Data          xmnv    Medium      Site=/    4c41b07b-f52f-4687-b7ad-52d656c55318
    02/28/2012 18:20:21.53     w3wp.exe (0x3BD4)                           0x305C    SharePoint Foundation             General                           8kh7    High        La liste n’existe pas.  La page sélectionnée contient une liste qui n’existe pas. Elle a peut-être été supprimée par un autre utilisateur.    4c41b07b-f52f-4687-b7ad-52d656c55318
    02/28/2012 18:20:21.68     w3wp.exe (0x3BD4)                           0x305C    SharePoint Foundation             General                           8kh7    High        La liste n’existe pas.  La page sélectionnée contient une liste qui n’existe pas. Elle a peut-être été supprimée par un autre utilisateur.    4c41b07b-f52f-4687-b7ad-52d656c55318
    02/28/2012 18:20:21.69     w3wp.exe (0x3BD4)                           0x305C    SharePoint Foundation             General                           8kh7    High        La liste n’existe pas.  La page sélectionnée contient une liste qui n’existe pas. Elle a peut-être été supprimée par un autre utilisateur.    4c41b07b-f52f-4687-b7ad-52d656c55318
    02/28/2012 18:20:21.69     w3wp.exe (0x3BD4)                           0x305C    SharePoint Foundation             Runtime                           tkau    Unexpected    System.Runtime.InteropServices.COMException: La liste n’existe pas.  La page sélectionnée contient une liste qui n’existe pas. Elle a peut-être été supprimée par un autre utilisateur.    à Microsoft.SharePoint.Library.SPRequestInternalClass.GetListsWithCallback(String bstrUrl, Guid foreignWebId, String bstrListInternalName, Int32 dwBaseType, Int32 dwBaseTypeAlt, Int32 dwServerTemplate, UInt32 dwGetListFlags, UInt32 dwListFilterFlags, Boolean bPrefetchMetaData, Boolean bSecurityTrimmed, Boolean bGetSecurityData, Boolean bPrefetchRelatedFields, ISP2DSafeArrayWriter p2DWriter, Int32& plRecycleBinCount)     à Microsoft.SharePoint.Library.SPRequest.GetListsWithCallback(String bstrUrl, Guid foreignWebId, String bstrListInternalName, Int32 dwBaseType, Int32 dwBaseTypeAlt, Int32 dwServerTemplate, ...    4c41b07b-f52f-4687-b7ad-52d656c55318
    02/28/2012 18:20:21.69*    w3wp.exe (0x3BD4)                           0x305C    SharePoint Foundation             Runtime                           tkau    Unexpected    ...UInt32 dwGetListFlags, UInt32 dwListFilterFlags, Boolean bPrefetchMetaData, Boolean bSecurityTrimmed, Boolean bGetSecurityData, Boolean bPrefetchRelatedFields, ISP2DSafeArrayWriter p2DWriter, Int32& plRecycleBinCount)    4c41b07b-f52f-4687-b7ad-52d656c55318
    02/28/2012 18:20:21.83     w3wp.exe (0x3BD4)                           0x305C    SharePoint Foundation             Monitoring                        b4ly    Medium      Leaving Monitored Scope (Request (GET:http://tmtgsrv:21289/orange/_layouts/Upload.aspx?List={9724368B-A204-4672-B81D-2B5D440FE655}&RootFolder=&IsDlg=1)). Temps d’exécution=328,602526788432    4c41b07b-f52f-4687-b7ad-52d656c55318
    0

    Si ca peut aider...

    mardi 28 février 2012 17:22
  • Bonsoir,

    Pourrais-je savoir si votre Site Collections est plus grand que 10 MB ?

    J'ai lu, dans un post ou le grand MVP "Erol" -, parlais d'une limitations

    Extrait Copier/Coller:

    dans les Attention il y a une limite sur les modèles de sites fait par le biais de
    l'interface graphique WSS. Cette limite est fixé à 10 Mo.

    Bien evidememnt, ceci est juste pr le SBS..

    Merci, Gokan


    Founder of SharePoint CookBook: http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal


    mercredi 29 février 2012 21:30
  • Bonjour,

    Comment connaitre la taille du site collection ?

    Cependant, je ne pense pas que ce soit le cas, vu que je suis en test et que sur le site j'ai pas grand chose...

    De plus si cette limitation est liée à l'interface graphique, je devrais pouvoir le faire avec le designer, non ?

    Autre soucis, j'ai essayé d'extraire un fichier de ma biliothèque de document et la aussi : erreur vous n'êtes pas autorisé à extraire ce document... Alors que je suis le propriétaire du site et par héritage des documents. D'ailleurs c'est moi qui ai mis le doc en ligne... Mais je vais faire un autre post pour cela.

    Décidément, ce sharepoint m'a l'air bancale... C'est dommage car je l'aimais bien, mais bon si mes tests ne sont pas plus concluants....

    Merci de votre aide ! ;-)


    • Modifié jerome44 jeudi 1 mars 2012 09:22
    jeudi 1 mars 2012 09:04
  • Bonjour,

    Executer ce script en PowerShell, pour vous donnez les droit de Farm Administrateur et re-testez :

    $site = Get-SPSite -Identity "http://mysite/"
            $user = Get-SPUser -Identity "mydomain\myuser" -Web $site.RootWeb
            $assignment = New-Object Microsoft.SharePoint.SPRoleAssignment($user)
            $role = $site.RootWeb.RoleDefinitions[[Microsoft.SharePoint.SPRoleType]::Administrator]
            $assignment.RoleDefinitionBindings.Add($role);

            foreach ($web in $site.AllWebs) {
            if ($web.HasUniquePerm) {
            $web.RoleAssignments.Add($assignment)
            }
          }

    Remplacez les valeurs http://Mysite et mydomain\myuser

    Bonne chance, Gokan


    My blog has been redesigned and relooked.. Have a look with a great pleausre.. :) : http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    SharePoint Server 2010 Contributor on BTgonulluleri.com

    samedi 3 mars 2012 09:44