none
Enorme problème de communication entre Exchange 2013 et Outlook 2013 RRS feed

  • Question

  • Bonjour

    j'ai débuté au sein de mon entreprise une migration de Exchange 2007 vers Exchange 2013 dont voici les caractéristiques générales:

    • 2 contrôleurs de domaines sur site sous Windows 2012, 1 contrôleur de domaine sous Windows 2008 x86. 1 seul domaine Active Directory
    • 1 Serveur Exchange 2007 version 8.3 build 83.6 sous Windows server 2003 x64, standard Edition. 3 bases de données d'environ 150Go chacunes. 32 Go de RAM, antivirus Sophos. roles Mailbox, CAS et Hub Transport
    • 1 Serveur Exchange 2013 version 15.0 build 847.32 sous Windows server 2012, Edition Datacenter. 1 base de données de 500 Go. 24Go de RAM, antivirus Sophos. Roles mailbox et CAS
    • 23 domaines mails gérés
    • environ 250 boites mails, allant de quelques dizaines de Mo à 14 Go en taille pour un nombre de mails entre quelques dizaines et 60000
    • Infrastructure VDI VMware View 5.2 avec clients Windows 7 et Office 2013
    • Le connecteur d'envoi primaire est un serveur Linux Debian

    Le serveur Exchange 2013 est accessible depuis l'extérieur comme l'intérieur sans problème aucun, Outlook Web Access fonctionne, envoi et reception de mails fonctionnels. Sur des postes fixes, pas de particularités, ralentissement léger de l'affichage des éléments dans Outlook mais rien d'alarmant. Par contre, sur les postes en VDI, l'affichage d'un mail peut prendre jusqu'à 10 ou 15 secondes par message, ce qui est tout de même extrêmement lent. Les utilisateurs n'ayant pas encore été migrés et donc sur Exchange 2007 ne rencontrent aucun problème. La seule chose ayant permis d'améliorer les choses a été d'utiliser le mode cache du compte exchange, mais c'est une solution qui n'est pas viable à long terme car il s'agit de client VDI donc limités en espace disque.

    les utilisateurs sont tous en profil itinérant, leur dossiers sont redirigés sur un partage réseau. les parefeux des ordinateurs Windows 7 sont désactivés, ceux des serveurs exchanges aussi. les clients et les serveurs sont dans le même subnet IP. Les serveurs comme les clients sont tous à jour tant concernant Windows que Office ou Exchange

    j'ai remarqué dans la gestion IIS du serveur 2013 que les liaisons sur les protocoles net.tcp, net.pipe, net.msmq et msmq.formatname sont dans un état inconnu, ainsi que plusieurs avertissements en provenance de Microsoft-Windows-WAS avec les ID 5013, 5138 et 5175

    exemple:

    • L'arrêt d'un processus servant le pool d'applications 'MSExchangeSyncAppPool' a pris trop de temps. L'identificateur de processus était '8400'. [erreur 5013]
    • Un processus de travail '8400' servant le pool d'applications 'MSExchangeSyncAppPool' n'a pas pu arrêter un canal de l'écouteur pour le protocole 'http' dans le délai accordé. Le champ des données contient le numéro de l'erreur. [erreur 5138]
    • L'adaptateur de l'écouteur servant le protocole 'net.tcp' a été déconnecté de façon inattendue. [erreur 5175]

    Si l'un de vous dispose d'un début de commencement de piste pour résoudre ce problème, je suis preneur

    Cordialement

    jeudi 24 juillet 2014 14:00

Réponses

  • Après beaucoup de tatonnements et de recherches alambiquées, j'ai trouvé une solution:

    ajouter dans dans HKLM\system\currentcontrolset\services\tcpip\parameters\interfaces un DWORD dans chaque clé utilisé

    • nom: TcpAckFrequency
    • valeur: 1

    redémarrer l'ordinateur et les problèmes de latences s'envolent. à noter que je ne rencontre pas le souci sur windows 8 ou 8.1

    mercredi 21 janvier 2015 08:47

Toutes les réponses

  • Vous pouvez essayer de désactiver l’accélération graphique native d'outlook 2013 : http://support.microsoft.com/kb/2768648

    Outlook Optionq / Advanced / Display / Disable hardware graphics acceleration



    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    vendredi 25 juillet 2014 04:43
    Modérateur
  • 

    voici la configuration actuelle définie par GPO pour tous les offices 2013 de l'entreprise déployés dans notre VDI.

    Microsoft Office 2013/Divers
    Stratégie Paramètre Commentaire
    Désactiver les animations Office Activé

    Si vous activez ce paramètre, l'accélération graphique matérielle n'est pas utilisée.

    Si vous désactivez ce paramètre ou si vous ne le configurez pas, l'accélération graphique matérielle est utilisée." gpmc_settingname="Ne pas utiliser l’accélération graphique matérielle" gpmc_settingpath="Configuration utilisateur/Modèles d’administration/Microsoft Office 2013/Divers" gpmc_supported="Au minimum Windows Server 2008 R2 ou Windows 7" tabindex="0">Ne pas utiliser l’accélération graphique matérielle
    Activé
    Microsoft Outlook 2013/OptionsOutlook/Autre
    Stratégie Paramètre Commentaire
    Microsoft Outlook 2013/OptionsOutlook/Autre/Archivage automatique
    Stratégie Paramètre Commentaire
    Paramètres d’archivage automatique Activé
    Activer l’archivage automatique Activé
    Exécuter l’archivage automatique tous les <x> jours 14
    Demander confirmation avant d’exécuter l’archivage automatique Désactivé
    Pendant l’archivage automatique :
    Supprimer les éléments arrivés à terme (dossiers de messagerie seulement) Désactivé
    Archiver ou supprimer les anciens éléments Désactivé
    Afficher le dossier d’archivage dans la liste des dossiers Activé
    Nettoyer les éléments antérieurs à 3
    Mois
    Supprimer définitivement les anciens éléments Désactivé
    Microsoft Outlook 2013/OptionsOutlook/Courrier/Écrire des messages
    Stratégie Paramètre Commentaire
    Microsoft Outlook 2013/OptionsOutlook/Préférences/Options de recherche
    Stratégie Paramètre Commentaire
    « Dossier en cours » sur tous les dossiers

    j'ai vérifié sur les machines concernées, les paramètres sont convenablement appliqués.

    en regardant votre lien, j'ai aussi utilisé le office configuration analyser tool, et il n'y a rien a signaler hormis les restrictions de sécurité concernant les hyperliensµ. les packages disponibles sur ce lien (http://support.microsoft.com/kb/2670838/EN-US) sont déaj en place sur les machines, ne reglant pas le problème

    vendredi 25 juillet 2014 10:15
  • Après beaucoup de tatonnements et de recherches alambiquées, j'ai trouvé une solution:

    ajouter dans dans HKLM\system\currentcontrolset\services\tcpip\parameters\interfaces un DWORD dans chaque clé utilisé

    • nom: TcpAckFrequency
    • valeur: 1

    redémarrer l'ordinateur et les problèmes de latences s'envolent. à noter que je ne rencontre pas le souci sur windows 8 ou 8.1

    mercredi 21 janvier 2015 08:47