none
ajouter un admin sharepoint RRS feed

  • Question

  • Bonjour,

    j'ai ajouté un "farm administrator" dans sharepoint 2010 mais le nouveau compte ne peut pas créer de nouveaux sites webs.

    le boutton est grisé.

    j'ai donné les droits de db owner dans sql server sur toutes les bases sharepoint à ce compte mais ça ne suffit pas.

     

    merci pour votre aide.

     

    bonne année.

     

    samedi 31 décembre 2011 19:21

Réponses

Toutes les réponses

  • Salut Ilannt,

    Veuillez regarder ce le site de Microsoft: http://technet.microsoft.com/en-us/library/ee662513.aspx ( regardez la 3ième case .. ) DB_OWNER seul ne suffit pas..

    Paul Stork, MVP en sharePoint expliqe ici que l'utilisateur doit également être administrateur local pour pouvoir écrire dans IIS: http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/db308496-db3b-4e57-b8f4-f7df97d9b735/

    Reseting le IE serait également une possibilité, car sur ce blog, ca à résolu le même cas: http://jasperbeerens.blogspot.com/2011/11/farm-administrator-cant-add-new-web.html

    Egalement UAC doit etre désactivé: regardez ce lien: http://spdeveloper.net/2010/06/you-cant-create-web-applications-in-central-admin-even-if-youre-farm-admin/

     

    Donc en gros:

    • DB_OWNER, SECURADMIN, DB_CREATOR
    • Admin local
    • Reset
    • Désactiver UAC

    testez ces possibilité, et dites nous quoi encore ..

    Merci et Joyeaux fêtes .. Gokan


    Founder of SharePoint CookBook: http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    • Marqué comme réponse ilannt dimanche 1 janvier 2012 18:48
    samedi 31 décembre 2011 21:12
  • j'ai essayé tout ça mais sans succès.

     

    samedi 31 décembre 2011 22:35
  • Bon,

    On va procèder par éliminations, on va créer une web app et voyons voir si PowerShell va reclamer, Si oui, il nous guidera avec son message d'erreur: Utilise cet ligne de commande pour créer et poste nous l'erreur qui nous donne !! ( oublie pas de changer les noms, moi je te fourni juste une exemple .. )

    New-SPWebApplication -Name "SharePoint Front End Web Application" -Port 81 -URL "http://www.contoso.com" -ApplicationPool "SharePoint Sites Application Pool" -ApplicationPoolAccount "DOMAIN\SP-AP" -DatabaseName "SP2010_ContentDB_Frontend"

    Merci, Gokan


    Founder of SharePoint CookBook: http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    dimanche 1 janvier 2012 08:46
  • je me suis connecté avec le compte en question sur la machine via rdc:

    j'ai lancé le shell sharepoint puis j'ai lancé la commande suivante:

    New-SPWebApplication -Name "mynewapp3" -Port XXXXX -URL "https://monurl" -ApplicationPool "monpool" -ApplicationPoolAccount "le compte auquel je veux donner les droits de farm admin" -DatabaseName "mabase" -securesocketslayer

    j'ai eu une premiere erreur:

    New-SPWebApplication : You need to have Machine administrator priviliges to run  this cmdlet.

    puis j'ai lancé le shell sharepoint en tant qu'admin et la ca a marché. pas de message d'erreur.

    je suis toujours au meme point.

    merci

     

    dimanche 1 janvier 2012 10:16
  • Ilannt,

    Comme j'ai dis au paravant, et comme le MVP Paul Stork le dis aussi, tu dois etre administrator local aussi, si tu n'est pas administrateur local ou IIS7 tourne tu ne pourrai pas créer une nouvelle application web !

    Re-verifie, car l'erreur le dis "You need to have Machine administrator priviliges to run this cmdlet."

    L'erreur est claire et net !!

    Verifie si tu est dans le groupe administrateur local sur le serveur applicatief ( ou sharepoint 2010 tourne ) et sur les server SQL et WFE !

    Merci, Gokan


    Founder of SharePoint CookBook: http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    dimanche 1 janvier 2012 12:48
  • je suis bien admin local.

     

    sharepoint et sql tournent sur ce meme serveur.

     

    dimanche 1 janvier 2012 17:23
  • j'avais oublié de relancer le serveur après avoir desactivé UAC. du coup je ne sais pas quels sont les étapes nécessaires ou pas.

    je penserai à  redésactiver UAC lorsque j'ai besoin de créer de nouvelles web apps.

    merci encore

    dimanche 1 janvier 2012 18:47