none
Impossible de terminer la configuration du serveur de Licence RDP sur Server 2012 RRS feed

  • Question

  • Bonjour à tous,

    Je suis vraiment furax concernant le système bureau à distance sur Windows Server 2012.
    C'était tellement bien sur 2008 R2, je ne comprend vraiment pas comment Microsoft a pu nous développer une cochonnerie pareille sur la version 2012 après avoir fait si bien sur la 2008.

    Bref.

    Je suis coincé avec le gestionnaire de Licence qui me dit qu'aucun mode de licence n'a été sélectionné dans l'hôte de session bureau à distance. (avec les 2 messages d'avertissements jaunes)

    Or, Microsoft a trouvé plus intelligent de supprimer cet outil pour le remplacer par une usine à gaz incompréhensible dont je n'arrive pas à déchiffrer le fonctionnement.

    Dans le gestionnaire de licence, j'ai ajouté la licence Open, et j'ai les 5 utilisateurs valides.
    Dans la gestion de serveur (qui visiblement remplace l'hôte) j'ai bien configuré le serveur avec un mode "Par utilisateur" et le SERVEUR.local est bien défini comme hôte. J'ai tenté par tout les moyens de faire disparaitre les 2 messages d'avertissements jaunes. Impossible !

    Sur 2008, il suffisait de cocher la méthode de licence dans l'hôte. Mais là je sèche. Cela fait 5h que je cherche.

    Si vous avez une solution c'est avec grand plaisir !

    Meilleures salutations


    Plus tu pédales moins vite moins t'avance plus vite

    mardi 1 avril 2014 21:35

Réponses

  • Bonjour,

    Problème résolu.

    Il fallait ajouter ces paramètres dans les GPO:

    Policy settings are located in Computer Configuration - Windows Settings - Remote Desktop Services - Remote Desktop Session Host - Licensing

    Donc il fallait préciser:
    - Le serveur de licence
    - Le mode de licence

    Par contre je ne comprend pas pour quelle raison il faut aller configurer ce paramètre ici ?
    Cela me semblerait logique que cet élément soit configurable ailleurs.

    Salutations


    Plus tu pédales moins vite moins t'avance plus vite

    mercredi 2 avril 2014 08:47

Toutes les réponses

  • Bonjour,

    Problème résolu.

    Il fallait ajouter ces paramètres dans les GPO:

    Policy settings are located in Computer Configuration - Windows Settings - Remote Desktop Services - Remote Desktop Session Host - Licensing

    Donc il fallait préciser:
    - Le serveur de licence
    - Le mode de licence

    Par contre je ne comprend pas pour quelle raison il faut aller configurer ce paramètre ici ?
    Cela me semblerait logique que cet élément soit configurable ailleurs.

    Salutations


    Plus tu pédales moins vite moins t'avance plus vite

    mercredi 2 avril 2014 08:47
  • Bonjour,

    La config du RD licensing server se fait entre autres méthodes, par GPO.

    Vous pouvez configurer manuellement votre RD Licensing Server via PowerShell :

    $obj = gwmi -namespace "Root/CIMV2/TerminalServices" Win32_TerminalServiceSetting

    $obj.SetSpecifiedLicenseServerList("Nom_Serveur_2_Licence.domain.local")

    Vérifiez la liaison du serveur RD Licensing avec les services de rôles RD SH & RD VH:

    $obj = gwmi -namespace "Root/CIMV2/TerminalServices" Win32_TerminalServiceSetting

    $obj.GetSpecifiedLicenseServerList()

    Pour changer de mode de licence:

    $obj = gwmi -namespace "Root/CIMV2/TerminalServices" Win32_TerminalServiceSetting

    $obj.ChangeMode(value) - Value can be 2 - per Device, 4 - Per user

    Pour confirmer /valider le mode de licence :

    $obj = gwmi -namespace "Root/CIMV2/TerminalServices" Win32_TerminalServiceSetting

    $obj. LicensingType

    $obj.LicensingName

    A+

    HK.


    Hicham KADIRI | IT Consultant /Director. MCP - MCSA - MCTS - MCSE - MCITP - MCT

    jeudi 10 avril 2014 08:06