locked
403 - Interdit : accès refusé. RRS feed

  • Question

  • Ca fait un moment que je suis bloqué sur une situation de droit d'accès dont je ne comprend plus rien.
    J'ai un site ASP.NET dont j'ai donnée tout les droits possible pour y accéder  mais j'ai toujours le message d'erreur suivant:

    403 - Interdit : accès refusé.

    Vous n'avez pas l'autorisation d'afficher ce répertoire ou cette page à l'aide des informations d'identification que vous avez fournies


    Voici tous les droits dont  j'ai octroyé à ce fichier :
                                                                               - IUSR_nomdelordinateur
                                                                                - SYSTEM
                                                                                - SERVICE LOCAL
                                                                                - SERVICE RÉSEAU
                                                                                - IIS_IUSRS
                                                                                - UTILISATEURS
                                                                                - ASP.NET Machine Account
                                                                                - Compte Invité Internet
    Est ce que j'ai manqué  quelque chose??
    Merci de votre aide

    cebon
    jeudi 21 janvier 2010 16:49

Réponses

  • Bonsoir,

    (en anglais dans le texte, je n'ai pas d'IIS7 en français sous la main ;)): Sélectionner le site ou l'éxécution de script doit être activé ensuite double-clicker sur l'icône "Handlers" ensuite, sur la droite, clicker sur "Edit Feature Permissions". cocher la case "Script".

    --- Marc Lognoul [MCSE, MCTS, MVP] Heureux celui qui a pu pénétrer les causes secrètes des choses Happy is the one who could enter the secret causes of things Blog EN: http://www.marc-antho-etc.net/blog/ Blog FR: http://www.marc-antho-etc.net/blogfr/
    lundi 25 janvier 2010 18:12
  • Vous pouvez aussi etudier de pret le process w3wp avec l'outil process monitor :
    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

    Celui ci comme anciennement filemon mettra en evidence les problemes de droits et bien plus encore, en ce qui me concerne, je commence toujours par la...


    Maxence Derieppe -- Consultant Overlap Groupe -- MCITP Windows Server - Exchange -- http://derieppe-maxence.blogspot.com
    mercredi 27 janvier 2010 17:07

Toutes les réponses

  • On ne voit pas la liste des droits mais la liste utilisateur... Peux tu nous faire une copie d'écran.
    Les utilisateurs qui accédent au site sont identifiés ou anonyme ?

    cdlt,
    Ludo
    http://ludovikdopierala.blogspot.com/
    vendredi 22 janvier 2010 13:07
  • En fait, j'ai confondue utilisateurs à droits! C'est la liste des utilisateurs plutôt.
    L'accès est anonyme.

    cebon
    vendredi 22 janvier 2010 14:27
  • Bonjour,

    Dans les propriétés du site IIS, veillez à ce que l'option d'éxécution des scripts soit cochée.
    Si cela ne résoud pas le problème, regardez dans les logs IIS le numéro correspondant au sous-status HTTP et référez vous à ce tableau pour les causes probables: http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/21079107-1740-470e-a933-23a45494b8ba.mspx?mfr=true

    --- Marc Lognoul [MCSE, MCTS, MVP] Heureux celui qui a pu pénétrer les causes secrètes des choses Happy is the one who could enter the secret causes of things Blog EN: http://www.marc-antho-etc.net/blog/ Blog FR: http://www.marc-antho-etc.net/blogfr/
    • Proposé comme réponse Marc Lognoul mardi 26 janvier 2010 11:16
    lundi 25 janvier 2010 09:37
  • Merci encore pour votre assistance,

    Je suis sur IIS 7.0 et je ne trouve pas l'option  "exécution des scripts".
    merci  de  m'indiquer où est ce que je peu trouver cette option.




    cebon
    lundi 25 janvier 2010 17:54
  • Bonsoir,

    (en anglais dans le texte, je n'ai pas d'IIS7 en français sous la main ;)): Sélectionner le site ou l'éxécution de script doit être activé ensuite double-clicker sur l'icône "Handlers" ensuite, sur la droite, clicker sur "Edit Feature Permissions". cocher la case "Script".

    --- Marc Lognoul [MCSE, MCTS, MVP] Heureux celui qui a pu pénétrer les causes secrètes des choses Happy is the one who could enter the secret causes of things Blog EN: http://www.marc-antho-etc.net/blog/ Blog FR: http://www.marc-antho-etc.net/blogfr/
    lundi 25 janvier 2010 18:12
  • Vous pouvez aussi etudier de pret le process w3wp avec l'outil process monitor :
    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

    Celui ci comme anciennement filemon mettra en evidence les problemes de droits et bien plus encore, en ce qui me concerne, je commence toujours par la...


    Maxence Derieppe -- Consultant Overlap Groupe -- MCITP Windows Server - Exchange -- http://derieppe-maxence.blogspot.com
    mercredi 27 janvier 2010 17:07
  • Bonjour,

    en effet, je suis d'accord avec Maxence, utilises-tu un pool d'application et quel compte windows (system ou du domaine) exécute le process w3wp.

    A+
    Joël
    mercredi 27 janvier 2010 17:10