locked
GPO d'écran de veille Windows 7 x64 RRS feed

  • Question

  • Bonjour,

    J'effectue actuellement des tests GPO afin de mettre en place un écran de veille spécifique sur tous les postes clients d'un domaine 2003.

    Cette GPO a pour rôle de:

    • Mettre un écran de veille identique au bout de 10 secondes (pour les tests)à tous les utilisateurs
    • Protéger la sortie de l'écran de veille par un mot de passe

    J'ai donc créé la GPO et elle fonctionne correctement sur mes postes clients Windows XP 32bits et Windows 7 32bits.

    Mais elle ne fonctionne pas correctement sur les ordinateurs Windows 7 x64. Je n'ai pas pu faire le test sur un poste XP x64. Par curiosité, j'ai essayé sur un poste 8 x64, le problème est le même.

    Le souci que je rencontre est qu'au bout de 10 secondes, l'écran de veille ne se met pas en route mais la session se verrouille bien.

    Mon écran de veille est pourtant bien configurer dans les options d'écran de veille des postes concernés.

    De plus, une fois la session verrouillée, toutes les 10 secondes l'écran scintille ; comme si la GPO se rappliquait.

    Pour info:

    • Contrôleur de domaine sous 2003
    • Création des GPO avec les outils d'administration intallés sur un poste Windows 7 32bits

    Je serais ravi que vous connaissiez une solution à mon problème.

    Cordialement,

    Irfan DEMIRKOPRU

    jeudi 7 mars 2013 10:57

Réponses

  • Bonjour,

    Suggestions habituelles, verifiez que les paramètres suivant soient appliqués:

    - Enable screensaver = Activé.

    - Force specific screen saver = Scrennsaver Operator.scr.

    - Password protect the screensaver = Désactivé.

    - Screen saver timeout = Activé ( paramètrez le temps 10', dans votre cas).

    - Qu'une autre politique plus restrictive ne soit pas appliquée, donc un "gpresult" ou un "rsop" vous donnera des indications.

    Et enfin le plus important:

    Dans un sytème 64 bits (%SystemRoot%SysWOW64) l'exécution d'une application 32 bits (%SystemRoot%System32) est redirigée vers SYSWOW64. Essayez de copier votre dossier "Economiseur d'écran" dans SYSWOW64 ou bien dans Windows.

    J'espère avoir été assez clair, je fini par m'y perdre dans toutes ces explications de chemin mal redirigé.

    Cordialement,

    Bricoleur.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT




    dimanche 10 mars 2013 01:03
  • Bonjour à tous,


    Merci, Bricoleur grâce à toi mon souci est résolu.

    Le problème venait du chemin que je spécifiais pour l'emplacement de l'écran de veille.

    J'avais indiqué C:\Windows\system32\"ecrandeveille".scr. Ce chemin fonctionnait sous les 32bits mais pas les 64bits même si le .scr s'y trouvait bien.

    La solution était qu'il ne fallait pas spécifier l'emplacement en entier mais ne mettre QUE le nom du .scr dans "Force specific screen saver". Le système se charge d'aller le récupérer dans l'emplacement par défaut.

    J'ai donc laissé les autres paramètres de la GPO comme avant mais dans "Force specific screen saver", j'ai mis "ecrandeveille.scr" au lieu de "C:\Windows\system32\"ecrandeveille".scr".

    Tests effectués sur:

    • XP 32bits OK
    • 7 32bits OK
    • 7 64bits OK
    • 8 64bits OK

    Merci à tous pour votre aide.

    Cordialement,

    Irfan


    lundi 18 mars 2013 08:26

Toutes les réponses

  • Bonjour,

    En regardant un peu, tu ne semble pas être le seul à avoir ce problème.
    J'ai l'impression que la gpo doit appeler le screen saver sous un chemin qui ne doit pas exister sous la version 64 bits.
    Je dirai peut être essayer de créer une GPO à partir des outils d'administration d'un poste sous 64 bits voir si ça change qqc.

    Sinon j'ai vu un solution ou la personne donnais en dur le chemin de fichier scr de l'ecran de veille.
    Style sur chaque PC tu crée un c:\screensaver\ tu copies le fichier d'écran de veille dedans et tu met un gpo qui pointe sur ce fichier.

    En espérant que ça puisse t'aider.



    Cordialement Denis ECHE, Ingénieur Système-Réseaux. Mon Blog Si ma réponse vous a été utile, ou a permis la résolution de votre problème; merci de Voter ou de la marquer comme Utile.

    jeudi 7 mars 2013 11:25
  • Bonjour,

    Merci pour ta réponse.

    J'ai déjà indiqué dans ma GPO le chemin en dur avec C:\windows\system32\"ecrandeveille".scr. Le chemin C:\windows\system32\ étant l'emplacement par défaut des écrans de veille Windows. A moins que ce chemin soit différent dans une version x64.

    Je vais tester avec les outils d'administrateur sur un poste x64, je reviendrais vers vous.

    Je continue donc mes tests ;)

    jeudi 7 mars 2013 12:14
  • Je reviens suite à mes tests.

    J'ai installé les outils d'administration sur un ordinateur en Windows 7 x64, j'ai désactivé mon ancienne GPO et j'ai refais une GPO avec les modèles d'administration de mon Windows 7 x64.

    J'ai refais mes tests:

    • PC 32 bits => OK
    • PC 64 bits => Mêmes soucis

    D'autres suggestions ?

    jeudi 7 mars 2013 14:01
  • Bonjour,

    Suggestions habituelles, verifiez que les paramètres suivant soient appliqués:

    - Enable screensaver = Activé.

    - Force specific screen saver = Scrennsaver Operator.scr.

    - Password protect the screensaver = Désactivé.

    - Screen saver timeout = Activé ( paramètrez le temps 10', dans votre cas).

    - Qu'une autre politique plus restrictive ne soit pas appliquée, donc un "gpresult" ou un "rsop" vous donnera des indications.

    Et enfin le plus important:

    Dans un sytème 64 bits (%SystemRoot%SysWOW64) l'exécution d'une application 32 bits (%SystemRoot%System32) est redirigée vers SYSWOW64. Essayez de copier votre dossier "Economiseur d'écran" dans SYSWOW64 ou bien dans Windows.

    J'espère avoir été assez clair, je fini par m'y perdre dans toutes ces explications de chemin mal redirigé.

    Cordialement,

    Bricoleur.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT




    dimanche 10 mars 2013 01:03
  • Bonjour à tous,


    Merci, Bricoleur grâce à toi mon souci est résolu.

    Le problème venait du chemin que je spécifiais pour l'emplacement de l'écran de veille.

    J'avais indiqué C:\Windows\system32\"ecrandeveille".scr. Ce chemin fonctionnait sous les 32bits mais pas les 64bits même si le .scr s'y trouvait bien.

    La solution était qu'il ne fallait pas spécifier l'emplacement en entier mais ne mettre QUE le nom du .scr dans "Force specific screen saver". Le système se charge d'aller le récupérer dans l'emplacement par défaut.

    J'ai donc laissé les autres paramètres de la GPO comme avant mais dans "Force specific screen saver", j'ai mis "ecrandeveille.scr" au lieu de "C:\Windows\system32\"ecrandeveille".scr".

    Tests effectués sur:

    • XP 32bits OK
    • 7 32bits OK
    • 7 64bits OK
    • 8 64bits OK

    Merci à tous pour votre aide.

    Cordialement,

    Irfan


    lundi 18 mars 2013 08:26