locked
Serveur d'impression 2008 R2 - Problème pilote HP PCL6 et Windows 7 64 bit RRS feed

  • Discussion générale

  • Bonjour, 

    Je suis actuellement en stage pour ma seconde année de BTS et j'aimerais que quelqu'un m'aide à comprendre un problème que je rencontre avec mon serveur d'impression et des machines windows 7 64 bit. 


    Le contexte : 

    J'ai un serveur d'impression Windows serveur 2008 R2 où sont installées toutes les imprimantes de l'entreprise. Les imprimantes étant à 90 % des HP, j'utilise donc le driver universel de HP pour toutes les imprimantes ("HP Universal Print Driver for Windows PCL6") disponible ici : 

    http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=18972&prodSeriesId=3442750&prodNameId=3442754&swEnvOID=4024&swLang=8&mode=2&taskId=135&swItem=ds-99374-2 

    Toutes les imprimantes ont été déployées et fonctionnent très bien pour tous les utilisateurs hormis quelques uns travaillant sous Windows 7 64 bit. 


    Voici le problème : 

    Quand il veulent imprimer un document, une vingtaine de feuilles blanches où avec quelques caractères bizarres sont imprimées à la place du document. J'ai donc analysé le problème et je me suis aperçu que les options d'impressions n'étaient pas accessibles comme sur les autres postes. 
    Au lieu d'avoir 6 onglets avec toutes les propriétés disponibles de cette imprimante, il y a juste 2 onglets avec les propriétés "paysage/portrait" et "noir et blanc/couleur". En faite le pilote ouvert quand on fait option d'impression est un pilote basique fourni par défaut par windows. Le pilote HP est pourtant toujours présent sur la machine mais il ne se lance plus.

    J'ai dû, pour arranger le problème, installer localement le pilote via l'exécutable fournit et pas juste indiquer l'emplacement du fichier .inf, puis refaire l'installation d'une des imprimantes HP du serveur. Après cela, toutes les imprimantes fonctionnaient correctement. 

    Questions : 

    Quel est la cause de ce problème? 

    PS: Malgré avoir trouvé une solution, j'aimerais mieux comprendre l'origine du problème car de plus en plus de machines vont devenir des Windows 7 64 bit. Merci d'avance !

    Le problème est peut être dû à l'un des logiciels métiers qu'ils utilisent...

    • Type modifié Florin Ciuca mercredi 22 février 2012 12:03
    mercredi 15 février 2012 11:47

Toutes les réponses

  • Bonjour,

    Le pilote utilisé est il x86 ou x64 ?

    A+


    Best Regards Don't forget to mark it as answer if it helps

    mercredi 15 février 2012 12:48
    Auteur de réponse
  • Le pilote est un pilote universel HP. Il s'installe sur le serveur d'impression donc il existe en version x86 et x64. En revanche, quand on ajoute le fichier .inf de ce pilote sur le serveur, celui installe en faite deux pilotes, compatibles à la fois avec un x86 ou un x64. D'où le nom d'universel, car c'est le même pour tous les OS Windows qu'ils soient x86 ou x64. (ça vient aussi du fait que se soit le même pour toutes les imprimantes HP !!)

    Donc toutes les imprimantes ont le même pilote à la fois compatible x86 et x64 mais les Windows 7 64bit commencent à tous produire le même problème explicité précédemment.

    Merci de ton intéret à mon problème !


    • Modifié mbailly17 mercredi 15 février 2012 13:15
    mercredi 15 février 2012 13:10
  • Une précision !

    Ce n'est pas un problème d'incompatibilité du pilote avec Windows 7 64 bit puisque les utilisateurs possèdant ces machines réussissaient à imprimer correctement jusqu'au moment où le pilote arrète de fonctionner.

    De plus, j'avais fait, avant de déployer les imprimantes, des tests sur une machine virtuelle Windows 7 64 bit et tout fonctionnait correctement.

    En revanche la machine virtuelle ne possèder pas les logiciels métiers utilisaient sur les postes physiques des utilisateurs. (ProIng, SolidWorks,...).

    J'espère que ces précisions seront utiles pour que vous puissiez m'aider !


    • Modifié mbailly17 jeudi 16 février 2012 10:05
    mercredi 15 février 2012 13:45
  • Bonjour,

    Je me permet de UP , nous rencontrons le même problèmes sur notre park.

    Les serveurs en 2K8 R2, et PCs en XP x32 et Seven en X64,

    Les Sevens impriment des caractères spéciaux, nous changeons de driver + réinstall de l'imprimante = OK mias le faire sur plusieurs postes a la hate n'est viable a long terme.

    Pouvez-vous nous aider??

    Merci

    lundi 29 octobre 2012 09:43