none
Problème de recherche avec des mots comportant des caractères avec accent RRS feed

  • Question

  • SharePoint 2010. Recherche d'un mot dont l'orthographe comporte un caractère accentué : le résultat est partiel.

    Exemple : Test avec le mot "bâtiment". 8 documents sont créés, chacun comportant une orthographe différente de "bâtiment" : batiment, bâtiment, BATIMENT, BÂTIMENT, batiments, bâtiments, BATIMENTS, BÂTIMENTS -> une recherche sur ce mot doit retourner 8 résultats

    1- si le mot est saisi  avec le caractère minuscule non accentué, les résultats retournés ne comportent que les mots exacts (mais avec et sans accent).

    -> saisie "batiment" (ou "BaTIMENT", Batiment, ...) retourne 4 résultats correspondant aux mots au singulier : batiment, bâtiment, BATIMENT, BÂTIMENT, mais ne retourne pas les mots au pluriel : batiments, bâtiments, BATIMENTS, BÂTIMENTS

    -> saisie "batiments" (ou Batiments, ...) retourne 4 résultats correspondant aux mots au pluriel : batiments, bâtiments, BATIMENTS, BÂTIMENTS, mais ne retourne pas les mots au singulier : batiment, bâtiment, BATIMENT, BÂTIMENT

    2-> par contre, si le mot est correctement orthographié (en minuscule ou majuscule) ou que la lettre en question est en majuscule sans accent, tous les résultats attendus sont retournés.
    -> saisie "Bâtiment" (ou "bAtiment", "BATIMENT", ...) retourne les 8 résultats attendus : batiment, bâtiment, BATIMENT, BÂTIMENT, batiments, bâtiments, BATIMENTS, BÂTIMENTS

    Comment corriger ce comportement ?

    mercredi 15 mai 2013 09:46

Réponses

  • L'explication probable est la perte de l'option "Activer la recherche basée sur le radical des termes" quand l'orthographe est erronée. En effet c'est cette option qui effectue la recherche avec les variantes de terminaison. Elle se trouve dans les paramètres de la webpart "Résultat principaux de la recherche" (Options de requête de résultat). Alors qu'elle est activée dans la webpart, le comportement constaté correspond au comportement en cas de désactivation.

    En l'état actuel, la solution pour régler le problème est de modifier la webpart "Résultat principaux de la recherche" pour changer la Langue de requête : remplacer la valeur par défaut "Paramètres régionaux du navigateur" (qui est le français dans mon cas) par "Anglais".

    • Marqué comme réponse Kael44 jeudi 30 mai 2013 12:58
    jeudi 30 mai 2013 12:57