locked
IIS5 et IE8 : lenteur en utilisant le nom de domaine RRS feed

  • Question

  • Bonjour,

    J'ai un Windows 2000 Server avec IIS 5 qui fait tourner une appli web et des clients en XP avec IE7 et d'autres en Windows 7 avec IE8. Lorsqu'à partir d'un client XP j'accède à l'appli web, tout fonctionne correctement. Lorsque j'y accède à partir d'un poste sous Win7 et en utilisant le nom du serveur dans l'url, le site est très long à répondre, IE se fige et met environ une minute à répondre après chaque clique/action. Si j'utilise l'ip du serveur dans l'url, cela fonctionne correctement.

    J'ai comparé la configuration DNS entre les 2 types de clients et je n'ai rien trouvé d'anormal. J'ai essayé avec l'UAC de désactivé ainsi que l'IPv6 mais le problème persiste.


    Si on regarde un extrait de Netmonitor sur le poste sous Win7 en utilisant le nom du serveur on voit des "pauses" tandis qu'en utilisant l'ip aucun arrêt n'est à signaler.

    J'ai ensuite vérifier les logs IIS5 mais rien de concluant.

    Avez-vous une idée d'où cela peu venir ?

    Merci d'avance.


     


    mardi 6 mars 2012 12:59

Réponses

  • La résolution des noms est correcte.

    J'ai résolu le problème en passant le mode d'authentification sur IIS de l'authentification Windows à l'authentification de base. Je me suis aperçu en plus qu'avec l'authentification Windows il suffisait de fermer la fenêtre demandant le login et mot de passe pour accéder tout de même à l'application.

    Dernier point que je ne comprends pas c'est pourquoi la méthode d'authentification Windows met beaucoup de temps à répondre sur un IE8 (sous Win7) en utilisant le nom du serveur comme adresse alors que par l'IP ou par IE7 (sous Xp) ça marche correctement.

    • Marqué comme réponse PimPamPoum_59 mercredi 7 mars 2012 10:18
    mercredi 7 mars 2012 10:16

Toutes les réponses