none
Accès RDP impossible sur le DC Windows 2012 R2 RRS feed

  • Discussion générale

  • Bonjour,

    L'erreur s'apparait directement dès qu'on clique "Entrée":

    Remote Desktop Disconnected
    ----------------------------------------------
    This computer can't connect to the remote computer.

    Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator.

    -------------------------------------------------------------------------------------------------------

     Vérification quelle application utilise le port 3389 : netstat -a -o

    ==> Le service Terminal service est utilise bien le port 3389 / le port est bien ouvert

     - Vérification de Certificat RDP: valide jusqu'à 2019

    - Le Firewall est désactivé

    Le RDP a fonctionné correctement la dernière fois au début Août

    Et, il ne s'agit d'un problème de certificat vu que il y a un autre serveur "xxxxxx" avec le même certificat et le RDP est opérationnel.

    Nous avons réinstaller/redémarrer le serveur (avant/après l' "uninstall/install"), et toujours pareil (même erreur).

    Ai vérifié les événements Windows, la dernière connexion correcte était à "22/08/2016 16:09:11" par l'IP x.X.X.X (voir ci-dessous)

    ==========

    Log Name: Microsoft-Windows-RemoteDesktopServices-RdpCoreTS/Operational
    Source: Microsoft-Windows-RemoteDesktopServices-RdpCoreTS
    Date: 22/08/2016 16:09:11
    Event ID: 131
    Task Category: RemoteFX module
    Level: Information
    Keywords: 
    User: NETWORK SERVICE
    Computer: xxxxxxxxxxxxx
    Description:
    The server accepted a new TCP connection from client x.X.X.X.X.

    ==============

    Et y a un "warning" RDP_TCP qui a été commencé  le même jour et à la même heure !!! (voir ci-dessous)

    ========================

    Log Name: Microsoft-Windows-RemoteDesktopServices-RdpCoreTS/Operational
    Source: Microsoft-Windows-RemoteDesktopServices-RdpCoreTS
    Date: 22/08/2016 16:09:11
    Event ID: 226
    Task Category: RemoteFX module
    Level: Warning
    Keywords: 
    User: NETWORK SERVICE
    Computer: xxxxxxxxxxxxx
    Description:
    RDP_TCP: An error was encountered when transitioning from StatePreparingX224CC in response to Event_ERROR_SendingX224CC (error code 0x0).

    ================

    Pour enlever l'hypothèse de l'antivirus, je ai stoppé (Firewall SEP), mais toujours la même erreur.

    J'ai vérifié aussi l'état de système de fichier, mais aucune erreur détecté.

    Le souci n'est pas lié au mise à jour Windows puisque la dernière installé est date de mois de MAI.

     

    ============

    sachant que le deuxième DC fonctionne sans soucis. (même OU, même plage)

    Merci


    vendredi 16 septembre 2016 06:51

Toutes les réponses

  • Bonjour,

    Pouvez vous détailler d'avantage votre problème, personnellement je n'ai compris votre besoin!!


    L’information n’a de valeur que si elle est partagée!! AK |Mon Blog|

    vendredi 16 septembre 2016 07:45
  • Nous avons un serveur en windows 2012 R2 (DC), qu'on n'arrive plus à accéder via RDP.

    Nous recevrons le message ci-dessous dès qu'on essaie de se connecter dessus vai rdp:

    ----------------------------------------------
    This computer can't connect to the remote computer.

    Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator.

    --------------------------------------

    En vérifiant, le port 3389 est bien ouvert et en écoute ainsi qu'il est bien attribué au service "termservice"

    Historiquement, nous avons eu l'accès sans problème sur ce serveur et d'un coup nous n'arrivons plus à se connecter.

    Pas de firewall sur ce serveur.

    Y a-t-il des pistes / des solutions envisagés ?

    Merci d'avance 

    vendredi 16 septembre 2016 07:54
  • AKA:

    Avez vous fait un telnet à partir de votre poste vers le DC sur le port 3389?

    Assurez vous que les connexions RDP ne sont pas désactivés sur le DC?


    L’information n’a de valeur que si elle est partagée!! AK |Mon Blog|

    vendredi 16 septembre 2016 09:07
  • J'ai testé via Telnet le port 3389 => le port est bien ouvert.

    Le "Remote Desktop" est en "Enabled"


    vendredi 16 septembre 2016 09:10
  • Pour information, la fonctionnalité RDS (Remote Desktop Services) est non installé, il s'agit en fait de service "Terminal Service" qu'on utilise.

    vendredi 16 septembre 2016 09:12
  • Pouvez vous vérifier les paramètres ci-dessous?

    Nous envoyer les evnts logs du dc.


    L’information n’a de valeur que si elle est partagée!! AK |Mon Blog|

    vendredi 16 septembre 2016 09:18
  • Cette imprime écran concerne le service RDS et non terminal service.

    Le rôle RDS est non installé, il s'agit de RDP par défaut (normal).

    Vous pouvez récuperer les EVENTs LOGS ici: 

    https://drive.google.com/file/d/0B7eA-RY55nANa3FoOEx2cTBaVHM/view?usp=sharing

    vendredi 16 septembre 2016 09:36
  • C:\Users\secadm>qwinsta
     SESSIONNAME       USERNAME                 ID  STATE   TYPE        DEVICE
     services                                    0  Disc
    >console           secadm                    1  Active
     rdp-tcp                                 65536  Listen
    vendredi 16 septembre 2016 09:50
  • Ok, donc vous avez que les deux session d'administration par défaut si le rôle Terminal Services n'est pas installé.

    Donc vous pouvez vérifier dans ce cas les paramètres de cette console:


    L’information n’a de valeur que si elle est partagée!! AK |Mon Blog|

    vendredi 16 septembre 2016 10:09
  • https://drive.google.com/open?id=0B7eA-RY55nANa1lwdVg3dmw4OUE
    vendredi 16 septembre 2016 10:14
  • Je suis au boulot je n'ai pas accès à google drive.

    Essayez de désactiver et réactiver "RDP-Tcp ".

    Voir aussi ce lien.


    L’information n’a de valeur que si elle est partagée!! AK |Mon Blog|


    • Modifié Ahmed KASMI vendredi 16 septembre 2016 10:27
    vendredi 16 septembre 2016 10:22
  • J'ai désactivé / Réactiver le RDP et toujours même erreur.

    J'ai fait la procédure indiquée dans le lien mais toujours la même erreur.

    vendredi 16 septembre 2016 11:29
  • Avez-vous redémarré votre serveur?

    L’information n’a de valeur que si elle est partagée!! AK |Mon Blog|

    vendredi 16 septembre 2016 11:50
  • Oui, je l'ai redémarré 
    vendredi 16 septembre 2016 11:52
  • Essayer ceci:


    L’information n’a de valeur que si elle est partagée!! AK |Mon Blog|

    vendredi 16 septembre 2016 11:56
  • Ou je peux trouver cette interface ? sachant que je n'ai pas le rôle terminal services (RDS) donc à priori il me semble qu'il s'agit d'une interface dédié à ce rôle ? non ?
    vendredi 16 septembre 2016 12:50

  • L’information n’a de valeur que si elle est partagée!! AK |Mon Blog|

    vendredi 16 septembre 2016 13:30
  • je n'ai pas le rôle terminal services (RDS) installé donc à priori il me semble qu'il s'agit d'une interface dédié à ce rôle 

    Je le trouve pas !!

    vendredi 16 septembre 2016 13:34
  • Bonjour,

    Oui donc désolé, il n'y a pas mal de changements entre 2008 et 2012!!

    Pouvez vous vérifier ceci sous le DC:

    gpedit.msc:


    L’information n’a de valeur que si elle est partagée!! AK |Mon Blog|

    samedi 17 septembre 2016 12:09
  • J'ai vérifié le paramètre de sécurité et il rassemble à votre imprime écran.

    avec "Add User or Group" grisé

    mardi 20 septembre 2016 07:00
  • Pour info: Lorsque j'essaie de me connecter en RDP sur le serveur et je reçois l'erreur, voici ce je trouve comme événement sur le serveur en question log "RemoteDesktopServices-RdpCoreTS"

    1- The server accepted a new TCP connection from client x.x.x.x:61609.

    2- Connection RDP-Tcp#2 created 

    3- PerfCounter session started with instance ID 2

    4- RDP_TCP: An error was encountered when transitioning from StatePreparingX224CC in response to Event_ERROR_SendingX224CC (error code 0x0).

    5- The server has terminated main RDP connection with the client.

    6- The disconnect reason is 0

    Est-ce que ceci vous dites quelques choses ??

     

    mardi 20 septembre 2016 10:12
  •  Essayer cette solution:

    1) Se déplacer dans : C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys\
    2) Sauvegarder les différents fichiers dans un répertoire à part - il  faut absolument sauvegarder ces fichiers
    3)Supprimer le contenu de ce répertoire  C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys\*
    4) Rebooter  le serveur et ressayer de vous connecter en RDP


    L’information n’a de valeur que si elle est partagée!! AK |Mon Blog|

    mardi 20 septembre 2016 10:35
  • :(

    Je l'ai essayé et ça n'a pas marché.

    mardi 20 septembre 2016 10:43
  • Je l'ai re-essayé toute à l'heure  et elle m'a donné le même résultat:

    "This computer can't connect to the remote computer.

    Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator."

    mardi 20 septembre 2016 12:38
  • Toujours pas de réponse ? Pas d'autres astuces ?
    lundi 26 septembre 2016 09:28
  • Pour moi la solution était de remastériser le contrôleur de domaine/

    jeudi 26 mars 2020 13:57