none
Problème sur un serveur DNS après un changement de connexion DSL. RRS feed

  • Question

  • Bonjour,

    Les faits : nous avons changé de connexion DSL (même routeur mais port WAN différent, les modem en bridge pour les 2 connexions).

    Après des tests de la bande passante avec nperf, les débits sont ok. par contre j'ai noté qu'une fois nperf n'arrivait pas à accéder au serveur de test.

    Puis petit à petit on m'a signalé de nombreuses erreurs lors de tentative d'accès à différents sites internet, ou d'envois de requêtes, c'était la fin de matinée. Après le retour de la pause déjeuner, plus d'internet, les pc clients ont tous des erreurs DNS_PROBE. Le serveur AD (et donc DNS) était déconnecté d'internet car après un diagnostique Windows "il y a peut-être un problème de serveur DNS". 

    L'investigation :

    Côté gestionnaire DNS, rien d'anormal (de ce que je vois mais je ne maîtrise pas ce monde ! En tout cas aucune erreurs dans les journaux). Les redirecteurs pointent sur des domaines Orange et google.

    Un redémarrage du serveur AD (une VM) n'a pas résolu le problème.

    Avec le support du serveur, on a donc remis la connexion adsl d'origine, le technicien "a laissé Windows récupérer les réglages réseaux" (je ne voyais rien à ce moment là) et m'a dit que Windows avait récupéré l'adresse Apipa. Il pensait qu'il yavait un second serveur DNS dans le réseau. Il a alors modifié manuellement les réglages réseaux de la VM en pointant le serveur DNS vers un serveur extérieur, un simple redémarrage n'a pas résolu le problème apparemment, il a fallu redémarrer le serveur physique pour retrouver une connexion.

    Quelle peut être l'origine du problème ? (il va falloir que je remette la nouvelle connexion quand même :)

    -> on m'a fait part du cache arp (mais alors celui du serveur physique ou de la VM ou des 2 ?)

    -> la présence d'un 2nd serveur DNS dans le réseau qui est réelle après recherche : c'est l'ancien serveur AD (dont les services Ad avaient été désactivés mais pas le serveur DNS) et que l'on retrouve en entrée dans DomainDNSzones (et foreign..) mais avec une ancienne date dans la colonne horodateur. Note  : ce serveur est réglé en dhcp.

    Il faudrait que je désactive le service DNS de ce vieux serveur ? Si oui quelle précautions à prendre ?

    Merci de vos lumières !

    vendredi 18 janvier 2019 06:27

Réponses

  • Il faut retirer l'ancien serveur partout où apparaissent son nom ou son adresse IP.

    S'il est bien configuré, il se réenregistrera là où ce sera nécessaire.

    A+


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(83 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    vendredi 18 janvier 2019 08:50

Toutes les réponses

  • Bonjour, est ce que votre serveur DHCP pointe vers le nouveau serveur DNS?

    Pouvez-vous vérifier le post ci-dessous qui remonte le même genre de problèmes.

    https://social.technet.microsoft.com/Forums/fr-FR/90d17f21-cd03-49a6-9342-864ca6fef38e/pb-daccs-certains-sites?forum=windowsserver16fr

    Cordialement.

    vendredi 18 janvier 2019 07:11
  • Bonjour,

    le cache ARP est important à vider lorsqu'une même adresse IP est réutilisée sur un nouvel appareil qui a donc une adresse matérielle(Mac) différente.

    => C'est souvent le routeur/switch qu'il faut arrêter/redémarrer pour garantir le vidage des adresses mises en cache.

    De manière classique, aucun serveur ne devrait être défini en DHCP. Si l'on veut utiliser l'ancien serveur correctement, on lui affecte une adresse IP statique et voir si son service DNS est récupérable. Si ce serveur n'est plus vraiment fonctionnel, autant désactiver le service DNS pour éviter les doutes.

    Si une machine utilise une adresse dite "APIPA", c'est qu'elle n'a pu contacter le serveur DHCP, cela équivaut à ne pas avoir de réseau. Ce n'est pas un bon signe.

    A bientôt,


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(83 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    vendredi 18 janvier 2019 07:38
  • Bonjour,

    le cache ARP est important à vider lorsqu'une même adresse IP est réutilisée sur un nouvel appareil qui a donc une adresse matérielle(Mac) différente.

    => C'est souvent le routeur/switch qu'il faut arrêter/redémarrer pour garantir le vidage des adresses mises en cache.

    Merci. Dans mon cas, le routeur n'a pas changé, mais le port WAN oui, est-ce que cela influe sur l'adresse mac ?

    Par précaution, il vaut donc mieux que j'éteigne le serveur physique avant de basculer la connexion.

    De manière classique, aucun serveur ne devrait être défini en DHCP. Si l'on veut utiliser l'ancien serveur correctement, on lui affecte une adresse IP statique et voir si son service DNS est récupérable. Si ce serveur n'est plus vraiment fonctionnel, autant désactiver le service DNS pour éviter les doutes.

    Ce vieux serveur n'a pas besoin d'être serveur DNS, donc je vais désactiver le service. Le fait que le nouveau serveur pointe dessus dans DomainDNSZones n'aura pas de conséquences ?

    Encore merci !

    vendredi 18 janvier 2019 08:38
  • Le serveur Dhcp actuel est sur la même machine que le serveur DNS.

    Le problème doit être lié soit au cache arp, soit au second serveur DNS.

    vendredi 18 janvier 2019 08:43
  • Il faut retirer l'ancien serveur partout où apparaissent son nom ou son adresse IP.

    S'il est bien configuré, il se réenregistrera là où ce sera nécessaire.

    A+


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(83 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    vendredi 18 janvier 2019 08:50