locked
repertoire Spool\Drivers\X64 grossi anormalement RRS feed

  • Question


  • Bonjour,

    infra : Serveur TSE 2008r2 sur vsphere 5.1 avec couche xenapp 6.5

    Sur certains de mes serveurs de productions, le repertoire C:\Windows\System32\Spool\Drivers\x64 gonfle de facon anormale (6Go a l'heure actuelle)!

    Tous les pilotes de mes imprimantes sont installés sur les serveurs TSE (replication auto citrix) et le spooleur est ensuite géré sur un serveur d'impression dédié (je n'utilise pas le serveur d'impression citrix universel).

    dans le repertoire en question j'ai des entrées qui semblent créées pour chaque user, comme si chaque utilisateur se servant de l'imprimante A créaient une entrée pour l'utilisation du pilote nécessaire pour faire fonctionner l'imprimante A.

    je me retrouve avec des :

    {3F826C21-8913-4699-8138-AFE82B0AED62} 27,8Mb

    {B9D3AFEE-DAC2-47C8-A286-C2F4AD80BF26} 27,8Mb

    {B911CA4A-21BF-4612-8B90-76E9EA685218} 27,8Mb

    {FD33164C-6043-4100-91F5-F594B611B64D} 27,8Mb

    {3A5AA60E-6B2B-4B15-8776-00084006CB7E} 21,2Mb

    {D58EE2F5-E054-4432-BCE5-664E06983AEB} 21,2Mb

    ....

    contenu d'un des reptoires :

    17/08/2012  16:12            78ÿ336 mfricr64.dll
    25/09/2012  14:52         1ÿ919ÿ488 RD01Kd64.dll
    22/08/2006  13:59            51ÿ712 ricdb64.dll
    17/08/2012  18:43           337ÿ920 ricu00cb.dll
    17/05/2013  11:59         5ÿ244ÿ416 ricu00cd.dll
    21/05/2013  11:17         1ÿ316ÿ606 ricu00cd.psz
    21/05/2013  11:15         1ÿ620ÿ327 ricu00cf.cfz
    28/02/2013  17:12           210ÿ983 ricu00ch.chm
    17/05/2013  11:59         1ÿ695ÿ744 ricu00ci.dll
    09/09/2011  14:31           297ÿ984 ricu00cj.dll
    21/05/2013  11:17               584 ricu00cl.ini
    16/02/2007  10:47            55ÿ808 ricu00ct.dll
    21/05/2013  11:15         3ÿ940ÿ823 ricu00cz.dlz
    17/05/2013  11:59         2ÿ958ÿ848 ricu00gr.dll
    17/05/2013  11:59         5ÿ362ÿ688 ricu00ug.dll
    21/05/2013  11:15               290 ricu00ug.miz
    17/05/2013  11:59         3ÿ972ÿ608 ricu00ui.dll
    21/05/2013  11:17               568 ricu00ui.irj
    16/04/2012  12:58                69 ricu00ui.rcf
    25/03/2013  08:48               195 ricu00ui.rdj
    17/05/2013  11:59             4ÿ608 ricu00ur.dll


    Lorsque je me met dans le repertoire, je vois qu'a certains moments de nouveaux repertoires se crééent et sont supprimés tout de suite... j'image que cela est le fonctionnement normalm lorqu un user se connecte et que ses imprimantes sont remontées ?

    J'ai essayé de supprimer les répertoires les plus anciens mais cela m'a vallu de devoir réinstaller les pilotes car lorsque les users se reconnectaient les imprimantes n'arrivaient pas a etre remontées....

    Quelqu'un aurait-il une idée ?

    Merci

    lundi 8 septembre 2014 15:07

Toutes les réponses

  • Bonjour,

    Si vous avez beaucoup d'imprimantes c'est normal, il faut quand même vérifier les points suivants:

    -vérifiez s'il n'y a pas  des doublons de pilotes

    -vérifiez que les utilisateurs n'ont pas d'imprimantes sur leurs postes  qui mappe  automatiquement  lors de l'ouverture de leurs sessions.

    Vous pouvez aussi utiliserl'utilitaire Print Detective Citrix pour  supprimer les pilotes d'imprimante à partir de votre serveur XenApp. Ensuite, utilisez le pilote d'imprimante universelle Citrix pour l'ensemble de vos imprimantes, comme ça vous réduisez énormément l’espace de stockage de pilote, et vous simplifiez aussi la gestion de vous imprimantes.

     

    A+


    L’information n’a de valeur que si elle est partagée!! AK

    lundi 8 septembre 2014 16:21
  • Bonjour,

    C'est bien tout le probleme... j'ai bien le pilote de chaque imprimante d'installé sur mes serveur de production (je les voient bien avec Print detetective) je ne comprends doncpas pourquoi les entrées sont repeteé dans le repertoire....

    Concernant le driver UPS, je ne l'ai volontairement pas utilisé car il est trop restrictif au niveau des possibilité de parametrage des imprimantes et j'ai a la fois des utilisateurs qui ont besoin de parametrer les couleurs, bac, etc.. et a la fois des imprimantes type imprimantes a aiguillies qui necessites des paramétrages spécifiques (oui oui ca existe toujours... :) )

    Comment puis je faire en sorte de nettoyer ce repertoire et que de nouvelles entrées ne se crééent pas (j'ai en effet d'autres erveurs TSE ou ce repertoire est tout a fait normal)

    mardi 9 septembre 2014 12:33
  • Apres analyse, il semble en fait que lorsqu'une imprimante est montée lors d'une ouverture de session, plutot que de se rendre dans le repertoire par defaut C:\Windows\System32\Spool\Drivers\x64\3 (ou tous mes drivers sont installés), le systeme créé une nouvelle entrée.... comme si le chemin par defaut du pilote au moment de la création d'une imprimante était C:\Windows\System32\Spool\Drivers\x64  au lieu de C:\Windows\System32\Spool\Drivers\x64\3....

    Ou puis-je définir ce chemin ?

    Lorsque je regarde les propriétés des drivers dans les options du serveur d'impression, le chemin est le bon !!

    Au secours ! :)

    vendredi 12 septembre 2014 09:22
  • Bonjour,

    Regardez dans Le chemin de Registre suivant qui contiennent des sous-clés, chacune d'elles  peut contenir une entrée de valeur définissant le répertoire qui contient les pilotes appropriés :

    Voir aussi ce kb.

    A+


    L’information n’a de valeur que si elle est partagée!! AK

    samedi 13 septembre 2014 14:03
  • Bonjour,

    Toutes les valeurs presentes dans les sous clés pointes bien vers les repertoires de drivers qui vont bien :

    C:\Windows\system32\DriverStore\FileRepository\XXX\XXX.inf

    J'avais modifié la clé de registre suivante suite au déploiement de mes imprimantes pour ne pas que les imprimantes soient supprimées lors de la fermeture de session car cela faisait sauter l'imprimante par défaut que selectionnait l'utilisateur... pensez vous que cela puisse venir de la..? :

    HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Ica\PrintingSettings

    Clé DisableNetworkPrinterDIsconnect 1

    mardi 16 septembre 2014 12:59
  • Bonjour,

    C'est tout à fait possible, avez-vous la même configuration sur les autres serveurs?

     

    A+



    L’information n’a de valeur que si elle est partagée!! AK

    mardi 16 septembre 2014 15:35
  • Bonjour,

    Si par même configuration vous faites reference a la modification de cette clé, alors oui tous mes serveurs ont été modifié sur ce point.

    Le probleme de remplissage du repertoire ne se produit pas partout car les se ne sont pas les meme imprimantes qui sont utilisées sur ces différents serveurs. J'ai un serveur par région et le parc d'imrpirmante differe... 

    JE vais essayer de modifier cette clé a fin de voir si le probleme persiste ou non.

    mercredi 17 septembre 2014 07:26
  • Bonjour,

    Le probleme se presente a nouveau sur un de mes serveurs... contrairement a ce que je disais plus haut la clé de registre HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Ica\PrintingSettings n'est pas modifiée partout... jsutement ce serveur la n'a pas l'entrée PrintingSettings... 

    Cela ne semble donc pas lié.....

    Une idée ?

    J'ai actuellement 10Go de contenu dans le rep ...\drivers\X64\ sur ce serveur....

    Pensez-vous que je puisse supprimer tous les rep en laissant le repertoire \drivers\X64\3 ?

    mercredi 8 octobre 2014 08:28