none
Comment modifier l'url de sites IIS / Sharepoint 2010 Foundation RRS feed

  • Question

  • Bonjour,

    Je viens de dupliquer mon serveur Sharepoint 2010 Foundation afin d'avoir un serveur de Prod et un de Test. J'ai renommé le serveur de Test (nom NetBios). Le serveur Test pointe toujours sur le serveur de Prod en ce qui concerne Sharepoint 2010 Foundation / IIS. Comment puis-je modifier les adresses sur le serveur de test sans modifier le serveur de Prod ?

    Quand j'essai d'accéder à mon site de test après avoir modifié les liaisons (comme indiqué plus bas an sle lien), j'ai le message suivant : "Impossible de se connecter à la base de données de configuration"

    http://ilovebluescreen.org/talkshit/?p=425

    Merci de votre aide


    • Modifié Tony-21 mercredi 26 décembre 2012 16:27
    mercredi 26 décembre 2012 14:55

Toutes les réponses

  • Bonjour Tony,

    Que voulez-vous dire par dupliquer? et surtout a savoir avez vous un serveur dedié pour SQL?

    J'ai écrit un article sur l'erreur "Impossible de se connecter à la base de données de configuration" qui en soit même est très vaste .. http://www.gknzcfc.net/subsite/unable-to-connect-to-database-check-database-connection-information-and-make-sure-the-database-server-is-running.html 

    Mais d'après mon éxperiance.. il ne sais pas se connecter sur L'SQL pour récuperer les informations..

    C'est assez simple pour résoudre cela..

    • Décomissioner votre serveur TEST  ( via Product Configuration Wizard )
    • Faire les modifications ( changer netbios, Ip, etc .. )
    • Commisioner votre serveur TEST ( via Product Configuration Wizard )
    • Faire multiple tests..

    Bonne chance,

    G.


    My New Technical Blog: WWW.GKNZCFC.NET
    SharePoint Community Expert

    mercredi 26 décembre 2012 21:07
  • Bonjour,

    Non pas de serveur dédié pour SQL c'est tout regroupé sur le même avec WSUS et un anti-virus.

    Ce que j'entend par dupliqué, j'ai appliqué l'image de mon serveur sur un autre.

    Qu'entendez-vous par "Décomissioner" ?

    Je pense que c'est un pb de droits d'accés

    http://support.microsoft.com/kb/823287/fr

    Comment fait-on aussi quand il y n'y a ni Enterprise Manager ni SQL Server Management Studio ?

    Merci bcp

    • Modifié Tony-21 jeudi 27 décembre 2012 08:26
    jeudi 27 décembre 2012 07:51
  • Tony,

    Si je comprend bien, vous avez juste fait une copie conforme et vous avez renommé votre serveur?

    Avez-vous aussi changer les adresses IP et relancer le "Product Configuration Wizard"?

    Merci,

    G.


    My New Technical Blog: WWW.GKNZCFC.NET
    SharePoint Community Expert

    vendredi 28 décembre 2012 08:37
  • Bonjour Gokan,

    Oui c'est tout à fait ça j'ai fait une copie conforme, renommé le serveur et modifié l'adresse IP.

    Sauf que si je lance le Product Configuration Wizard ça le lance sur l'original car le serveur de copie pointe sur l'original. Je ne sais pas comment modifier cet aspect et ou ?

    Sur le serveur source l'assistant ne se lance pas et il n'y a aucun message...

    Merci


    • Modifié Tony-21 vendredi 28 décembre 2012 10:43
    vendredi 28 décembre 2012 10:40
  • Bonjour,

    Vous pouvez tenter d'utiliser un SQL server ALIAS.

    http://mmman.itgroove.net/2012/07/setting-up-a-sql-server-alias-with-sharepoint-server-2010/

    Courage,

    G.


    My New Technical Blog: WWW.GKNZCFC.NET
    SharePoint Community Expert

    dimanche 30 décembre 2012 11:24
  • Bonjour Gokan,

    Tout d'abord mes meilleurs vœux pour cette nouvelle année.

    J'ai suivi la procédure décrite et en lançant l'assistant de configuration Sharepoint j'ai le message ci-dessous.

    Auriez-vous je vous prie également un tutoriel afin de gérer les comptes de service liés au fonctionnement de Sharepoint ? Car je pense que ma configuration n'est pas bonne mais je ne trouve rien qui détails de A à Z...

    Merci de votre aide

    Extrait du fichier log :

    01/02/2013 09:16:42  1  INF  Entering function PsconfigUserInterfaceMain.Main
    01/02/2013 09:16:42  1  INF    Entering function Common.SetCurrentThreadCultureToInstalledCulture
    01/02/2013 09:16:42  1  INF      Entering function Common.SetThreadCultureToInstalledCulture
    01/02/2013 09:16:43  1  INF        Current thread culture is French (France), current thread ui culture is French (France), installed culture is French (France)
    01/02/2013 09:16:43  1  INF      Leaving function Common.SetThreadCultureToInstalledCulture
    01/02/2013 09:16:43  1  INF      The current ui culture French (France) is NOT right to left
    01/02/2013 09:16:43  1  INF    Leaving function Common.SetCurrentThreadCultureToInstalledCulture
    01/02/2013 09:16:43  1  INF    Creating the psconfig application context
    01/02/2013 09:16:43  1  INF    Entering function PsconfigApplicationContext.PsconfigApplicationContext
    01/02/2013 09:16:43  1  INF      Entering function UserInterface.UserInterface
    01/02/2013 09:16:43  1  INF      Leaving function UserInterface.UserInterface
    01/02/2013 09:16:43  1  INF      Entering function TaskDriver.TaskDriver
    01/02/2013 09:16:43  1  INF        Entering function TaskDriver.BuildCommandCollection
    01/02/2013 09:16:43  1  INF          Entering function CommandCollectionBase.CommandCollectionBase
    01/02/2013 09:16:43  1  INF          Leaving function CommandCollectionBase.CommandCollectionBase
    01/02/2013 09:16:43  1  INF          Entering function CommandCollection.CommandCollection
    01/02/2013 09:16:43  1  INF          Leaving function CommandCollection.CommandCollection
    01/02/2013 09:16:43  1  INF          Entering function CommandCollectionBase.CommandCollectionBase
    01/02/2013 09:16:43  1  INF          Leaving function CommandCollectionBase.CommandCollectionBase




    • Modifié Tony-21 mercredi 2 janvier 2013 20:47
    mercredi 2 janvier 2013 08:32
  • Bonjour Tony,

    C'est l'erreur le plus courant quand on désinstalle et réinstalle SharePoint sur le même serveur, quelques fichier dans la machineKeys te donne des access denied même si vous êtes admin local.

    Prière de remettre tout dans le bon etant en regardant le KB de Microsoft: KB278381(http://support.microsoft.com/kb/278381).

    Courage,

    G.


    My New Technical Blog: WWW.GKNZCFC.NET
    SharePoint Community Expert

    jeudi 3 janvier 2013 07:27
  • Gokan,

    Je n'ai pas désinstaller et réinstaller SharePoint mais j'avais vue et essayé d'appliquer cette solution...

    Je ne sais pas ce que je dois attribuer comme droits excatement à "Everyone  (Special) This folder only" cela comprend quoi car des droits spéciaux il y en a plusieurs ?!!!

    Merci

    • Modifié Tony-21 vendredi 4 janvier 2013 14:06
    jeudi 3 janvier 2013 12:36
  • Salut,

    Allez dans ce folder sur votre SharePoint 2010:
    C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys

    Et donnez les droits de "read&execute" au dossier et à tous les elements qui sont à l'interieur pour l'administrateur de ferme .. ( celui qui installe SharePoint ) ..

    Bien à vous,

    G.


    My New Technical Blog: WWW.GKNZCFC.NET
    SharePoint Community Expert

    vendredi 4 janvier 2013 13:43