none
Demande de mot de passe Outlook RRS feed

  • Question

  • Bonjour,

    J'ai un Exchange 2010  sur un serveur interne.

    Et souvent  quand on démarre Outlook il demande de façon persistant le mot de passe et il faut fermer Outlook et réouvrir avant qu'il se connecte automatiquement.

    Avez vous déjà eu ce problème et comment on peut remédier à cela ?

    Merci,

    vendredi 10 octobre 2014 08:12

Réponses

  • Bonjour, sedos,

     

    Je voudrais vous remercier encore une fois pour toute l'information partagée par vous, concernant votre souci et les resultats des solutions proposées.

    Je suppose que le problème de demande de mot de pass Outlook est lié avec votre probleme, decrit dans:

    Outlook anywhere probleme d'authentification (RPC sur HTTP)

    (je me suis permis de fusionner votre thread avec celle de l'utilisateur Sunspark7, vue la similarité du souci et le nombre des solutions offertes).

    Malheureusement, jusqu'a maintenant vous arrivez pas à trouver une solution définitive et c'est pour cette raison que je vous suggère encore une fois d'ouvrir en parallèle un ticket aupres du support O365 (une bonne partie des actions d'analyse et de résolution ne peuvent se faire qu'au niveau de l'infrastructure, ce à quoi seul le support officiel à accès).

    Cordialement,

    Téodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    mardi 14 octobre 2014 10:52
  • J'avais posté cette solution dans le sujet fusionné. J'utilise cette solution et elle fonctionne parfaitement :

    Votre certificat acheté correspond t-il à un enregistrement A présent sur la zone DNS de votre nom de domaine ?

    Cet enregistrement A pointe t-il sur l'IP publique derrière laquelle se trouve votre serveur Exchange ?

    Testez d'abord l'accès OWA (utilisation du port 443) Si ça ne fonctionne pas : le port est bloqué. Si le browser donne une alerte concernant le certificat, vérifier le certificat et le nom. Si ça fonctionne sans alerte, la redirection est OK.

    Créez un enregistrement SRV sur la zone DNS de votre nom de domaine externe avec les renseignements suivants :

    Nom du service : _autodiscover._tcp

    Server : nom utilisé pour certificat. (doit être identique à l'enregsitrement A qui pointe sur l'IP publique du seveur Exchange)

    Priority : 0

    Weight : 0

    Port : 443

     TTL : 3600

    Ajoutez le nom de domaine externe dans les suffixes UPN, modifiez le nom de domaine dans la partie Account" du compte de l'utilisateur dans l'AD de manière à ce qu'il puisse se connecter en utilisant son adresse email.

    Faites un test de connectivité, ça doit fonctionner. Et vous pouvez configurer votre Outlook depuis n'importe où dans le monde comme avec Office365

    mercredi 15 octobre 2014 13:14
  • Sedos,

    Votre autodiscover doit être renseigné au niveau de votre zone DNS externe. Si ce n'est pas fait, la découverte automatique (autodiscover) ne fonctionnera pas.

    Votre Outlook effectue 3 tests pour se faire :

    1 - domain.fr/autodiscover

       Vous avez un certificat (délivré par une authorité de certification publique) avec ce nom et l'enregistrement A avec la racine de votre nom de domaine pointe sur l'IP publique de votre serveur : ça va fonctionner

    2 - autodiscover.domain.fr/autodiscover

      Vous avec un certificat (délivré par une authorité de certification publique) avec ce nom et l'enregistrement A avec ce nom  qui pointe sur l'IP publique de votre serveur : ça va fonctionner

    3 - enregistrement SRV

      Vous avez un certificat (délivré par une authorité de certification publique) qui a le même nom qu'un enregistrement A présent sur la zone DNS de votre nom de domaine externe et qui pointe sur l'iP publique de votre serveur, ça fonctionnera également.

    L'avantage de l'enregistrement SRV est de pouvoir utiliser un certificat avec n'importe quel nom tant qu'il correspond à un enregistrement A présent dans la zone DNS externe et qui pointe sur l'IP publique.

    Si le problème est juste en interne et que vous ne voulez pas acheter de certificat, créer un certificat de domaine et liez-le à votre Exchange (Enable-ExchangeCertificate -ThumbPrint <thumbprint du certificat> -Services "SMTP, IIS, POP, IMAP"). Faite un export du certificat de l'autorité de certification du serveur qui a servi à générer ce certificat. Installez ce certificat sur tous les postes dans le magasin de certificats de racines de confiance. Et le problème est réglé.

    mercredi 15 octobre 2014 13:45
  • Bonjour,

    pour vérifier le mode d'accès, tu peux toujours lancer Outlook avec l'option RPCDIAG

    "Outlook /rpcdiag"

    Ceci te permettra quelles sont les connexions qui s'ouvrent (Annuaire ou Messagerie), et dans quel mode (HTTP=rpc sur Https, ou RPC=direct réseau).

    Dans le cas de Exchange 2010, il vaut mieux travailler en mode RPC  et ce sont les connexions HTTPS qui provoquent généralement les demandes d'authentifications intempestives.

    A+


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(80 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    mardi 14 octobre 2014 13:20
    Modérateur

Toutes les réponses

  • Bonjour,

    Il y a plusieurs chose à vérifier :

    - Le bon fonctionnement de l'autodiscover

    - L'authentification au niveau des répertoires Exchange dans IIS

    - Le proxy si vous en avez un

    - Le(s) certificat(s)


    m.geyer

    vendredi 10 octobre 2014 08:21
  • Bonjour ,

    Merci pour votre réponse.

    l'autodiscover ne marche pas bien.

    j'ai ouvert sujet ici https://social.technet.microsoft.com/Forums/fr-FR/2327f674-5b0b-4722-9b15-f3a9df9f00e1/tentative-de-test-de-lurl-potentielle-de-dcouverte-automatique?forum=1109&prof=required 

    Je n'ai pas de proxy.

    Le certificat a été renouvelé il y a pas longtemps, quel test je peux faire sur le certificat?

    mais je n'ai pas encore une réponse.

    Merci,


    • Modifié sedos vendredi 10 octobre 2014 08:40
    vendredi 10 octobre 2014 08:39
  • Il est possible que lors du démarrage des clients ceux-ci tentent de se connecter en outlook anywhere, il faudrait aussi vérifier que celui-ci fonctionne correctement.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    vendredi 10 octobre 2014 09:31
    Modérateur
  • Oui c'est possible qu'il cherche à se connecter sur outlook anywhere mais mon Outlook anywhere marche bien https://webmail.domaine.fr/owa .Es ce qu'il y a une possibilité de le forcer à ne pas passer par OWA? 

    Merci,

    vendredi 10 octobre 2014 11:53
  • Je confirme que les Outlook se connecte bien vers le OWA car quand je fais fichier 

    En desous de Paremetres de compte et réseau sociaux c'est l'adresse du  https://webmail.domaine.fr/owa (sur certains postes ) et  https://nom_du-serveur.domaine.fr/owa (sur d'autres postes).

    Merci,


    • Modifié sedos vendredi 10 octobre 2014 12:00
    vendredi 10 octobre 2014 11:58
  • OWA c'est le webmail

    OA c'est Outlook Anywhere (le dossier /rpc sur IIS)

    HTTPMapi c'est le nouveau protocole 2013 (le dossier /mapi sur IIS)


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    vendredi 10 octobre 2014 12:21
    Modérateur
  • Bonjour,

    le client Outlook n'utilise jamais /OWA. L'URL indiquée est donnée à titre d'information.

    En revanche, même si Outlook se connecte en RPC sur le serveur Exchange 2010, la configuration automatique et les autres paramètres utilisent les autres répertoires virtuels (/autodiscover, etc...). Ce sont souvent ces autorisations activées ou non sur ces répertoires qui nécessitent (à tord) l'authentification.

    Avec des serveurs Exchange 2010, l'ordre d'utilisation (RPC ou RPC/HTTPS) sur Outlook est important à définir pour une bonne connexion.

    A+


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(80 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    vendredi 10 octobre 2014 12:50
    Modérateur
  • J'ai bien /rpc  et rpcwithcert sur IIS. comment jeoux savoir si Outlook passe par le OA?

    Merci,

    vendredi 10 octobre 2014 12:51
  • Bonjour Thierry,

    Qu'es ce qu'il faut donc faire ?

    lundi 13 octobre 2014 07:33
  • Bonjour, sedos,

     

    Pour vérifier qu’Outlook Anywhere a été activé, consultez le journal des événements Applications sur le serveur d’accès au client.

    Vous pouvez aussi suivre les liens en bas pour avoir une  infomation plus detailléé sur OA:

    Enable Outlook Anywhere in Outlook

     

    Exchange 2010 - Outlook Anywhere

    Cordialement,

    Téodora  


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    lundi 13 octobre 2014 07:56
  • Bonjour Teodora,

    Merci pour la réponse.

    J'ai lu les pages suggérées mais le OA est déja activé sur le server Exchange et le lien externe est webmail.domaine.fr mais le probléme qui se pose est que  parfois (pas toujours) quand les utilisateurs ouvrent outlook, il  demande aux utilisateurs de saisir le nom utilisateur et le mot de  passe alors que normalement  outlook devrait se connecter automatique.

    Merci,

    lundi 13 octobre 2014 11:25
  • Re-bonjour, sedos,

    Vous pouvez proposer aux utilisateurs la solution suivante:


    1) Ouvrez Outlook

    2)Allez dans Outil>>Paramètre du compte>>Ensuite sélectionnez votre compte, puis

    cliquez sur Modifier

    (dans la Fenêtre qui s'ouvre pour Modifier votre Compte de messagerie n'oubliez pas de vérifier si la case qui concerne les Information de Connexions est bien cochée)

    3)Cliquez ensuite sur Paramètres Suplimentaires>>Serveur Sortant>

    cochez la case>>Mon serveur Sortant(SMTP) requiert une Identification>>

    4) cochez la case << Se connecter à l'aide d'un Nom d'utilisateur et d'un mot de passe>>

    et vous cochez ensuite - <<Mémoriser mon mot de passe>>.

    Je vous remercie d'avance pour votre retour.

     

    Cordialement,

    Téodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    lundi 13 octobre 2014 12:25
  • téodora,

    On utilise pas la connexion SMTP  mais la connexion Microsoft exchange directe.

    Par contre quand l'utilisateur à la fenêtre qui lui demande de saisie ces identifiants  , il coche bien la case mémoriser les informations mais  la fenêtre revient encore. La seule chose qui résout se problème est de fermer outlook et ré-ouvrir et outlook se connecte automatiquement.

    Merci,

    lundi 13 octobre 2014 14:13
  • Bonjour, sedos,

     

    Je voudrais vous remercier encore une fois pour toute l'information partagée par vous, concernant votre souci et les resultats des solutions proposées.

    Je suppose que le problème de demande de mot de pass Outlook est lié avec votre probleme, decrit dans:

    Outlook anywhere probleme d'authentification (RPC sur HTTP)

    (je me suis permis de fusionner votre thread avec celle de l'utilisateur Sunspark7, vue la similarité du souci et le nombre des solutions offertes).

    Malheureusement, jusqu'a maintenant vous arrivez pas à trouver une solution définitive et c'est pour cette raison que je vous suggère encore une fois d'ouvrir en parallèle un ticket aupres du support O365 (une bonne partie des actions d'analyse et de résolution ne peuvent se faire qu'au niveau de l'infrastructure, ce à quoi seul le support officiel à accès).

    Cordialement,

    Téodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    mardi 14 octobre 2014 10:52
  • Bonjour,

    pour vérifier le mode d'accès, tu peux toujours lancer Outlook avec l'option RPCDIAG

    "Outlook /rpcdiag"

    Ceci te permettra quelles sont les connexions qui s'ouvrent (Annuaire ou Messagerie), et dans quel mode (HTTP=rpc sur Https, ou RPC=direct réseau).

    Dans le cas de Exchange 2010, il vaut mieux travailler en mode RPC  et ce sont les connexions HTTPS qui provoquent généralement les demandes d'authentifications intempestives.

    A+


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(80 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    mardi 14 octobre 2014 13:20
    Modérateur
  • Bonsoir Teodora,

    Oui je suppose aussi que les deux problemes sont liées mais je ne suis pas sur.

    Mon exchange n'est 0ffice365, j'ai juste vu leur post et me suis dit que c'est peut etre la meme chose.

    Moi exchange 2010 sur serveur 2008 R2 avec des poste client outlook 2010 et 2013

    Mon probléme demeure toujours et l'erreur mentioné dans ce post https://social.technet.microsoft.com/Forums/fr-FR/66395dde-4a12-4928-b834-34cf92bc7e0b/outlook-anywhere-probleme-dauthentification-rpc-sur-http?forum=1109 est toujours présent

    Merci
    • Modifié sedos mardi 14 octobre 2014 15:56
    mardi 14 octobre 2014 15:56
  • BBonsoir Thierry,

    J'ai fait le diag avec outlook /rpcdiag .Le protocole est RPC/TCP.

    

    S'il y un client outlook qui établie une connexion en HTTPS comment le forcer à établir une connexion RPC ?

    MErci,

    mardi 14 octobre 2014 16:03
  • Dans votre capture, le protocole est indiqué sur RPC/TCP, vous n'êtes pas en outlook anywhere par défaut. par contre en cas de problème réseau, votre client outlook va tenter de se connecter en outlook anywhere, ce qui provoque souvent une demande de mdp.

    Dans ce cas précis, il n'y a en général pas de problème au niveau d'Exchange, mais plutôt au niveau de l'interconnexion du client avec la messagerie (par exemple un problème réseau).

    Si le problème perdure, vous pouvez faire appelle à une société extérieur pour un audit, cela vous donnerait une autre vision de votre infrastructure. Il existe pas mal de sociétés qui proposent ce type de prestation.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mercredi 15 octobre 2014 07:25
    Modérateur
  • J'avais posté cette solution dans le sujet fusionné. J'utilise cette solution et elle fonctionne parfaitement :

    Votre certificat acheté correspond t-il à un enregistrement A présent sur la zone DNS de votre nom de domaine ?

    Cet enregistrement A pointe t-il sur l'IP publique derrière laquelle se trouve votre serveur Exchange ?

    Testez d'abord l'accès OWA (utilisation du port 443) Si ça ne fonctionne pas : le port est bloqué. Si le browser donne une alerte concernant le certificat, vérifier le certificat et le nom. Si ça fonctionne sans alerte, la redirection est OK.

    Créez un enregistrement SRV sur la zone DNS de votre nom de domaine externe avec les renseignements suivants :

    Nom du service : _autodiscover._tcp

    Server : nom utilisé pour certificat. (doit être identique à l'enregsitrement A qui pointe sur l'IP publique du seveur Exchange)

    Priority : 0

    Weight : 0

    Port : 443

     TTL : 3600

    Ajoutez le nom de domaine externe dans les suffixes UPN, modifiez le nom de domaine dans la partie Account" du compte de l'utilisateur dans l'AD de manière à ce qu'il puisse se connecter en utilisant son adresse email.

    Faites un test de connectivité, ça doit fonctionner. Et vous pouvez configurer votre Outlook depuis n'importe où dans le monde comme avec Office365

    mercredi 15 octobre 2014 13:14
  • Bonjour bruce,

    Merci pour votre réponse.Oui il est probable que le problème soit la communication entre le client Outlook et Exchange car le problème est ponctuel et se résout seule en fermant et ré ouvrir Outlook mais très embetant pour certains utilisateurs.

    Es ce possible que ces demandes de mot de passe soit aussi du à cette erreur mais si la connexion des client est RPC? 

    Tentative de test de l’URL potentielle de découverte automatique https://xxxxx.fr:443/Autodiscover/Autodiscover.xml

    Le test de cette URL de découverte automatique éventuelle a échoué.

    Merci,


    mercredi 15 octobre 2014 13:16
  • Sedos,

    Votre autodiscover doit être renseigné au niveau de votre zone DNS externe. Si ce n'est pas fait, la découverte automatique (autodiscover) ne fonctionnera pas.

    Votre Outlook effectue 3 tests pour se faire :

    1 - domain.fr/autodiscover

       Vous avez un certificat (délivré par une authorité de certification publique) avec ce nom et l'enregistrement A avec la racine de votre nom de domaine pointe sur l'IP publique de votre serveur : ça va fonctionner

    2 - autodiscover.domain.fr/autodiscover

      Vous avec un certificat (délivré par une authorité de certification publique) avec ce nom et l'enregistrement A avec ce nom  qui pointe sur l'IP publique de votre serveur : ça va fonctionner

    3 - enregistrement SRV

      Vous avez un certificat (délivré par une authorité de certification publique) qui a le même nom qu'un enregistrement A présent sur la zone DNS de votre nom de domaine externe et qui pointe sur l'iP publique de votre serveur, ça fonctionnera également.

    L'avantage de l'enregistrement SRV est de pouvoir utiliser un certificat avec n'importe quel nom tant qu'il correspond à un enregistrement A présent dans la zone DNS externe et qui pointe sur l'IP publique.

    Si le problème est juste en interne et que vous ne voulez pas acheter de certificat, créer un certificat de domaine et liez-le à votre Exchange (Enable-ExchangeCertificate -ThumbPrint <thumbprint du certificat> -Services "SMTP, IIS, POP, IMAP"). Faite un export du certificat de l'autorité de certification du serveur qui a servi à générer ce certificat. Installez ce certificat sur tous les postes dans le magasin de certificats de racines de confiance. Et le problème est réglé.

    mercredi 15 octobre 2014 13:45