locked
Windows 7 force les attributs en "lecture seule" lors de copie ou installation sous c:\xxx RRS feed

  • Question

  • Pourquoi Windows 7 force les attributs en "lecture seule" lors de copie ou installation sous c:\xxx ? Comment eviter ceci?

    J'ai transféré certains de mes programmes nécessitant pas l’installation et les fichiers associés de mon ancien Win2000 PC via clé flash USB sur le  lecteur C:\ de la nouvelle machine sous Windows 7 Home. Après essais d’exécution de ces programmes a partir de C:\XXX  j'obtiens une série de messages d'erreur indiquant que certains fichiers sont en lecture seule ou que l’accès est refusé (pourtant je suis logué comme administrateur de PC). Mais le Windows 7 me permets d’exécuter les mêmes programmes a partir de ma clé USB!!! 
    Quand je télécharge certaines applications nécessitant leur installation par la simple copie sous C:\ et PAS sous C:\programmes, je rencontre le même problème. En passant par les "propriétés" je ne peux pas enlever le "read-only".

    Comment faire pour inhiber ce comportement de Windows 7 Home et pouvoir copier les fichiers sans que leurs attributs de lecture soit modifié ??

    Je sais qu'on peut faire tourner ces programmes avec un clic droit de la souris et selection "run as administrator", mais j'aurais preferé que Windows ne change pas les atributes de fichiers copiés/installés sur C:\XXX

    mercredi 15 février 2012 15:56

Réponses

    • Marqué comme réponse Florin Ciuca lundi 20 février 2012 11:27
    jeudi 16 février 2012 17:05
  • Bonjour ,

    1. D après vos propos :

    "Pourquoi Windows 7 force les attributs en "lecture seule" lors de copie ou installation sous c:\xxx ?"

    • Les fichiers que vous avez transférés  proviennent d un ancien O.S (Win2000).Cependant ,Windows 7 les reconnait comme etant des dossiers personnalisés et leurs attribuent automatiquement le paramètre "lecture seule ".Dans votre cas ,la meilleur solution pour éviter ce désagrément est de réinstaller le logiciel ayant  créer le dossier et non de le transférer le dossier présent .D autre part ,vous pouvez executer la procèdure ci-dessous .

    2. D après vos propos :

    "En passant par les "propriétés" je ne peux pas enlever le "read-only""

    • Afin de contourner ce problème ,une modification de la base des registres est necessaire (penser à sauvegarder celle-ci avant manipulation ) :

    1. Modifier la clé suivante :HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\Explorer
    2. Créer la valeur DWORD32 UseSystemForSystemFolders
    3. Assigner à cette valeur Dword32 le valeur 1
    4. Quitter l éditeur de la base des registres
    5. A l invite de commande en tant qu administrateur ,executer la syntaxe suivante : attrib -r +s c:\xxx OU accéder au propriété de votre dossier et désactiver l option lecture seule .

    Cordialement







    jeudi 16 février 2012 17:18
    Auteur de réponse

Toutes les réponses

    • Marqué comme réponse Florin Ciuca lundi 20 février 2012 11:27
    jeudi 16 février 2012 17:05
  • Bonjour ,

    1. D après vos propos :

    "Pourquoi Windows 7 force les attributs en "lecture seule" lors de copie ou installation sous c:\xxx ?"

    • Les fichiers que vous avez transférés  proviennent d un ancien O.S (Win2000).Cependant ,Windows 7 les reconnait comme etant des dossiers personnalisés et leurs attribuent automatiquement le paramètre "lecture seule ".Dans votre cas ,la meilleur solution pour éviter ce désagrément est de réinstaller le logiciel ayant  créer le dossier et non de le transférer le dossier présent .D autre part ,vous pouvez executer la procèdure ci-dessous .

    2. D après vos propos :

    "En passant par les "propriétés" je ne peux pas enlever le "read-only""

    • Afin de contourner ce problème ,une modification de la base des registres est necessaire (penser à sauvegarder celle-ci avant manipulation ) :

    1. Modifier la clé suivante :HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\Explorer
    2. Créer la valeur DWORD32 UseSystemForSystemFolders
    3. Assigner à cette valeur Dword32 le valeur 1
    4. Quitter l éditeur de la base des registres
    5. A l invite de commande en tant qu administrateur ,executer la syntaxe suivante : attrib -r +s c:\xxx OU accéder au propriété de votre dossier et désactiver l option lecture seule .

    Cordialement







    jeudi 16 février 2012 17:18
    Auteur de réponse