none
Autologon et Configuration Manager RRS feed

  • Discussion générale

  • Bonjour,

    Je gère un parc informatique de plus de 2000 postes et j'installe l'intégralité de ces postes via SCCM.

    Récemment, j'ai une série de postes sous Windows 10 v1709 que j'ai installé par SCCM avec lesquels je rencontre un étrange problème. Ces postes doivent disposer d'un autologon (les clefs de registre paramétrant l'autologon sont descendues par GPO : autoadminlogon, Defautlusername, defaultpassword, defaultdomain). Aprés la descente de l'image sur les postes tout fonctionne parfaitement mais aprés un certain temps (je dis bien temps et pas nombre de redémarrage), l'autologon ne fonctionne plus. Voici les différentes investigations que j'ai réalisé et qui m'ont conduit à centrer le problème sur le client SCCM présent sur le poste :

    - les anciens postes en Windows 7 qui disposaient eux aussi de l'autologon fonctionnent et disposent également du client SCCM

    - J'ai vérifié toutes les clefs de registre (même forceautologon ou encore autologoncount) mais rien à faire, l'autologon ne fonctionne plus aprés environ 1h de session ouverte. Je peux redémarrer le poste une vingtaine de fois si la session reste ouverte quelques minutes et l'autologon fonctionne mais si je laisse la session ouverte trop longtemps (1h d'aprés ce que j'ai remarqué), c'est à ce moment que l'autologon ne fonctionne plus

    - J'ai épuré au maximum ma séquence de tache (Je descend uniquement l'OS et le client configuration manager) ainsi que mes GPO (J'ai bloqué l'héritage afin de n'appliquer que les clefs de registre nécessaire à l'autologon) et j'aboutis au même problème => Autologon non fonctionnel si la session autologé reste ouverte trop longtemps.

    - J'ai testé avec une version ultérieur de Windows 10 v1803 => idem

    - J'ai testé avec un modèle/marque de matériel différent => idem

    - J'ai testé avec un poste sorti de sa boite et non descendu par SCCM et là tout fonctionne sans limite de durée d'ouverture de session

    - J'ai donc testé une installation avec SCCM mais où je place dans la séquence de tâche la désinstallation du client avec la ligne de commande "c:\windows\ccmsetup\ccmsetup.exe /uninstall" et là tout fonctionne également

    Mon problème est donc lié au client SCCM présent sur les postes qui, je ne sais pas pourquoi, m'empêche de m'autologé au bout d'un certain temps et cela uniquement pour les postes déployés en Windows 10.

    Quelqu'un aurait une solution, je m'arrache les cheveux (qu'il ne me reste pas beaucoup) sur le sujet

    Merci d'avance

    mardi 19 juin 2018 08:52

Toutes les réponses

  • Bonjour,

    Petit message pour faire remonter ce sujet que je n'ai toujours pas réussi à résoudre. (Entre temps, j'avais donc déployé les postes sans client SCCM mais ce n'est pas une solution pérenne dans le temps)

    mercredi 20 janvier 2021 14:16
  • Bonjour,

    Petit message pour faire remonter ce sujet que je n'ai toujours pas réussi à résoudre. (Entre temps, j'avais donc déployé les postes sans client SCCM mais ce n'est pas une solution pérenne dans le temps)

    Bonjour, assez marrant de tomber sur ce post fraichement mis à jour alors que j'ai du le voir il y a quelques temps... :)

    J'ai un problème similaire pour créer un autologon temporaire en "safemode", sur certains PC ça fonctionne et sur d'autres non... Je n'ai pas encore pu vraiment tester mais je suis tombé sur un post similaire qui laisse penser que les "legal caption" peuvent bloquer ?

    Donc :

    reg delete "HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System" /v legalnoticecaption /f
    reg delete "HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System" /v legalnoticetext /f

    Si une GPO applique ces clés, ça pourrait expliquer votre phénomène... après deux ans ça coûte rien d'essayer :D

    vendredi 29 janvier 2021 10:47
  • Bonjour,

    C'est vraiment étrange que ça arrive.

    Ce que je peux vous dire, c'est de vérifier si vous avez des paramètres de conformité déployées par Configuration Manager et qui écrasent les paramètres du autologin, sinon ce que vous pouvez faire, c'est qu'à la fin de votre séquence de tâches, après l'installation du client SCCM, vous réappliquez les paramètres relatifs au autologin.


    Youssef Saad | New blog: https://youssef-saad.blogspot.com | Linkedin: linkedin.com/in/youssef-saad

    dimanche 31 janvier 2021 10:10
  • Bonjour, 

    Merci pour votre réponse. Les deux clefs sont bien présentes mais malheureusement la suppression ne règle pas le problème.

    L'autologon ne veut toujours pas fonctionner...

    jeudi 18 février 2021 10:03