none
Lancement des applications Remote Apps échoue RRS feed

  • Question

  • Bonjour,

    Afin de m'aider dans la mise en place des services de bureau à distance sous Windows 2012, j'ai suivi le guide de M. V. Pourchet : http://vpourchet.com/microsoft/

    Sur un serveur déporté OVH Windows srv 2012, j'ai installé les rôle AD, DNS, Hyper-V ; nom du serveur : SRV01

    J'ai créé une Machine virtuelle Win srv 2012, que j'ai joint au domaine AD ; nom de la VM : VIRTSRV01

    J'ai installé sur VIRTSRV01 mes services de bureau à distance et configuré une collection de programmes Remote Apps.

    J'ai créé dans mon AD une OU-RDWeb dans laquelle j'ai créé un groupe d'utilisateurs RdWeb_Users et des utilisateurs que j'ai joint à ce groupe.

    Sur le serveur Virtuel VIRTSRV01, dans groupes et utilisateurs locaux, j'ai enregistré le groupe RdWeb_users comme membre du groupe Utilisateurs du bureau à distance.

    Lorsque je me connecte depuis un ordinateur tiers via Accès Web, https://ip_de_VIRTSRV01/RDWeb : je peux m'authentifier à l'aide des utilisateurs RDWeb_Users, j'arrive à la page avec les icônes des programmes Remote Apps mais lorsque je veux les lancer, j'ai une demande d'enregistrer sous ou ouvrir avec "Connexions Bureau à distance". Peu importe le moyen sélectionné je me retrouve avec le message d'erreur suivant "RemoteApp déconnecté. Ordinateur distant introuvable."

    Je précise que depuis un navigateur Web sur VIRTSSRV01 ou SRV01 cela fonctionne très bien. C'est donc à l'extérieur du réseau, bref depuis n'importe quel poste relié à Internet que cela bloque. Je cherche des procédures et des messages sur ce problème depuis plusieurs jours, mais je ne trouve quasiment que des articles parlant de 2008R2, citant des outils ou des chemins que je ne retrouve pas sous 2012.

    Concernant mon problème, il semble revenir que cela touche à la configuration du gestionnaire de la passerelle bureau à distance (outil installé sur SRV01) mais je ne vois pas où ça coince dans mes paramètres.

    Toute aide sera grandement appréciée. Merci,

    Manu.


    • Modifié ManuTssi lundi 9 juin 2014 10:34
    lundi 9 juin 2014 10:33

Réponses

  • Pour un accès depuis l'extérieur (pour les 5 magasins), une passerelle BàD est recommandé pour tout simplement pouvoir contrôler et gérer aux mieux les accès au serveur RemoteApp.

    De plus, une passerelle BàD permettra de renforcer la sécurité niveau échange entre postes externes et votre serveur interne, en effet, une passerelle BàD utilise un certificat SSL pour les communications (requetes HTTPS).

    Si vous avez déployé une passerelle BàD, normalement côté Hote de la session bureau à distance, vous devez précisé que ce dernier doit utiliser la passerelle des BàD, côté client, depuis le client connexion bureua à distance, dans les proprités => onglet avancé => vous devez configurer le client pour faire en sorte de passer par la paserelle au moment du lancement des apps depuis RDWeb.

    Donc votre problème peut être situé soit :

    Au niveau du certificat (auto signé) SSL qui a été generé au moment de la config de la paserelle Bureau à distance : dans ce cas, il faut le déployer sur les postes client (mmc => ajout composant logiciel enfichable => certificats => importer le certificat

    Au niveau propriétés client RDC (onglet avancé) et configurer l'add IP de la paserelle BàD.

    Je viens de jeter un coup sur le blog de Valentin, l'article n'est pas complet, il ne traite pas le déploiement et configuration de la RD Gateway.

    Je vous invite à consulter cette article MS très complet sur le déploiement de l'ensemble des services bureau à distance sous W2012 :

    http://technet.microsoft.com/fr-fr/library/hh831447.aspx

    vu que vous êtes sur un LAB, n'hésitez pas à remonter tout l'infra RDS, ca vous permettra de maitriser les choses et de rien louper, je ne peux malheureusement vous détailler toutes les étapes sur ce poste, ca risque de me prendre des heures de rédactions.

    Goodluck

    A+

    HK.



    lundi 9 juin 2014 22:07
  • Bonjour,

    tentez ça 

    1. Depuis le serveur ou la passerelle BàD est installée, lancez le gestionnaire IIS (depuis l'interface metro saisir : INETMGR.exe)

    2. depuis le gestionnaire IIS, naviguez jusqu'au : Sites => Site Web Par défault => RDWeb => Pages => Paramètres applications => Localisez le paramètre DefaultTSGateway et dites moi ce ui affiché comme valeur du paramètre

    Tenez moi au jus.

    A+

    HK.


    Hicham KADIRI | Just Another IT Guy

    • Marqué comme réponse Florin Ciuca vendredi 11 juillet 2014 21:43
    mardi 10 juin 2014 16:48
  • Je vous remercie Hicham mais j'ai commencé à refaire l'infra, en plus simple pour le moment, afin de mieux comprendre la logique de tous ces services de rôle et je n'ai pas installé de VM.

    A mon avis, c'était un problème de certificats SSL. Tout poste client inscrit au domaine à un accès normal aux RemoteApps car ils ont un certificat racine du contrôleur de domaine. Mais tous les clients externes (hors AD) a un message d'erreur.

    Le problème est que je n'y comprends pas grand chose à ces histoires de certificats, pour le moment. Il faut que je me renseigne plus.

    Peut-être peut-on fermer le sujet, à défaut de l'avoir résolu.

    Merci encore pour votre aide et votre temps.

    Manu.

    • Marqué comme réponse Florin Ciuca vendredi 11 juillet 2014 21:43
    mardi 10 juin 2014 18:55
  • Je vous en prie.

    Je vous encourage à vous documenter avant toute chose, il faut pas se précipiter surtout "j'imagine" qu'après déploiement vous allez gérer la solution RDS donc vous devez connaître au moins l'architecture, fonctionnement et les options à configurer pour pouvoir assurer du support derrière.

    Bonne lecture et bonne maquette.

    A+

    HK.


    Hicham KADIRI | Just Another IT Guy

    • Marqué comme réponse Florin Ciuca vendredi 11 juillet 2014 21:43
    mardi 10 juin 2014 19:14

Toutes les réponses

  • Bonjour,

    Merci de suivre les instructions suivantes et me tenir informé du résultat :

    1. Depuis VIRTSRV01, ouvrir l'invite de commande en tant qu'administrateur et saisir :

    Netsh advfirewall set allprofiles state off


    A+

    HK.


    Hicham KADIRI | Just Another IT Guy

    lundi 9 juin 2014 11:01
  • Bonjour Hicham,

    J'ai lancé la commande tel que proposé, ce qui a généré le message OK dans l'invite de commande.

    J'ai re-testé mais toujours le même message d'erreur "RemoteApp déconnecté. Ordinateur distant introuvable. Pour plus d'informations sur cette erreur, contactez votre support technique."

    Sur ce type d'erreur "RemoteApp déconnecté", je crois comprendre que la fin du message donnait une procédure à suivre différente en fonction des problèmes (...contactez votre admin reseau, ....contactez support technique, ...).

    J'ai également essayé en désactivant les firewall de VIRTSRV01 et SRV01, sans plus de succès.

    Je voudrais aussi préciser que lorsque je clique sur le programme à distance, une fenêtre de connexion bureau à distance se lance qui fait pop une fenêtre d'information avec le message " L'éditeur du programme RemoteApp ne peut pas être identifié. Voulez-vous vous connecter pour exécuter le programme quand même ? > clic sur connexion et Message d'erreur apparaît.

    D'autres conseils ou instructions ? Merci,

    Manu.


    • Modifié ManuTssi lundi 9 juin 2014 15:12
    lundi 9 juin 2014 11:41
  • Je vois.

    c'était pour cerner le pb avant d'aller plus loin dans le diagnostic.

    Parce que pas mal de fois la root cause de ce pb était tt simplement blocage niveau FW.

    Maitenant, j'ai 2 questions pour vous :

    1. Quel est le type du vSwitch auquel votre VM VIRTSRV01 est attaché ? 

    2. vous aurez pas déployé /configuré une passerelle RD en rajoutant les services de rôles BàD ?

    A+
    HK.


    Hicham KADIRI | Just Another IT Guy

    lundi 9 juin 2014 11:57
  • 1/ le vSwitch est de type externe.

    SRV01 a une IP Publique et VIRTSRV01 a une adresse IP Fail-Over publique (de deux plages réseau différentes).

    2/ Déploiement/configuration passerelle RD :

    J'ai en premier lieu installé le service de rôle de passerelle de bureau à distance sur SRV01 et paramétré une stratégie d'authorisation de connexion et d'accès (il n'y en avait pas par défaut).

    comme cela ne marchait pas,

    j'ai ensuite ajouté VIRTSRV01 comme serveur de passerelle des services bàD et ai laissé les stratégies par défaut donnant droit de connexion et d'accès à tous les utilisateurs du domaine.

    Cela ne marche pas non plus. J'ai maintenant deux serveurs passerelle de services BàD et lorsque j'essaie d'en supprimer un, il ne me propose que VIRTSRV01, or j'aurais voulu supprimer SRV01 comme serveur de passerelle.

    A+,

    Manu.



    • Modifié ManuTssi lundi 9 juin 2014 15:16
    lundi 9 juin 2014 12:38
  • Donc c normal que vous avez ce pb de lancement des remoteApps.

    la passerelle des bureaux à distance est basé sur un site IIS, qui doit être mal configuré, de plus le fait que votre serveur VIRTISRV soit situé sur un vréseau de type "Externe" nécessite d'autres configuration aux niveaux des policies d'autorisation.

    Une dernière question pour pouvoir vous donner une solution adaptée a ce que vous voulez mettre en place.

    Cette infra RDS que vous avez mis en place est une phase de test de la solution RDS ?

    j'aimerais savoir si l'infrastructure RDS finale devrait avoir une passerelle BàD ou vous avez déployé une passerelle juste pour faire des tests.

    quels sont les éléments que vous avez défini sur votre architecture ?

    Les configurations ne sont pas les mêmes, avec une paserelle BàD les choses sont plus compliquées et certains paramètres doivent être respectés et configurés dans l'ordre et correctement.

    A+

    HK.


    Hicham KADIRI | Just Another IT Guy

    lundi 9 juin 2014 13:22
  • L'infra que je mets en place est en effet une phase de test pour une solution RDS dont j'aurai besoin à court terme.

    Je ne savais pas si j'avais besoin ou non d'une passerelle RD ; Et comme ça ne fonctionnait pas sans, j'ai installé le service de rôle et l'ai configuré au niveau des stratégies (sur les 2 serveurs...).

    vous saurez sûrement me dire si j'en ai le besoin en vous détaillant mieux l'infra. Voici ce que je souhaite faire grâce aux Services de bureau à distance :

    Installer sur VIRTSRV01 un logiciel commercique (Caisse, Vente,...) qui sera utilisable par accès RDweb à cinq magasins franchisés différents appartenant au même propriétaire (Centralisation des opérations commerciques.)

    Merci de votre aide Hicham,

    Manu


    • Modifié ManuTssi lundi 9 juin 2014 15:12
    lundi 9 juin 2014 15:09
  • Pour un accès depuis l'extérieur (pour les 5 magasins), une passerelle BàD est recommandé pour tout simplement pouvoir contrôler et gérer aux mieux les accès au serveur RemoteApp.

    De plus, une passerelle BàD permettra de renforcer la sécurité niveau échange entre postes externes et votre serveur interne, en effet, une passerelle BàD utilise un certificat SSL pour les communications (requetes HTTPS).

    Si vous avez déployé une passerelle BàD, normalement côté Hote de la session bureau à distance, vous devez précisé que ce dernier doit utiliser la passerelle des BàD, côté client, depuis le client connexion bureua à distance, dans les proprités => onglet avancé => vous devez configurer le client pour faire en sorte de passer par la paserelle au moment du lancement des apps depuis RDWeb.

    Donc votre problème peut être situé soit :

    Au niveau du certificat (auto signé) SSL qui a été generé au moment de la config de la paserelle Bureau à distance : dans ce cas, il faut le déployer sur les postes client (mmc => ajout composant logiciel enfichable => certificats => importer le certificat

    Au niveau propriétés client RDC (onglet avancé) et configurer l'add IP de la paserelle BàD.

    Je viens de jeter un coup sur le blog de Valentin, l'article n'est pas complet, il ne traite pas le déploiement et configuration de la RD Gateway.

    Je vous invite à consulter cette article MS très complet sur le déploiement de l'ensemble des services bureau à distance sous W2012 :

    http://technet.microsoft.com/fr-fr/library/hh831447.aspx

    vu que vous êtes sur un LAB, n'hésitez pas à remonter tout l'infra RDS, ca vous permettra de maitriser les choses et de rien louper, je ne peux malheureusement vous détailler toutes les étapes sur ce poste, ca risque de me prendre des heures de rédactions.

    Goodluck

    A+

    HK.



    lundi 9 juin 2014 22:07
  • Bonjour,

    J'ai ajouté l'adresse IP du serveur de passerelle dans l'onglet avancé du client RDC mais ça n'a pas aidé à résoudre le problème.

    En ce qui concerne le certificat, je l'ai exporté puis installé sur le poste client mais ça ne fonctionne toujours pas.

    Je pense que je vais étudier votre lien et remonter toute l'infra...

    Ca ne semble pourtant n'être qu'un détail qui bloque, c'est frustrant.

    Hier vous parliez d'un site IIS mal configuré en rapport avec la passerelle de BàD ; il n'y a rien à tenter par là ?

    A+,

    Manu.


    mardi 10 juin 2014 08:15
  • Bonjour,

    tentez ça 

    1. Depuis le serveur ou la passerelle BàD est installée, lancez le gestionnaire IIS (depuis l'interface metro saisir : INETMGR.exe)

    2. depuis le gestionnaire IIS, naviguez jusqu'au : Sites => Site Web Par défault => RDWeb => Pages => Paramètres applications => Localisez le paramètre DefaultTSGateway et dites moi ce ui affiché comme valeur du paramètre

    Tenez moi au jus.

    A+

    HK.


    Hicham KADIRI | Just Another IT Guy

    • Marqué comme réponse Florin Ciuca vendredi 11 juillet 2014 21:43
    mardi 10 juin 2014 16:48
  • Je vous remercie Hicham mais j'ai commencé à refaire l'infra, en plus simple pour le moment, afin de mieux comprendre la logique de tous ces services de rôle et je n'ai pas installé de VM.

    A mon avis, c'était un problème de certificats SSL. Tout poste client inscrit au domaine à un accès normal aux RemoteApps car ils ont un certificat racine du contrôleur de domaine. Mais tous les clients externes (hors AD) a un message d'erreur.

    Le problème est que je n'y comprends pas grand chose à ces histoires de certificats, pour le moment. Il faut que je me renseigne plus.

    Peut-être peut-on fermer le sujet, à défaut de l'avoir résolu.

    Merci encore pour votre aide et votre temps.

    Manu.

    • Marqué comme réponse Florin Ciuca vendredi 11 juillet 2014 21:43
    mardi 10 juin 2014 18:55
  • Je vous en prie.

    Je vous encourage à vous documenter avant toute chose, il faut pas se précipiter surtout "j'imagine" qu'après déploiement vous allez gérer la solution RDS donc vous devez connaître au moins l'architecture, fonctionnement et les options à configurer pour pouvoir assurer du support derrière.

    Bonne lecture et bonne maquette.

    A+

    HK.


    Hicham KADIRI | Just Another IT Guy

    • Marqué comme réponse Florin Ciuca vendredi 11 juillet 2014 21:43
    mardi 10 juin 2014 19:14