locked
RDS : soucis prise de main à distance RRS feed

  • Question

  • Bonjour,

    Je rencontre quelques soucis avec la mise en place de RDS (en lieu et place d'une archi TSE).

    Le problème vient principalement de la prise de main à distance.

    -> Cette prise de main à distance plante au bout de quelques secondes avec un message "Bureau à distance déconnecté : Cette session sera déconnectée car une erreur de protocole s'est produite. Essayez de vous reconnecter à l'ordinateur distant "

    -> Sur des sessions ouvertes, lorsque l'on veut quitter la prise de main à distance par la combinaison de touche, l'utilisateur est lui aussi déconnecté.

    Merci de votre aide

     

    vendredi 25 février 2011 07:58

Réponses

  • Bon pour ceux que ça interesse, j'ai fini par trouver la solution.

    Le problème vient d'une incompatibilité d'humeur entre le protocole RDP monté sur les boitiers légers AXEL et le celui embarqé dans Windows Seven.

    Une solution consiste à utiliser un Client RDP pour Windows Seven plus ancien (testé avec succès avec un client 5.0 )

    Merci pour votre aide

    • Marqué comme réponse Yuma23 lundi 28 février 2011 15:34
    lundi 28 février 2011 15:07

Toutes les réponses

  • Bonjour,

    Est ce que tu utilises le client RDP 7 ?

    Est ce que cela se produit en Lan ou en Wan ?


    Eric Perromat [MVP Remote Desktop Services]
    vendredi 25 février 2011 09:51
  • -> Constaté plusieurs fois sur un client RDP* Version de noyau 6.1.76 | Version de contrôle 6.1.76 | Authentification au niveau réseau prise en Protocole RDP 7.0 pris.

    -> LAN

     

    * C'est la version du client RDP de l'admin voulant prendre la main à distance

     

    MErci à toi

     

    vendredi 25 février 2011 10:25
  • As tu déjà essayé sans le Network Authentification level ?

    et avec un client RDP 7 ?

     


    Eric Perromat [MVP Remote Desktop Services]
    vendredi 25 février 2011 13:07
  • Sauf erreur de ma part, je ne trouve pas de client RDP 7 pour windows seven (nos admins sont équipés de windows seven)

     

    Concernant l'authentification level, on parle bien d'un réglage sur le serveur RDS ?

    vendredi 25 février 2011 14:01
  • Oublies et regardes http://support.microsoft.com/kb/976110/en-us (je l'avait oublié celui là)

    Tu as un fix à passer ...


    Eric Perromat [MVP Remote Desktop Services]
    vendredi 25 février 2011 14:14
  • Merci pour ta réponse.

    Que je comprenne mieux, le fix est passer sur chaque poste client de mes admins ou sur le serveur RDS ?

    vendredi 25 février 2011 14:39
  • Sur les postes des admins mais essayes la methode de contournement c'est plus simple je pense.

     


    Eric Perromat [MVP Remote Desktop Services]
    vendredi 25 février 2011 14:46
  • Cette solution de contournement ? :

    "Workaround for Windows XP Service Pack 3 or for Windows 7

    To work around this issue, click to clear the Desktop Composition check box on the Experience tab in the Remote Desktop Connection dialog box of the RDC client."

    L'exeprience tab ?

    Hum... je dois rater ma traduction, je ne trouve pas :s

    vendredi 25 février 2011 15:18
  • Bonjour,

    Je viens d'effectuer quelques tests ce matin, notamment la solution de contournement proposée ci dessus.

    Sur le poste de mon admin, j'ai décoché dans l'onglet avancé tout les fonctionnalités  (arrière plan, composition bureau etc). Cela n'a rien changé, j'ai toujours les mêmes coupures...

     

    Merci

    lundi 28 février 2011 07:59
  • Bonjour,

    Perso j'aurai plutôt fait :

    Workaround for Windows Server 2008 or for Windows Server 2008 R2
    To work around this issue, disable the Set compression algorithm for RDP data policy on terminal servers.
    
    To disable this policy on terminal servers that are running Windows Server 2008, follow these steps:
    
      1. Open the Local Group Policy Editor, and then locate the following policy:
    
       Computer Configuration\Administrative Templates\Windows Component\Terminal Services\Terminal Server\Remote Session Environment\Set compression algorithm for RDP data
    
      2. Set the value for this policy to Balances memory usage and network bandwidth.
      3. Refresh the Group Policy settings to apply the settings.
    
    To disable this policy on terminal servers that are running Windows Server 2008 R2, follow these steps:
    
      1. Open the Local Group Policy Editor, and then locate the following policy:
    
       Computer Configuration\Administrative Templates\Windows Component\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment\Set compression algorithm for RDP data
    
      2. Set the value of Set compression algorithm for RDP data to Do not use an RDP compression algorithm.
      3. Refresh Group Policy settings to apply the settings.


    Eric Perromat [MVP Remote Desktop Services]
    lundi 28 février 2011 08:06
  • J'ai exploré la piste "sur le poste des admins" en premier lieu

    Je vais tenter cette solution, je vous tiens au courant

    lundi 28 février 2011 08:11
  • Tenté à l'instant sur un de nos serveurs RDS 2008 R2 : Désactivation via gpedit.msc de l'algorithme de compression pour les données RDP... Toujours pareil, coupure de la prise de main à distance et erreur de protocole.

    Le test de la coupure est radical, des clics souris sur le bureau de chaque coté et hop, coupure du coté de l'admin qui a pris la main

    Ca devient rageant ^^

    lundi 28 février 2011 08:52
  • Pourtant je suis à peu prés sur du truc là ...

     


    Eric Perromat [MVP Remote Desktop Services]
    lundi 28 février 2011 09:22
  • Je vais refaire un test cette apres-midi je vous donnerai les détails pour être sûr qu'on est bien sur la même voie (Mais à priori, je ne pense m'être trompé)...
    lundi 28 février 2011 09:30
  • Bon, voici donc

    mon test :

    Du coté du poste que je vais appeler "admin" , celui qui prend la main sur la session : Windows Seven, Client RDP Version de noyau 6.1.76 | Version de contrôle 6.1.76 | Authentification au niveau réseau prise en Protocole RDP 7.0 pris

    Du coté du client , un poste client léger AXEL avec le dernier firmware proposé par l'éditeur

    Du coté serveur , Windows 2008 R2 sur lequel j'ai appliqué la stratégie proposée dans la solution de contournement à savoir :
    -ouverture de gepedit.msc
    -Dans Config Ordinateur -> Modèles d'admin -> Composants Windows -> Service bureau à distance -> Hoete de la session bureau à distance -> Environnement de session à distance -> Définir l'algorithme de compression pour les données RDP : Activé | Ne pas utiliser d'algorithme de compression RDP

    Le poste de l'admin, le client Axel et le serveur sont sur le même réseau d'entreprise.

     

    --> Lors d'une prise en main à distance erreur à chaque coup : Cette session sera déconnectée car une erreur de protocole s'est produite. Essayez de vous reconnecter à l'ordinateur distant

    lundi 28 février 2011 13:10
  • Bon pour ceux que ça interesse, j'ai fini par trouver la solution.

    Le problème vient d'une incompatibilité d'humeur entre le protocole RDP monté sur les boitiers légers AXEL et le celui embarqé dans Windows Seven.

    Une solution consiste à utiliser un Client RDP pour Windows Seven plus ancien (testé avec succès avec un client 5.0 )

    Merci pour votre aide

    • Marqué comme réponse Yuma23 lundi 28 février 2011 15:34
    lundi 28 février 2011 15:07