none
Connexion SMTP via un programme - Changer de port RRS feed

  • Question

  • J'ai un programme Windev qui se connecte en SMTP via un compte existant pour envoyer une série de mail prédéfinis toutes les semaines, mais ça ne fonctionne pas. Sachant que le programme accède au serveur (dans le code source) via un couple mail/mdp.

    Il faut ainsi que SMTP écoute sur un autre port, en plus du 25 et du 465. Comment faire sous Exchange 2013 ?

    Merci.




    mercredi 3 juin 2015 08:00

Réponses

Toutes les réponses

  • Bonjour,

    Il faut créer un connecteur de réception.
    Ce qui peut se faire au niveau d'EAC dans "flux de messagerie".
     -- Cordialement,

    Yves Gourlé
    [MVP WSSMB - MCSE 2012 & Exchange 2013]
    http://tinyurl.com/luykqs4 - http://blog.gourle.com


    Cordialement, Yves Gourlé [MVP - MCSE - MCITP]
    mercredi 3 juin 2015 11:40
  • Bonjour,

    Je veux plutôt envoyer des mails et non recevoir. Est-ce toujours un réception qu'il faut créer ?

    Si oui, dois-je ouvrir le port désiré sur le firewall ?

    De plus, quelles sont les options à choisir  sur le connecteur de réception (ci-dessous) ?

    Pour finir, la création de ce connecteur ne risque-t-il pas de ne plus faire fonctionner le connecteur STMP sur le port 25 et celui sur le 465 ? (Les actuels)

    Merci pour vos réponses.



    mercredi 3 juin 2015 13:21
  • Bonsoir,

    De ce que je comprends de votre cas, votre serveur Exchange va se contenter de relayer les mails qu'il reçoit de votre application.
    Pour cela il doit disposer d'un connecteur de réception autorisant de recevoir sur le port x depuis l'ip y (celle où se trouve votre appli).
    Voyez par exemple ici pour plus de détails :
    http://www.petenetlive.com/KB/Article/0000891.htm
     -- Cordialement,

    Yves Gourlé
    [MVP WSSMB - MCSE 2012 & Exchange 2013]
    http://tinyurl.com/luykqs4 - http://blog.gourle.com


    Cordialement, Yves Gourlé [MVP - MCSE - MCITP]
    mercredi 3 juin 2015 20:36
  • Bonjour, j'ai crée exactement le même connecteur SMTP que celui qui est écoute sur le port 25, avec cette cette fois-ci le port voulu et tout marche parfaitement.

    Merci pour vos réponses. :)

    Bonne journée.

    jeudi 4 juin 2015 08:34