none
Exchange 2016 - Pop3s/Imap4s Certificat RRS feed

  • Question

  • Bonjour,

    On m'a demandé d'investigué sur un probléme de certificat qui n'arrête pas de tomber sur les services Pop3s/Imap4s de la ferme exchange de ma société.

    La ferme est conposé de deux serveurs en cluster avec un DAG, et deux serveurs de secours.

    En regardant rapidement, j'ai constaté que les services avaient une valeur X509CertificateName qui ne correspondent pas avec le certificat :

    [PS] C:\>Get-PopSettings | select X509CertificateName ; Get-ImapSettings | select X509CertificateName
    X509CertificateName
    -------------------
    pop.int****.fr
    imap.int****.fr
    [PS] C:\>Get-ExchangeCertificate -Thumbprint F584241044287F363EB291*****************
    Thumbprint                                Services   Subject
    ----------                                --------   -------
    F584241044287F363EB291*****************  ...WS..    CN=outlook.***.fr, OU=*****, OU=********, O=****, C=FR


    J'ai essayé d'appliquer le certificat aux services en powershell, ou via la console ecp, mais invariablement au bout de 5 à 10min, les services retournes sur leurs anciennes valeurs :

    [PS] C:\>Enable-ExchangeCertificate -Thumbprint F584241044287F363EB291***************** -Services Pop, Imap
    [PS] C:\>Get-PopSettings | select X509CertificateName
    X509CertificateName
    -------------------
    outlook.***.fr
    outlook.***.fr


    En regardant dans les logs, j'ai des traces d'events de ce type :

    J'ai également essayé de modifier d'autres paramétres des services Pop3/Imap4, et eux ne reviennent pas sur leurs valeurs d'origines.

    Ma question est existe il un mechanisme qui applique un certificat sur les services d'un cluster exchange?

    Et également si vous avez des idées, ca m'aiderait bien.

    Merci


    • Modifié CAO Paul lundi 15 juin 2020 08:35
    lundi 15 juin 2020 08:35

Réponses

Toutes les réponses