locked
Basculement de stockage partagé Hyper-v RRS feed

  • Question

  • Bonjour à tous,

    j'ai un petit probleme avec mon cluster hyper-v r2:

    -deux noeuds identiques lancluster: 192.168.1.x, isci:10.0.0.x switch et cables dédiés, pas de lien physique entre le lan et le iscsi.

    -1 stockage iscsi ,réseau dédié donc.

    la livemigration fonctionne sans probleme si je la provoque à la main.

    par contre, si je redémarre un des noeuds pour simuler une panne grave, la, en fonction du proprietaire du stockage partagé à ce moment, c'est la panique. J'ai donc exploré un peu plus loin et apparemment, je ne peux pas migrer mon stockage d'un noeud à un autre.

    je comprends pas.

    au secours)))

    mercredi 9 juin 2010 06:26

Réponses

  • On va reprendre histoire de balayer une piste que l'on aurait pas vu : 

    noeuds : W2K8 R2 EE , sans AV  et Fw de windows Off, au domaine, IP & DNS fixe. Role HV + FailoverCluster activé. Résolution de noms ok - Hotfix up to date

    Carte réseau dédié pour les vms hyper-v & carte addidtionnelles de communication pour le hôte désactivé.

    Pas de teaming sur aucune interface.

    Noeuds 1 & 2 dans le même lan / datacenter, pas de hop, ou de sous réseaux différents.

    Stockage : Serveur dédié + MSA60 + Starwind. création de luns virtuelles. Configuration IP du serveur, Ip fixe et même DNS. Pas d'AV & firewall off. pas de teaming.

    Réseau stockage : Isolé du lan, 1 interface par serveur physique, même sous reseau, pas de GW, matériel de type switch / hub idéalement.

    Domaine AD, sain et réplication opérationnelle. DNS 1, 2, 3, à jour, avec version de SOA identique (ou delta)

    Pas de wins. pas de netbios, ni de lmhosts.

    Montage d'un failover cluster, RAS. Nom + IP + Quorum (avec wizard)--> RAS. Test de bascule ressouce cluster raq

    Création d'un lun, affectation des droits all access pour noeud 1 & 2. + SCVMM.

    N2 éteint, monter la ressource Lun1 sur le serveur 1, affecter la lettre de son choix ( E:\), tester R/W sur la ressource. Si ok eteindre N1, redémarrer N2, tester accès R/W sur lun 1, affecter la même lettre de lecteur.

     Montage de la ressource dans le cluster, , test d'accès depuis N1, bascule depuis N2, RAS.

    Installation de SCVMM 2008 R2, conf IP fixe + DNS 1, pas d'av ni de FW, ni de teaming, test de résolution ok. Ajout du cluster dans le mgmt RAS.

    Tests de bascule des ressources, RAS.

    Création d'une VM dans la ressource disk précédente, ras.

    pas de modification des affinitées, passage en mode HA, run bascule gauche/droite RAS

    Quid des eventlog, du cluster.log, bpa. quid du test de supportabilité (console Failover cluster).

    Si tout est ok :

    Déplacement de toutes les ressources sur le noeud 1 & arrêt du node 2. Reboot. Quid du fonctionnement ? Si ok, inverser l'opération, reboot du n1 ? Résultat ?

    Si c'est ok, test du mode fractal, reboot du noeud actif .)

    Si le cluster est toujours là, mettre la bouteille au frais, supprimer la vm, formatage rapide  de la ressource (nettoyage), passage en CSV. Allumer un cierge, se prendre les pieds dans le cable électrique,  résultat ?

    PS : Je ne pense pas que le netgear changera grand chose...

    See you tomorrow


    Spice IT
    lundi 14 juin 2010 16:11

Toutes les réponses

  • mettez à jour votre serveur hyper-v avec les add-ons BPA pour W2K8

    Update for Best Practices Analyzer for HYPER-V for Windows Server 2008 R2 x64 Edition 

     http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=89d80c15-0082-4fef-a4fc- fefa463bed08

    Ensuite, lancez un scan, idem pour le SCVMM.

    Si l'outil ne vous aide pas, tentez une bascule, & publiez les eventlog & message d'erreurs.

    Nous avons besoin de plus d'éléments pour vous aider.

     

     


    Spice IT
    jeudi 10 juin 2010 08:32
  • hi,

    i have two same servers 2008 R2 enterprise in a hyper-v cluster, plus one management server + dc + starwind san software (the real storage is HP MSA 60)

    My cluster work almost fine, i can dynamically migrate vm to each node.

    but if i make one server down, the storage don't migrate to the alive server. i tried to migrate storage with the two servers alive, but it wasn't work.  For the san, i'm working with starwind san software enterprise license. i have a lan dedicate to iscsi, switch two. When i made the validate before creating the cluster, everything been ok, except some update for windows, which corresponding to windows XP update????

    Maybe install complete version of windows server 2008 R2 enterprise on my nodes was a mistake? i didn't install another role on them.

    Please someone could help me.

    Thanks a lot.

    samedi 12 juin 2010 08:40
  • donc bpa:

    -installation complete de server 2008 r2 plutot que core = non-conforme

    c'est tout.

    erreur lors de la tentative de migration de stockage: 1038,1069

    je précise qu'apres la tentative de migration de stockage, il est impossible de remettre en ligne la ressource de stockage, je dois la supprimer, deconnecter la cible iscsi sur chaque node, voire redémarrer mes noeuds, reconnecter les cibles et ajouter le stockage dans le cluster.

    quand j'ai de la chance. si ça se passe mal, le volume en question est détecté comme non-formaté par un des noeuds(((

    la validation avant création de cluster m'indique seulement comme avertissement que je n'ai pas les memes update sur chaque noeud, qui apres recherche sont apparemment des mises à jour de IE8 pour xp 64 bits ?!

    j'ai essayé avec ou sans nic-teaming.pareil

    les disques mpio doivent etre en =basculement seulement ,repetition alternée, avec sous -ensemble?

    le san est starwind san software version entreprise qui publie des cibles depuis ma HP MSA60

    J'ai deja refait l'installation complete de tous les serveurs y compris dc, ayant peur d'avoir fait ça avec les pieds)))

    serai-je en train de me fourvoyer en pensant que csv peut tolerer la panne physique d'un des noeuds?

    samedi 12 juin 2010 09:51
  • Mouais, personne pour répondre quoi. Je suis plutôt inquiet parce que des gars dans mon cas, on en trouve quelques uns dans le monde dans les forums, et toujours la même réponse: personne ne répond.

    D'un autre coté, on a des avis de gens a priori qualifiés puisque formateur dans des centre que l'on connait tous, qui après test, sont tous d'accord pour dire que la live migration c'est bien quand c'est planifié, mais la mise en production d'un mode "fault tolerance" c'est pas vraiment une bonne idée avec hyper-v.

    Des personnes qui disent que ça marche, on en trouve aussi, mais quand on demande des infos, plus personne non plus....

    je vois deux hypothèses:

    - je suis un abruti, je vais changer de métier.

    -ça marche pas c'est tout.

    bon en même temps y'a vmware))))

    oups, je l'ai pas dit.

    merci aux éventuels spécialistes de me passer un tuyau ou deux.

    Cordialement, un microsoftiste (un peu) déçu.

    dimanche 13 juin 2010 06:58
  • Tiens, le temps de faire ce petit mot et mon stockage partagé est revenu à la vie (enfin sur son noeud d'origine), c'est déja ça, si j'ai un serveur qui fume, je me retape pas l'install de la machine virtuelle, faut juste attendre 2 ou 3 semaines que le nouveau noeud soit livré. Mes clients vont etre content de le savoir....
    dimanche 13 juin 2010 07:03
  • Bonjour,

    pouvez publier un nouveau volume et valider que chacun des noeuds peut écrire dedans sans se sentir obligé de le formater ? Idem après intégration dans le cluster puis en mode CSV.

    J'ai eu le cas une fois, d'un pbl de csv, j'ai du supprimer le lun car son guid  était toujours dans la conf du failover cluster.

    Pas d'antivirus ou de FW sur les noeuds ? Même version de build ? même version des drivers réseaux ? La conf du quorum a bien été réalisée avec le wizard ?

    Avez vous essayé de migrer le rôle master du CSV dans un premier temps ?

    Si ca marchait du premier coup, se serait pas drole.

    Là je pense qu'il faut reprendre ce fil sur le site US ...

     

     


    Spice IT
    lundi 14 juin 2010 08:50
  • Hi, is not true on the french forum I try to help you but it's a strange case.

    I suspect a quorum ressource issue. Could you try to move all your ressource (VM, Disk and quorum and CSV owner) from node 1 to node 2, then node 2 to 1.
    Do you get error ?

    If ok, try to shutdown the free node, and check anny error. Do it again with the second node after you have migrate all datas.

    Note it's necessary to the csv to migrate the owner and the master recorder too.

    If all, it's fine, try to execute again the quorum wizard, to detect mistake in the configuration.

    If you get error, post clusterlog and event error.

    Good Luck

     

     

     


    Spice IT
    lundi 14 juin 2010 08:59
  • Merci Spice, je me sens moins seul.

    Pour l'ajout de noeud, il n'y a pas de probleme, avant intégration et après.

    j'ai éliminé l'inconnu du nic-teaming en le supprimant.

    j'ai recréer le cluster suite à ça, tout est vert sauf les mises à jour et le pilotes log me in.

    Ton idée de guid me plait assez, car j'y pensais aussi, et le fait d'avoir éliminé les pbs réseaux potentiels, me pousse un peu plus vers ça.

    J'ai pas d'antivirus, ni firewall nulle part pour l'instant.

    le quorum a bien été configuré avec l'assistant.

    quelles approche as-tu choisis pour supprimer le lun?

    lundi 14 juin 2010 10:15
  • La seule, la vrai, destroy & création d'un lun de taille légèrement différente :) Faut dire que j'étais sur un SAN physique.

    Peux tu créer à la limite un nouveau lun, avec starwind, c'est facile ;)   et tu refais l'ensemble des tests que je t'ai proposé dans l'autre thread.

    Tu n'as pas d"erreur d'écriture disque en rouge, avec ton CSV ?

    Au cas où vérifie bien les drivers de la carte réseau (stable & supporté W2K8 R2) & si les firmwares de toute la couche matérielle est up to date.

    Sinon, en dehors, je vois pas trop, car sur de l'iscsi avec du starwind, ca devrait tourner. Question, gratuite,  elle apparait comme supporté dans le Failover Cluster ? 


    Spice IT
    lundi 14 juin 2010 12:17
  • Pour starwind je peux pas vérifier du coup mais je pense qu'en édition gratuite c'est supporté car il y a l'option cochable à la création dun lun (connexion concomitantes cluster), mais la dans le doute, j'ai acheté une licence entreprise. je précise que j'avais une version d'essai full (ha,etc...) que la très charmante commerciale europe Tatiana m'avait envoyé mais le problème était déjà la.En tout cas même en gratuit tu crée un cluster sans erreur. la fonction ha qu'ils proposent permet en fait de mettre en miroir plusieurs serveurs starwind, ou plusieurs disques sur le même.

    je vais tenter le lun, j'avais déjà essayé me semble-t-il mais pour être sûr.

    clusterophobe s'abstenir)))

    en même temps quand ca va marcher (j'y crois encore) j'aurais fait le tour de la question.

    lundi 14 juin 2010 14:01
  • tenter un nouveau lun pour voir mais échec quand je le migre sur un nouveau noeud. initialisé en mbr (les autres sont en gpt). les drivers des cartes réseau sont ceux de hp, reste le switch un netgear gigabit mais pas très haut de gamme. Quand je le teste avec l'utilitaire hp des cartes réseau, tout va bien. Le fond de panier est peut-être trop faible. Je vais en installer un autre (gagné un déplacement gratuit là).

    Tu as une idée pour les kb manquantes- si je les installe à la main forcément windows ne les veut pas puisque elles sont pour xp 64 bits?
    lundi 14 juin 2010 14:19
  • On va reprendre histoire de balayer une piste que l'on aurait pas vu : 

    noeuds : W2K8 R2 EE , sans AV  et Fw de windows Off, au domaine, IP & DNS fixe. Role HV + FailoverCluster activé. Résolution de noms ok - Hotfix up to date

    Carte réseau dédié pour les vms hyper-v & carte addidtionnelles de communication pour le hôte désactivé.

    Pas de teaming sur aucune interface.

    Noeuds 1 & 2 dans le même lan / datacenter, pas de hop, ou de sous réseaux différents.

    Stockage : Serveur dédié + MSA60 + Starwind. création de luns virtuelles. Configuration IP du serveur, Ip fixe et même DNS. Pas d'AV & firewall off. pas de teaming.

    Réseau stockage : Isolé du lan, 1 interface par serveur physique, même sous reseau, pas de GW, matériel de type switch / hub idéalement.

    Domaine AD, sain et réplication opérationnelle. DNS 1, 2, 3, à jour, avec version de SOA identique (ou delta)

    Pas de wins. pas de netbios, ni de lmhosts.

    Montage d'un failover cluster, RAS. Nom + IP + Quorum (avec wizard)--> RAS. Test de bascule ressouce cluster raq

    Création d'un lun, affectation des droits all access pour noeud 1 & 2. + SCVMM.

    N2 éteint, monter la ressource Lun1 sur le serveur 1, affecter la lettre de son choix ( E:\), tester R/W sur la ressource. Si ok eteindre N1, redémarrer N2, tester accès R/W sur lun 1, affecter la même lettre de lecteur.

     Montage de la ressource dans le cluster, , test d'accès depuis N1, bascule depuis N2, RAS.

    Installation de SCVMM 2008 R2, conf IP fixe + DNS 1, pas d'av ni de FW, ni de teaming, test de résolution ok. Ajout du cluster dans le mgmt RAS.

    Tests de bascule des ressources, RAS.

    Création d'une VM dans la ressource disk précédente, ras.

    pas de modification des affinitées, passage en mode HA, run bascule gauche/droite RAS

    Quid des eventlog, du cluster.log, bpa. quid du test de supportabilité (console Failover cluster).

    Si tout est ok :

    Déplacement de toutes les ressources sur le noeud 1 & arrêt du node 2. Reboot. Quid du fonctionnement ? Si ok, inverser l'opération, reboot du n1 ? Résultat ?

    Si c'est ok, test du mode fractal, reboot du noeud actif .)

    Si le cluster est toujours là, mettre la bouteille au frais, supprimer la vm, formatage rapide  de la ressource (nettoyage), passage en CSV. Allumer un cierge, se prendre les pieds dans le cable électrique,  résultat ?

    PS : Je ne pense pas que le netgear changera grand chose...

    See you tomorrow


    Spice IT
    lundi 14 juin 2010 16:11
  • Merci spice je vais essayer de tester tout ça aujourd'hui, mais normalement je suis en réunion)))

    TRES cordialement.

    PS: je fais appel à un marabout, on va bruler quelques poulets pour voir.

    mardi 15 juin 2010 06:17
  • Salut spice,

    j'ai réinstallé hier mes deux noeuds en mode core.

    recréé mes lun, probleme toujours la. J'attends d'autre cartes réseaux aujourd'hui m'est d'avis que c'est la que ça se passe.

    Je t'en dis plus quand j'ai des billes.

    jeudi 24 juin 2010 07:23
  • Salut Spice,

    bon j'ai tout ré essayé depuis un mois avec d'autre serveurs (nec r120) d'autre carte réseaux (d-link, intel, broadcom) d'autre switches, enfin tout quoi.ec du matériel standard pour voir

    Enfin, ça marche pas quoi: je peux toujours live migrer ms vms, je peux stopper le service cluter sur un noeud ça bascule, mais pou ce qui est de la bascule du stockage d'un noeud à un autre, non, ça ne marche pas.

    Merci pour tout.

     

     

    lundi 26 juillet 2010 05:52
  • Starwind m'a finalement apres que je leur ai envoyé les logs, donner une version à jour qui regle le probleme...

    ça marche.

    Encore merci.

    lundi 26 juillet 2010 19:10